ワークブック、ワークシート、列

Less grand image workbooks 650px.png

目次

ワークブック、ワークシート、列の基本

Originのワークブックは、インポート、整理、変換、グラフ作成のためのフレームワークを提供する、名前付け、移動、サイズ変更可能なウィンドウです。

  • Originのワークブックは、1つ以上のOriginワークシートで構成されます。(最大1,024まで)
  • それぞれのワークシートには連続的な列があり(最大65,500まで)、列にはセルで構成される行が含まれています(最大90,000,000まで)。
  • 各列には、ワークシート内で列を一意に識別するショートネーム(「A」など)と、プロットおよび分析操作でのデフォルトの処理方法を決定する列のXY属性(「(X)」など)があります。
  • 各ワークシートおよび各ワークシート列には、行(インデックス)番号で識別されるデータを含むセルがあります。 そして先行メタデータはロングネーム単位コメントなどのオプションのラベル行で構成される領域(「ヘッダ」)を含みます。

ワークブック、ワークシート、列の制限

オブジェクト 最大数

ワークブックに含めるワークシート
1列のワークシートに入力可能な行数
5列のワークシートに入力可能な行数
32列のワークシートに入力可能な行数
1行のワークシートに入力可能な列数
100行のワークシートに入力可能な列数
1000行のワークシートに入力可能な列数

1024†
90,000,000
90,000,000
90,000,000
65,500
65,500
65,500

† 255シート以上の場合、Unicodeファイル形式 (例 *.opju) で保存する必要があります。Unicode対応のファイルは、Origin 2018 より前のバージョンのOriginでは開けません。

ワークブック、ワークシート、列に名前を付ける


Workbooks 01C.png
ワークブック
  • ワークブックはショートネームと任意のロングネームコメントを持ちます。Origin内部のオペレーションにはショートネームが使用されます。
  • ショートネームは、プロジェクト内で固有で、スペースや特殊文字を含まず、文字(A-Z, a-z)で始まる最大13文字まで、と制限されています。
  • ワークブックロングネームは、必須ではありません。プロジェクトで固有である必要はなく、スペースや特殊文字を含めることができ、長さは最大5,506文字(半角)まで入力可能です。
  • ワークブックに名前を付けるには、ウィンドウのタイトルバーを右クリックして、プロパティを選びます。ここでロングネーム、ショートネーム、コメントを編集できます。ウィンドウタイトルドロップダウンを使ってウィンドウタイトルバーにどちらの名前を表示するか制御できます。
ワークシート
  • ワークシートは名前ラベルコメントを持ちます。
  • 名前は、ワークブック内で固有である必要があります。
  • ワークシートの名前には、スペースを含めて最大64文字まで設定できます。特殊文字{}|"<>()![]は使用できません。
  • ワークシートのラベルコメントは任意です。プロジェクトファイル内で一意である必要はなく、任意の文字を任意の順序で使用でき、実用的な長さにすることができます。
  • ワークシートの名前を付けるには、シートタブでダブルクリックするか、タブを右クリックして表示するシート名を選択します。詳細は、以下のワークシートを参照してください。
  • 列はショートネームロングネーム(任意)を持ちます。
  • ショートネームは、ワークシート内で固有である必要があります。アイコンが表示され、スプレッドシートセル表記が有効な場合(デフォルト)、列ショートネームを編集できません(列ショートネームの制限を参照)。セル表記が無効になっている場合、列ショートネームを編集できます。列のショートネームは、特殊文字を含まず、文字(A-Z, a-z)または、数字で始まり18文字に制限されています。
  • ロングネームは、必須ではありません。プロジェクトで固有である必要はなく、スペースや特殊文字を含めることができ、長さは最大30,000文字(半角)まで入力可能です。ロングネームは、ロングネームセルをクリックするか列ヘッダを右クリックしてプロパティを選択して直接編集できます。
  • (1) ロングネームが存在している、 (2) ロングネームが利用可能な時はそれを使うチェックボックス(環境設定:オプション:その他のオプションタブ) を選択している場合に、選択したデータ範囲を参照するダイアログボックスとステータスバーは、ロングネームを表示します。そうでない場合は、ショートネームが使われます。

ワークブック

Originのワークブックは高度にカスタマイズ可能であり、データありワークブックファイルなど)またはデータなしワークブックテンプレートなど)の両方で保存できます。それらは多くの異なるアプリケーション用に構成できるため、時間の経過とともに多数のカスタムファイルを収集する可能性が高くなります。新しいブックダイアログは、使用するこれらのファイルを整理および選択するのに役立ちます。

新しいブックとブックテンプレート

New Book Dialog Controls.png

新しいブックダイアログを開くには

  1. ファイル:新規作成:ワークブック:参照をクリックするか、Ctrl + Nキーを押します。

Origin 2022では、新しいブックダイアログにテンプレートを開くボタン Template Center Button.png が追加されました。ボタンをクリックすると追加のワークブックテンプレートを参照でき、ダウンロードしてテンプレートリストに追加できます。


  • ダイアログには、アドオン(拡張)ファイルとユーザ定義(ユーザ)ファイルの両方が一覧表示されます。
  • ファイルは、名前ブックの種類カテゴリーまたはユーザでソートすることができます。
  • Icon New Book Preview.pngアイコンにカーソルを合わせると、ファイルプレビューが表示されます。
  • テンプレート名を右クリックしてメタデータを編集するか、デフォルトとして設定します(例:新規ワークブックボタンButton New Workbook.png)。また、右クリックでデフォルトをクリアを選択できます。
  • メニューで表示を有効にして、新規: ワークブックまたは新規: 行列メニューにウィンドウを一覧表示します。
  • 「All Categories」メニューを使用して、カテゴリーでウィンドウをフィルタリングします。
  • ブックの種類ドロップダウンメニューで、ウィンドウを種類でフィルタリングします。リセットですべてを表示します。.
  • テンプレートを右クリックして、デフォルトとして設定またはメタデータの編集を選択します。
  • 開始時および新規プロジェクトで表示を有効/無効にします。

各ウィンドウプロパティダイアログにはテキスト入力のためのコメント欄があります。これらのコメントは、新規ブックダイアログのプレビューとプロジェクトエクスプローラのプレビューに含まれています。さらに、コメントは編集: プロジェクト内を検索ツールから検索できます。

スプレッドシートセル表記(SCN)

Originのワークブックではスプレッドシートセル表記:Spreadsheet Cell Notation (SCN)をサポートしています。SCNは表計算でよく知られているセルレベルの計算が可能です(詳しくはこちら)。

  • デフォルトで、新しいワークブックのSCNはオンになっています。
  • Origin 2017 - 2019のバージョンでは、SCNがワークブックでオンになっているとき、ワークシートの左上にこのアイコンSpreadsheet cell notation mode.pngが表示され、SCNがオンであることを示していました。
  • Origin 2019b以降、SCNアイコンはデフォルトで非表示になっていますが、SCNは有効です(これもデフォルトです)。 SCNを有効にしておくと、データコネクタアイコン用にワークブックウィンドウにスペースを確保できます。
  • ほとんどの場合はSCNを有効にしたままで問題ありませんが、例えば列のショートネームをカスタマイズする必要がある場合にはSCNをオフにすることをお勧めします。SCNを無効にするには、ワークブックのタイトルバーを右クリックして、プロパティを選びます。ページの中程にあるスプレッドシートセル表記チェックボックスを確認します。
  • SCNが無効の時、すべてのバージョンのユーザにこのアイコンButton SCN OFF.pngがワークブックの左上隅に表示されます。
  • Originでプロジェクトウィンドウまたはワークブックウィンドウを開き、ワークブックでSCNがオフになっていると、左上にSCN OFFボタンButton SCN OFF.pngが表示されます。これにはOrigin 2017以前に作成されたプロジェクトやワークブックが含まれます。SCNを有効にするには、ブックのタイトルバーを右クリックしてプロパティを選択し、スプレッドシートセル表記 チェックボックスをオンにします。

ワークシート

Origin2018より前のバージョンでは、ワークブックには最大255シートまでしか含めることができませんでした。Origin 2018では1024シートまで増えました。ブック内に255シート以上ある場合、Unicode形式のファイル(opju, oggu, otwu)で保存する必要があります。

ワークシートをワークブックに追加するには、ワークシートタブを右クリックして、以下のうち一つを選択します。

  • 挿入  アクティブなワークシートの前にワークシートを挿入します。
  • 追加 1つのワークシートを追加します。
  • データなしで複製 アクティブなワークシートをデータなしで複製します。
  • 複製 アクティブなワークシートをデータを含めて複製します。

ワークブック内のシートは、それぞれの設定を持っています。ワークシートの挿入または追加は、ORIGIN.otwuファイルを元にした新しいシートが作成されます。デフォルトのORIGIN.otwuファイルを編集した場合は、ユーザーファイルフォルダに保存されています。ワークブックにある既存シートを元にして新しくシートを追加するには、複製データなしで複製ショートカットメニューを使います。

シートは1つの名前をもち、これはスペースや特殊文字を含めることができます。オプションで、ラベルコメントを追加できます。

シート名を編集する方法

  1. シートタブをダブルクリックして名前を入力します。あるいは、シートタブを右クリックして名前とコメントを選択し、名前を編集します。


システム変数@SSLでシートの命名動作を変更できます。LabTalkシステム変数リストの@SSLを参照してください。

ワークシートタブにマウスカーソルを合わせると、ツールチップとしてワークシートの名前ラベルコメントが表示されます。

ワークシートプロパティ

ワークシートのプロパティダイアログを開く

  1. ワークシートの右側にある灰色の領域(ワークブックの内側)を右クリックして、ワークシートの表示属性を選びます。


ワークシートプロパティダイアログボックスは次のようなシートのプロパティをカスタマイズできます。

  • 行ラベル、ヘッダ、グリッド線の表示(表示タブ)
  • 行や列の数、列および行ヘッダの高さなどのワークシート寸法(サイズタブ)
  • リッチテキスト、テキスト折り返し、シートのフォントおよび色(フォーマットタブ)
  • 行の自動追加、作図と分析で非表示の行を無視、セルサイズ変更(その他タブ)
  • グリッド、ヘッダ、フッタ、背景色の印刷/エクスポート(印刷/エクスポートタブ)
  • インポート後またはデータ変更時に実行するスクリプト(スクリプトタブ)
  • ユーザツリーの表示と編集(ユーザがテンプレートで使用する構成情報を追加するなど)(ユーザツリータブ)


シートの設定のほとんどは、セルを選択して右クリックしてセルのフォーマットを選択すると、セルレベルでも適用できます。

詳細情報は、ワークシートプロパティダイアログを参照してください。

オブジェクトマネージャでシートを操作

オブジェクトマネージャのショートカットメニューを使ってワークブック内容の表示を操作できます。

  • アクティブウィンドウ内のシートをリスト表示します。
  • オブジェクトマネージャでシートをクリックして、ワークブック中の対応するシートをアクティブにします。
  • オブジェクトマネージャで右クリックして、削除挿入追加移動コピー名前変更といった一般的なワークシート操作にアクセスできます。


UG UI OM workbook.png

ワークシート列

  • 既存のワークシートの右側に新しい列を追加するには、ワークシート列の右側の灰色の領域で右クリックし、新しい列の追加を選択または、標準ツールバーの列の追加ボタン Button Add New Columns.png をクリックします。
  • ワークシートに複数列を追加するには、ワークシートがアクティブであることを確認し、メニューから列:新規列の追加を選択します。新規列の追加ダイアログで、追加する列数を入力し、OKをクリックします。または、フォーマット: ワークシートの表示属性を選択するかF4キーを押して、ワークシートプロパティダイアログを開き、サイズタブで列数に値を入力します。
  • ワークシートに列を挿入する場合、列を右クリックして挿入を選択します。選択した列の前に新しい列が挿入され、ショートネームが調整されます。


列名は次の方法で変更できます:

  • 列ヘッダをダブルクリックし、列プロパティダイアログボックスを開きます。そして、ショートネームロングネームを入力します。
  • ワークシートの先頭にあるロングネームのセルをダブルクリックして、ロングネームを直接入力します。
  • データファイルをインポートし、インポート時にワークブック、ワークシート、および列の名前を指定します。
  • 列プロパティダイアログのラベルの番号付けタブを使用して、名前とラベルの連番付けや複製を行います。
  • 列にPeak 1Peak 2などを入力しての名前をつけ、このラベルセルを選択し、選択範囲の右下にマウスカーソルを移動して、カーソルの表示が変わった時にドラッグすることで、オートフィルタ機能による連番付けをします。この操作は、コメントなど、その他のヘッダ行でも可能です。


ワークシート列の命名規則は上の表をご確認ください。

列のXY属性

前述のように、ワークシートの列のXY属性(別名「プロット属性」)は、通常、分析および作図の操作中にデータがどのように処理されるかを決定します。たとえば、X列+ 3つのY列を選択して、X値の共通セットに対して各Yデータセットの同時線形フィットを実行できます。または、同じ列を選択して、共通のX値のセットに対して3本の線のプロットをグラフ化することもできます。さらに、Z値、エラーデータ、ラベルなどの指定があります(詳細については、Originヘルプファイルの列属性を参照してください)。

Designation symbols.png


ユーザインターフェイスには、分析や作図の操作中に列を指定できる場所がいくつかありますが、基本的なレベルでは、(1)列ヘッダをクリックして列を選択し、次に列ヘッダをクリックしてワークシートに設定します。 (2)次のいずれかを実行します。

  • 列レベルのミニツールバーからオプションを選択します。
  • ツールバーのボタンをクリックします。
  • 列を右クリックして列XY属性の設定を選択し、ショートカットメニューからオプションを選択します。
  • 列を右クリックし、プロパティを選択して、プロット属性を設定します。

列プロパティダイアログボックス

列プロパティダイアログボックスは次のような列のプロパティをカスタム化できます。


「列プロパティ」ダイアログボックスを開くには:

  1. ワークシート列のヘッダをダブルクリックします。
  2. 選択した列を右クリックして、列フォーマットを選択します。

ショートネームプロパティタブで編集できます。その他のプロパティ(ロングネーム単位コメントなど)もここで編集するか、列ラベル行に直接入力します。

列データのフォーマット設定

Originのワークシートのデータはテキストまたは数値データのどちらかとして扱われます。ワークシート内のテキストデータの表示は簡単ですが、数値データの表示はより複雑です。

特に指定しない限り、ワークシート内のすべての数値は、内部的に浮動小数点、倍精度(Double(8))の数値として格納されます。これには、日付と時刻、桁単位で表示するようにフォーマットされたデータ、または固定小数点数を表示するようにフォーマットされたデータが含まれます。

数値データを扱うときは、ワークシートに表示されている内容が、内部的に格納されている数値を(ワークシートの設定によって)表現したものであることに注意してください。この点は2つの理由から重要です:

  • ワークシート値を含む計算は、ワークシートに表示される値ではなく、内部的に格納されている倍精度数値で行われます。
  • さまざまなフォーマットおよび表示オプションを適用して、この数値がワークシートに表示される際の方法を変更することができます。

ワークシートデータをフォーマットするための中心的な場所は、上記のようにプロパティダイアログですが、数値データと日時データの表示を変更するためのクイックアクセスミニツールバーボタンがあることに注意してください。これらのボタンを表示するには、最初に選択した列のフォーマット日付または数値/文字と数値に設定する必要があることに注意してください。

UG MT Numeric Format Buttons.png


数値表示フォーマット
  1. 列ヘッダをダブルクリックして列プロパティダイアログを開きます。
  2. プロパティタブをクリックし、フォーマット = 数値と設定します。
  3. 表示十進数: 1000指数: 1E3工学: 1K十進数: 1,000またはカスタムのいずれかに設定します(詳細は以下)。


日付と時間のフォーマット

デフォルトでは、Originは日時データをユリウス暦の値として保存し、日時の計算にこの数値を使用します。ただし、通常は、このユリウス歴の値をより意味のある日時形式で表示することをお勧めします:

  1. 列ヘッダをダブルクリックして列プロパティダイアログを開きます。
  2. プロパティタブをクリックし、フォーマット時間日付または曜日のいずれかに設定します。
  3. 表示リストのオプションからいずれかを選択します。
  4. リストのオプションのどれも適さない場合にはカスタム表示を選択し、これらの日付ー時間のフォーマット指定子を作成します。

日時データをワークシートにインポートするとき、Originはこのデータをテキストとして認識することがあります(OriginのCSVコネクタは通常、日時データをうまく認識することができます)。日付ー時間データがワークシートのセル内で左揃えになっている場合、Originはそれをテキストと認識しています。この場合、列プロパティダイアログボックスを開いて適切なフォーマット表示のオプションを選択する必要があります。日付ー時間データがセル内で右揃えになっている場合、Originはそれを数値と認識し、日付ー時間形式で表示します。

Workbooks formatting data1.png
カラーフォーマット

Origin 2021では、まったく新しい列とセルのフォーマット-が利用できます。

UG Cell Color Format.png
  • ワークシートのセルへのHTMLカラーコードの直接入力をサポートし、セルの背景色を設定します。オプションで、セルでHTMLコードを表示または非表示にすることができます。
  • color()関数を使用して16進値を計算し、列値の設定またはセル式を使用して他のデータ列のRGB値から色を設定します(たとえば、color(A,B,C)は列A、B、CのRGB値を使用して色を設定します) 。
  • フォーマットの列を選択し、ミニツールバーのボタンを使用して、グラフで使用するために推移リストの保存(カラーリスト) をします。
  • または、カラーチューザーカスタムカラーメニューから、列からカラーリストを作成を選択し、フライアウトからワークシート列を選択します。
UG Color List From Column.png
その他のカスタム表示フォーマット

Originは、さまざまなカスタム形式で数値をワークシートに表示できます。この図は、同じ数値セットに適用されるさまざまなフォーマットを示しています(列A(X))。

ColProperties Custom Formats.png

以下は、サポートされているカスタムフォーマットオプションのサンプルリストです(Origin 2019に組み込まれている事前入力済みのリストです)。カスタム表示は、カスタム表示リストに直接入力することができ、それらはこのリストに保存されます。

他にも多くのフォーマットオプションがあります。詳細は、カスタム数値フォーマットを参照してください。

表示フォーマット 説明 例:
セルの値 = 123.456の場合
*n n桁の有効桁数を表示します。 *3123と表示します。
.n n 桁の小数桁数を表示します。 .4123.4560と表示します。
S.n 科学的表記1E3n桁の小数桁数を表示します。 S.41.23456E+02と表示します。
E.n 工学表記でn 桁の小数桁数を表示します。 E.2123.46と表示します。
* "pi" 数字を10進数で表示し、その後に記号πを表示します。 * "pi"39.29727πと表示します。
#/4 "pi" 分母を"4"とし、πの小数部として数値を表示します。 #/4 "pi"157π/4と表示します。
#/# "pi" 数字をπの小数部として表示します。 #/# "pi"275π/7と表示します。
##+## 数字を1桁、"+"区切り記号、2桁の数字(例:測量ステーション)として表示します。 ##+##01+23と表示します。
#+##M 数字を1桁、"+"区切り記号、2桁の数字、および"M"を接尾辞として表示します。 #+##M1+23Mと表示します。
#n 数字をn桁の整数で表示し、必要に応じて先頭にゼロを付加します。 #500123と表示します。
#% 数字をパーセンテージで表示します。 #%12346%と表示します。
# ##/## 数字を適切な割合で表示します。 # ##/##123 26/57と表示します。
# #/n 数字を適切な割合でn番目に表示します。 # #/8123 4/8と表示します。
DMS 1度 = 60分、1分 = 60秒として、数字を度° 分’ 秒"の形式で表示します。 DMS123°27'22"と表示します。
D MDn EW (経度)
D MDn NS (緯度)
度数と小数点以下の桁数で数字を表示します。パラメータnは小数点桁数を指定します。正の値には "E"または "N"が付加され、負の値には "W"または "S"が付加されます。負の値を保持したい場合は、 "EW"または "NS"を付加しないでください。 D MD3 EW123° 27.360 Eと表示します。
D MDn EWB (経度)
D MDn NSB (緯度)
度数と小数点以下の桁数で数字を表示します。パラメータnは小数点桁数を指定します。文字"B" ("before") は、正の値に"E"または"N"が前置され、負の値に"W" または"S"が前置されることを指定します。負の値を保持したい場合は、 "EWB"または "NSB"を追加しないでください。 D MD3 EWBE 123° 27.360と表示します。
 %#x 数字を32ビットの16進数(最大8桁)で表示します。"#"記号は "0x"接頭辞を指定します。 %#x0x7bと表示します。
 %#0nx n文字の文字列として数字を32ビットの16進数(最大8桁)の表記法で表示し、必要に応じて先頭に0を付けます。 %#06x0x007bと表示します。
 %#0nI64X n文字の文字列として数字を64ビットの16進数(最大13桁、#= "0x"を含む15の合計)の表記法で表示し、必要に応じて先頭に0を付けます。 %#014I64X0X00000000007Bと表示します。

列ラベル行

列ラベル行には、メタデータ、つまり他のデータを説明するデータが格納されます。一般に、このメタデータは、インポートされたファイルのヘッダ情報として取り込むことも、手動で入力することもできます。列ラベル行の表示は任意で、必要に応じてユーザーは選択的に表示または非表示にできます。

列ラベル行情報は、作図操作(たとえば、ワークシートロングネームはグラフ凡例または軸タイトルのテキストとして使用される)で頻繁に使用されます。F(x)= 行は、データの列における数学演算を実行する際に使用されます(下記参照)。ユーザパラメータ行に格納されたデータは、プロット、データ操作、統計解析、または数学演算におけるデータセットのラベル付けまたはグループ化などで使用されます(チュートリアル2参照)。

align="center"

ワークシートの部分範囲を選択してコピー貼り付けの操作をする際、ラベル行を含めることができます。ラベル行を含めてデータセルをコピーするには、選択した部分範囲を右クリックして、コピー(ラベル行を含む)を選択します。

列ラベル行の表示設定

列ラベル行の表示(表示または非表示)は、ショートカットメニューコマンドで制御できます。

Workbooks 03B.png
  1. 右クリックして、ショートカットメニューから表示を選びます。
  2. 右クリックして列ラベル行を編集を選択するか、他のラベル行のコマンドを選択します。
  3. 右クリックしてワークシート要素のコントロール(行ラベルや列ヘッダの表示など)、あるいは、この領域のセルを選択後右クリックしてコメントの書式を設定可能です。

ラベル行を管理するためのワークシート列ラベル行ミニツールバーもあります。選択したラベル行の非表示、リッチテキストの有効化、ラベル行の順序を変更などを行う「ために使用します。

UG MT worksheet label row.png

列リストビュー

Origin 2019では、列ラベル行メタデータの転置ビューである列リストビューと呼ばれるワークシートの新しい表示モードが導入されました。このビューは、ワークシートに多数のメタデータ行があり、そのメタデータの特定の側面に注目したい場合に便利です。ワークシートをアクティブにして、表示: 列リストビューを選択するかCTRL + Wを押します。

Workbook Column List View 1.png

列リストビューのメタデータにデータフィルタを適用することができます。標準のワークシートビューに戻ると(表示:列リストビューの横のマークをオフにすると)、フィルタ処理されたメタデータに関連付けられているデータのみがワークシートに表示されます。

列リストビューは列ショートネーム(+列属性)の前に列番号を表示します。さらに、列ロングネームの左端にマウスカーソルを合わせると、ツールチップにデータセットサイズが表示されます。列番号の表示を無効にするには、@DSI=1に設定します。

UG CLV index.png

スパークライン

列に保存された数値データは、スパークラインという特別な行ラベルの列ヘッダにグラフィカルに表示できます。 スパークラインはその列内のデータの小さなインセットグラフで、これは行番号を独立変数(X)、列内数値を従属変数(Y)としてプロットしたものです。データをインポートすると、列数が50以下の場合はデフォルトでスパークラインを表示します。

Sparklines column label row.png


スパークラインの表示と非表示

  • メニューから列:スパークラインの追加と選択してスパークラインを表示します。すると、スパークラインの追加ダイアログが開きます。
  • 列を選択し、ツールバーのスパークラインの追加ボタンButton Add Sparkline.pngを押してスパークラインを表示します。
  • ワークシートのスパークライン列ラベル行を右クリックして、スパークラインを追加または更新を選択します。
  • スパークライン列ラベル行を右クリックし、Deleteキーを押してスパークラインを削除します。
  • デフォルトの折れ線グラフに加え、スパークラインはヒストグラムやボックスチャートでも表示できます。列ヘッダでクリックして1つ以上の列を選択し、右クリックして列:スパークラインの追加を選択します。開いたダイアログボックスで、プロットタイプヒストグラムまたはボックスに変更します。
Sparklines histogram box.png
  • スパークラインのプロパティは編集可能です。スパークライン上でダブルクリックするとグラフウィンドウとして開くことができます。開いたグラフウィンドウでダブルクリックして作図の詳細ダイアログを開き、編集可能です。グラフウィンドウを閉じると、編集内容がスパークラインに適用されます。

ワークブックオーガナイザ

前述したように、ワークブックにはメタデータが保存され、その一部は列ラベルの行に表示されます。ほかのメタデータはワークブック内で非表示になっています。非表示のメタデータには、インポートファイルのパス、名前、データをインポートした日付と時間、ヘッダ情報、様々な名前や変数等のメタデータ等が含まれます。これらの非表示のメタデータは、ワークブックオーガナイザで表示できます。

テーマオーガナイザーを開くには、ワークブックウィンドウのタイトルバーで右クリックし、ショートカットメニューからオーガナイザの表示を選択します(これによりパネル表示のオン/オフを切り替えます)。このオーガナイザは、個々のワークブックに保存される情報をすべてツリー形式で表示します。

Workbook organizer.png

ミニツールバーによるワークブックの設定

ブック、シート、列およびセルレベルのプロパティの多くは、ミニツールバーのボタンで設定することまたはオン/オフを切り替えることができます。

MT worksheet column selected.png
  • 使用可能なツールを確認するには、ワークシートを選択してから、選択内容にカーソルを合わせます。
  • ページレベルのフォーマットオプションは、シートの左上隅、またはワークシート列の右側の灰色の領域のウィンドウの余白の近くにカーソルを合わせると表示されます。
  • ワークシートのミニツールバーの完全なリストについては、こちらをご覧ください。

ワークシートの検索と置換

シートまたは列を選択したときに表示される、ミニツールバーの検索ダイアログが改善され、検索と置換ダイアログと統合されました。

MT Find Button.png
  • 検索をクリックすると小さいダイアログが開き、現在のワークシートの検索が可能です。
  • このダイアログでは、文字列と数値の前方および後方検索が可能です。
  • ダイアログを最小化すると検索範囲を変更でき、CTRL + Page Up/Page Down キーを使って前方検索または後方検索できます。また、ワークシートの選択を変更してダイアログを初期化して新しい検索を実行できます。
  • ...のボタンをクリックすると、Originの検索と置換ダイアログが開きます。

Big Find.png

Originには、スクリプトでできるもう1つの置換ツールであるwreplaceがあります。ダイアログを開く場合は、スクリプトウィンドウ(ウィンドウ:スクリプトウィンドウ)を開き、wreplace -dを入力して実行します。スクリプトのオプションなど詳細は、wreplaceのXファンクション文書を参照してください。

列に数値を入力するシンプルな方法

Originは、ワークシートのある範囲や、ワークシート列に数値を入力するためのユーティリティをいくつか提供しています。最も簡単な方法は、メニューコマンドを使って列に行番号一様乱数正規乱数を入力する方法です。この方法は、Originの機能を確認する時にテスト用のデータセットを生成するのに便利です。

また、この方法では、事前に選択したワークシートの範囲または列(複数可)でデータセットを作成します。

アクション ツールバーボタン メニューコマンド
行番号を入力する Button Set Col Values Index.png
  • 列:列値の一律設定:行番号

または

  • 列を右クリックし、列値の一律設定:行番号を選択
0から1までの一様に分布した数値でワークシートデータセットを作成 Button Set Col Values Uniform Random.png
  • 列:列値の一律設定:一様乱数

または

  • 列を右クリックし、値の一律設定:一様乱数を選択
正規分布した乱数でワークシートデータセットを作成 Button Set Col Values Normal Random.png
  • 列:列値の一律設定:正規乱数

または

  • 列を右クリックし、値の一律設定:正規乱数を選択
繰り返しまたはランダムな数値のセットを作成 --
  • 列を右クリックし、列値の一律設定:数値セットを選択
繰り返しまたはランダムな日付/時間のセットを作成 --
  • 列を右クリックし、列値の一律設定:日付/時間の値のセットを選択
任意のテキストと数値セットを作成 --
  • 列を右クリックし、列値の一律設定:テキストと数値の任意のセットを選択


オートフィル機能は、列ラベルの行やワークシートデータ部分のセルで使用することができます。

オートフィル機能を使って拡張パターンを入力する(数値データのみ)には、

  1. データパターンを含む連続したセルを選択し、選択領域の右下角にマウスを移動します。
  2. 選択領域の右下角にマウスを移動し、カーソルが、+の形状になったらALTキーを押しながら、下方向または右方向の入力したいセルにドラッグします。


オートフィル機能を使って繰り返しパターンを入力する(テキストまたは数値データ)には、

  1. データパターンを含む連続したセルを選択し、選択領域の右下角にマウスを移動します。
  2. 選択領域の右下角にマウスを移動し、カーソルが、+の形状になったら、CTRLキーを押しながら、下方向または右方向の入力したいセルにドラッグします。


LabTalkスクリプトを使用してデータを作成することも可能です。例えば、

  1. 新規ワークシートを作成し、ウィンドウメニューのスクリプトウィンドウを選択して開きます。以下のスクリプトコードをコピーして貼り付けます。
  2. col(1)={0:0.01:4*pi};
    col(2)=sin(col(1));
  3. これらをハイライトしてEnterキーを押して実行します。ワークシートの1、2列目にデータが入力されます。

列値の設定

Origin 2022では、より簡単な組み込み関数へのアクセスが可能です。

  • 値の設定ダイアログおよびF(x)=セルで自動補間機能をサポートしました。入力を始めると利用可能な関数のリストが表示されます。
  • 値の設定ダイアログの関数メニューから開ける関数の検索ダイアログが、メインメニューのツール:関数の検索を選択することで直接開けるようになりました。

値の設定ダイアログでは、一つ以上のワークシートデータ列へのデータ作成、またはデータの変換を行うことができます。このダイアログボックスには、メニューバー、出力範囲の定義に使用するコントロール、LabTalk関数を検索して式に挿入するツール、1行の数式を定義する列式ボックス、データの前処理や列式で使用される変数の定義を意図した 実行前の処理スクリプトパネル(任意で使用)、および Pythonユーザーの場合、式で使用できるPython関数を定義および使用するためのPython関数タブが含まれています。

SetValues.png

Origin 2017から、値の設定にある計算式のボックス(上部のボックス)は、MS ExcelとGoogleシートのようなスプレッドシートセル表記をサポートしています。セルはショートネーム+行インデックス番号の使用してアドレス指定されます(例えば、列Aの第一セルは以前は"col(A)[1]"でしたが、"A1"で示されます)。

新しいワークブックでは、スプレッドシートセル表記はデフォルトで有効になっています。スプレッドシートセル表記は、列の計算式を定義する場合のみ利用できます。これは、「列値の設定」の実行前の処理スクリプトパネルでもLabTalkスクリプトでも利用できません。「古い」列とセル表記は「スプレッドシート」モードでも機能し、古い表記法に慣れていてこれを使いたい場合は、いつでも入力できます。スプレッドシートセル表記や以前の方法については、列式のサンプルを参照してください。

単一列の値の設定ダイアログボックスを開くには:

  1. ワークシート列を選択するか、ワークシート列のセルの範囲を選択します。
  2. メニューから、列:列値の設定を選択するか、選択した列で右クリックして、ショートカットメニューから列値の設定を選びます。


複数列の値の設定ダイアログボックスを開くには:

  1. ワークシートで連続した複数列かすべての列を選択します。
  2. メニューから、列:複数列値の設定を選択するか、選択した列で右クリックして、ショートカットメニューから複数列の値を設定を選びます。
SetValues Multiple.png

値の設定メニューコマンド

メニューコマンド
  • 計算式:計算式入力ボックスに、保存した計算式の情報をロードします。計算式の保存は、計算式:保存または計算式:名前を付けて保存を使用します。
  • wcol(1):計算式内や、実行前の処理スクリプトにワークシート列を含めるときに使用します。正しく列を選択するために、列ブラウザを利用できます。列は列インデックスにより、リストされます。
  • Col(A):wcol(1)メニューの似ていますが、列名を使用したリストが表示されます。
  • 関数: OriginのLabTalk関数を挿入するために使用します(カーソルの場所に関数が挿入されます)。メニューリストないの関数上にマウスを置くと、ステータスバーに関数の説明が表示されます。関数を選択すると、スマートヒントに関数の説明が表示されます。

Origin 2022では、値の設定の式入力時の自動補間機能をサポートしました。入力を始めると利用可能な関数のリストが表示されます。

  • 変数: 計算式実行前の処理スクリプトに変数、定数、範囲変数(選択も可能)やファイルのメタデータを挿入します。
  • オプション:ワークシートの数式行で計算式の直接編集を可能にし、式についてのコメントを追加や、値が設定された列のテキストを保存(テキストを欠損値として扱わない)保持するなどのオプションを利用できます。
列の計算式
  • データ生成のために計算式を1行で入力します。関数、条件演算子、変数を使うことができます。
実行前の処理スクリプト
  • LabTalkスクリプトを入力することができ、列の計算式編集ボックスの計算式を実行する前に実行します。
Python関数

値の設定ダイアログの関数メニューに表示される、関数の上にマウスカーソルに移動すると、ステータスバーに関数の概要が表示されます。関数を選択すると、スマートヒントにより詳細な説明と関数のシンタックスやサンプルなどへのリンクが表示されます。

また、関数の検索と挿入ボタンSearch Insert Functions.pngをクリックすると、キーワードで利用可能な関数を検索して挿入できます。


詳細は、列値の設定 - クイックスタートを参照してください。

F(X) = ワークシート列ラベル行

簡単な式であれば、F(x)= 行を使用して列の値を設定できます。ここで入力した数式は、値の設定ダイアログに直接入力されます。値の設定の計算式で使用できたスプレッドシートセル表記は、F(x)=でも使用できます。

  1. F(x)=列ラベル行のセルをダブルクリックして、
  2. 式を入力して、データ列に結果を出力します。
Fx column label row.png

Origin 2022では、数式バー、セル式(=記号から入力)、F(x)=セル、2022ダイアログで関数名前付き範囲自動補間をサポートしています。表示されるヒントは関数のドキュメント(関数の場合)またはデータ範囲(名前付き範囲の場合)にリンクされています。

UG autocomplete open help.png

自動補間機能を非表示にしたい場合は、システム変数@FAC=0を設定すると無効にできます。

列値の設定チュートリアル

チュートリアル1:F(x)= を使った単位変換

  1. 新しいワークブックを開き、\Samples\Graphing\WIND.DATをインポートします。
  2. B列に「速度」の値が、毎時mile(MPH)の単位で入力されているとします。列Cの列ヘッダを選択してから、右クリックしてから挿入を選択します。新規に列Cを挿入し、「力」の値を列Dに移動します。
  3. 列BにあるMPHの値を毎時kmの単位に変更します。列CのF(x)=セルでダブルクリックして、
    B*1.6を入力してから、
    Enterキーを押します。列Cの値の単位は、KPHになります。


チュートリアル2:移動平均と移動標準偏差を算出する

  1. ファイルSamples\Signal Processing\fftfilter1.DATをインポートします。
  2. Button Add New Columns.pngを二回クリックして、ワークシートに2列追加します。
  3. 3番目の列のヘッダをクリックし、右クリックして開くコンテキストメニューから、列値の設定を選択します。
  4. 値の設定ダイアログが開いたら、上部パネルに以下を入力します。
    movavg(B,5,5)
    適用ボタンをクリックします。列3には、2列目のデータに対する11ポイントの移動平均の値が入力されます。(movavg のような関数は、値の設定ダイアログの関数メニューから挿入できます)
  5. >>ボタンをクリックして、4列目の編集ボックスに切り替えます。
  6. 4列目の編集ボックスで以下の式を入力します。
    movrms(B,5,5)
    OKボタンをクリックします。これにより、4列目には、各点で11のウィンドウサイズを使用した平均平方の平方根(RMS)の値が入力されます。


チュートリアル3:複数列の値を同時に設定する

  1. 標準ツールバーの新規プロジェクトボタンButton New Project.pngをクリックして、新しいプロジェクトを作成します。
  2. 複数ASCIIのインポートボタンButton Import Multiple ASCII.pngをクリックして、<Origin フォルダ>\Samples\Import and Export\ のパスにあるF1.datとF2.datをインポートします。impASCダイアログで複数ファイル(第一以外)インポートモードブックを新たに作って読み込むにしてOKをクリックします。
  3. 2つのワークブック、F1とF2が作成されます。標準ツールバーの新規ワークブックボタン New Workbook.pngをクリックし、もう1つワークブックを作成します。
  4. 3番目のワークブックがアクティブな状態で、列の追加ボタン Button Add New Columns.pngをクリックします。ワークシートのすべての列を選択し、列: 複数列の値を設定とメインメニューから操作するか、右クリックして複数列の値を設定をコンテキストメニューから選択して値の設定ダイアログを開きます。
  5. スクリプトを表示ボタンButton Show Scripts.pngをクリックして下部パネルを拡張します。次のスクリプトを実行前の処理スクリプト編集ボックスに入力します。
range r1=[F1]F1!wcol(j); //"j" is the column index.
range r2=[F2]F2!wcol(j);
  1. 列の式編集ボックスに(r1+r2)/2 と入力します。
  2. オプション:式セルを直接編集の項目のチェックを外します。
  3. オプション:式テキストと選択して、式テキストダイアログに(F1+F2)/2を入力してOKボタンをクリックします。
  4. 値の設定ダイアログでOKボタンをクリックします。結果がワークシートに反映され、F(X)=列ラベル行には式では無くて(F1+F2)/2 が表示されます。

セル値の設定

Origin 2022では、セル式での関数および名前付き範囲自動補間機能を追加しました。

バージョン2018より、Originは他のスプレッドシートプログラムと同様、セルレベルの式をサポートしています。セルレベルの式は、ワークシートデータセルまたは、列ラベル行のユーザパラメータ行のセルに式を入力して値(数値、文字列、日時など)を出力できます。編集モード(編集: 編集モード)が有効な時はセル式が表示されます。編集モードが無効の時は、式の結果が表示されます。編集モードに関係なく、セルの内容は編集できます。

Set Cell Values 1.png
  • セル式を利用可能にするには、必ずワークブックのスプレッドシートセル表記を有効にする必要があります(デフォルト設定)。
  • セル式は、イコール記号から始まります(例:=B1 - C1)。
  • セル式は、数値、文字列、日時データを返すことができます。
  • セル式には、セル参照、変数、演算子、LabTalkサポート関数、定数を組み込むことができます。
  • セル式は、他のシートまたはブックの値を参照できます。
  • セル式は、マウスでドラッグして他のセルに拡張できます。


詳細は、式を使ってセル値を設定を参照してください。

数式バー

Origin 2022では、数式バーでの関数および名前付き範囲自動補間機能を追加しました。

セルまたは列の数式を作成する場合(F(x)=を使用)、数式バーを使用すると、関数の検索と挿入、セル範囲の選択、式の表示と編集、特にセル幅を超える長い式の表示と編集が簡単になります。

UG Formula Bar UI.png


セル(データセルまたはF(x)=)に式を入力するには、セルをクリックしてから、次の操作を行います:

  1. =」を入力して式を入力します。または、FB FunSel.pngボタンをクリックして関数の検索と挿入ダイアログを開きます。
  2. 目的の関数を検索し、ダブルクリックして数式バーの式に挿入します。
  3. ワークシートのデータ範囲を選択するには、(a)列ヘッダをクリックするか、(b)ドラッグしてセルの範囲を選択します。
  4. 式が完成したら、FB OK.pngボタンをクリックするか、Enterキーを押します。

数式バーの端をドラッグしてサイズを変更できます。デフォルトのフォントサイズを変更するには、 LabTalkシステム変数の値を変更します @FBFS (デフォルトでは「130」です)。

セル値の設定チュートリアル

チュートリアル1: セル式を他のセルに拡張

  1. 新規ワークブックボタンButton New Workbook.pngをクリックし、新しいワークブックを作成します。
  2. 列Aのヘッダをクリックして選択し、右クリックして列値の一律設定: 行番号を選択します。
  3. B1セルをクリックして次のように入力します。
    =A1+A$1
  4. ENTERキーを押します。A1の値にA1の値を足した結果が出力されます。
  5. セルを選択した状態のまま、セルの右下の角にカーソルを移動し、アイコンが+の形に変化したらダブルクリックすると、セルの計算式が列の下まで拡張されます。
  6. 列の追加ボタン Button Add New Columns.pngをクリックして、新しい列Cを追加します。
  7. C1を選択し、ここでは次の式を入力します("$"を省略)。
    =A1+A1
  8. ENTERキーを押します。A1の値にA1の値を足した結果が出力されます。
  9. セルを選択した状態のまま、セルの右下の角にカーソルを移動し、アイコンが+の形に変化したらダブルクリックすると、セルの計算式が列の下まで拡張されます。すると結果の値が異なることがわかります。
  10. メニューから編集: 編集モードを選択すると、実際のセル式が表示されます。列Bの"$"は、2番目のセルA1 参照が他のセルでも変更されないように「ロック」しています。しかし、列Cでは省いたため、他のセルにセル式を拡張したときに変更されてしまったことがわかります。
Extending cell values.png

チュートリアル2: "This"を使って複数列をまたがって最大値を素早く検索

ワークシート列ラベル行(ワークシートヘッダ行)でセル式を使用できるのは、ユーザパラメータのみです。

  1. 新しいワークブックを作成し、メニューからデータ:ファイルからインポート: 単一ASCIIファイルを選択して\Samples\Import and Export\S15-125-03.datをインポートします。
  2. F(X)= 行ヘッダの左側にマウスカーソルを移動し、右向き矢印のアイコンに変化したら右クリックしてユーザパラメータの追加を選択します。
  3. 開いたダイアログボックスで、"MaxValue"と入力してOKをクリックします。
  4. A列MaxValueセルに次式を入力します。
    =Max(This)
  5. Enterキーを押すと、「10」が表示されます。
  6. 再度このセルをクリックして選択し、セルの右下角にカウスを移動してアイコンが変化したらクリックして右にドラッグし、セル式をB(Y)C(Y)D(Y)列のMaxValueセルに拡張します。全てのMaxValueセルに各列の最大値が表示されます。

チュートリアル3: セル式で列ラベル行の値を使用

ユーザパラメータ行を含むワークシート列ラベル行のすべてのデータは文字列として格納されています。列ラベル行の値を数値としてセル式で使用するには、文字列を数値に変換する必要があります。次のサンプルでは、LabTalk関数value()を使って列ラベル行データを数値に変換し、セル式で使用できるようにします。

  1. 新しいワークブックを作成し、メニューからデータ:ファイルからインポート: 単一ASCIIファイルを選択して\Samples\Import and Export\S15-125-03.datをインポートします。
  2. F(X)= 行ヘッダの左側にマウスカーソルを移動し、右向き矢印のアイコンに変化したら右クリックしてユーザパラメータの追加を選択します。
  3. 開いたダイアログボックスで、"Correction"と入力してOKをクリックします。
  4. 列DのCorrection行に0.2を入力します。
  5. 列の追加ボタン Button Add New Columns.pngをクリックして、新しい列Eを追加します。
  6. E1セルに次のように入力します。
     =D1+value(D[Correction]$)
  7. ENTERキーを押します。Correctionの値が数値に変換され、D1セルの値と加算されます。このセルには101.9と表示されます。


NOTE: 上述の"$" の式は、最初の散布図のように絶対セル参照を作成するようには機能しません。このコンテキストでは、文字列を数値に変換する前に、"$"構文を使用して、ユーザーパラメータセルの文字列変数を表現します。

データ範囲の名前付け

Origin 2022から、データ範囲に名前を付け、セル式列式で名前を使用したり、グラフの参照線を定義できます。


名前付き範囲を作成

UG named range dialog.png
  1. セルまたはセル範囲を選択して、データ:名前を定義を選択します。
  2. 新しい名前ダイアログで、選択範囲(参照範囲)につける名前を入力します。
  3. 名前付き範囲にスコープを設定します。
  4. オプション:名前付き範囲を使用して補間値を返す場合は、関数として定義にチェックを付けたえい、コメントを追加できます。


名前付き範囲の管理

  1. ワークシートをアクティブにして、データ:名前の管理を選択します。
  2. このダイアログで、名前、スコープ、範囲、コメントを修正できます。
UG named range manager.png

ワークシートデータを操作

Originには、データ操作のためのユーティリティが用意されています。ほとんどの機能はワークシートメニューにあり、それ以外は編集解析メニューにあります(ワークシートがアクティブでないと表示されません)。ショートカットメニューから利用できるユーティリティもあります。データを選択して右クリックします。

操作 メニュー操作
  • データのソート

カテゴリー順でワークシートデータをソート

ワークシート: ソート(領域)
ワークシート: ソート(列)
ワークシート: ソート(ワークシート)
ワークシート: ソート(ラベル)

  • 検索
  • 置換
  • 行にジャンプ

シートや列選択状態で利用可能なミニツールバーの検索ダイアログOrigin 2022で改良されました。

MT Find Button.png

編集: プロジェクト内を検索 編集: シート内を検索

編集: 置換

編集: 行にジャンプ

  • 列を隠す
  • 行を隠す

列:列を隠す/隠さない

行を隠す/隠さない(ショートカットメニューのみ)

  • 列の移動
  • 列の交換

列:列の移動またはツールバー

列: 列の交換

  • ワークシートデータの抽出

ワークシート:ワークシートクエリ

  • 列を別の場所にコピー

ワークシート: 列のコピー

  • ワークシートの追加

出力ワークシートのデータの前にデータセット識別子を挿入するオプション

ワークシート: ワークシートの追加

  • ワークシートを結合する

Origin 2022では、列列でワークシートを結合する機能が新しくなりました。このダイアログでは、1つ以上の一致する列で2つのワークシートを結合します。不一致や倍数を削除する、すべての組み合わせを一致させる、一致した列を1つに統合する、といったオプションを利用できます。

出力ワークシートのデータの前にデータセット識別子を挿入するワークシートをラベルで結合するオプション

ワークシート:列でワークシートを結合する
ワークシート:ワークシートをラベルで結合する

  • 列データの分割
  • ワークシート分割
  • ワークブックの分解

ワークシート:列データの分割

ワークシート:ワークシートの分割

ワークシート:ワークブックの分解

セルの文字列を複数列に分割

メニューなし。ダイアログボックスを開くには

  1. ウィンドウ:スクリプトウィンドウ を選択します。
  2. text2cols -dを入力してEnterを押します。


詳細は、このリンクをご覧ください。

  • 複数の列をスタックする
  • 複数列にアンスタックする

ワークシート:列スタッキング

ワークシート:列アンスタッキング

  • ピボットテーブル

ワークシート:ピボットテーブル

  • 1列、または複数列に、ある定義条件によってフィルタリング

列:フィルタメニューまたは、ワークシートデータ操作ツールバー

参考: データマスク操作

  • データ削減

ワークシート: 重複行の削除
ワークシート: 列の削減
ワークシート: 行の削減
解析: データ操作: データ削減:重複X
解析: データ操作: データ削減:クラスタX
解析: データ操作: データ削減:等間隔X

  • ワークシート転置

ワークシート:データ転置

  • ワークシートデータ変換

XYZ形式に変換行列に変換

  • 条件付きフォーマットをワークシートセルに適用する

ワークシート:条件フォーマット:ハイライト
ワークシート:条件フォーマット:ヒートマップ
ワークシート:条件フォーマット:重複検出

  • 逆順

列:列の反転

ワークシートデータの条件フォーマット

上記のワークシートデータユーティリティに加えて、Originワークシートは条件フォーマットをサポートしています。条件フォーマットには3つのモードがあります。

  • ハイライトモードでは、1つまたは複数の条件(「等しい」、「等しくない」、「含まれるテキスト」など)に基づいてワークシートセルに色を適用するコントロールを含むダイアログボックスが開きます。
  • 重複検出モードでは、重複した値を含むワークシートのセルに適用するコントロールを含むダイアログボックスが開きます。
  • ヒートマップモードでは、ワークシート値に基づいてセルにカラーマップを適用するためのコントロールを含むダイアログボックスが開きます。ワークシートのヒートマップはズームおよびスクロール可能なので、3次元のデータ変動の概要を簡単に把握できます。
US Temperature Data wMap Overlay.png

条件フォーマットマネージャを使ってアクティブシートの条件フォーマットを管理します。

3色限定混合を使用してワークシートヒートマップの色を塗る場合、中央の色の位置を指定できるようになりました。パーセンタイルによる、パーセントによる、によるから指定します。

分析とレポートのためのワークブック

テキストおよび数値データの他に、ワークブックにはさまざまな種類の情報を含めることができます -- 画像、グラフ、ノート、行列;他のワークブックセルの値へのリンク、プロジェクト変数、ドキュメント、ウェブページ;さらにはインポートファイルのメタデータ、変数やスクリプト -- などです。これらの要素により、ワークブックを研究データを収集したり、カスタムレポートを作成するための柔軟な媒体として利用できます。

さらに、ワークブックは複雑な一連の分析操作を「格納」することができます。例えば、適用されたデータフィルタ、フィルタリングデータのフィット操作、カスタマイズされた結果のプロットなどを、分析テンプレートというものに格納します。分析テンプレートを使用すると、新しいデータを入力するだけで、結果のカスタムレポートを自動的に生成することができます。


Custom worksheet report.png

レポートを生成するための選択肢の1つ は、カスタムMS Wordテンプレート、あるいは、PDFファイルへのデータエクスポートです(他の方法は、このセクションの一番下にあるヒントを参照してください)。これはOriginで分析の結果出力を実行し、Wordテンプレートのブックマークに関連する結果を構成して、ワークブックを分析テンプレートとしてワークブックを保存します。レポートを作成するには、バッチ処理ツールを開き、分析テンプレートとWordテンプレートの両方を選択してバッチ処理を実行し、レポートを作成します。

  • MS Wordテンプレートを使用したカスタムレポートを作成するための情報はチュートリアルのWordテンプレートを使ったバッチ処理を参照してください。
  • バッチ処理についての詳細な情報については、バッチ処理の項目の、「繰り返し処理の方法」の章を確認してください。
Word report template PDFout.png

レポート作成のほかのオプションとして、Originのノートウィンドウを使ってHTMLレポートを作成することもできます。ノートウィンドウは、直接またはプレースホルダシートを使用して、グラフ、ワークシートセルなどにリンクできます。詳細は、ノートウィンドウからHTMLレポートを作成をご覧ください。

ワークシートのセルにメモを挿入し、マウスカーソルをあわせると内容を表示できます。セルを選択し、ノートウィンドウで開くミニツールバーボタンをクリックすると、ノートウィンドウでメモを編集できます。

2022 CellNotes.png

参考