Originのインターフェース

Originのワークスペース

このセクションでは、Originワークスペースの基本要素と機能について簡単に説明しています。以前からOriginをご利用の場合は読み流してください。

GSB Origin Interface.png

Origin 2022bでは、ウィンドウのサイズとワークスペース内の位置は、さまざまな表示に対応するように自動調整されます。これにより、すべてのウィンドウやダイアログボックスのサイズを変更/再配置しなくても、例えば、ノートPCと高解像度モニターで表示を統一できます。再スケール動作を制御するためのシステム変数@SRWS0 =以前の動作、1 =幅を合わせ、yをスケール、2 =高さを合わせ、Xをスケール、3(デフォルト)=幅と高さを合わせる)が追加されました。

2: 高さを合わせ、XをYスケールでスケーリング;

3(デフォルト) : 幅と高さを合わせる;

Windowsファイルエクスプローラでのプレビュー

Originインターフェイスの一部ではありませんが、Windowsファイルエクスプローラ(以前のWindowsエクスプローラ)を使用して、プロジェクトファイル内のグラフをプレビューできます。

Interface Windows Explorer2.png
  • Windowsエクスプローラのまたは特大(ファイルエクスプローラで右クリックし、表示:大アイコンまたは特大アイコンを選択するか、エクスプローラの表示メニューから選択)アイコンで、プロジェクトファイルが保存されたときにアクティブなグラフのイメージを表示します。
  • プレビューウィンドウを開き(ALT + P)、スクロールすると、プロジェクトファイル内の全てのグラフがプレビューできます。
  • グラフプレビューをファイルに保存したくない場合(アイコンビューまたはエクスプローラーのプレビュー表示)、LabTalkシステム変数@PESS=0または=-1に設定します。システム変数の値を変更する方法については、FAQ-708 システム変数を永続的に変更するにはにあるシステム変数の変更を参照してください。

Originのメニューとメニューコマンド

  • 状況依存型のメニューバーとメニュー:メニューバーやメニューの内容は、アクティブなウィンドウの種類(グラフやワークブック、行列など)に依存し変化します。ウィンドウに対して適切なメニューのみ表示されます。
  • メニューのアイコン、ツールバーボタン、ショートカットキーへのアクセス:一部のメニューコマンドには、コマンドの左側にアイコンが付いています。さらに、メニューコマンドの右にショートカットキーの組合せがあります。ボタンアイコンとショートカットキーは、同じ機能を開くためのそれぞれ別の方法です。
  • ショートカットメニューコマンド:多くのコマンドをショートカットメニューから利用可能です。ショートカットメニューを開くには、操作を実行したいオブジェクト上(ワークシートウィンドウ、グラフの軸、テキストオブジェクトなど)で右クリックします。適当なメニューコマンドのみ表示されます。
  • 折りたたみメニューデフォルトで、Originのメインとショートカットメニューは「折りたたみ」で、コマンドの折りたたみ設定で表示されています。メニュー外の項目を使用すると、その項目はメニューに追加されます。開いたときにすべてのメニューを表示する場合は、環境設定:オプションをクリックし、その他タブをクリックし、メニューの折りたたみの利用のチェックボックスをオフにします。
  • 最近よく使われたメニューコマンド:最近よく使われたメニューコマンドは、解析メニューの下に表示されています。 (ワークシート, 分析, 統計, イメージ, etc.).これにより、繰り返し操作をする際に、ツールをすぐに利用できます。
  • カスタムメニューオーガナイザ:Origin 8.1より、カスタムメニューオーガナイザを使用して新しいメニューを作成したり、組込メニューを非表示にすることができます。詳細情報は、Originのカスタマイズの章をご確認ください。

Originのツールバー

ツールバーのカスタム化ダイアログボックス(表示:ツールバー)で、ツールバー表示をカスタマイズしたり、ツールバーを初期化したりできます。

  • ツールバーボタンの外観表示をカスタマイズする:ツールバーのカスタム化ダイアログボックスのオプションタブでツールバーの表示を設定できます。
  • ツールバーのドッキングとフローティング:ツールバーは、ツールバーの領域からドラッグして切り離し、ワークスペース上でフローティングにすることができます。フローティングにする場合、マウスカーソルをツールバーの左側に移動します。カーソルの表示が4方向の矢印に変わったら、マウスでドラッグし、ツールバーから切り離します。ツールバーを元の位置に戻すには、ツールバーのタイトルバーをダブルクリックします。
  • ツールバーの表示/非表示:ツールバーの閉じるボタンをクリックすると非表示にできます。非表示にしたツールバーを、表示するには、ツールバーのカスタム化ダイアログボックスを開き、表示したいツールバーを選択します。
  • ボタンの表示/非表示:ツールバーの終わりの小さい矢印をクリックして、ツールバーのボタンのオンとオフを切り替えます。
  • ボタン位置の移動Altを押しながらボタンをドラッグして、新しい位置やツールバーの間にそのボタンを移動します。Altを押しながら空白のワークスペースにドラッグして、新しいツールバーを 作成します。Altを押しながらボタンを子ウィンドウにXが表示されるまでドラッグして、ボタンを削除します。

ミニツールバー

OriginLabは、一般的なオブジェクトとタスクのため、ミニツールバーのサポートを改善し続けています。これらのツールバーは、がオブジェクトを選択したとき、または、ページ内の特定の領域をクリックしたときに表示されます。利用できる設定項目は、コンテキスト(オブジェクト、ウィンドウタイプなど)に依存します。

UG interface mini toolbars.png
  • ミニツールバーを使用する前に、メインメニューの表示:ミニツールバーjにチェックがついている(デフォルト)ことを確認してください。
  • ツールバーを表示するには、データプロット、テキストラベル、ワークシートセルなどのオブジェクトを選択します。
  • さらに、より一般的なページレベルおよびレイヤレベルのカスタマイズ用のツールバーがあり、これらのツールバーはウィンドウの余白の近くにカーソルを合わせると表示されます。マウスカーソルがこのようなものUG sheet toolbar cursor 2.pngに変わると、これは、この場所をクリックすると、関連するツールのミニツールバーが表示されるという合図です。
UG sheet toolbar cursor.png
  • ほとんどのミニツールバーには、より複雑な設定(グラフウィンドウの作図の詳細ダイアログボックスなど)にアクセスできるプロパティボタンButton MT Properties.pngがあります。
  • カーソルを移動したり、十分な速さで操作しないと、ミニツールバーは消えてしまいます。消えたミニツールバーを再度表示するには、SHIFTキーを押します。
  • ミニツールバーにボタンを追加または削除するには、ツールバーの中央下にある3つのドットをクリックします。これによりミニツールバーのカスタマイズダイアログを開くので、必要に応じてボタンを有効または無効にできます。
UG customize mini toolbar dialog.png

Origin 2022bより前のバージョンでは、表示:ミニツールバーの設定はセッション間で記憶されておらず、例えば、現在のセッションでオフにした場合も、Originの再起動時に復元されていました。現在は、セッションが変わっても変更されないようになりました。また、システム変数@DMT (ON=0; OFF=1)を使ってミニツールバーの表示を制御可能です。

スタートメニュー

検索ツールボックスにキーワードとフレーズを入力して、メニュー項目、アプリFAQsビデオXファンクションを検索します。最近使用したファイルメニューアプリを開きます。

(1)F1を押すか(他のダイアログが開いていないとき)、(2)Originワークスペースの左下隅にある虫眼鏡アイコンをクリックする、またはメインメニューの(3)ヘルプ:スタートメニューをアクティブにする項目をクリックしてスタートメニューを開きます。

Start menu result.png

検索範囲を絞り込むには、検索語句の前に次の文字を入力します:

m = メニュー項目のみ検索
a = アプリのみ検索
h = ヘルプとFAQのみ検索
v = ビデオのみ検索
x = Xファンクションのみ検索
p = 最近使用したプロジェクトを検索
s = サンプルプロジェクトを検索
e = メニュー、アプリ、Xファンクション(実行可能なもののみ)を検索

その他の方法

検索ボックス付近の「歯車」アイコンをクリックして設定ボックスを開きます。ここでは、検索結果を制限し、他の検索設定を調整することができます。

Start menu settings.png

スタートメニューから直接アプリを検索してインストールできます。UG start menu install apps.png

ラーニングセンター

ラーニングセンターは、グラフ作成と解析のサンプルに加えて、学習リソース(チュートリアル、ビデオ、OriginLabブログなど)にすばやくアクセスできるようにすることを目的とした「スタートアップ」ダイアログです。

  1. このダイアログを開くには、ヘルプ: ラーニングセンターを選択するかF11キーを押します。
  2. Originが起動するたびにこのダイアログを表示または非表示にするには、開始時に表示チェックボックスをオンまたはオフにします。

ORG-14520-75PC.png

  • グラフを再作成するためのサンプルデータとメモを含んだサンプルのグラフを選択してロードします。
  • データ付きの分析サンプルをロードします。
  • チュートリアルやビデオ、Origin Blog、User Forum、Originソーシャルメディアページへのリンクについては、ラーニングリソースタブを参照してください。
  • これまでのUser Filesフォルダから、新しいUser Filesフォルダにファイルを移動します。


Origin 2021bの新しいグラフ形式を確認するには、ラーニングセンターを開き、グラフサンプルタブをクリックして、フィルタドロップダウンですべてのプロットタイプ を選択し、2021b を検索します。

プロジェクトエクスプローラ

プロジェクトエクスプローラ(PE)は、Originのプロジェクトファイルを効率よく、整理・管理するためのツールです。

PE window features2.png

プロジェクトエクスプローラは2つのパネルを持ちます。第一パネルではOPJのフォルダ構造を表示します。サブパネルには、メインパネルで強調表示されているフォルダに含まれるウィンドウが表示されます。


プロジェクトエクスプローラを使ってウィンドウを管理する

  • プロジェクトエクスプローラのタイトルバーを右クリックするかドロップダウンメニューをクリックして、垂直方向の表示(上下積上げ)か水平方向(隣合う)の表示か選択できます。
  • 両方のパネルで、右クリックして開くコンテキストメニューから、削除、非表示、印刷などのオプションを選択できます。表示されるメニューは、どの項目で右クリックしたかに応じて変化します。
  • ShiftキーやCtrlキーを押しながらクリックして、サブパネル内に表示されたウィンドウの複数選択が可能です。
  • サブパネルで、ウィンドウ表示を変更:詳細 (デフォルト), リスト, 小さいアイコン, 大きいアイコン, 特大アイコン
  • どの表示でも、マウスカーソルを移動すると、ウィンドウアイコンがグラフ、ワークスート、行列、レイアウトウィンドウのプレビューを表示します。ウィンドウコントロールはツールチップに表示されます。
PE Preview on Hover.png

Origin 2022bでのプロジェクトエクスプローラの改良:

  • サブパネルを右クリックし、Ctrlキーを押してプレビューを表示を選択してチェックマークを付けることで、ポップアッププレビューの表示を制御します。チェックを付けると、ポップアップはCtrlキーを押したときのみ表示されます。
  • サブパネルのフォルダ表示にチェックを付けると、フォルダサイズが表示されます。
UG show folder size PE.png
  • 特大アイコンでウィンドウを表示した場合、PEサブパネルにグラフ、レイアウトウィンドウ、ワークブック、行列ブックのサムネイルが表示されます。ウィンドウコントロールはツールチップに表示されます。
PE XLicons and tooltip3 600.png

Origin 2018以前のバージョンでは、PEのサブパネルは上パネルで選択されたフォルダ内のサブフォルダを一覧表示していました。表示モードを戻すには、システム変数@PEF = 1の設定をします。

PEフォルダ(上のパネル)を右クリックしてコピーを選択するか、またはフォルダを選択してCTRL+CとCTRL+Vを実行して、現在のプロジェクト内の別のフォルダ、または(b)2番目のOriginセッションで実行中の別のプロジェクトにフォルダ構造と内容をコピーして貼り付けます。単一のワークブックウィンドウをコピーするには、ウィンドウ(下パネル)を右クリックしてコピーしてから(a)同じプロジェクト内の別のフォルダ、または(b)2番目のOriginセッションで実行中の新しいプロジェクトに貼り付けます。

  1. ヘルプ: フォルダを開く: プログラムデータフォルダを選択して、Samplesサブフォルダをクックし、Tutorial Data.opjをOriginワークスぺースにドラッグします。
  2. デフォルトでは、プロジェクトエクスプローラはOriginのワークスペースの左端にドッキングされ、自動非表示モードになっています。プロジェクトエクスプローラタブ上にマウスを移動すると、ウィンドウが開きます。
    PE tab mouseover.png
  3. プロジェクトエクスプローラのタイトルバー上にある画鋲のアイコンをクリックして、このウィンドウを指定の位置にドッキングします。
    PE tab pushpin.png
  4. デフォルトでは、サブパネルは詳細表示モードになっています。この表示では、名前サイズコメント、といったウィンドウのメタデータが表示されます。列ヘッダをドラッグして、順序を変更してみましょう。
    PE headings.png
  5. 列ヘッダで右クリックしてそれぞれの項目のチェックによって、表示/非表示を切り替えできます。
    PE hide show headers.png
  6. コメント欄でコメントを追加するには、一度クリックし、一息おいて2回目のクリックをします。これにより編集モードになります。コメントを入力します。
    PE add comments.png
  7. ウィンドウの名前を変更するには、行で右クリックして名前の変更を選択します。名前欄ではデフォルトでウィンドウのショートネーム、ロングネームが存在する場合はロングネームを表示します。(全てのウィンドウはショートネームを持ち、ロングネームはオプションです)。編集可能な名前フィールドの右側にあるSNまたはLNボタンをクリックして、ショートネームまたはロングネームを編集します。ロングネームがない場合、入力できます。
    PE rename.png
  8. プロジェクトエクスプローラの上部パネルで、3D Surface with Point Labelフォルダにスクロールし、クリックします。サブパネルはフォルダ内の3つのウィンドウを表示します。ワークシートウィンドウeastcali3053は太字で表示され、アクティブなウィンドウであることを示します。アクティブウィンドウは操作されているウィンドウで、使用可能な操作を決定します。また、ノートウィンドウとMBook4行列ウィンドウがあります。
    PE active window.png
  9. サブパネルでMBook4をダブルクリックすると、太字表示になり、アクティブウィンドウである"halo"が表示されます。ウィンドウ全体(ワークスペース内)には、システム変数 -@AWCで色をカスタマイズすることができるハローが表示されます。これは、これが「アクティブ」ウィンドウであることを示す別のインジケータです。MBook4アイコンを再度ダブルクリックすると、アイコンが淡色表示されます。ワークスペースから実際のウィンドウがなくなります。これはMBook4が非表示になったからです。MBook4を再度ダブルクリックすると、ウィンドウが復元され、アクティブになります。
    PE window hidden.png
  10. Mbook4をアクティブにして、作図:をアクティブにして、作図> 3D: 曲面: 3カラーマップ曲面をクリックします。これで3Dカラーマップ曲面を作成できます(確認メッセージは閉じます)。新しいウィンドウGraph1がプロジェクトエクスプローラのサブパネルに表示されます。
  11. サブパネルの空いている部分を右クリックして、表示モード: より大きいアイコンを使用を選択します。Graph1がサムネイル表示になります。
    PE XLarge Icons.png
  12. また右クリックして表示モード: 大きいアイコンを選びます。ウィンドウはアイコンで表されるようになりますが、アイコン上にマウスを置くと、ウィンドウの内容がポップアップとして表示されます。
    PE large icon popup.png

PEのプレビューを無効にする場合、スクリプトウィンドウ(ウィンドウ:スクリプトウィンドウ)を開き、次のいずれかまたは両方を入力してから、テキストを選択状態にしてEnterキーを押します。

@PESS=-1; // PEでウィンドウプレビューをオフ、ウィンドウコメントをツールチップとして表示 @PESH=0; //ウィンドウコメントツールチップをオフ

スクリプトウィンドウを使って、システム変数値を設定する場合、現在のセッションのみでOriginの仕様を変更します。システム変数値がセッションをまたぐように設定するには、FAQをご確認ください。

アプリセンターとアプリギャラリー

アプリは、特別なグラフ作成や分析タスクを行うためのアドオンアプリケーションです。科学技術分野で広く適用されるいくつかのアプリは、Originソフトウェアに事前インストールされています。
LaTeX apps gallery.png

アプリセンターダイアログを利用して、Originアプリを検索したりアップデートやダウンロードを行えます。この新しいダイアログでは、ブラウザを開くことなく、OriginLabのファイル交換の場のすべてのアプリケーションに直接アクセスできます。
Interface App Central.png

アプリセンターを開くには、Originのワークスペース右側にあるアプリギャラリー内のアプリの追加ボタンをクリックします。アプリギャラリーがないときは、表示: アプリ(またはALT + 9)をクリックして、アプリの横にチェックマークがあることを確認します。

  • アプリセンターでは、インストール済みで最新のアプリには緑のチェックマークのアイコンが表示されます。 AC OK Icon.png
  • インストール済みで、新しいバージョンがあるアプリには更新アイコンが表示されます。 AC Update Icon.png
  • インストールされていないアプリは、ダウンロードとインストールアイコンが表示されます。 AC Download Icon.png

Originの統計解析: フィット解析: ピークと基線メニューには、アプリ検索メニューが含まれます。アプリ検索をクリックすると、アプリセンターが開き、統計などのメニューに関連するアプリのみを表示します。アプリセンターから直接アプリのダウンロードや更新か可能です。

アプリギャラリーを使ってインストール済みのアプリにアクセスしたり管理できます。

Origin 2022bからの新機能

アプリの新しい/更新バージョンは、OriginおよびOriginProユーザーが継続的に利用できます。F10キーを押してアプリセンターを開いてください。赤い今すぐダウンロードボタンが表示されている場合は、クリックして利用可能なアプリの最新リストを取得してください。

Check Apps Update.png

アプリについての詳細は、www.originlab.com/appsを参照してください。

オブジェクトマネージャ

オブジェクトマネージャは、ワークスペースの右側に開く、デフォルトで接続可能なパネルです。オブジェクトマネージャを使ってアクティブグラフまたはワークブックウィンドウに対して素早い操作が可能です。


グラフウィンドウ

  • オブジェクトマネージャの要素(レイヤ、プロットグループ、データプロット、特定ポイント)を選択して、グラフウィンドウで対応する要素とvice versaを選びます。選択すると、(a)グラフレイヤ内の他のすべてのプロットも薄暗くなり、(b)ワークシートのソースデータが選択されます。
Object manager highlight.png
  • オブジェクトマネージャはグラフオブジェクトビューとプロットビューを切り替えできるようになりました。表示モードを切り替えるには、オブジェクトマネージャの何もない領域を右クリックして「プロットを表示/グラフオブジェクトの表示」を選択するか、Ctrl + Shift + Sキーを押します。
UG OM objects vs plots.png
  • プロジェクトマネージャ内の対応するチェックボックスにチェックを付ける、または外して、プロットまたはグラフオブジェクトを非表示/表示にします。
Object manager hide element.png
  • グラフレベルで、オブジェクトマネージャのリスト順を変更(描画順またはその逆の見た目の順
  • レイヤレベルでレイヤ順変更
  • プロットレベルでは、ラベルの表示、プロットの表示または非表示、プロットの並べ替え、またはプロットグループの作成を行います。
  • プロットグループ(gNと表示)内で、プロットのグループ化を解除し、ドラッグまたはショートカットメニューコマンドでプロットの順序を変更し、プロットタイプを変更します。
  • グラフウィンドウからプロットを永久に削除します。
  • プロット詳細, レイヤコンテンツプロットセットアップダイアログボックスにアクセスします。
  • レイヤアイコン上で右クリックして、プロットを逆順に並べるを選択


ワークブックと行列ウィンドウ

オブジェクトマネージャは、ワークブックと行列における特定の操作もサポートしています。

  • アクティブワークブックまたは行列内のシートをリスト表示します。
  • Ctrlキーを押しながら上/下矢印を押して、複数のシートをすばやく選択します。
  • オブジェクトマネージャでシートをクリックして、ワークブックまたは行列中の対応するシートをアクティブにします。
  • オブジェクトマネージャで右クリックして、削除挿入追加移動コピー複製といった一般的なワークシート操作にアクセスできます。
  • オブジェクトマネージャで行列または仮想行列を右クリックして名前変更できます。


UG UI OM workbook.png


レイアウトウィンドウ

レイアウトページがアクティブなとき、オブジェクトマネージャのショートカットメニューコマンドをつかってオブジェクトを一覧表示し、配置できます。

  • 追加されたグラフや表、テキストオブジェクトなどの全オブジェクトがオブジェクトマネージャで一覧表示されます。
  • チェックボックスにチェックを付ければオブジェクトが表示され、チェックを外せは非表示になります。
  • オブジェクトマネージャで複数オブジェクトを選択してから、右クリックして揃えたり、整列することができます。

Originの子ウィンドウ

アクティブウィンドウ(グラフや解析が実行されるウィンドウ)はアクティブなことを明瞭に示すために、色付きの枠で囲みます。@システム変数 @AWC(color)と@AWI(style)を使用して、アクティブなウィンドウインジケータのプロパティ(フレームの色、フレームのフレームスタイルを示すフレームラインスタイル)をカスタマイズできます。

Active window halo.png
  • ワークブック:Originのワークブックは、データのインポート、管理、分析、演算、プロットのためのフレームワークを提供しています。ワークブックは、ノートブックのような構造になっており、最大1,024枚のシートを持つことができます。各シートは65,000列で100万行以上のデータを含めることができます。 データに加え、ワークブックウィンドウは、グラフ、注釈、関数を基にした列、スクリプトやプログラミング可能なボタンオブジェクト、LabTalk変数やインポートフィルタなどを保存することができます。
  • 行列ブック:ワークシートのように、行列シートは行と列で整列したセルのグリッドです。ワークシートの場合、各列はデータセットで、さまざまな形式のデータ(文字列、文字と数値、数値 (倍精度、double)、数値 (単精度、int)など)を含めるように設定できます。それに対して、行列は、XY平面上の行(Y) と列(X) のインデックス番号で並んだ数値のZデータ 1つを含みます。行列ブックは、最大1,024枚のシートを持つことができます。各シートに複数の行列オブジェクト(最大65,504)を含めることができます。
  • グラフ:グラフウィンドウは作成したグラフの主要コンテナです。Originは、科学技術系のさまざまな分野で利用可能な100種類以上のグラフをサポートしています。これらのグラフは、組込みテンプレートか、ユーザが編集したテンプレートを基に作成されます。データプロットに加え、グラフには注釈(テキストと描画オブジェクト)または、トリガによって、グラフ化または分析タスクを実行するボタンオブジェクトを付加することができます。グラフウィンドウはワークシートセルに挿入またはワークシート上に貼り付け(セルグリッドの外側も含む)できます。
  • イメージ:イメージウィンドウは、ラスター画像とビデオ(.avi、.mov、.mp4)をインポートおよび表示、編集するためのウィンドウです。
  • 関数グラフ:関数グラフは、関数で記述される曲線を表示する特別なグラフウィンドウです。関数グラフは他のOriginグラフと異なり、離散値のデータセットから作成されていません(作図後にデータを生成することはできます)。
  • レイアウトページ:レイアウトウィンドウでは、グラフウィンドウとワークシートを組み合わせて並べ、表示することができます。また、レイアウトウィンドウのレイアウト表示パネルにさまざまな注釈を付けることができます。これは主にプレゼンテーション資料を作成するために使用します。
  • Excelワークブック:ExcelワークブックをOrigin内で開いたり、作成することができます。ワークブックは、Originのプロジェクトファイルの一部として、またはプロジェクトファイルとは別に保存することができます。
  • Note: ノートウィンドウは、プレーンテキスト、リッチテキスト、HTML、およびMarkdownをサポートしています。分析手順の記録、学生や同僚へのメモの作成、他のアプリケーションからのテキストの切り取りと貼り付けといった簡単なタスクに使用できます。または、HTMLレポートや数式など、高度にフォーマットされたテキストをレンダリングするためにも使用できます(次を参照)。

ノートウィンドウでLaTeXKaTeXの両方がサポートされ、高度にフォーマットされた数式をレンダリングできるようになりました。

KaTeX Notes window.png
Note:子ウィンドウについての詳しい情報は、以下で確認できます。

ヘルプ:Origin:Originヘルプ > Originの基本 > Originのワークスペース > 子ウィンドウ の作成

ヘルプ:Origin:Originヘルプ > Originの基本 > Originのワークスペース > 子ウィンドウの基本操作



Originプロジェクトファイルとは独立してOriginの子ウィンドウを保存するには:

  • ファイル:ウィンドウの新規保存...を選択して、アクティブウィンドウを保存します。ファイル拡張子OGW(U), OGG(U), OGM(U)は、それぞれOriginのワークブック、グラフ、行列ウィンドウのものです。
  • ウィンドウタイトルバーを右クリックして、コンテキストメニューの名前を付けて保存...を選択します。

Note:外部のExcelファイルとしてExcelウィンドウを保存するには、Origin内でExcelウィンドウタイトルを右クリックして、コンテキストメニューからワークブックの新規保存...を選択します。

Origin 2018 でUnicode (UTF-8)対応のOriginプロジェクト、子ウィンドウ、テンプレートを追加しました。ウィンドウファイルを保存する場合、ファイル形式名にuが付くものと付かないもの(*.opj または *.opju)から選択できます。最新バージョンのOriginでのみファイルを使用する場合は、パフォーマンス上のメリットがあるため、Unicode対応(u付きのファイル形式)オプションを選択します。


ファイルに保存したワークシート、グラフ、行列、ノートウィンドウを開くには、

  • ファイル:開くを選択するか、標準ツールバーの 開くボタンButton Open.pngをクリックして、ウィンドウファイルを開きます。
  • ファイル: 最近使ったブック, ファイル: 最近使ったグラフを選択して、最近保存したワークブックとグラフウィンドウファイルを開きます。

Note: Originでは、ウィンドウショートネームロングネームコメントをサポートしており、ショートネームはOriginプロジェクトでユニークである必要があります。ウィンドウショートネームが、すでに使われている名前であれば、名前を付け直します。現プロジェクトでウィンドウファイルを開き、プロジェクトを保存すると、ウィンドウはプロジェクトに含まれます。


Excelワークブックファイルを開くには

OriginでExcelファイルを操作する場合は、あらかじめ、Originヘルプファイルのこのセクションをご確認ください。

  • ファイル:Excelを開く...を選択して、外部Excelファイルを開きます。または、標準ツールバーのExcelを開くボタンか、メインメニューのデータ:ファイルからインポート:Excel (XLS, XLSX, XLSM)...を選択してExcelファイルをインポートします。

NoteExcelを開くを選択すると、Originの内部でExcelのセッションが起動して、Excelファイルが開きます。このモードでは、使用できるOriginの機能は限られます。データ:ファイルに接続:Excelまたはデータ:ファイルからインポート:Excelを選択した場合、Excelファイルは、Originのワークブックにインポートされるので、Originの全ての機能を使用することができます。

子ウィンドウの整列

これまでは子ウィンドウを重ねて並べたり上下/左右に並べるといった基本的な配置機能のみ利用できましたが、Origin 2022bでは、新しいウィンドウ整列ツールが追加されます。高解像度モニタを使って多くのウィンドウを使用して作業しているようなユーザには役に立つツールです。

ウィンドウを整列ダイアログ

この機能の中心となるのは、メインメニューのウィンドウ:ウィンドウを整列を選択して開くウィンドウを整列(winarrange)ダイアログです。

UG winarrange dlg.png

このダイアログを使ってOriginのワークスペース内の子ウィンドウをソートしたり、配置することができます。

  • ウィンドウをいくつの列に分割するか?
  • アクティブにした順、プロジェクトエクスプローラでの順序、またはウィンドウ名(昇順、降順)で並べ替え。
  • ウィンドウタイプ内で並べ替え。
  • 水平(左から右)または垂直方向(上から下)に整列。
  • ユーザーが定義したオフセットで各列(カスケード)を重ねて並べる。
  • 設定をダイアログテーマとして保存
ウィンドウのスナップ

行と列で整列されたウィンドウは「スナップ」できます。これにより、あるウィンドウの端をドラッグすることで同じ行または列にあるウィンドウサイズを変更できます。スナップする際には緑色のバーが表示されます。

  1. ウィンドウ:ウィンドウのスナップ(Ctrl + F12)を使用して、この機能のオフとオンを切り替えできます。
UG snap green bar.png


  • スナップせずに単一のウィンドウのサイズを変更するには、SHIFTキーを押しながらウィンドウの端をつかみドラッグします。
  • ウィンドウのタイトルバーをドラッグしながらALTキーを押すと、2つのウィンドウの位置を入れ替えられます。
  • ウィンドウを空のスペースにスナップするには、Shiftキーを押しながらドラッグします。

コマンドウィンドウとスクリプトウィンドウ

コマンドウィンドウを使用して、OriginにLabTalkコマンドを発行したり、数学的な計算を行ったり、LabTalk変数に対する値を確認することができます。コマンドウィンドウには、あるセッションから別のセッションに持ち越すことができる、タイムスタンプ付コマンド履歴と、Xファンクションコマンドを入力する際に自動修正機能があるインテリセンスが組み込まれています。

コマンドウィンドウは、ドッキング可能なウィンドウで、2つのパネルがあります。左側パネルにコマンド履歴が表示され、右側パネルにはコマンドラインがあります。

スクリプトウィンドウには、コマンドウィンドウと同じ機能があります。コマンドウィンドウの機能の一部(インテリセンス、コマンドプロンプト、コマンド履歴なし)がありませんが、単純なLabTalkコマンドの実行(LabTalkシステム変数の値の変更など)には便利です。ウィンドウのツールメニューで、Originの変数、関数、マクロ、ルースデータセットのリストを表示可能なLabTalk変数と関数ダイアログボックスを開くこともできます。


コマンドウィンドウを開くには

  • 標準ツールバーにある、コマンドウィンドウボタンButton Command Window.pngをクリックします。または、ウィンドウ:コマンドウィンドウを選択するか、[ALT+3]を押します。


スクリプトウィンドウ開くには、

  • ウィンドウ:スクリプトウィンドウを選択するか、[SHIFT+ALT+3]を押します。

数式バー

数式バーは、OpenOfficeやExcelのものと同じように使うことが出来ます。数式バーを使用してセル式を入力する必要はありませんが、関数検索、インタラクティブな範囲選択、および式、特にセル幅を超える長い式の見やすさの向上という利点があります。

UG Formula Bar UI.png
  1. ワークブックがアクティブな状態で、メインメニューの表示:数式バーをクリックして、数式バーの表示と非表示を切り替えます。
  2. フォントサイズを変更するには、 LabTalkシステム変数の値を変更します @FBFS (デフォルトでは「130」です)。


より詳細な情報は、ワークブック、ワークシート、列の章を参照してください。

  • 値の設定ダイアログなどの関数メニューから開ける関数の検索ダイアログが、メインメニューのツール:関数の検索を選択することで直接開けるようになりました。

ステータスバー

The Status Bar-1.png

ステータスバー は、Originのワークスペースの一番下にあります。ステータスバーには、次のようなものが表示されます:

  • ヘルプメッセージとツールの説明
  • 現在のワークブック、行列、グラフの中のデータ選択部分の統計量
  • 自動更新分析機能が利用可能かどうか
  • 設定していれば、システムテーマ
  • アクティブウィンドウに関連した情報
  • 角度の単位(ラジアン、度、グラジアン)
  • 値の設定ダイアログの関数メニューにある関数の説明
  • ステータスバーの右側に小さな赤い旗で示されるOriginLabからの情報
    The Status Bar-2.png


ステータスバーデータの設定とコピー

  • ステータスバー上で右クリックして開くコンテキストメニューで、バーに表示する項目を選択できます。
  • ステータスバーに表示された統計情報は、右クリックして開くコンテキストメニューから統計をコピーを選択してコピーできます。コピーすると、名称と値はTABで区切られ、それぞれの値は改行コードで区切られます。

スマートヒントとスマートヒントログ

スマートヒントは、ユーザー行った操作に関するヘルプを提供するものです。これらのヒントは次の例のようにダイアログの中で、短い時間表示されます。

Smart Hint1.png



または、スマートヒントは次の例のようにOriginのワークスペースの左下角に表示されます。

Smart Hint2.png


カーソルをヒントの上に移動しない限り、ヒントはすぐに消えます。スマートヒントログの下部にある「次回からメッセージを出さない」ボックスにチェックをいれると、各ヒントの表示を消すことができます。

現在のOriginセッションのヒントはログとして保存されているので、Originのワークスペースの端にドッキングされていスマートヒントログタブをクリックすると表示できます。(注意:ダイアログ内のヒントは、ログが残りません。)

Smart Hint3.png


スマートヒントログウィンドウを開く(閉じる)には次の操作を行います。

  1. Originのメニューから、ウィンドウ:スマートヒントログを選択するか、[ALT+7]を押します。

現在のセッション内で特定のヒントを非表示にするには、スマートヒントログウィンドウ内のヒント上で右クリックして、コンテキストメニューからこのヒントは再度表示しないを選択してチェックを入れます。「このメッセージを表示したいか、ログに残したいか」を聞かれます。

スマートヒントの表示をオフにするには、スクリプトウィンドウを開き、以下のコマンドを実行します。

@SHS = 0;

個別に非表示に設定したものを含め、スマートヒントを表示させるには、システム変数@SHS = 1 にセットし、メニューからヘルプ:全てのヒントの復活

スクリプトウィンドウを使って、システム変数値を設定する場合、現在のセッションのみでOriginの仕様を変更します。システム変数値がセッションをまたぐように設定するには、FAQをご確認ください。

コードビルダ

Origin Cの統合開発環境 (IDE)をコードビルダといいます。コードビルダは、Origin Cのプログラムを記述したり、コンパイルしたり、デバッグするためのツールを提供します。さらに、Pythonコードの実行とデバッグに使用できます。

コードビルダを開くには

  1. Originメニューから、表示:コードビルダを選択するか、標準ツールバーのコードビルダボタンButton Code Builder.pngをクリックするか、ALT + 4を押します。
  2. コードビルダは、接続:新規untitled.pyをクリックして開くこともできます。このモードでは、CTRL + F5を押して、Pythonコードを貼り付けて実行できます。

メッセージログ

メッセージログ ウィンドウは動作に関するメッセージ(出力、結果、エラーを含む)を表示します。スクリプトウィンドウコマンドウィンドウに表示されないメッセージを表示します。


メッセージウィンドウを開く(閉じる)には次の操作を行います。

  1. メニューから、表示:メッセージログを選択するか、[ALT+6]を押します。

結果ログ

Originは、多くの分析やフィッティングの結果を自動的に結果ログに書き出します。結果ログの各項目には、日時スタンプ、ウィンドウ名、ユリウス暦の数値スタンプ、実行した分析の種類、結果が含まれます。

通常、結果がレポートされたり、結果ログに出力されると、結果ログは自動的に開きます。手動で結果ログを開いたり、閉じたりするには :

  1. 「標準」ツールバーの結果ログボタンButton Results Log.pngをクリックします。あるいは、メニューから表示:結果ログを選択するか、ALT+2を押します。


結果ログの内部で右クリックすると、 コピー印刷クリア全てのフォルダ内の結果表示が可能です。

ウィンドウのフロート/ドッキングと自動非表示

フローティング、ドッキング、自動非表示、非表示といったOriginのウィンドウがいくつかあります。これらのウィンドウは、 プロジェクトエクスプローラ結果ログコマンドウィンドウメッセージログを含みます。この機能により、スクリーンサイズ大までOriginのワークスペースをカスタマイズ可能です。

数値の扱いについて

  • 表示されるセルの値と実際のセルの値:ワークブックや行列ブックにデータをインポートしたり、入力するとき、Originは、ユーザが設定した方法で、各セルのデータを表示します。しかし、その表示は単にデータ値の見かけ上の表示であり、実際のデータ値は、データセットのデータ型(下記の表を参照)によって完全な精度で保存されています。計算を実行する際には、表示している値ではなく、実際の値(内部値)が使われます。
  • コンテンツがセル幅を超える場合: Origin 2020bより前のバージョンでは、シートセルの文字シーケンスが現在のセル(列)幅で表示できる文字数を超える場合、Originは記号(######)を表示します。これは、MS Excelのワークシートの動作と同じように変更されました。
  • テキスト文字列は、列の幅に関係なく######の表示をトリガーしません。文字列全体を表示するには、列幅を広げる必要があります。
  • 列幅を超える数値は、最初に最も近い10進数に丸められ、それが完全な整数値を表示するのに十分でない場合に限り、数値の代わりに######が表示されます。
  • この数値の丸めは、表示上のものです。内部に保存された値は変更されません。
  • セルの内容が完全に表示されなかった場合に、######を表示するという以前の動作に変更するには、システム変数@WPE = 1を設定します。システム変数の値を変更する方法については、このFAQを参照してください。
  • ワークシートの欠損値:表計算プログラムが最初にリリースされた頃から、実際の数値ではない特殊な値-欠損値-を計算の中で扱う必要性が知られていました。Originでは、欠損値の値として内部的にある数値(-1.23456789E-300)を割り当てています。Originは、これを特別な値として認識しているので、ワークシート(や行列シート)に欠損値を入力するのに使われ、計算やスクリプトに使用することができます(例えば、条件が満たされない場合に欠損値を返す)。Originはワークシートまたは行列シートの欠損値を " -- "として表示します。ただし、この表示(出力)と入力した値(入力値)を混同しないでください。
  • 10進数、指数、工学表記:Originは、 10進数:1000指数:1E3工学:1k10進数:1,000の形式でワークシートや行列データを表示します。指数表記を使ったデータをワークブックまたは行列ブックに手動で表示させるのではなく、あるしきい値を超えたときに、その値の表示オプションを変更し、数値を自動的に指数表記で表示するように設定できます。デフォルトで、これらの指数表記のしきい値は、それぞれ 6 乗(上限) および -3 乗(下限)に設定されています。
  • 日付と時刻:天文学のユリウス暦番号に基づいて、Originの長年の数学的なシステムは12時間のオフセットをしています。このシステムは、1月1日-4712(1月1日紀元前4713年)、グリニッジ標準時12時間をゼロとして定義します。近年のバージョンで、Originは2つの代替時間システムを提供しています:(1) 真のユリウス暦の値(0は真夜中の午前0時ではなく正午)、(2) 0は2018年1月1日00:00と定義されている「2018」システム。たとえば、インポートウィザードでデータをインポートすると、2018システムはより高い精度をサポートします(例:カスタム日付フォーマットは "MM'/'dd'/'yyyy HH':'mm':'ss'.'######」 の形式をサポートします)。以前は、精度は0.0001秒に制限されていました。詳細は、Originの日付と時間をご覧ください。
Note: 数値の詳細については、次のヘルプを確認してください。

ヘルプ:Origin:Origin ヘルプ > Originの基本 > Originのワークスペース > 数値の扱いについて


Originのワークブックと行列ブックは、次のデータ型をサポートしています。

ワークブック 行列ブック バイト長 値の範囲

double

double

8

±1.7E±308 (15ケタ)

real

float

4

±3.4E±38 (7ケタ)

short

short

2

-32,768から32,767

long

int

4

-2,147,483,648 から 2,147,483,647

char

char

1

-128 から 127

byte

char, unsigned

1

0 から 255

ushort

short, unsigned

2

0 から 65,535

ulong

int, unsigned

4

0 から 4,294,967,295

complex

complex

16

±1.7E±308 (15ケタ)、それぞれ8バイト

参考