OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis                     
 

12 Customizing Graphs


Grand image customizing graphs3.png

Introduction

This chapter introduces you to various aspects of graph customization. All Origin graphs start from a graph template. If the graph you are making is fairly standard for its type, the options that were stored in the graph template may be entirely adequate to produce a polished-looking graph. The business of basic graph creation was covered in the last chapter, Graphing.

Sooner or later, however, you are going to want to add annotations, modify axis scales, or change plot colors. Hence, the purpose of this chapter is to introduce you to some key Origin graph customization tools and techniques, as well as to point you toward resources that will help you manage more complex graph customization tasks.

We begin with a discussion of the graph customization-related toolbars, as these toolbars have tools that are commonly used for quick modifications of graph elements.

Toolbars

Toolbar buttons useful for graph-customization tasks:

Description Toolbar
(default configuration)
Format toolbar buttons:
  • Creating and customizing text objects.
Format bar.png
Style toolbar buttons:
  • Editing colors, line thickness, fill patterns.
Style bar.png
Tools toolbar buttons:
  • Add text objects, lines, arrows, rectangles/circles/polygons.
Tools bar.png
Graph toolbar buttons:
  • Add graph layers incl. inset graphs, merging or extracting graphs; exchanging axes; anti-aliasing and Speed Mode.
Graph toolbar 92.png
Add Object to Graph toolbar buttons:
  • Add legends/color scales/bubble scales; date & time and project path stamps; XY scale; table objects.
Add Object to Graph Toolbar.png
Object Edit toolbar buttons:
  • Arranging and aligning objects and layers on the page.
Object Edit bar.png

Menus and Dialog Boxes

Many graph customizations are initiated via commands on the the Graph menu. Options for customization are explained in the sections below.

The following table lists key dialog boxes used for customizing graphs:

Task Dialog Name Method
Customize the graph Page, Layer, or Data Plot
  • Plot Details dialog
  • Double-click on Page, Layer or Data Plot
  • Format: Page Properties... menu
  • Format: Layer Properties... menu
  • Format: Plot Properties... menu
Customize Axes
  • Axis Dialog
  • Double-click on axes or tick labels
  • Format: Axes... menu
  • Format: Axis Tick Labels... menu
  • Format: Axis Titles... menu
Add or Customize Legend
  • (Text Object -) Legend dialog
  • Update Legend dialog
  • Legends/Titles tab at Page level of Plot Details dialog
  • Ctrl + double-click on the legend object text
  • Right-click legend and choose Legend: Update Legend or choose Graph: Legend: Update Legend...
  • Double-click on the legend plot symbol
Merge multiple graph windows into one graph window
  • Merge Graphs dialog
  • Graph: Merge Graph Windows... menu
Layer level customizations: resize, move, swap, align, or add layers
  • Layer Management dialog
  • Graph: Layer Management... menu
Save settings as graph template
  • Save Template As dialog
  • File: Save Template As... menu
  • Right-click graph window title and choose Save Template As...
Manage graph templates, add plots to a template
  • Template Library (custom graph templates)
  • System Templates (built-in graph templates)
  • Plot > Templates: Template Library menu
  • Plot > Templates: System Template Library menu
Save settings as graph Theme
  • Save Format as Theme dialog
  • Right-click and choose Save Format as Theme... context menu
Manage Graph Themes: edit, combine, apply Theme, set as System Theme
  • Theme Organizer dialog
  • Tools: Theme Organizer.. > Graph tab.
  • F7 hotkey.

Customizing Page, Layer and Data Plots

A graph window is a collection of objects, organized in a hierarchical structure. As we shall see, there are editable properties at the page, layer and data plot levels.

Quick formatting of some graph properties can be done using toolbar buttons, as mentioned above. However, the vast majority of properties are customized via Origin's Plot Details dialog box. To open Plot Details, (1) double-click on your plot or (2) click the Format menu, then choose Page Properties, Layer Properties or Plot Properties.

The figure below shows an example of the Plot Details dialog box:

  • The left panel depicts the Page > Layer > Plot hierarchy as an expandable/collapsible tree.
  • The right panel contains controls, organized by tabs, that pertain to the object that is currently selected in the left panel.
  • To customize an object, select it in left panel and modify the corresponding properties that appear on the various tabs in the right panel.
    PD customizing graphs 2.png

Selected Left Panel Object Right Panel, Controls for...
Page Print/Dimensions, layer drawing orders, page display color, legends/titles.
Layer Layer background colors, layer size and speed mode settings, layer display settings, stack settings for applicable plot types. Some plot types will include extra tabs/controls specific to the plot type.
Data Plot Plot specific properties. The tabs and controls are pertinent to the plot type.
Data Point Point specific properties. Available for some plot types. The tabs and controls are generally similar to those available at the Data Plot level.


You can UNDO customizations made in the Plot Details dialog box. Click OK to close Plot Details and choose Edit: Undo Modify Page or press CTRL + Z.


:PD customizing graphs 1a.png

Prevent text and label objects from scaling when resizing layer, by going to the Display tab of Plot Details (at the Layer level) and setting Fixed Factor to 1.

Origin 2018b adds a Layer tab at the Page Level in Plot Details. Use controls on this tab to customize a graph layer and contained plots, then apply those customizations to other layers and plots in the page. This is particularly useful for modifying the appearance of stack or panel graphs. Previously, for instance, if you wanted to customize a 9-panel graph you had to customize each panel individually. Now, you can apply multiple customizations to all plots, simultaneously. For more information, see The (Plot Details) Layer Tab.Plot Details common diisplay.png

Customizing Grouped Plots

When you select and plot multiple data ranges to a single graph layer, the plots are grouped in the layer. By default, plots within a group are automatically differentiated by cycling through customizable increment lists, one for each plot property (symbol shape, symbol color, line style, etc.). These increment lists are saved with the graph template (.oggu) or Theme file (.oth) so that you can easily recreate graphs with the same look.


:PD Group tab 2015.png

The above image shows the Plot Details Group tab settings for a line + symbol plot in the upper-left. The first column lists Line Color, Symbol Type, Line Style Symbol Edge Color and Symbol Interior. Line Color, Symbol Type and Symbol Edge Color are set to increment By One Between Subgroups (grouping occurs using the column Long Name), while Line Style and Symbol Interior are set to increment by None (they do not vary).

This arrangement is completely customizable and you can save customizations with the graph template:

Starting with Origin 2018b, you can use the Object Manager to group or ungroup data plots in the layer. If plots are grouped, ungroup by right-clicking on the group icon ("gN") and choosing Ungroup. To group plots in the layer, right-click on a plot and choose Set as Group Begin.

OM group ungroup.png

Customizing Individual Data Points

For some plot types such as scatter and column, you can modify the display properties of a single data point. This is another plot customization that happens via the Plot Details dialog box.

To edit a single point:

  1. Press the CTRL key and double-click on the data point in the graph. This opens the Plot Details dialog box with the focus set to edit this data point. The data point will be identified in the left-panel of Plot Details by its row index number. # Use the controls on the tabs in the right panel to modify the appearance of the data point. Changes you make to the appearance of this point will not affect the appearance of other points in the same plot.
PD point-edit mode.jpg

Alternately, when the Custom Construction box is checked, you can use these controls to customize the symbol.

PD point-edit mode ALT.jpg

To remove customizations made to a single data point:

  • Right-click the single point in the left panel of the Plot Details dialog and choose Delete.
  • In the graph window, click on the single point to select it, then press DELETE on the keyboard.

The point properties revert to those of the containing dataset.

Customizing Graph Axes

Most graph axis customizations are made via the Axis Dialog box. Double-click on the graph axis or tick labels to open the Axis Dialog - Layer N dialog box.

This image shows the tab-based axis dialog used by most 2D and 3D graphs.

Axis dialog box.png

In earlier versions of Origin, you had to customize each layer's axes from separate Axis dialogs. Starting with Origin 2017, you can switch layers inside the Axis dialog using the Layer drop-down at the bottom of the dialog box.

In the left panel, you can select one or more icons (hold the CTRL key to select multiple icons) to specify the axis or axes to be customized, then select the desired tab and choose your options.

Tab Controls for
Scale Scale range of values, scale type, rescale mode and margin, reverse scale, major and minor ticks.
Tick Labels Display and format options for major and minor tick labels, including custom labeling by formula.
Title Axis title (often set using variable notation) and font options. Note that you can directly edit by double-clicking the text object in the graph.
Grids Control display and properties of grid lines at major and minor ticks.
Line and Ticks Global axis line and tick display options for all axes.
Special Ticks Placement of special tick labels.
Reference Lines Placement of reference lines and "recession bars" (shaded areas with transparency, that can be added on top of the data plot).
Breaks Enable line breaks and configure each break.

Click the Apply To... button to apply the axis format settings of the currently selected axis to another axis.

Note: For more information on axis customization and for axis controls for specialized graph types (e.g. polar, ternary, radar chart.etc), refer to:

Help: Origin: Origin Help > Graphing > Graph Axes

Graph Legends

How the Default Legend is Created

A graph legend is automatically created when you plot data. For 2D and some 3D graph templates, Origin creates a default legend that combines (A) plot style information stored with the graph template, with (B) dataset information stored in the worksheet column label rows, and places the resulting legend object on the graph page.

Customizing Graphs Default Legend.png


The default legend object is created using LabTalk script. The reason for this is:

  • The legend object is able to incorporate identifying information such as data that has been entered into the worksheet column headings (entered manually or automatically added on file import).
  • The legend object is dynamically linked to the plotted data so that the legend can be updated when data are added or removed from the graph. The substitution notation becomes visible when you double-click inside of the legend object (as if to edit it).
    Auto Creation of Legend.png

The notation used for legend texts is controlled by the Translation mode of %(1), %(2) list in the Legends/Titles tab of the Plot Details dialog box (Format: Page Properties...). Custom formatting of the notation(s) is supported.

Graph Editing Tips

  • If you do not want a legend automatically added to your graph each time you create the graph, delete the legend object and save the graph template.
  • Right-click the legend object for some useful controls such as Reverse Order, Show Legend for Visible Plots Only, and Hide Legend for Fitted Curves.
  • Select the legend object; then press CTRL while dragging a selection handle to change the layout of the legend (e.g. drag horizontally to create a legend that is all on one line).
  • Ctrl + double-click on the legend text to enter in-place edit mode (for overwriting legend text).
  • Double-click the legend text to open the Legend dialog box.
  • Double-click a legend symbol to open the Plot Details dialog box with corresponding plot selected.

Customizing Legends

There are a number of reasons for modifying the default graph legend. We suggest that you look at this topic to see what sort of customizations are supported.

For the standard data plot legend used with most 2D plots (line, line+symbol, bar/column, pie, etc.), customizations are done using the (Text Object) Legend dialog box. To open the Legend dialog box, double-click on the legend text. This dialog gives the best access for line-by-line customization of the data plot legend. Note that there is a separate dialog box for customization of color scales.

  • Ctrl + double-click on the legend text or right-click and choose Properties..... The Legend dialog includes controls for customizing legend text and symbols, legend object frame and background, and associating LabTalk scripts with the legend object.
  • Double-click on the legend symbol or right-click on the graph legend and choose Plot Details. Modify the size, color, line width and data plot symbols associated with each plot.
  • Click on the legend border (if shown) to view border line controls for adjusting padding between the legend entry (symbol + text) and the legend border.

Adding and Updating the Default Legend

The table below lists tasks associated with adding, updating and reconstructing the default legend, and where to find controls for each. Before proceeding, you should know the difference between updating a legend and reconstructing a legend:

  • Updating will preserve any previous customizations, including size and position adjustments and legend symbol and text customizations.
  • Reconstructing will overwrite previous customizations, defaulting to legend settings stored in the graph template.
  • The graph template stores a Legend Update Mode setting that determines how the legend is refreshed when adding or removing data plots from the graph. For more information, see Legend Update Mode.


Task Method (graph is active)
Add or reconstruct legend
  • Graph: Legend: Reconstruct Legend menu.
  • Reconstruct Legend button Button New Legend.png (Add Object to Graph toolbar).
  • CTRL+L.

Note: Customizations made to an existing legend will be lost when you use these commands.

Update legend Open the legendupdate dialog box:
  • Graph: Legend: Update Legend menu.
  • Right-click on legend and select Legend: Update Legend.
Advanced legend customizations Right-clicking the legend object provides several advanced options to customize the graph legend. Applies primarily to:
  • Categorical data plots.
  • Box charts.
  • Legends constructed point-by-point.
Add color scale Only available for color-mapped plots (e.g Contour Plots).
  • Click the Add Color Scale button Add color scale button.png (Add Object to Graph toolbar).
  • Right-click in the layer and select New Color Scale.
  • Graph: New Color Scale menu.
  • For multiple color-mapped plots with different color scale in one graph, click on each plot to select it and add corresponding color scale.
Control color scale Available when a color scale object is added to a graph. To open the Color Scale Control dialog:
  • Double click on the color scale object.
  • Right-click on the color scale object and choose Properties.
Add bubble scale Available for bubble plot, or when symbol size is controlled by a dataset.
  • Select Graph: New Bubble Scale.
  • Right-click in the layer and select New Bubble Scale.
  • Click the Add Bubble Scale button Button Add Bubble Scale.png in the Add Object to Graph toolbar.
  • Right-click the legend to select Add Bubble Scale from the context menu.
Control bubble scale

Available when bubble scale object is added to a graph. To open the Bubble Scale Control dialog:

  • Double click on the bubble scale object.
  • Right-click on the bubble scale object and choose Properties.

The legendupdate dialog box and the Legend/Titles tab at page level of Plot Details both offer options for incorporating metadata properties such as the Long Name, Comment, User Parameters, etc., in the graph legend. For information on constructing legend text from metadata, see Legend Substitution Notation.

Origin 2018 added an interface tool to manually Add Legend Symbols to the graph legend. Right-click on the legend object and choose Properties. Click the Add Legend Symbol button in the lower-right corner of the dialog box.

Add Legend Symbol.png
Note: For more information on creating and customizing graph legends, see:

Help: Origin: Origin Help > Graphing > Graph Legends and Color Scales

Controlling Legend Update

When a data plot is added or removed from a graph layer, the default behavior is to update the legend. The Legend/Titles tab at the graph page level in the Plot Details provides a Legend Update Mode drop-down to control this behavior.

The default setting Update when Adding only affects the legend display of data plots that are added or removed. Previous legend customizations to existing plots, such as literal text entered manually, will be maintained.

Tutorial: Customize legend and add data plots

  1. Start with a new project in Origin.
  2. Open Windows Explorer and navigate to the subfolder <Origin EXE folder>\Samples\Import and Export\
  3. Shift-select the files S15-125-03.dat, S21-235-07.dat, S32-014-04.dat and then drag-and-drop the files onto an empty Origin workbook. The three files will be imported into three separate workbooks.
  4. Click on one of the workbooks, select the column B, and create a line plot.
  5. Right-click on the legend and select Legend: Update Legend... to open the legendupdate dialog.
  6. Change the Auto Legend Translation Mode drop-down to Custom, and in the edit box that appears below, enter the string:
    @WS, @LD3
    and then press OK to close the dialog box. The legend updates, displaying the sheet name and the third user parameter.
  7. Click on the second workbook, select column B, move the mouse over the right-edge of the column until it changes to Drag and drop mouse.png, and then drag-and-drop this data onto the graph to create a 2nd data plot.
  8. Repeat the procedure with column B from the third workbook. The graph will now display three data plots, and the legend will automatically update to display the identifier for all three plots.
  9. Click on each individual curve and use the Style toolbar to set a different line color for each. The legend will automatically update and display the new line color.

GSB Legend Tutorial.png

Special Legend Types

Origin also has several special legends used with certain graph types. These legends can be customized and updated similarly to the default legend object.

Legend Type Menu Access Used When..
Legend for Categorical Values Graph:Legend:Categorical Values At least one plot attribute (e.g. color, symbol shape.etc) is controlled by data indexing. See the Legend for Categorical Values help page.
Point by Point Legend Graph:Legend:Point by Point The symbol style is controlled by data indexing, or increment list, or color mapping. See the Point by Point Legend help page.
Legend for Box Chart Components Graph:Legend:Box Chart Components The graph is a box chart, or a grouped box chart. See the Legend for Box Chart Components help page.

Annotating Your Graph

Origin 2018 added Unicode (UTF-8) support.

Annotating a graph can be as simple as adding a static text object and formatting it with Format toolbar tools. Or you might add a more complex object that is linked to some LabTalk script that is executed whenever some user-specified event occurs (e.g. object is moved, window is activated, graph axes are rescaled, etc.).

Task Method
Label Data Points
  • Choose Format: Plot Properties, then click the Label tab and select Enable (not available for all plot types).
  • To annotate individual points, see "Annotate a Data Point", below.
Add Text Objects
  • Click the Text Tool Button Text Tool.png button, then click on graph to place object.
  • Right click on the graph and choose Add Text from the shortcut menu.
  • Double click on text to do rich text editing.
Add Layer Title
  • Right-click on graph and choose Add/Modify Layer Title from the shortcut menu to add/modify layer title in active layer.
Add Vertical/Horizontal Line
  • With 2D graph active, use the Graph: Add Straight Line... menu item.
Annotate a Data Point
Add Drawing Objects Use the corresponding toolbar buttons on Tools toolbar. Origin supports:
  • Arrow, Curved Arrow.
  • Line, Polyline, Freehand Draw.
  • Rectangle, Circle, Polygon, Region.
Insert Equation, Word Object, Excel Object, Other OLE Object
  • Insert Equation group on the Tools toolbar.
Insert Image
  • Right click on the graph and choose Insert Images From Files.
Add Table
  • Click the New Link Table Button New Link Table.png button on the Add Object to Graph toolbar and then click on the graph.
  • Right click on the graph and choose New Table from the context menu.
  • Double click the table object to edit and customize the table.
Insert Date & Time Stamp
  • Date & Time Button Date Time.png button on the Add Object to Graph toolbar.
Insert Project Path
  • Project Path Button Project Path.png button on the Add Object to Graph toolbar.
Add Bracket with Asterisk
  • To indicate statistical groupings, click the Add Asterisk Bracket Button Add asterisk bracket.png button on the Add Object to Graph toolbar. Manually adjust the size and placement of brackets by dragging handles on the object.
Add XY Scale This is useful when using a nonlinear xy scale.
  • New XY Scale button Button Add XY Scale.png and click on a graph layer.
  • Right click on a graph layer and choose New XY Scale from the shortcut menu.

Tips for Editing Your Graph Annotations

  • Pressing CTRL when drawing with the Rectangle Button Rectangle Tool.png or Circle Button Circle Tool.png tools, will draw a square or circle (as opposed to a rectangle or ellipse).
  • Right-click an object and choose Properties... to edit the properties of the text or drawing object and set the default.
  • Use the Format and Style toolbar buttons to quickly modify some plot elements including plot colors and axis title font face or size.
  • For text objects, including the axis titles, you can edit text objects directly in "In-place Edit" mode. Double-click on a text object to edit. Use the Format toolbar buttons to add superscript, subscript, and Greek characters.
  • Do NOT set font size while in "In-place Edit Mode" unless you need to mix font sizes. The correct way to change font size is to click the text object once so that the green selection handles appear, then select font size from the Format toolbar. If you set while in In-place Edit mode, Origin will not indicate the proper font size when you hover on the text object.
  • When you are in In-place Edit mode, you can right-click and choose Symbol Map to insert special characters into your text object.
  • You can insert the contents of a worksheet cell into a text object by copying and pasting the cell contents. While in In-place Edit mode in the text object, right-click and choose Paste or Paste Link from the shortcut menu. Pasted data is static; Paste Linked data is dynamic and will change if the linked cell data changes.
  • Also, when in In-place Edit mode, you can right click and choose Insert Info. Variable... to insert information related to plotted data, into the text object. Since the pasted information is linked to a LabTalk variable value, the inserted data updates if the variable value changes.
  • You can insert variable values into a text object using the LabTalk %, and $ substitution notation by setting the Link to (%,$), Substitution Level to 1 in the text object's Properties dialog box, Programming tab. Right-click on the text object and choose Properties from the shortcut menu.
  • You can use controls on the Programming tab to associate LabTalk script with a text or drawing object (for instance, see Linking Text Labels to Data and Variables). Enter your script in the text box and specify a Script, Run After condition for running the script. Use the Apply to drop-down to set the scope for the script.
  • You can copy a range (of cells) from a workbook and paste it into a graph as a table object. The table object is editable.

Object Attachment and Scaling

When you add a text or drawing object to an Origin graph window, the object becomes part of the active graph layer. This is important because if you resize or delete that graph layer, you could resize or delete the object.

To view or change a text or drawing object's attachment method:

  1. Right-click on a text or drawing object and choose Properties....
  2. Click on the Programming tab and note the object's Attach to setting.
    Object Properties Attachment.png

Though objects remain a part of the layer that was active at the time of their creation, you can manage some object behaviors by changing the object attachment method. An object is attached in one of three ways:

  • Page. When attached to the page, objects are not affected by moving or resizing the graph layer, nor are they affected by a change in axis scales. These objects are still associated with a particular graph layer and they will be hidden or deleted if the layer is hidden or deleted.
  • Layer Frame. Objects that are attached to the layer frame, resize and move with the layer frame, but are not tied to axis scales and, thus, are unaffected by changes in the layer's axis scale values. Objects are hidden or deleted if the associated layer is hidden or deleted.
  • Layer and Scales. Objects are linked to a particular range of axis scale values. If you resize the layer, the object is resized accordingly. If you rescale the axes, the object moves in relation to the visible scale and will disappear from view if the linked axis scale range is not displayed. These objects are hidden or deleted if the associated layer is hidden or deleted.
Note: Each object has a default object attachment method that determines how an object behaves when graph layers are resized. For more information on object attachment methods, see Default Object Attachment Methods.

Grouping, Aligning and Arranging with the Object Edit Toolbar

Object Edit bar.png
You can group text labels and drawn objects so that they move or resize as a unit:

  1. To select objects, press SHIFT + click; or drag out a box around objects using the Pointer Button Pointer.png tool.
  2. To group the selected objects, click the Group button Group button.png on the Object Edit toolbar.
  3. To ungroup objects, click the Ungroup button Button Ungroup.png on the Object Edit toolbar.


You can align text labels and drawn objects using the tools on the Object Edit toolbar:

  1. Select objects to be aligned by holding the SHIFT key while selecting (or drag out a selection box using the Pointer Button Pointer.png tool), then click one of the align objects buttons on the toolbar. Note that objects will be aligned with respect to the first-selected object.


You can bring overlapping objects to the front or send them to the back:

  1. Select the objects that you want to move to the front or the back.
  2. Click the Front button Button Front.png or the Back button Button Back.png on the Object Edit toolbar.
Note: For more information on graph annotations, see your Origin User Guide:

Help: Origin: Origin Help > Graphing > Adding Text and Drawing Objects

You can also use Object Edit Toolbar manipulate graph layers. Selected graph layers respond just like text or drawing objects. Use it to align and set a uniform size for multiple graph layers or to swap layer order.

Arranging Graphs and Layers

Task Method
Merge multiple graph windows into a single graph window.
  • Graph: Merge Graph Windows... menu command

or

  • Merge Graph Windows button Button Merge.png on the Graph toolbar.

Origin 2018b has a new Fitting Layers to Page dialog box that complements the Fit Page to Layers dialog. These dialogs are handy for arranging multi-panel graphs and trimming white space.

Extract data plots in one layer to multiple layers.
  • Extract to Layers button Button Extract To Layers.png on the Graph toolbar. Hint: to preserve your original graph, click the Duplicate button Button Duplicate.png before extracting to layers.
Extract multiple layers in a single graph to multiple graph windows
  • Graph: Extract to Graphs

or

  • Click the Extract to Graphs button Button Extract To Graphs.png on the Graph toolbar.

All layers are extracted to individual graph windows, even if a layer is linked to another layer.

By default, Extracted Layers is set to 1:0, which specifies that all layers be extracted. To act only on certain layers, clear Auto and use the layextract X-Function's comma/colon notation to point to specific layers. The notation 1:0 means starting with layer 1, extract all layers to graphs (0 denotes all). Specifying 1,3:4, for example, tells Origin to extract only the first, third and the fourth layer.

Add, arrange, resize, position, swap, align, or link layers Graph: Layer Management... menu.

Hint: to physically swap inplane positions for layers (don't reassign layer number), use the Layer Management tool's Swap control (Graph: Layer Management,Size/Position tab).

Link graph layers
  • Linked Axes Scales tab, layer level of Plot Details dialog box.
  • Link tab of the Layer Management dialog box.

When linking layers, the child layer must have a higher layer number than the parent layer.

Linked layers can be moved and resized together.

You can link layers' axis scale values to be Straight (1:1) or you can specify a Custom mathematical relationship.

Reorder layers

There are several ways to reorder graph layers (reassign Layer number for each Layer). Learn more about reassigning layer numbers in the mini tutorial below this table.

  • Method 1: Open the Layer Management dialog and click the row header (shown in image below) and drag it up or down to change the Layer order.

Swap area.png

For more information, see the Layer Management tool.

  • Method 2: Enter the following LabTalk script in the Command Window (Window:Command Window), then press Enter to execute.

page.reorder(n,m)

The command changes the nth Layer to the mth Layer.

  • Method 3: Use the Front and Back buttons on the Object Edit toolbar (these buttons work on the active layer as indicated by the graph layer icon Layer icon active.png). Alternately, you can right-click on the graph layer icon and change layer order using shortcut menu commands.


Note: Reordering layers may break layer linking relationships.

Exchange X-Y Axes
  • Graph: Exchange X-Y Axes menu command
  • Exchange Axes button on the Graph toolbar.
Move a plot(s) to another layer
  • Method 1: Open Plot Setup dialog(by selecting Graph:Plot Setup), expand the bottom panel, select a plot and drag it from a layer to another layer.
  • Method 2: Run laymplot -d; (e.g. open the Script Window, type the command and press <Enter>) to open the Move Plot dialog to specify plot(s) to move and a target layer.

You can move a plot by Copying(CTRL+C or Copy Range context menu) and Pasting(CTRL+V or Paste context menu) operations, between different layers or different graphs. Please note, the pasted plot won't be associated with the source data of copied plot, but exists as a loose dataset.

In a multi-layer graph, layer order determines drawing order. The 1st layer is plotted and then 2nd layer is plotted on top of it, and so on. The layer with higher number is drawn on top of the layer with lower number. This is important when plots in one layer overlay plots in another layer. When necessary, you can change layer order to change plot drawing order.

This mini tutorial shows you how layer reassignment works. Use the preview window to see how layer number reassignment affects your graph.

  1. Click Help: Origin Central or press F11.
  2. Click on the Graph Sample tab, set the Samples in drop-down list to Area Plots and double-click on this graph:
    Custom graph layermanage tutorial.png
  3. Activate the graph Area Plot With Horizontal Color Gradient, then click the Extract to Layers button Button Extract To Layers.png on the Graph toolbar. Set both number of rows and columns to 1, click OK, then, click OK again for the page spacing. The green layer is on the top of the yellow layer in the figure. The purpose of this last step was simply to create a two layer graph in which the data in one layer partially hides the data in the other layer. What we will do now is to reorder the layers and set the yellow layer on the top, giving you a better view of the two plots.
    Reorder1.png
  4. Choose Graph: Layer Management... menu, then drag the row header "1" of the Layer1 in the Layer Selection downward under the Layer2 (indicated by a blue line), and click OK.
  5. You can see the yellow layer is on the top now.
    Reorder2.png


Alternate Method: Beginning with Origin 2017, you can use the Front Button Front.png or Back Button Back.png toolbar buttons (located in the Object Edit toolbar, or at the top of Layer Selection box in the Layer Management dialog) to bring a layer forward or push it backwards. Just as with the previous method by dragging row header in Layer Management, this method swaps layer numbers.

You can easily add an inset layer with data by clicking the Add Inset Graph With Data button Button Add Inset Graph With Data.png on the Graph toolbar or Graph: New Layer(Axes): Inset With Data (Linked Dimension) .

You can copy a layer from one graph window to another graph window. Click to select the layer first (a frame shows around the layer). Then press Ctrl+C or right-click and choose Copy. Click on the target graph window, then right-click to Paste.

Note: For more information on merging graphs, see your Origin User Guide:

Help: Origin: Tutorials > Graphing > Layers > Adding and Arranging Layers

Help: Origin : Origin Help > Graphing > Reference > The Merge Graph Dialog Box

Templates and Themes

Origin's flexible Page > Layer > Plot hierarchy, plus an extensive list of editable object properties makes it easy to customize and save your graph settings for repeat use. You can preserve your custom settings in a couple of ways -- either with templates or with Themes. These concepts are introduced below.

Note: For detailed information please refer to Origin Help file, see:

Help: Origin: Origin Help > Graphing > Creating Graphs from Graph Templates

Help: Origin: Origin Help > Customizing Your Graph > Graph Formats and Themes

Templates

Customizations to your graph can be saved to template files for repeat use. For example, you can customize a graph page to add multiple layers, set relationships between layers, modify data plot properties, and then save all of these attributes as a graph template (.otpu) file. You can further specify that the graph template be "cloneable" allowing you to link these graph customizations to dataset Long Name, Short Name or worksheet column index number and quickly re-create your graph with new data.

A few things to note:

  • By default, new, blank 2D graphs are created from the ORIGIN.otpu template. Other graph windows use different templates, saved with a set of customizations pertinent to a specific template.
  • Origin ships with over 100 built-in graph templates. These "system" templates are installed to the Origin software folder. These templates are customizable but you cannot overwrite the template files in your software folder (see next).
  • You can customize and save a system template to the same file name, in your User Files Folder. If the system template was the default template associated with a menu command or toolbar button (e.g. ORIGIN.otpu and the New Graph New Graph.png toolbar button), the customized template becomes the new default template associated with the command or button.
  • To view system or custom graph templates, click Plot (workbook or matrix should be active) and under Templates, choose User or System Templates.
  • You can save a graph template anywhere and with any name that you like -- it does not need to be saved with the name of a system template. However, by saving your templates to your User Files Folder, they will be collected in one, easily-remembered place and from there, they can easily be transferred to your new User Files Folder when you upgrade your Origin software.
Template Library 2016 GSB.png

Themes and Copy/Paste Format

An Origin Theme is a file containing a set of object properties. There are four kinds of Theme files in Origin: graph Themes, worksheet Themes, dialog Themes and function plot Themes. Graph Themes are a collection of properties of different elements in a graph window (e.g. a Theme could be as simple as axis major and minor tick direction settings, a colormap for a plot, or a combination of page dimensions, layer background, axis scales, color palettes used in a plot, etc.).

Themes allow you to quickly change one or more object properties in an existing graph; or to apply a consistent set of properties for all graph windows. For example, you might apply a black-and-white Theme to one of your color graphs in order to prepare it for journal publication; or you could change the font in all of your graph windows to Times New Roman.

The properties that can be saved as a Theme differ depending upon the selected object. At a basic level, it works like this:

  1. Right-click on an object in a graph window, e.g. a plot and choose Copy Format. Depending on what you click on, there may be sub-menu items under the Copy Format shortcut menu, which give you the option as to what exact format to copy.
    • To apply the copied formats to a single graph, right-click on your target graph and choose Paste Format To. Again, this shortcut menu might has some sub-items that limit what to paste. In this way, the formatting option(s) from your source graph should be applied to your target graph.
    • To apply the copied formats to multiple windows in the project, keep the source graph window active and select Edit:Paste Format(Advanced)... from the Origin menu. This opens the Apply Formats dialog box. Here you have the option of editing or selectively applying formats to one or more graph windows in the Origin Project.
  2. You can do the above on-the-fly copy and paste format or you can choose the Save Format As a Theme... shortcut menu item instead of Copy Format, then use Tools: Theme Organizer to apply the Theme in the future.

Theme Organizer

Use the Theme Organizer (Tools: Theme Organizer) to organize and apply Themes to graphs. With this dialog box you can apply a graph Theme simultaneously to multiple graphs in the Origin project file.

To combine multiple Themes in the Theme Organizer dialog box:

  1. Press the CTRL key while selecting multiple Themes, then right-click and choose Combine from the shortcut menu. The shortcut menu in the tool provides an option for editing a Theme, allowing the user to add/delete properties from an existing Theme.


Graph theme organizer.png


  • If you right-click on a graph Theme and save it as your System Theme in the Theme Organizer, then each time you plot a new graph, the System Theme will be applied regardless of the settings that were saved with the graph template.
  • If you don't want a System Theme to be applied automatically to the graph, choose File: Save Template As and make sure the Apply System Theme to Override check box is cleared.
  • You can load a graph Theme in the Export Graph dialog and the Theme will be applied to the exported image file.

Topics for Further Reading

 

© OriginLab Corporation. All rights reserved.