データのインポート

Import grand image4 650px.png

Origin 2019bでデータコネクタと呼ばれる新しいデータインポートの仕組みが追加されました。名前の通り、データコネクタはプロジェクトと外部のソースファイルの間にリンクを作成します。ソースファイルはローカルにあっても、会社のネットワーク上にあってもかまいません。Webサーバ上に置くこともできます。データコネクタは、プロジェクトを保存時にインポートデータを含まずに保存するオプション(ファイルサイズを軽くし、ソースデータへのリンクを維持)と、偶発的な変更または削除操作からデータを保護するオプションをサポートします。データコネクタは、HTMLテーブルJavaScript Object Notation (JSON)データなど、これまで利用できなかったデータソースのインポートをサポートします。 データコネクタは、ドラッグアンドドロッププロジェクトオープン時の自動インポートをサポートします。さらに、OriginLabでは新しいデータ形式への対応を進めています。たとえば、Origin 2021bでは、National Instruments TDMSおよびNetCDFファイル用のコネクタが改善されました。 さらに、新しいThermo Fisher Scientific MSRawFileコネクタを追加しました。


その他のサポートされているインポート方法:

  • OriginLabは、ASCII、CSV、Excel、バイナリファイル、およびMATLAB、pClamp、NI TDM、NetCDFを含む多くのサードパーティ形式向けの、OriginのXファンクション+フィルターベース ルーチンを引き続きサポートしています。これまで使用してきたインポートフィルタやテーマがある場合は、問題なく機能します。
  • コピー&ペーストで、単純に構造化されたデータをすばやくインポートできます(主にワークシートにデータを素早く追加するのに役立ちます)。
  • 複雑なASCII、バイナリ、またはユーザ定義のファイルタイプの場合、インポートウィザードのわかりやすいインターフェイスを使用してファイル内容を確認しながらインポートできます。インポート設定はフィルタファイルとして保存できます。インポートウィザードは、ファイルメタデータを変数に保存したり、データ処理やインポートのためにカスタムOrigin C関数を使用したりするなどの強力な機能をサポートしています。
  • SQLデータベースで作業したい場合、OriginのデータベースコネクタおよびSQLエディタを使って接続文字列やSQLクエリを作成できます。

アップグレードユーザ向け情報

以前のバージョンでは、ファイルメニューにあったインポートルーチンが、最近のバージョンではデータメニューに移動していることに注意してください。Originの最新のデータインポートツールであるデータコネクタがあります。

Import fF Moved.png

データコネクタ

Data Connector General Concept.png

データコネクタは、ローカルまたはwebベースのファイルやページからOriginプロジェクトにデータをインポートするための一般的なメカニズムです。データコネクタは、主に2つのデフォルト(変更可能な)の古いOriginのインポート方法とは異なります。

  • コネクタを介してインポートされたデータは編集がロックされています。これにより、データの整合性が確保されます。
  • コネクタを介してインポートされたデータは、プロジェクトとともに保存されません。これにより、プロジェクトファイルを小さくすることが可能です。


データコネクタは多数の一般的なデータフォーマットをサポートしています。

  • Text/CSV
  • Excel
  • MATLAB
  • Originファイル(プロジェクト、ワークブック、行列)
  • HTML表
  • JavaScript Object Notation (JSON)
  • HDFファイル
  • TDMSファイル
  • NetCDF
  • インポートフィルタ(データコネクタの仕組みでカスタムインポートフィルタを使用)

Origin 2022では、ANSI/IEEE N42.42ファイルのインポートが可能なN42データコネクタが追加されました。

SQLデータベースに接続するには、データベースを参照してください。


データコネクタでデータをインポートする方法

  1. ワークブックをアクティブにして、データメニューをクリックします。
  • ローカルまたはネットワークファイルに接続する場合、ファイルに接続をクリックしてファイルタイプを選択します。
  • 複数ファイルに接続するには、複数ファイルに接続を選択します。
  • Webデータに接続する場合、Webに接続を選択してURLを入力します。

データコネクタについて知っておくべきこと

  • インポートデータのファイルサイズが500kBを超える場合、インポートされたデータとそのデータから作成されたグラフは、デフォルトでOriginファイルとともに保存されません(LabTalkシステム変数@FSEを参照)。インポートされたデータに起因するすべての分析出力はOriginファイルと一緒に保存されます。プロジェクトファイルと一緒に生データを保存しないと、ファイルサイズが大幅に削減され、サイズの大きいプロジェクトを操作するときのパフォーマンスが向上します。
  • 重要:デフォルトでは、コネクタでインポートされたデータ(>500kB)はプロジェクトファイルと一緒に保存されないため、ユーザーはインポートされたデータを保存する必要があるかどうかを常に確認する必要があります。これは、データソースがWebベースであり、制御できない場所に保存されている場合に問題になることがあります。データコネクタ経由でインポートした全データをOriginファイルと一緒に保存したい場合は、データコネクタアイコンをクリックし、保存時にインポートデータを除外の横のチェックマークを外します。各データコネクタを含むブックには、それぞれ独自の除外...チェックマークが付きます。あるいは、データコネクタが必要でないと判断した場合、データコネクタアイコンをクリックしてデータコネクタを削除(このブックから)または、全てのブックからコネクタを削除(プロジェクト内)を選択します。
  • ワークシートの左上隅にあるデータコネクタアイコン(DC Icon DataMod.pngまたはDC Icon Live.png)をクリックしてインポート (Ctrl+4) またはすべてインポートを選択すると、いつでもデータを再インポートできます。
  • デフォルトでは、データコネクタ経由でインポートされたデータは編集できません。グラフ作成や分析をすることはできますが、変更することはできません。これにより、誤って変更することを防ぐことができますが、制限が厳しすぎると感じる場合もあります。コネクタアイコンをクリックし、インポートされたデータを解除を選択することにより、接続されたデータのロック解除できます。コネクタインポートデータから編集制限を削除する方法については、このFAQを参照してください。
  • ワークブックに接続できるコネクタのタイプは1つのみです(例:Text/CSV)。Text / CSVなどの単純な構造のファイルの場合、同じコネクタを共有している限り、それぞれが別々のファイルに接続する複数のシートを持つことができます。ExcelやMATALABなどのより複雑な構造のファイルの場合、最初に1つのシート/変数に接続し、次にデータナビゲータシートの追加と接続ショートカットメニューコマンドを使用して、必要に応じてブックに他のシート/変数を追加します。1つのExcelまたはMATLABファイルは、1つのOriginワークブックまたは行列ブックにのみ接続できます。
  • 単純な構造のファイル(CSVなど)を含むブックでは、シートタブを右クリックして新しいシートを追加すると、シートは空のコネクタで追加されます。未接続状態は、淡黄色のコネクタアイコンDC Icon Empty.pngで示されます(下記のコネクタの状態を参照ください)。コネクタアイコンをクリックしてショートカットメニューを開き、シートをデータソースに接続できます。
Data Connector Shortcut Menu.png
  • 使用しないデータコネクタを非表示にするには、データ:ファイルに接続:カスタマイズ...を選択し、未使用のコネクタのチェックを外します。
  • Originにインストールされていないファイル形式のデータコネクタは、データ: ファイルに接続: 新規追加...をクリックして利用できます。新しいデータコネクタが データ メニューに追加されます。
UG data connector add new.png

Originは、 データ:Webに接続によってインポートされたデータを、LabTalkのシステム変数 @CFDTとファイルサイズで決定された期間キャッシュします。デフォルトでは、10MBのファイルの場合キャッシュされたデータを24時間保存します。つまり、24時間以内に再インポート(つまり、Webファイルに再接続)した場合、最初のインポートでキャッシュされたデータが使用されます。24時間経過後、この10MBのファイルに再インポートすると、キャッシュがクリアされ、データが新たにインポートされます。このキャッシュに関する動作を制御する方法については、以下のトピックを参照してください。

データソースファイルパス

データコネクタアイコンは、次の5つの状態のいずれかで表示されます。

  • データソースが接続されると、アイコンは次のようになります。 DC Icon Live.png
  • シート内のデータのロックが解除されて編集できるようになると(コネクタメニューまたはLabTalkシステム変数@IPDC=0)のいずれかで)、アイコンは次のようになります。 DC Icon Unlocked.png
  • データソースのインポートが保留中の場合、アイコンは次のようになります。 DC Icon DataMod.png
  • 接続されたブックに新しいシートが追加されると、空のコネクタがシートに追加され、アイコンは次のようになります DC Icon Empty.png
  • データソースが実行可能でなくなった場合(データソースが移動された場合など)、アイコンは次のようになります。 DC Icon Broken.png


接続の状態に関係なく、コネクタアイコンをクリックし、データソースファイルパス共通データパスを使用して、Originファイルとソースデータ間の接続を維持できます。

UG Common Data Path Dialogs.png
  • プロジェクトパスからの相対パス: :データがプロジェクトファイルの下のフォルダに保存されている場合は、データソースファイルへのパスをプロジェクトパスからの相対パスに設定できます。その後、プロジェクトとデータソースを一緒に移動しても、それらの相対パスは維持されます。ネットワーク上の別の場所からプロジェクトファイルを再度開くときに、パスの修正は必要ありません。
  • 共通データパスからの相対パス:データソースが何らかの共通パスの下にある場合は、データソースファイルパスを共通データパスからの相対パスに設定できます。その後ファイルを移動した場合は、共通データパスを再確立してからすべてのブックをインポートを選択します。

データナビゲータ

データナビゲータは、Excel、MATLAB、Originプロジェクトなどの複数ページ/複数変数のファイルに接続したときに、ブックに自動的に追加される折りたたみ可能なパネルです。

UG data navigator overview.png
  • Originは最初のシートからデータをインポートし、他のシートを淡色表示にします。
  • 淡色表示されたシートを右クリックするか、CtrlキーまたはShiftキーを押しながら複数のシートを選択してから、シート追加および接続を選択します。
  • ファイル名はブックのロングネームに割り当てられ、シートは元のシート名がシートの名前に割り当てられます。
  • 接続されたシートは、現在のOriginワークブックから削除できます。

データコネクタとドラッグアンドドロップ

データ: ファイルに接続にあるファイルタイプでドラッグアンドドロップがサポートされています。古いインポートフィルタをドラッグアンドドロップインポート(以下を参照)に使用している場合、テンプレート、データフォルダ、またはUser Files\Filters folderに保存されている限り、フィルタを優先します(このFAQを参照してください)。

ただし、データコネクタを使ったドラッグアンドドロップの場合、CSVファイル内の日時データ列のフォーマット設定や、Origin行列オブジェクトへのMATLAB変数の自動インポート、シーケンスの画像を表示するためのスライダコントロールの追加などの利点があります。

詳細は、次のトピックをご覧ください。

Text/CSVに接続

データコネクタを使用して、ローカルまたはWebに保存されたテキストファイル(TXT、DAT、CSV)をインポートできます。データコネクタ機能は、これらのファイルタイプで適切に機能し、Originの古いX-Functionベースのインポートルーチンに関連する問題の一部を簡素化し、場合によっては排除します。たとえば、日時データのインポートでは、常に日時列は手動で構成する必要がありました。コネクタを使用すると、日時データが標準の簡単に認識できる形式である場合、その構成は自動的に行われます。

Origin 2022では、ドイツOSでの、日時データの","小数の処理を含む、千の区切り文字と小数の処理が改善されました。

CSVコネクタについては、メインヘッダ行自動のチェックが外れている場合は、メインヘッダ行の終了ボックスが追加され、メインヘッダ行の数を指定できます。


ローカルドライブまたはLANドライブ上のファイルに接続するには:

  1. ワークブックをアクティブな状態で、メニューからデータ:ファイルに接続: Text/CSVを選択します。
  2. ファイルを参照して選択します。
  3. CSVインポートオプションを設定します。多くの場合、デフォルトを受け入れるだけでファイルがきれいにインポートされるため、テストとして、デフォルトを変更せずにデータをインポートしてみてください。結果が良くない場合は、インポートを再実行してデフォルト設定を変更します。

このミニチュートリアルでは、Text/CSVコネクタを使用して、日時コンポーネントを含むテキストファイルをインポートします。古いOriginのインポート方法では日時データがテキストとして扱われ、ユーザーは手動で日時列をインポート後の日付に設定する必要がありましたが、Text / CSVコネクタはインポート時にワークシート列を自動的に構成できます。

  1. 新規ワークブックボタンButton New Workbook.pngをクリックし、データ:ファイルに接続:Text/CSVを選択します。
  2. <Origin Program>\Samples\Import and Export\フォルダを参照し、Date with higher precision.dat.を開きます。
  3. CSVインポートオプションダイアログの設定はデフォルトのままにして、 OKをクリックします。データがワークブックにインポートされます。
  4. Aヘッダをクリックして列を選択し、右クリックして列プロパティを選択します。フォーマットは自動的に日付に設定され、表示カスタムに設定され、カスタムフォーマットはカスタム表示に表示されることに注意してください。
Import custom date time.png

このミニチュートリアルでは、データコネクタを使用して複数のファイルをインポートします。これらの同じ構造のファイルには、保持したいメタデータの複数の行があります。したがって、インポートフィルタを使用して作られたインポートフィルタファイルを使用して、ファイルをインポートし、ファイルメタデータを各ワークシートの複数の列ラベル行に書き込みます。そうすることで、(a)データコネクタを使用して複数のファイルをインポートする方法、および(b)以前のバージョンのOriginで開発されたインポートフィルタファイル (*.oif)を使用して、Originの新しいデータコネクタテクノロジーを使用してファイルをインポートする方法を確認できます。

  1. 新しいプロジェクトを開始し、ワークブックをアクティブにして、データ:複数ファイルに接続を選択します。
  2. files2dcダイアログボックスで、以下のように設定します。
    • データコネクタ = インポートフィルタ
    • ソース = 指定したファイル
    • ファイル名 = <Origin Program>\Samples\Import and Export\S15-125-03.dat, S21-235-07.dat and S32-014-04.dat
    • 同一ブック = 有効(チェックボックスをオンにすると、すべてのファイルが1つのブックになります)
  3. OKをクリックし、開かれたダイアログで、インポートフィルタ = データフォルダー:VarsFromFileNameAndheader.oif]を設定します。
  4. OKをクリックすると、3つのファイルがワークブックに別々のシートとしてインポートされます。


Web上のファイルに接続するには:

  1. データ:Webに接続
  2. ファイルのURLがある場合は、URLボックスに入力します。それ以外の場合は、ファイルタイプText/CSVに設定し(オプションですが、最近使ったURLをフィルタリングするのに役立ちます)、最近使ったURLを直接クリックして、リストから選択します。
Connect to web dialog URL.png

CSVインポートオプション ダイアログを使用して、ローカルに保存されたファイルと同様、Webに保存されたファイルの部分インポートを指定できます。部分インポートボックスをチェックして、およびインポートを定義するために使用しるシンタックスのガイドを開きます。

Note:Text/CSVコネクタと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > Text/CSVコネクタ

MATLABファイルに接続する

Originは、これまでのXファンクションベースのMATファイルインポートを引き続きサポートしていますが、データコネクタにはローカルに保存されたMATLABファイルとWebに保存されたMATLABファイルの両方のインポートにいくつかの利点があります。

  • ルートレベルでMATLABファイルに接続すると、すべての変数がOriginの行列オブジェクトとして行列シートに追加されます。
  • スライダーが追加され、シート内のOrigin行列オブジェクトをめくることができます。ミニツールバーのボタンスライダーまたはサムネイルを使用して、スライダーとサムネイルを切り替えることができます。
  • また、コネクタは、折りたたみ可能なデータナビゲータパネルをウィンドウに追加します。変数を個別のシートとして追加する場合は、データナビゲータリストを右クリックして追加できます。
UG slider or thumb MAT.png


MATLABファイルに接続するには:

  1. ワークブックまたは行列ブックをアクティブにして、データ: ファイルに接続: MATLABまたはデータ: フWebに接続をクリックして、.matファイルへのURLを入力します。
  2. インポートする変数を選択し(ブラウザの下部パネルに追加します)、OKをクリックします。


Note:JSON/MATLABコネクタと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > JSON/MATLAB

NetCDFファイルとシェープファイルに接続する

NetCDFファイル形式は、多次元の科学データを共有するために使用されます。主に気候科学で広く使用されています。シェープファイルは通常、地理的境界やその他の地理空間データを格納するために使用されます

Import NetCDF Image Map.png


NetCDFファイルに接続するには:

  1. ワークブックまたは行列ブックをアクティブにして、データ: ファイルに接続: NetCDFまたはデータ: Webに接続をクリックして、.ncファイルへのURLを入力します。
  2. インポートする変数を選択し(ブラウザの下部パネルに追加します)、OKをクリックします。
  3. ワークブックがアクティブであるが、変数に行列ブックが必要な場合は、アクティブなワークックに新しい行列ブックまたは埋め込み行列ブックを追加するように求められます。


シェープファイルに接続するには:

  1. ワークブックまたは行列ブックをアクティブにして、データ: ファイルに接続: Shapefileをクリックして.shpファイルを選択します。
  2. (オプションで)エンコーディングと属性をロードするかどうかを指定し、OKをクリックします。


Note:NetCDFコネクタと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > NetCDFコネクタ

クラウドドライブに接続

Origin 2022はは、MS OneDrive または Googleドライブに保存されているOriginMS ExcelASCIIファイルに接続可能です。アカウント認証後、ローカルファイルへの接続と同じようにクラウドファイルへの接続が可能です。

  1. ワークブックをアクティブにして、データ:クラウドに接続をクリックします。ブラウザが開いたらファイルを選択します。
  2. 必要に応じてブラウザのドロップダウンでクラウドサービスやアカウントの選択を行います。
    Data Connect to Cloud Browser.png
  3. ファイルを選択して、開くをクリックします。

初めてクラウドアカウントに接続するときは、アカウントの確認が必要です。Originは一時ファイルを使用して、クラウドアカウントとローカルコンピュータ間でデータにアクセスして転送します。それ以外の情報の通信は実行されません。

Excelデータを操作する

OriginでExcelデータを扱う場合、以下の5つの方法があります。

  • Excelのデータをクリップボードにコピーして、そのデータをOriginに貼り付けるか貼り付けることができます。
  • データコネクタを使用して、(1)データ:ファイルに接続:Excelをクリックするか、(2)標準ツールバーのボタンButton Import Excel.pngをクリックするか、(3)ExcelファイルをOriginワークスペースにドロップすることでローカルExcelファイルをインポートできます。
  • データ:Webに接続:Excelをクリックすると、データコネクタを使用してWebからExcelデータをインポートできます(以下、参照)。
  • Originの古いX-Functionベースのルーチンを使用して、データ:ファイルからインポートをクリックすると、ローカルのExcelファイルをインポートできます。Excelコネクタ対応のため、最近このオプションは非表示になりましたが、使用したい場合は、Originヘルプファイルのこのセクションを参照してください。
  • また、Origin内部で「Excelワークブック」として、Excelワークブックを開くことができます(MS Excelウィンドウのインストールが必要です)。これは、メニューのファイル:Excelを開く... と選択すると可能です。Note: この方法は、制限されたテクノロジーを使用しています(次の段落を参照してください)。このオプションを使用したい場合は、このページの手順に従って操作してください。

ExcelワークブックのデータをOriginのワークブックにペーストまたはインポートすると(データコネクタによるインポートを含む)、Originの強力なグラフ作成および分析機能に完全にアクセスできます。Origin内部でExcelブックを開いた場合、実際にはOriginのワークスペース内でExcelのOLEインスタンスが実行されています。この場合、Excelのメニューや機能を使うことができますが、Originのグラフ機能や分析機能は制限されます。Origin上のExcelワークブックをExcelワークブックとして開くよりも、Excelインポートオプションの1つ(最初の4つのオプション)を選択する方が推奨されます。


OriginでExcelを操作する際の注意事項

  • ExcelファイルをOrigin内でExcelワークブックとして開く には、Office 97以降のバージョンがコンピュータにインストールされている必要があります。しかし、Excelがインストールされていない 場合も、コネクタを使用するか、impMSExcelをつかってExcelファイルをOriginにインポートできます。
  • Originは.xls, .xlsx または .xlsmをインポート可能です。
  • Excelコネクタを使ってデータをインポートする場合、コネクタアイコンDadta connector icon connect.pngをクリックしてインポートを選択することで、いつでもOrigin上のデータを更新できます。また、Excelに接続したOriginプロジェクトを開いたときもExcelデータを再インポートします。
  • 以前のXファンクションimpMSExceベースの機能を使用してインポートする場合、特定のファイルインポート情報がワークブックに保存されます。ExcelファイルをOriginのワークブックにインポートした後は、標準ツールバーの再インポート ボタンを使用して、更新されたExcelファイル(複数のシートを含むものも含む)をOriginのワークブックに再インポートできます。
  • Originは、あるExcelブックを別のExcelブックに動的にリンクすることや、Excelの数式を認識、変換などはサポートしていません。


Note:Excelと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > Microsoft Excelの操作およびファイルに接続 > Excel

ExcelコネクタimpMSExcel ルーチンは、Excelファイルの部分インポートをサポートしています。詳細は、Originヘルプの部分インポートと再インポートを参照してください。

Excelファイルに接続する

Originのデータコネクタは、Originプロジェクトの外部データファイルとのライブリンクを作成します。

  • ローカルのファイルに接続するには、データ:ファイルに接続をクリックします(または標準ツールバーのButton Import Excel.png ボタンをクリックします)。
  • Webに保存されたファイルに接続するには、データ:Webに接続をクリックします。
  • Originのワークブック1つにつき、Excelファイル1つを接続できます。
  • ファイルが複数シートファイルの場合、最初に1つのシートに接続する必要があります。これにより、データナビゲータパネルが開き、必要に応じて追加のページに接続できます。
  • すべてのシートが同じ構造である場合、最初のシートへの接続の設定を細かく行うと、ほかのシートとの接続がクリアになります。サンプルとして以下のミニチュートリアルをご参照ください。
Excel connect import options structure.png
  1. 新規ワークブックButton New Workbook.pngボタンをクリックして新しいワークブックを作成し、データ:ファイルに接続:Excelを選択します。
  2. <Origin Program>/Samples/Import and Export/United States Energy (1980-2013).xlsを検索し、開くをクリックします。
  3. Excelインポートオプションダイアログで、次のように設定します。
    Excelシート = Oil
    メインヘッダ行 = 0
    列ラベルを有効にします。
    ロングネーム = 3
    単位 = 4
    コメント(開始行) = 1
    コメント(最終行) = 2
  4. OKをクリックすると、Oilシートがワークブックにインポートされます。
  5. ブックの左側に表示されるデータナビゲータパネルで、Ctrlキーを押しながら他の3つのシートを選択し、右クリックしてシートの追加と接続を選択します。残りのシート(Natural GasCoal、およびTotal Primary Energy)はワークブックにインポートされます。接続されていないシートのサイズが大きい場合は、必要に応じて、一度に1枚ずつ接続することを選択できます。

ファイルからインポート

データ: ファイルからインポートの下にリストされているインポートルーチンは、データコネクタより前のものです。ファイルからインポートルーチンはもう開発されていませんが、引き続きサポートされており、場合によっては、ユーザが古いルーチンを好むことがあります(信頼できるインポートルーチンを使用しているならば、データコネクタのデータ保護は必要ありません)。

さらに、この表にリストされているファイルの種類によっては、コネクタが存在しない場合があります。このような場合は、引き続きデータ: ファイルからインポートを利用する必要があります。

標準ツールバーの単一ASCIIのインポートボタンButton Import ASCII.pngで、データ:ファイルに接続: Text/CSVルーチンが呼び出されるようになりました。impASCルーチンについては、次のセクションを参照してください。

impASCでASCIIファイルをインポート

  • データ:ファイルからインポート:複数ASCII...Button Import Multiple ASCII.png)この方法は、一般に、単純な構造のテキストファイルをインポートするのに十分です(単一ファイルまたは複数ファイルのインポートで機能します)。この2つのメソッドは、通常、一般的に使用される区切り文字とシンプルなヘッダ構造を持つファイルを調整なしで処理可能です。
  • ファイルのインポートを調整する必要がある場合は、ASCIIダイアログでファイルを選択するときにオプションダイアログの表示チェックボックスを選択します。これにより、ImpASCダイアログボックスが開き、ファイルインポート時の処理方法を調節可能です。
Import data 1.png
Note:impASCダイアログを使用したASCIIインポートについての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ >ASCIIインポートオプションのカスタマイズ

インポート設定を保存

インポート設定を調整した場合、次の2通りの方法でこれを保存できます。

ワークシートテンプレートを使用してインポート設定を保存すると、移植性が向上します(テンプレートは同僚と簡単に共有できます)。テーマとしてインポート設定を保存すると、impASCダイアログボックスでインポートするときにインポートオプションの組み合わせをいくつでも呼び出せるという利点があります。

テーマとテンプレートの詳細については、このユーザーガイドの後の章にあるOriginのカスタマイズをご覧ください。さらに、「詳細情報」にある、トピックスもご覧ください。

データメニューの下部にあるリストからカスタムインポートテーマをすばやく読み込むことができます。また、データ:ファイルからインポート:ファイルの種類の追加/削除と選択して開く、インポートメニューのカスタマイズダイアログを使用して、保存したユーザテーマデータ:ファイルからインポートで表示されるサブメニュー内に表示させることができます。

サードパーティ製データ

特定のサードパーティ製のデータコネクタが存在しない場合でも、Originの古いX-Functionベースのインポートルーチンを使用できます。これらには、pClamp、NI TDM、NetCDFなど、広く使用されている含む幅広いサードパーティ製データが含まれます。すべてのX-Functionベースのルーチンと同様に、サードパーティのファイルインポートオプションをカスタマイズし、ワークシートテンプレートを使用して、または後で使用するためのダイアログテーマとして設定を保存できます。サポートされている他のファイルタイプと同様に、ドラッグアンドドロップでサードパーティのファイルをインポートできます。

ファイルの種類 方法 より詳細をご覧いただくには次を参照してください:

ヘルプ:Origin:Originヘルプ > データのインポートとエクスポート


Thermo (SPC, CGM)
pCLAMP (ABF, DAT, AB?)
Princeton Instruments (SPE)
音声(WAV)
NetCDF (NC)
CDF (CDF)
HDF5 (H5, HE, HDF5)
NI DIAdem (DAT)
Famos (DAT, RAW)
ETAS INCA MDF (DAT, MDF)
IgorPro (PXP, IBW)
Prism (PZFX, XML)
MATLAB (Mat)
Minitab (MTW, MPJ)
KaleidaGraph (QDA)
SigmaPlot (JNB)
MZXML(mzData, mzXML, mzML, imzML)
EarthProbe (EPA)
EDF (EDF, BDF, REC, HYP)
Somat SIE (SIE)
JCAMP-DX (DX, DX1, JDX, JCM)
HEKA (DAT)
SPSS (SAV)
BRUKER OPUS
SAS (sas7bdat)
Tektronix (ISF)
Data Translation (DCF, HPF)
バイナリ2D配列 (IMG, B2D)
画像

データ:ファイルからインポート > サードパーティ製ファイルのインポート
Note:デフォルトでは非表示になっているサードパーティ製ファイルフォーマットもあります。追加するには、データ:ファイルからインポート:ファイルの種類の追加/削除...を選択します。これにより、インポートメニューのカスタマイズダイアログボックスが開き、ファイルからインポートメニューに表示するファイルの種類を選択できます。もし、メニューコマンドの間に区切りが必要な場合、このダイアログの右側のパネルで右クリックし、区切りの追加を選択します。区切りを削除するには、右側のパネルで区切りをダブルクリックします。

特定のファイルタイプ(つまり、上記の表にリストされているもの)にデータコネクタが存在しない場合、ドラッグアンドドロップのサポートは、フィルタマネージャーダイアログを使用してファイル拡張子によって管理されます。メインメニューから、環境設定:基本設定:インポートフィルタマネージャ...をクリックします。

Note:サードパーティー製ファイルと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ:Origin:Originヘルプ > サードパーティ製ファイルのインポート

インポートウィザード

上記2つの方法では十分に扱えない、複雑な構造のASCIIファイルをインポートする場合、インタラクティブなインポートウィザード を使用します。任意のヘッダ部とその後にバイナリデータが続くような構造を持つバイナリファイルはOriginのインポートウィザードでインポートします。インポートウィザード


インポートウィザードを開くには:

  1. データ:ファイルからインポート:インポートウィザードを選択するか、標準ツールバーにあるButton Import Wizard.pngボタンをクリックします。


  • ワイルドカードを使用して、同じ名前のデータファイルのグループを対象としたインポートフィルタを作成できます。このフィルタはドラッグ&ドロップでのインポート操作に使用できます。適切なファイルをワークスペースにドロップすると、Originはファイル名を調べ、それを正しいカスタムインポートフィルタと照合して、指定に従ってファイルをインポートします。
  • Webページなどにあるデータをクリップボードにコピーしてインポートします(下記を参照ください。)
  • インポートファイル名やヘッダから変数を抽出します。
  • データを解析するためのカスタム区切り記号と日付形式を指定します。
  • インポートデータに対して実行するLabTalkスクリプトを含めます。


Note:詳細情報は、次のヘルプファイルをご覧ください。

ヘルプ:Origin ヘルプ > データのインポートとエクスポート > インポートウィザード

クリップボードのデータをコピー/貼り付け

Originでデータを取得するひとつの方法として、クリップボードにコピーしたデータをOriginに貼り付ける、という方法があります。 この方法は、Excelワークブックの一部分を選択し、Originのワークブックに貼り付けるという簡単な操作を実現します。しかし、クリップボードのデータは、Originへ正しくデータを貼り付けることができるように、フォーマットされた配列、または区切りではありません。ここでの注意点として、

  • ExcelからコピーしてOriginに貼り付けたデータは、Excelで表示されている小数点桁数にかかわらず、完全精度で貼り付けられます。
  • ヘッダ行のあるExcelファイルの場合、クリップボードのデータをOriginの1行目(ラベル行でない)に貼り付けた後、行を選択して右クリックし、開くショートカットメニューから、ロングネームに設定単位として設定コメントとして設定を使用して、ヘッダ情報をタグ付けすることができます。
  • また、ウェブからコピーされたデータは、様々な方法でフォーマットすることができます。きれいにデータを貼り付けるためには、いくつかの操作を試す必要があります。もし、単にコピーアンドペーストするだけではうまくデータを取得できない場合、インポートウィザードを使用して試すことができます。インポートウィザードは、クリップボードのデータをインポート処理するためのインタラクティブなインターフェースと、同じ形式のデータに対して適用できるインポートフィルタ(.oif)の保存機能を提供します。さらに詳しい情報は、チュートリアルのインポートウィザードを使ってクリップボードデータをインポートするをご覧ください。
Import data wizard composite resample office 600px.png

Originファイルをクエリして選択的にデータをインポート

インポートに先立ってデータコネクタブラウザでSQL同様のクエリの指定により、外部Originファイルからデータ列を選択的にインポートできるようになりました。

UG Import Origin SQL.png

Originコネクタを使ってOriginファイルを選択的にクエリ

  1. ワークシートをアクティブにして、データ:ファイルに接続または、Webに接続を選択します。
  2. Originファイルを参照して、開くをクリックします。データコネクタブラウザが開きます。
  3. クエリを選択ボタンUG Select Query Button.pngをクリックします。
  4. クエリを選択ダイアログでクエリを入力し、OKボタンをクリックします。

クエリで指定した通りに、アクティブワークブックに選択的にデータがインポートされます。


一般的なキーワード

キーワード 説明
_SName ショートネーム。例:_SName, Sheet_SName
_LName ロングネーム。例:_LName, Book_LName
_Comments コメント。例:_Comments, Sheet_Comments
Column_D1 列ユーザ定義パラメータで、1 はパラメータ番号
Column_[Name] 列ユーザ定義パラメータで、[Name] はスペースを含めたパラメータ名


サンプル:

Select Column from Project where _SName == "A";
Select Column from Project where _Comments like "S*3";
Select Column from Project where (Column_P1 like "*y*" and Column_D1 > 3);
Select Column from Project where Sheet_SName like "Trial*";
Select Column from Project where (Book_SName like "Book*" or Book_LName like "*fit*")


詳細情報は、ユーザガイド: OriginコネクタでSQLクエリを使用するサンプルを参照してください。

データベース

Originは、ODBCとOLE DBによるデータベースへの接続をサポートしています。さらに、Originには、接続文字列を追加し、Origin内でSQLクエリを生成するためのシンプルなSQLエディタが含まれています。


SQLデータをインポートするには、データ:データベースに接続メニューコマンドから開始します。

  • 開くは、保存された接続(ODS)またはクエリ(ODQ)ファイルを参照して開くことができます。
  • 新規作成は、データベースコネクタダイアログを開きます。
UG database connector dialog.png
  • 接続文字列: 指定されたデータソース(ODBCまたはOLE DB)のテキストベースの接続文字列がすでにある場合は、これを選択します。
  • ODBCデータソースODBC データ ソース アドミニストレーターアプレットを使用してODBCデータソースを定義している場合は、これを選択します。
  • ODBCドライバ: ODBCドライバを使用していて、このデータコネクタインスタンスに適用可能なデータソースを作成したい場合は、これを選択します。
  • Windows"データリンクプロパティ"ダイアログ: OLE DBベースのデータソースなどをSQLサーバーまたはアクセスクライアントライブラリとして使用している場合は、これを選択します。


他の事項:

  • LabTalkシステム変数@IPDBを使ってインポートされる範囲を制御できます(0 = 保護なし、1 = 保護するが再配置許可、2 = 保護)。
  • 他のコネクタと同様に、OPJU/OGWUとして保存時にインポート(データ)を除外するオプションがあります。
DB Save wo data.png
Note:詳細は、Originヘルプファイルをご覧ください。

ヘルプ:Origin ヘルプ > データのインポートとエクスポート > データベースからデータをインポートする

デジタイザ

詳細に探求したい、いくつかのデータのグラフ画像のみある場合、このような場合には、Originのデジタイザツールが便利です。デジタイザを使って、イメージファイルをインポートします。そして、Originの分析およびグラフ作成ツールを使って、イメージを検定や再プロット可能な数値データに変換して、プロットをデジタイズします。

Digitizer data import chapter 2.png
  • 最も汎用的なイメージフォーマットをインポートします。
  • 開始と終了の値を指定して、インポートしたイメージの回転、ノイズの除去、スケール測定を行います。
  • 手動か自動で、曲線上のポイントを指定します。
  • 手動では、必要に応じて、曲線の編曲点を追加します。
  • デジタイズしたくない点は、インタラクティブに削除します。
  • 直交、極座標、三角座標のサポート


デジタイザを開くには、

  1. 標準ツールバーのイメージのデジタイズボタンButton Digitize Image.pngをクリックするか、メインメニューの ツール:デジタイザ...を選択します。

インポートデータを除外してOriginファイルを保存する

今までの方法でも、Originデータをデータなしで保存することはできました。テンプレートとして保存...ワークブックを分析テンプレートとして保存プロジェクトをデータなしで保存は、ファイルと設定や操作を維持しながら、データのない起源ファイルを保存するための3つのオプションでした。

また、インポートされたデータなしでOriginファイルを保存することができるようになりました。これは、大きなデータファイルを扱うユーザにとっては特に便利なオプションです。ファイルを使ってそのデータを保存すると、パフォーマンスが低下したり、ディスク容量が無駄になったりする可能性があります。

  • デフォルトでは、インポートファイルサイズが500kBを超える場合、データコネクタを使用してインポートされたデータはブックと一緒に保存されません。各ブックには保存時にインポートデータを除外チェックマークがあり、ブック内の任意のページのチェックマークを外すと、インポートされたすべてのデータがブックと共に保存されます。
Exclude imported when saving.png
  • プロジェクト内のどのブック(データコネクタがないものも含む)でも、インポートデータを除外するオプションを選択できます。ウィンドウのタイトルバー上で右クリックしてプロパティを開き、ダイアログ下部のプロジェクト保存時にインポートデータを除外ボックスにチェックします。
Exclude imported when saving Properties dialog.png


保存時にデータを除外するという動作は、いくつかの重要な点でテンプレートファイルの保存とは異なります。

  • インポートされたデータを除外しても、インポートされたデータに対する分析操作の結果(フィット結果、統計分析、設定値の計算など)の結果はすべて保存されます。インポートされたデータやインポートされたデータのグラフは保存されません。
  • データをインポートせずに保存したブックは、元のデータソースへの「ライブ」リンクを保持します。データコネクタを含むブックの場合は、データコネクタアイコンをクリックし、インポート(アクティブシート)またはすべてインポート(ブック内の全てのシート)をクリックします。標準のファイルインポートに使用されるブックの場合は、空のブックをアクティブにして、データ:直接再インポートをクリックします。またはインポートツールバーの再インポート(ダイアログなし)ボタンをクリックします(次を参照)。

データファイルの再インポート

データメニューには、同じファイルを繰り返しインポートするための2つのインポートコマンドがあります(ファイルパスと名前は同じである必要があります)。

  • 直接再インポート デフォルトでOriginのワークシートや行列シートにファイルをインポートする場合、ファイルパスと名前を含むパラメータは、シートに保存されています。定期的に更新される外部データファイルがある場合、または標準ファイルをワークシートに再ロードする場合は、インポートダイアログを開かずに直接再インポートできます。
  • 再インポート... このメニューコマンドで、ファイルタイプに必要なXファンクションのダイアログボックスを開き、再インポート前にインポートオプションを設定することができます。

Note:

  • 一度に再インポートできるのは1つのファイルだけです。 これら2つのメニューコマンドのいずれか1つを使うと、アクティブワークシートあるいは行列シートと結びついたファイルのみがインポートされます。 選択したデータを複数のファイルからインポートすると、再インポートは失敗します。
  • ASCIIファイルをインポートウィザードを使ってインポートしてデータ: 再インポート...を選択する場合、インポートウィザードの代わりにimpASCダイアログが開きます。
  • 再インポートは、インポートウィザードを使ったバイナリユーザ定義データタイプには操作できません。

クローンインポート

クローンインポートは、インポート(および、オプションで関連する分析操作)を「モデリング」し、最初のファイルに対して行われた内容を一連の類似ファイルに適用する機能です。アクティブなブックにインポートされたデータと関連する操作が含まれている限り、クローンを作成できます。この意味で、クローン作成は分析テンプレートの作成に似ていますが、いくつか制限があります(たとえば、バッチ処理ツールでは使用できません)。

クローンインポートは、データコネクタXファンクションベースのインポート方法の両方でサポートされています。簡単なチュートリアルで、クローンインポートと分析操作の基本について説明します。

  1. 新規ワークブックボタンButton New Workbook.pngをクリックし、新しいワークブックを作成します。
  2. ファイルエクスプローラーを使用して、<Origin Program>\Samples\Curve Fitting フォルダーを参照し、Sensor01.datというファイルを見つけます。このファイルを新しいワークブック内にドラッグアンドドロップします。Text/CSV コネクタを使用して.datファイルをインポートします。
  3. 列Bのヘッダをクリックして列を選択し、散布図ボタンButton Scatter.pngをクリックして散布図を作成します。
  4. XまたはYグラフの軸スケールをクリックし、表示される ダイアログボックスで スケール タブをクリックし、Ctrlを押して、左側のパネルで水平軸アイコンと垂直軸アイコンの両方を選択します。再スケール自動 に設定して、OKをクリックします。
  5. グラフがアクティブな状態で、 解析 : フィット : 線形フィット をクリックして、ダイアログボックスを開きます。再計算自動に変更し、他の設定はデフォルトのままOKボタンをクリックしてフィットを実行します。確認メッセージに「いいえ」と答え、OKをクリックします。
  6. ワークブックのタブを1つ右クリックし、グラフをシートとして追加をクリックします。これにより、線形フィットの結果を含む散布図がワークブックのページとして追加されます。
    UG clone import add graph.png
  7. Sensor01.datのデータがアクティブな状態で、インポートツールバー上のクローンインポートボタンButton Clone Import.pngをクリックします。
  8. もう一度、<Origin Program>\Samples\Curve Fitting フォルダを参照し、CtrlキーまたはShiftキーを押して、Sensor02.datからSensor07.datファイルを選択します。ファイルの追加をクリックし、OKをクリックします。元のブックをインポートおよび分析操作のモデルとして使用すると、SensorファイルはText / CSV コネクタを使用してインポートされ、1つずつ処理されます(すべて完了するまでに数秒かかる場合があります)。
    UG clone import results.png

参考