8.8.2 Inserting Image into Graph

You can insert an image into Graph window, no matter the image is in an Image window or outside of Origin. You can also copy an image outside of Origin and paste in a Graph window, or copy a Graph page as image inside of Origin and paste it in other Graph window.

Insert an Image

Insert an Image File Outside of Origin

  1. Active a Graph window. Select menu Insert: Image from file....
  2. Select an image file from the File Browser to insert it to the active graph layer. Multiple image types are supported, including png, svg, jpg, tif, bmp, etc.

This will insert the image as image object by default. You can convert it to the layer background later.

Note: Prior to Origin 2021b, images inserted to the graph window (not as layer background) were inserted as type = BMP, with interpolation enabled by default. In Origin 2021b, the same image was inserted as type = OIMAGE, which did not support interpolation and which, in rare cases, resulted in a poorer quality image. If you experience degradation of inserted images, you can try setting @IMGB = 1 BEFORE inserting the image. To confirm interpolation, right-click on the BMP image, choose Properties, click on the Image tab and verify that Enable interpolation is checked. For information on setting the value of a system variable, see this FAQ). Does NOT apply to images inserted as background.

If you insert the image as image object

  • You can resize (aspect ratio is kept) and reposition the image by mouse-dragging.
  • The image object is attached to Layer Frame by default.
  • Double click on the image will open it in an Image window. You can further customize the image in the Image window such as crop or clip the image to an interested region, or rotate the image. Once done, click Close embed graph.png button to return to the Graph window.

Insert Image ROI clip.gif

Crop vs. Clip

Crop does not keep the original image,
Clip keeps the original image so you can later move or resize ROI to clip the image again. The graph window will update accordinglly.
If delete the ROI after clipping, you can right click inside Image window and select Remove Clipping to restore the image to full range in the Graph window.

Learn more about ROI on Image, please refer to this page.

Learn more about what you can do in the separated Image window, see below section.

If you want to insert the image as layer background

To convert image object to layer background

  1. Double click on the image object to open it in an Image window.
  2. Right click inside the Image window and choose Set as Layer Background.


To open background image in a separated Image window

  • The background image cannot be selected by mouse-clicking. But you can still open it in a seperated Image window by one of the following ways:
  1. Single click on the edge of the graph layer. A mini toolbar appears.
  2. Click Open Image button Popup Open Image.png to open the background image in an Image window.
Insert Image Open BGImage2.png
OR,
  1. Open the Object Manager. Right click inside it and select Show Graph Objects from the context menu.
  2. Double click the Layer Background icon to open the background image in an Image window.
Insert Image Open BGImage.png


To rescale graph according to image coordinates

  • You can set XY coordinates in the Image window and then rescale the Graph window accordingly. See below section for details.

No matter the image is inserted as background or object

  • The inserted image is embeded to the graph.
  • You can double click on the image node in the Object Manager to open it in a separated Image window.
  • Right click inside the Image window you will get a list of menus.
Insert Image linked file.png
Add ROI Add a ROI box on the image. Learn about what you can do with image ROI on this page.
Apply Whole Image Scale to Graph Available only when image is inserted as background. Rescale the graph according to coordinates set in Image window.

Apply whole iamge scale to graph.gif

Display Actual Size/
Fit to Window
Display the image in 1:1 pixel, or fit the image to window size.
Linked File

You can choose to save the image with project or not. Check this item will link the inserted image to the source image file outside of Origin. The image will be excluded when saving the project. Only keep the connection between the source image file and the Origin project. Next time you open the project, you will see a down arrow on the graph. Click it to reload the image.

This featrue is help to reduce the project size especially when the inserted image is very large.

Source File Path Check or change the path of the source image file in the open dialog. If the current project has been saved, you can check Relative to Project to save the path relative to project.
Extract Image from Graph

Extract the embeded image into a "real" Image window which serves as the container. That means, the image will be saved in the Image window and thus saved along with the project.

This feature integrates everything in the project and makes it easier to share your work with others.

Below shows you how to insert an image that was first inserted as layer background in another graph.

  1. In the graph with image background, right click in the Object Manager and choose Show Graphic Objects.
  2. Double click Layer Background entry to open it in an Image Window.
  3. Right click inside the Image Window and choose Extract Image From Graph.
  4. Activate another graph without background and choose Insert: Image from Image Window to insert it.

Insert same img to 2graph.gif

Insert an Image Inside of Origin

  1. Active a Graph window.
  2. Select Insert: Image from Image Window.... This will open the following dialog.
    Insert Image from Image Winwod.png
    Layer Background
    • Check this check box to insert image as layer background, which cannot be selected nor moved manually. In this case, the insert position and size are determined by the XY coordinates of the image. Refer to shis page of how to set XY coordinates of an image.
    • Uncheck this check box to insert image as graph object. You can drag to reposition and resize the object.
    Rescale Layer using Image Coordinates Available only when insert image as background. Check this check box to rescale graph's XY axes according to XY coordinates of the inserted image.

Advantages of Inserting Image from Image Window

  • Inserting image by Insert: Image From File will build up the project file size dramatically. To reduce the project size, we recommand importing the image file into Origin's Image window and then inserting it to graph.
  • Image window allows you to set XY coordinates of the image and then insert it to the graph of the exact position, or rescale the graph according to the image coordinates.
    Refer to shis page of how to set XY coordinates of an image.
    Below is a quick example of how to set XY coordinates of an image and insert it to the graph as background.

Suppose we have a screenshot from Google Map. We want to insert it to the Bubble graph as background.

  1. Import the molecule image file into Origin Image window by File: New: Image: Image/Videos...
  2. With the Image window active, select Image: Set Coordinates... to set XY coordinates of the image.
    Note: The Unit doesn't take effect when inserting the image to graph. The inserted position only determines by the values of XY coordinates. Unit set in this dialog is used to determine the actual scale of the image and will save to the Image window.
  3. With the Graph window active, select Inssert: Image from Image Window to insert the molacule image to the graph according to the specified coordinates. Make sure Layer Background checkbox is checked.

Insert Image setXY.gif


  • If you insert the image as background, after setting XY coordinates to the image, you can further add a ROI on the image to clip the graph background to that region and update the graph axes accordingly.
  1. Insert an image as background by Insert: Image from Image window.
  2. Activate the Image window. Add a ROI.
  3. Spcify the ROI coordinates.
  4. Right click on ROI and choose Apply Scale To: Graph1.
Apply Scale to Graph.png
  • More options support by right clicking inside the Image window.
Insert Image window context menu.png
Add ROI Add a ROI box on the image. Learn about what you can do with image ROI on this page.
Apply Whole Image Scale to Graph Available only when image is inserted as background. Rescale the graph according to coordinates set in Image window.

Apply whole iamge scale to graph.gif

Display Actual Size/
Fit to Window
Display the image in 1:1 pixel, or fit the image to window size.
Link File

You can choose to save the image with project or not. Check this item will link the inserted image to the source image file outside of Origin. The image will be excluded when saving the project. Only keep the connection between the source image file and the Origin project. Next time you open the project, you will see a down arrow on the graph. Click it to reload the image.

This featrue is help to reduce the project size especially when the inserted image is very large.

Source File Path Check or change the path of the source image file in the open dialog. If the current project has been saved, you can check Relative to Project to save the path relative to project.
Embed Image to Graph

This will save the image to the Graph window as an embeded object.

Paste Image into Graph page

  1. Copy an image out of Origin
    or
    Copy the graph page in Origin as an image
  2. Go to Graph window, and right-click on the blank space to select Paste: Paste, or press Ctrl + V, or select Edit: Paste in the main menu.
  3. Double-clicking on the pasted image will open the image in an Image window. Learn more about the Image Window and how to customize it on this page.