Die Menüs Daten: Aus Datei importieren und Datei: Export benutzerdefiniert anpassen


Wie schon in den vorherigen Abschnitten erwähnt, können Sie im Menü Aus Datei importieren ein Dateiformat wählen, um die X-Funktion auszuführen, die Dateien des angegebenen Formats importiert. Gleichzeitig kann das Menü Export auch zum Exportieren von aktiven Matrizen, Arbeitsmappen oder Diagrammen in ein ausgewähltes Format verwendet werden.

Diese zwei Menüs werden mit dem Durchsuchen der X-Funktionen in den folgenden zwei Ordnern beim Starten von Origin dynamisch erstellt:

1. Der Unterordner \Import and Export des Ordners \X-Functions im Origin-Programmordner

2. Der Unterordner \Import and Export des Ordners \X-Functions im Origin-Anwenderdateiordner

Die X-Funktionen in diesen zwei Ordnern sind nach ihren Dateinamen in einem der Menüs aufgelistet:

1. Diejenigen, die mit "imp" anfangen, befinden sich im Menü Daten: Aus Datei importieren.

2. Diejenigen, die mit "exp" anfangen, werden im Menü Datei: Export aufgeführt.

Hinweis: Es hängt vom Anwendungskontext einer X-Funktion ab, ob die X-Funktion in den Menüs erscheint. Weitere Einzelheiten zum Anwendungskontext einer X-Funktion finden Sie unter dem Thema X-Funktionen erstellen in der Dokumentation der X-Funktionen. (Nur in den digitalen Hilfedokumenten verfügbar.)

Aufgrund ihres Aufbaus können wir Menüs durch Verändern der X-Funktionen im Ordner \Import and Export anpassen. Um ein Menü zu entfernen oder Dateiformate zu verbergen, die Sie nie verwenden, können Sie einfach die unerwünschten X-Funktionen in irgendeinen anderen Ordner als diese beiden verschieben. Wenn Sie andererseits neu importierte oder exportierte X-Funktionen geschrieben haben, können Sie sie in imp*.oxf oder exp*.oxf umbenennen und dann im Ordner \Import and Export abspeichern.

Bei jedem Start von Origin wird das Durchsuchen der X-Funktion durchgeführt. Daher können Sie beim nächsten Starten von Origin die Aktualisierungen der Menüs Daten: Aus Datei importieren und Datei: Export sehen, wenn die X-Funktionen im Ordner \Import and Export verändert werden.

Der Dialog Benutzerdefinierte Anpassung des Importmenüs

Mit Origin können Sie festlegen, welche Dateitypen und Importdesigns im Menü Daten: Aus Datei importieren gezeigt werden. Dazu verwenden Sie den Dialog Benutzerdefinierte Anpassung des Importmenüs, der über das Menü Daten: Aus Datei importieren: Dateitypen hinzufügen/entfernen geöffnet wird.

Customizing the File Import 01.png

In diesem Dialog können Sie:

  • Dateityp oder Anwenderdesign aus der Auswahlliste oben links im Dialog auswählen, um alle unterstützten Dateitypen oder gespeicherten Dialogdesigns im linken Bedienfeld anzeigen zu lassen. Wenn Sie einen .oif-Filter im Importassistenten oder ein Dialogdesign für das Hilfsmittel impASC gespeichert haben, können Sie Anwenderdesign in dieser Auswahlliste auswählen und zur schnellen Verwendung zum Menü Aus Datei importieren hinzufügen.
  • Mit den Pfeiltasten Links/Rechts fügen Sie den Dateityp oder das Design zum rechten Bedienfeld hinzu oder entfernen sie, um das Menü Aus Datei importieren benutzerdefiniert anzupassen.
  • Setzen Sie das Menü Aus Datei importieren zurück, indem Sie auf die Schaltfläche Zurücksetzen klicken, und verschieben Sie das gewählte Element im rechten Bedienfeld nach oben/nach unten, indem Sie die Pfeiltasten Nach oben/Nach unten verwenden.
  • Aktivieren/deaktivieren Sie das Kontrollkästchen Menü "Dateitypen hinzufügen/entfernen" zeigen, um festzulegen, ob das Menüelement Dateitypen hinzufügen/entfernen im Menü Aus Datei importieren gezeigt werden soll.
Hinweis: Wenn das Kontrollkästchen Menü "Dateitypen hinzufügen/entfernen" zeigen deaktiviert ist, können Sie den Dialog Benutzerdefinierte Anpassung des Importmenüs nur noch im Dialog Importfilter verwalten öffnen.