レイアウトページウィンドウの利用

レイアウトページウィンドウは、別々の子ウィンドウで作成および編集されたワークシートおよびグラフの「表示パネル」として機能します。レイアウトウィンドウにはグラフオブジェクトを追加することもできます。これらの図やオブジェクトをレイアウトウィンドウ内で整列してプレゼンテーションを作成し、Originから印刷したり、クリップボードまたは画像ファイルへエクスポートできます。

Using the Layout Page Window-01.png

レイアウトウィンドウを開くには

  • ファイル:新規作成:レイアウトを選択して空のレイアウトウィンドウを作成します。

もしくは、

  • ツールバーの新しいレイアウトウィンドウボタンButton New Layout.pngをクリックします。

Note:レイアウトウィンドウの名前は、Layout1, Layout2...のようになります。

レイアウトページへのグラフとワークシートの図の追加

グラフまたは、ワークシートをレイアウトウィンドウに追加するには

  1. レイアウトウィンドウがアクティブな状態でメニューから、挿入:グラフもしくは挿入:ワークシートを選択します。(もしくはレイアウトウィンドウの白い部分で右クリックしてコンテクストメニューからグラフの追加もしくはワークシートの追加を選択します) これによりグラフブラウザまたはシートブラウザダイアログボックスが開きます。
  2. リストボックスのグラフまたはワークシートを選択します。
  3. OKをクリックします。
  4. レイアウトページウィンドウ中をクリックして、デフォルトサイズの図を作成します。
    または、
  5. レイアウトページウィンドウ中のボックスをクリック&ドラッグして、図のサイズを指定します。 マウスボタンを離すと、選択したグラフまたはワークシートの図(オブジェクト)が表示されます。

元のウィンドウがワークシートウィンドウの場合、ワークシートのグリッドとセルがレイアウトウィンドウ内で図として表示されます。 ワークシートウィンドウのテキストラベルはレイアウトウィンドウには表示されません。

元のウィンドウがワークシートウィンドウの場合、ワークシートのグリッドとセルがレイアウトウィンドウ内で図として表示されます。 テキストラベルとその他のオブジェクトは、そのオブジェクトがグラフウィンドウのページ内にある場合、レイアウトページに表示されます。 (グラフウィンドウの灰色の領域はページの外側です。)

レイアウトウィンドウを使用して、一般的なカラースケールを使用するカラーマップグラフ(コンタープロットやサーフェスプロットなど)を集約して配置する場合でも、Origin 2019以降では、独立したカラースケールをレイアウトウィンドウに追加できます。詳しくは、独立したカラースケールの追加.を参照してください。

図を選択する

  • レイアウトウィンドウで図を選択するには:
  1. 図をクリックします。

または、

  1. 別の方法として、ポインタツールPointer.png(デフォルトのマウスの状態)を使用して、図を囲むように四角形を描いてドラッグします。
    レイアウトページウィンドウの利用
  2. マウスボタンを離すと、コントロールハンドルが付いた境界線が図の周囲に表示されます。

この図を選択を解除するには、レイアウトウィンドウの任意の場所(図以外)をクリックします。

  • 複数の図を選択するには

1つ以上の図をレイアウトウィンドウで選択するには

  1. SHIFTキーを押しながら、任意の図をクリックします。

または、

  1. ポインタツール(デフォルトのマウスの状態)を使用して、複数の図を囲むように四角形を描いてドラッグします。
レイアウトページウィンドウの利用

図のサイズを変更する

  • レイアウトウィンドウの図のサイズを変更するには
  1. 図をクリックして、図の周囲にコントロールハンドルの付いたボックスを表示します。
  2. コントロールハンドルをドラッグして、図のサイズを変更します。
    水平方向と垂直方向のコントロールハンドルで、図の横方向と縦方向の大きさを変更します。 斜め方向(角にある)のコントロールハンドルを使用すると、縦横比を維持して図のサイズを水平方向と垂直方向両方に同時に変更できます。
  3. レイアウトウィンドウ中の図以外の場所をクリックして、図の選択を解除します。 コントロールハンドルで大きさや位置を変更するだけでなく、オブジェクト表示制御ダイアログボックスで制御することができます。(「オブジェクト表示制御」ダイアログボックスを開くには、レイアウトウィンドウでオブジェクトをダブルクリックします。 制御タブを使って、オブジェクトへのアクセスを編集します。)

図のサイズ変更について

  • 図の縦横の比率をサイズ変更の際に保つには、オブジェクトを右クリックしてショートカットメニューから縦横比を保つを選ぶか、オブジェクト表示制御ダイアログボックスにある大きさタブの「縦横比を保つ」チェックボックスにチェックを付けます。(図をダブルクリックして、ダイアログボックスを開きます)
  • 大きさを変更するときに縦横比を維持する別の方法として、CTRLキーを押しながらコントロールハンドルをドラッグする方法があります。 コントロールハンドルを目的の場所までドラッグします。 CTRLキーとマウスボタンを離すと、図の大きさが変わります。
  • 図の縦横の比率を維持したままでサイズを変更するには、CTRLキーを押したままコントロールハンドルをクリック&ドラッグします。 (ハンドルを掴めたら、CTRLキーを離して問題ありません) コントロールハンドルを目的の場所までドラッグします。 マウスボタンを離すとサイズが変更された図が表示されます。
  • レイアウトページ中のワークシートの図のサイズを縮小したり拡大したりすると、図中に表示される行や列の番号が制御されます。 これがワークシート画像のサイズです。

図の移動と整列

  • レイアウトウィンドウで図を選択するには:
  1. 図をクリックして適当な位置までドラッグします。
  2. レイアウトウィンドウ中の図以外の場所をクリックして、図を選択されていない状態にします。

オブジェクト表示制御ダイアログボックスの大きさタブを使って、図の位置や大きさを変更することもできます。

  1. 図をダブルクリックしてオブジェクト表示制御ダイアログボックスを開きます。
  2. 大きさタブを選択します。
  3. ドロップダウンリストや「サイズ」テキストボックスの設定を編集します。
  • テキストや画像などのオブジェクトを整列するには、レイアウトグリッドを使用できます。
  1. レイアウトページをアクティブにして、表示:グリッド線の表示を選択するか、ウィンドウ上部でカーソルがMt prompt.pngの表示になったらクリックしてミニツールバーを表示して、グリッドを表示ボタンをクリックします。
    • グリッドにオブジェクトをスナップするには、フォーマット:グリッド線に揃えるを選択するか、ミニツールバーのグリッドを表示ボタンのメニューにあるグリッドにスナップオプションにチェックを付けます。

レイアウトグリッドの色は、color() 関数@GCLシステム変数を使用して変更できます。スクリプトウィンドウ(ウィンドウ:スクリプトウィンドウ)を開いて、以下のスクリプトを入力してEnterキーを押します(スクリプト内のRGB値を実際の値に置き換えます)。

@GCL=color(R, G, B, 1)

グリッドが既に表示されている場合は、F5キーを押して変更を確認します。

  • オブジェクト操作ツールバーを使用して図を整列する方法

オブジェクト操作ツールバー(表示:ツールバー)を使用して、レイアウトウィンドウで図(または、他のオブジェクト)を整列します。 「オブジェクト編集」ツールバーのボタンは、ウィンドウ内のアクティブなオブジェクトの表示を制御します。

  • 図をクリックして、オブジェクトをアクティブにします。
  • 複数の図をアクティブにするには、SHIFTキーを押しながら図をクリックします。または、図の周囲にボックスを表示して、グループ単位で選択します。
  • オブジェクト表示制御ダイアログボックスを使って図を整列する方法
  1. 図をダブルクリックしてオブジェクト表示制御ダイアログボックスを開きます。
  2. 「大きさ」タブを選択し、位置グループの左位置または上位置を編集します。 複数のオブジェクトに対してこのボックスを編集すれば、垂直または水平にオブジェクトを整列させることができます。

図の編集

レイアウトウィンドウ内の図の表示を変更するには、関連するウィンドウでグラフまたはワークシートを編集します。

  • ソースとなるグラフやワークシートウィンドウを編集するには:
  1. グラフまたはワークシートウィンドウをアクティブにするには
  2. ショートカットメニューからウィンドウにジャンプを選択します。

グラフまたはワークシート中の図を変更した後にレイアウトウィンドウをアクティブすると、変更が反映されます。 レイアウトウィンドウに変更が反映されない場合は、ウィンドウ:リフレッシュメニューまたは「標準」ツールバーリフレッシュButton Refresh.pngボタン を選択してウィンドウを更新します。

図に背景を追加

他のオブジェクトと同様、レイアウトウィンドウの図に背景の表示を追加することができます。

  • 図に背景の表示を追加するには
  1. 図をダブルクリックしてオブジェクト表示制御ダイアログボックスを開きます。
  2. イメージタブを選択します。
  3. 背景チェックボックスを選択して、該当するドロップダウンリストから適当な背景を選択します。

Note: この背景の適用ができるのは、1つのウィンドウまたはウィンドウ内の各オブジェクトに対してです。 ウィンドウの各オブジェクトに適用すると、背景表示は図から無くなります。

レイアウトウィンドウにあるグラフオブジェクトについてのコンテキストメニューのフォーマットのコピー/貼り付け

グラフオブジェクトのフォーマットをコピーし、そのフォーマットを他のグラフオブジェクトに貼り付けることができます。例えば、

  1. レイアウトページを開き、レイアウトページにテキストオブジェクトを2つ、「test1」と「test2」を追加します。
  2. テキストオブジェクト「test1」を右クリックし、オブジェクトの表示属性をクリックしてオブジェクトプロパティダイアログを開きます。
  3. 背景ドロップダウンリストでを選択します。OKをクリックしてダイアログを閉じます。OKをクリックしてダイアログを閉じます。
  4. オブジェクト「test1」を右クリックし、コンテキストメニューフォーマットのコピー:背景を選択します。
  5. オブジェクト「test1」を右クリックし、コンテキストメニューフォーマットの貼り付けを選択します。「test1」の背景が「test2」に反映されました。

レイアウトウィンドウの再描画の高速化

次の二通りの方法で、レイアウトウィンドウの再描画の高速化できます。

  • 図をイメージ枠で表示する方法:
  1. 図をクリックして選択します。
  2. レイアウト:イメージ枠の設定を選択します。

イメージ枠が表示されると、メニューコマンドの隣にチェックマークが現れます。

イメージ枠から図の表示に戻すには:

  1. イメージ枠をクリックして選択します。
  2. レイアウト:イメージ枠のクリアを選択します。
    または、
  3. 図のオブジェクト表示制御ダイアログボックスのイメージタブにあるピクチャフォルダを使用するチェックボックスのチェックのオンオフ、またはオブジェクトを右クリックして、イメージ枠の設定/クリアを選択し、図のイメージ枠の表示を制御します。

図を移動したり、そのサイズを変更したりするのと同様に、イメージ枠を移動したり、サイズ変更したりできます。 イメージ枠をダブルクリックすると、そのイメージ枠の「オブジェクト表示制御」ダイアログボックスが開きます。 背景ドロップダウンリストに入力された変更は、イメージ枠を非表示した際に表示されます。

Note: レイアウトウィンドウを印刷する場合、図のイメージ枠の表示は印刷に影響しません。

  • 関連するウィンドウの表示モードとは関係なく、図をページビューモードで表示する方法

レイアウトウィンドウ中の全ての図(及び追加のオブジェクト)をページビューモードで表示するオプションがあります。これは、図のウィンドウの表示モードに影響されません。 ページビューモードでは、印刷ビューモードより速く画面が更新されます。 レイアウトウィンドウの図(及びオブジェクト)をページビューモードで表示するには

  1. レイアウト:スピードの全般制御を選択します。

または、

  1. レイアウトウィンドウの内側、ページの外側を右クリックして、スピード全般の制御を選択します。 図がページビューモードで表示されている時には、このメニューコマンドにチェックマークが付けられています。 このモードの選択を解除するには、スピード全般の制御メニューコマンドを選択し直します。

ページビューモードの画面の表示には、プリンタドライバではなくスクリーンドライバが使用されます。(プリントビューではプリンタドライバが使用されます)したがって、スピード全般の制御メニューコマンドが選択されている場合、レイアウトウィンドウでのテキストの位置は、それ程厳密にはなっていません。 ただし、編集作業はそれぞれのウィンドウで行われるので、実際には問題ありません。 ウィンドウをアクティブにして表示:印刷ビューを選択して、テキストの位置付けを確認してください。 レイアウトウィンドウ中の図は、ウィンドウの印刷ビューモードでの表示にしたがって印刷されます。

レイアウト・グラフウィンドウのワークシートオブジェクトを変更を更新する

ワークシートの列の幅、行の高さ、フォントの色、塗りつぶしの色などが変更した際には、レイアウト・グラフウィンドウのワークシートオブジェクトを右クリックしてコンテクストメニューから更新を選びます。

オブジェクトのプロパティダイアログのプログラミングタブ更新ボタンをクリックすることで、同様にレイアウトやグラフを更新できます。

オブジェクトにレイアウトページサイズを合わせる

レイアウトページサイズを拡張して、挿入されたすべてのオブジェクトを含めるには、

  1. レイアウトウィンドウがアクティブな状態で、フォーマット:オブジェクトにページを合わせるを選択してページをレイヤ群のサイズに合わせるダイアログを開きます。
  2. レイアウトページの余白を指定します。
  3. OKボタンをクリックしてページサイズと余白を適用します。