3.1 Origin GUI

Summary

This tutorial will introduce you to the Origin workspace. You will learn about the different kinds of Origin windows that make up a Project, how to manipulate these windows with Project Explorer, how to manipulate layers and plots with Object Manager and how to manage Apps with Apps Gallery.

Minimum Origin Version Required: Origin 2016 SR0

What you will learn

This tutorial will show you how to:

  • Manipulate Workbooks
  • Create Graph Windows
  • Manage workspace with Project Explorer
  • Manipulate Layers and Plots with Object Manager
  • Manage Apps with Apps Gallery

Origin Application: Title Bar and Status Bar

The Origin Title Bar displays the Origin(Pro) version, any open project name and the current folder within that project (if any) along with the standard Window controls for moving, sizing and closing the window.

The Status Bar appears at the bottom of Origin's Window and displays messages, the state of Auto Update, overview of the statistics on selected worksheet cells, Child Window Theme (if any), Last active Workbook, Current Window and Angular Units indicator.

Navigating your way in Origin 1 new.png

You can select what shows in the Status Bar by right-clicking on the Bar and selecting (or clearing) items from the context menu. You can copy the displayed basic statistics by selecting Copy Statistics from the context menu. The copied data are TAB separated between quantity and values, with each key value pair separated by a CRLF delimiter.

Windows

Dynamic menus according to the active child window

The Origin menu dynamically changes according to the active Child Window. Some menus (Help, File, Edit, etc.) appear on all Child Window menus, although their content may change.

  1. Click on the New Project button Button New Project.png on the Standard Toolbar.
  2. The workbook window is the active window. Note that there are 13 menu items.
  3. Click on the New Graph button Button New Graph.png on the Standard Toolbar. A new window called Graph1 is created. Note that there are 11 menu items displayed.

Thus, we say that the menus are "context sensitive." They will change depending on which type of Child Window is active.

Note: New Child Windows may be added by selecting the File: New menu option or clicking the appropriate button on the Standard Toolbar. All Child Windows have standard controls for moving and sizing and windows can be placed anywhere within the Origin workspace. The Window menu has options (cascade, tile) for arranging child windows within the workspace. In the central Origin Workspace is where you will find all Origin Child Windows which can include:


Workbooks - The Origin workbook is the primary structure for organizing your data. Each workbook is composed of one or more, up to 255 worksheets.


Graphs - With Origin, you can create over 60 graph types, each from a built-in graph template. Graph windows can be embedded in a worksheet cell.


Matrices - The Origin matrix holds data and images and is required for many 3D graph types.


Notes - Notes windows are a text-only Origin child window useful for recording analysis procedures, making notes to students and colleagues, etc. You can embed notes windows in a worksheet cell.


Layouts and Excel (If you have Excel installed)

Workbook

The Origin workbook is the primary structure for organizing your data. Each workbook is composed of one or more Origin worksheets. Each worksheet, in turn, is composed (usually) of one or more worksheet columns or datasets. Columns in Origin have different column types, such as X, Y, Z, yError, etc, These plotting designations determine how the data are treated when creating a graph.

Starting with version 2017, Spreadsheet Cell Notation icon Spreadsheet cell notation mode.png will show in the upper-left corner of the workbook by default, that means the new simplified worksheet cell notation(similar to that used in MS Excel) is turned on. You can learn more details about how this mode works in the tutorial Setting Column Values.
Tutorial GUI 001.png

To get familiar with manipulating Origin workbooks, try the following:

  1. Select File: New from the menu and choose Worksheet to create a new worksheet.
  2. Select Data: Import from File: Single ASCII to bring up the Open dialog. Browse to the \Samples\Curve Fitting subfolder of the Origin program folder. Highlight the file Gaussian.dat and click the Open button to import the data into the Origin worksheet.
  3. On import, sparklines were automatically turned on, allowing you to quickly view the shape of the data; the sheet name became the name of the file; and as needed an additional column was added to the worksheet. You can see from the Long Name that the 3rd column represents data error. To set this column as an Error Column, click the column title to highlight the column, right-click to bring up a fly-out menu, and then select Set As: Y Error.
  4. Plotting data in Origin is now easy; highlight column B and C (Y and Y error), then select Plot: Symbol: Scatter from the menu to create a scatter plot with error bar.

Tutorial GUI 002.png

Graph

The Graph window is a container for graphical depictions of your experimental data and your analysis results. Graph windows may contain a single plot in a single graph layer or they may contain multiple plots in multiple graph layers.

The graph layer is the fundamental unit of the Origin graph. The layer is comprised of a set of axis scale values, one or more data plots, and any included text labels, drawing objects, graph legends/color scales, button objects, etc. Graph layers can be created, sized, and moved independently of one another, allowing you a great deal of latitude in charting your data.

To learn how to organize layers in a graph window, try the following:

  1. Create a new workbook, and import the file Linear Fit.dat from the \Sample\Curve Fitting folder. You can see that there are three Y columns and one X column after import; each Y column will use the left-most X column as its X coordinates.
  2. Highlight columns B and C, and select Plot: 2D: Multi-Panel: Vertical 2 Panel to plot the curves. This is a two layer graph. While a graph can have multiple layers, only one layer is active at any given time. You can perform operations on the active layer, such as resizing, changing the plot color, etc. When working on a layer, the active layer is denoted by a depressed layer n icon in upper left corner of the graph window.
    Tutorial GUI 003.png
  3. To rearrange these two layers, with the graph window active, select the menu item Graph: Layer Management to bring up the dialog. Activate the Arrange tab, on the middle panel. Enter 2 in the Column edit box. Enter 1 in the Row edit box and click the Apply button. After you click the OK button, the graph layers are arranged horizontally.
    Tutorial GUI 004.png

Most often you will use the worksheet for tabulating and manipulating your data, while you will use the graph window for plotting your data.

Matrix

The Origin matrix window is a container for one or more Origin matrices. Each matrix window contains one or more matrix sheets, and each matrix sheet can contain one or more matrix objects. The matrix object itself, is a vector of Z values. These Z values are related to one another in the X and Y dimensions by their relative row and column positions in the matrix. Matrices are a precursor to constructing Origin's 3D graph types such as contour graphs and color-mapped surfaces, and since they are used in depiction and manipulation of 3D data, they are used by Origin in image processing and analysis. We will show you how to use the Origin Matrix to create a 3D plot in a later tutorial.

Toolbars

The Customize Toolbar dialog box handles displaying or hiding toolbars and toolbar buttons.

  1. Select View: Toolbars from the Origin menu. The Customize Toolbar dialog opens.
  2. Check the box next to Column. This toolbar now appears in the workspace.
  3. Make the Button Groups tab active.
  4. Scroll to select AutoUpdate in the Groups list.
  5. Click and drag the one button which appears in this group and drop the button next to the green version of this button without the red line, on the Standard Toolbar. You can drag buttons back and forth.
  6. Click Close.

All these toolbars may be dragged away from their docked positions to become floating windows. Floating windows have additional controls besides the X to hide a window. A push-pin control can allow or prevent docking and a minimize button can roll-up a window to save space and restore the window when it is needed.

Toolbar Reference

Below are the most commonly used toolbars.

Standard Toolbar
Standard Toolbar.png

Worksheet Data Toolbar
Worksheet Data Toolbar.png

Graph Toolbar
Graph Toolbar.png

Format Toolbar
Format Toolbar.png

Style Toolbar
Style Toolbar.png

Tools Toolbar (vertical on the left side of the Origin workspace)
Tools Toolbar.png

2D Graphs Toolbar
2D Graphs Toolbar.png

3D and Contour Graphs Toolbar
3D and Contour Graphs Toolbar.png

Mask Toolbar
Mask Toolbar.png

Project Explorer

Project Explorer is a tool to help you organize your Origin data. It is particularly useful if you are working with a project that contains numerous child windows. Use Project Explorer to develop a folder structure to organize the child windows in your project.

Open/Close Project Explorer

When you first start Origin, Project Explorer displays docked to the edge of the workspace. You can dock it to any other edge or float it in the workspace. Because Project Explorer uses some of your workspace, you may want to close Project Explorer, even if you have already created a folder structure. To close/open Project Explorer, click the Auto Hide button to pin the Project Explorer, then press Alt + 1 or select menu item View: Project Explorer.

Change the Display Properties of Project Explorer

The project explorer can be auto-hidden, hidden, floating or docking. In another aspect, it has vertical and horizontal alignment.

  1. Select Customizing Graphs.opj in <Origin EXE Folder>\Samples\Graphing folder.
  2. By default the Project Explorer is auto hidden, move mouse over to the Project Explorer bar in the left of work space to expand it.
  3. Click the Auto Hide button to pin the Project Explorer, so it will be always displayed.
    Tutorial GUI AutoHide.png
  4. Select the Window Position drop-down and select Floating to make the Project Explorer float over the work space, and you can freely move its position:
    Tutorial GUI Floating.png
  5. Right click on the title bar of the floating Project Explorer and select Horizontal Alignment:
    Tutorial GUI PE Alignment.png

Note: Other dockable windows (Object Manager, Apps, Message Log, Smart Hint Log, etc.) have the similar controls to change the display properties.

Browse Origin windows in Project Explorer

There are two panels in Project Explorer: the folders panel and the contents panel, which displays all objects in the active folder. When you start a new Origin session, you can click the new workbook New Workbook.png, new graph New Graph.png or new matrix New Matrix.png button to create some blank windows, and then you can see these window's icons in the contents panel. Double-click the icon to hide/view the window.

Tutorial GUI 005.png

Add a Sub Folder in Project Explorer

To create a new folder, right-click on the project folder (or a subfolder) in the folder panel, and select New Folder from the shortcut menu.

Tutorial GUI 006.png

Once you have created one or more subfolders, you can move child windows between folders by dragging & dropping them within the Project Explorer workspace.

Object Manager

Object Manager provides a hierarchy structure to help you view and manipulate layers and plots in the active graph window. It is particularly useful if the graph contains multi-layers and each layer contains multi-plots.

Open/Close Object Manager

When you first start Origin, Object Manager is docked to the right edge of the workspace. Like Project Explorer, you can dock it to any other edge or float it in the workspace. To close/open Object Manager, select menu item View: Object Manager.

Manipulate layers and plots in Object Manager

Object Manager works interactively with active graph window. Selecting layer or plot in graph window will highlight the corresponding item in Object Manager and vice versa. This makes it very easy to select an item and then show or hide it.

For example, try the following:

  1. Select Help: Learning Center menu or press F11 key to open Learning Center. Select Graph Sample in the left side of dialog, choose Multiple Panel for Samples in drop-down list. Double-click on Multiple Panel by Column Label thumbnail to open the sample graphing project.
  2. Select any plot object(such as a layer, a plot group or a curve) in graph window, the corresponding items will be highlighted in Object Manager. Select items in Object Manager, the corresponding object will be highlighted in the graph window.
  3. In Object Manager, Uncheck the checkbox before the plot Trail Run 1 of Layer1 to hide this plot.
  4. Right click on the plot Trail Run 2 of Layer1 and select Hide Plots with Same Name to hide all plots named Trail Run 2.
  5. Right click on the plot Trail Run 2 of Layer1 again and select Show All Plots. All Trail Run 2 plots are back.

Tutorial GUI 009.png

The plot names in Object Manager is the Auto Legend Translation mode set in the graph. Therefore same name or not depends on what the legend translation mode is used.

Besides using Object Manager to turning on or off layers or plots, it can also be used to:

  • Change plot orders by right clicking on a plot and selecting Move Up/Move Down
  • Change plot type by right clicking on a plot and selecting Change Plot To
  • Go to source workbook/matrix book by right clicking on a plot and selecting Go to xxx
  • Double click on an item to open corresponding node in Plot Details dialog for futher customization or use context menu to open Useful dialogs.

Tutorial GUI 008.png

Apps

Apps are custom applications for Origin that perform specific graphing and/or analysis tasks. Apps are not pre-installed with Origin. If you want to get an App, you can

  • Browse to our File Exchange page of the OriginLab website, search and download the app you desired to install.
  • Open App Center(by selecting Help:App Center, or pressing F10 key, or clicking the Add Apps button that appears on all tabs of the Apps Gallery), browse available Apps, search for Apps using keywords and phrases, and install or update Apps with a single click.
    App Center installation.png

When Apps get installed, they will be visible in the Apps Gallery window of the Origin interface.

Origin Apps.png

In the Apps panel, you can add new tabs from the context menu and then classify these installed APPs by putting them to different tabs, see "Graphing", "Analysis" tab in the above APP Gallery. All Apps will be presented in the All tab in the order of their installation times.

Each installed App will be displayed as an icon in the gallery window. You can simply click on the icon to launch the App and right-click on the icons for other options such as hiding, uninstalling the App or movement between the tabs.

Origin Apps Shortcut Menu.png

Learning Center

Learning Center dialog helps you get started with Origin easily. You can select Help: Learning Center from Origin menu or press F11 key to open it.


Learning Center 2019.png


With this dialog, you can

  • Open Graph and Analysis Samples
  • With the Learning Sources, get started with Origin
  • Transfer User Files

Messages Log

The Messages Log window shows messages about operations including Output Information, Results and Errors. It displays messages that are not sent to the Script Window or the Command Window. To close/open Messages Log, press Alt + 6 or select menu item View: Messages Log.

  1. Open a new workbook, highlight the A(X) and B(Y) columns, right-click and and choose Fill Columns With: Row Numbers from the shortcut menu.
  2. Highlight the columns and from the Main Menu, choose Plot: 2D: Line: Line. A simple line plot is drawn.
  3. Select File: Export Graphs... from the main menu to open the ExpGraph dialog. In this dialog, keep the default settings and click OK to export the graph.
  4. The Output Information is reported to the Messages Log window.