出版とエクスポート


Grand image graphic export.png

目次

マスターページ

マスターページの機能は グラフのエクスポートおよび印刷で1つ以上の共通オブジェクトを追加するために使用します。マスターページを使ってプロジェクト内の選択されたグラフウィンドウにプロパティやオブジェクトのセット(カスタム背景、企業ロゴ、テキストラベル、画像など)を追加できます。

Master items applied.png

この機能を使用するためには、最初にマスターページを作成する必要があります。マスターページは他のグラフウィンドウで表示したいプロパティやオブジェクトのみを含みます。

  1. メニューからファイル: 新規作成: マスターページを選びます。このメニュー項目を選択したときにプロジェクトのルートフォルダにいない場合、プロジェクトルードフォルダに切り替えるか尋ねられます。
  2. マスターテンプレートを編集します。マスターテンプレートを保存ボタンの下に表示されるコメントは「非表示」で、グラフウィンドウには適用されません。
  3. マスターテンプレートを保存ボタンをクリックします。 保存すると、マスターテンプレートが、 "アクティブウィンドウ名".otpu (例: "C:\Users\YourName\Documents\OriginLab\User Files\Master.otpu")という名前でユーザファイルフォルダに保存されます。


マスターページについて知っておくべきこと:

  • マスター項目は、テンプレートと同じ寸法のグラフページでのみ表示されます。全グラフに寸法を適用ボタンは、マスターテンプレートのページ寸法を同じ方向のグラフ全てに適用します。
  • グラフを作成してページサイズを変更する場合は、ファイル:新規:マスターページを選択し、マスターテンプレートをワークスペースにロードすると、変更されたグラフページのページディメンションがマスターテンプレートにロードされます。
  • 回転ボタンはマスターテンプレートのページ寸法を入れ替えます(横と縦の向きを切り替え)。
  • 全てのグラフに寸法を適用をクリックすると、同じアスペクト比のグラフ、または同じ方向(縦または横)のすべてのグラフにのみ寸法を適用するかどうかを確認するメッセージが表示されます。
  • 縦向きグラフのマスターページ項目は、横向きのグラフには表示されず、逆もまた同様です。
  • マスター項目を使用しない場合、編集:ページコピー(CTRL + J)は、編集可能なOriginのOLEグラフオブジェクトをクリップボードにコピーします。マスター項目を使用している場合、編集:ページコピーするとクリップボードに画像 をコピーします。画像としてグラフをコピーダイアログが開くので必要に応じて画像設定を変更してコピーをクリックします。
  • マスター項目使ったグラフの場合、PowerPointにグラフを送る機能において埋め込みオブジェクトのオプションはサポートされません。代わりに、グラフを画像として挿入するオプションはマスター項目をサポートしています
  • ワークスペースおよびエクスポートまたは印刷ページでマスター項目を選択的に除外するメカニズムがあります。エクスポート/印刷されたページに表示したくないオブジェクトは、「NoExport」で始まる必要があります(たとえば、矢印オブジェクトのプロパティダイアログを開き、プログラミングタブで名前を「NoExport_Arrow」に変更します)。
  • マスターページをカスタマイズしてユーザファイルフォルダに保存すると、次回ファイル: 新規作成: マスターページを選択したときに、編集したテンプレートがロードされます。
  • ワークスペースでマスター項目を表示したくない場合、表示: 表示様式: マスター項目の画面表示を選択してチェックを外します。エクスポートグラフはマスター項目を含みます(ワークスペースでのみ非表示)。
  • ワークスペースエクスポートグラフの両方でマスター項目を表示しないようにするには、フォーマット: ページ表示指定タブでマスター項目を使うのチェックを外します。

テキストツールを使用してプロジェクトやシステム情報を静的テキストオブジェクトとしてマスターテンプレートに追加することもできますが、再利用できるテンプレートを作成することが目的であるため、情報を「ソフトコーディング」したテキストラベルを検討してください。詳細は、以下のトピックを参照してください。

エクスポートの余白ダイアログボックス

コピーまたはエクスポートグラフの余白は、デフォルトでは、ツール: オプションのページタブにあるページコピーの設定グループの、環境設定:オプション の、余白の制御(コピーの場合)または、グラフエクスポートダイアログのエクスポート設定(エクスポートの場合)によって決定されます。エクスポート余白幅ダイアログボックスを使って、デフォルトの余白を動的に調整できます。

Export margin control.png
  1. グラフウィンドウをクリックしてアクティブにし、編集: エクスポート余白の設定を選択します。エクスポート余白の設定ダイアログが開きます。
  2. ページ上に表示される青い選択ハンドルをドラッグ、または、ダイアログの編集ボックスに値を入力して適用をクリックします。

ページをレイヤサイズ、レイヤをページサイズに合わせる

エクスポートする前に余白を削除したり、グラフの周りに余白を設定するのに便利なダイアログです。

  • レイヤにページサイズを合わせるグラフ操作:レイヤにページサイズを合わせるを選択して、pfit2lダイアログボックスを開きます。
  • ページにレイヤサイズを合わせるグラフ操作:ページにレイヤサイズを合わせるを選択して、gfitpダイアログボックスを開きます。
DB pfit2l 1 small.png

両方のダイアログを使用して余白を削除できます。両方とも、グラフのアスペクト比を変更してもしなくてもサイズ変更を実行できます。両方のドキュメントを参照して、どちらが最適なのかを判断できますが、基本的には、特定のページサイズを維持する必要があるかどうかを判断します。ページサイズを維持する場合は、ページにレイヤサイズを合わせるがお勧めです。ページサイズを変更してもいい場合はどちらもうまく機能するでしょう。

グラフのコピーと他のアプリケーションへの貼り付け

Originグラフを別のアプリケーションのファイル(Microsoft Wordの.docxファイルなど)に貼り付ける場合、次の2つの方法があります。

  • 画像として
  • 編集可能なOLEグラフオブジェクトとして


画像として貼り付けた場合、静的オブジェクトとして貼りつきます。たとえば、MS Wordでは、Wordの画像編集ツールを使用して画像を変更できますが、Originでグラフを編集して、Word上のグラフを更新することはできません。Originで編集する場合は、既存の画像を削除して置き換える必要があります。

対照的に、編集可能なOLEグラフオブジェクト として貼り付ける場合は、後に貼り付け先のアプリケーションでオブジェクトをダブルクリックすると、Originが起動します。開いたOriginで、グラフや関連するデータシートを編集可能です。編集が終わったら、メニューからファイル:終了して文書…に戻るを選択して、埋め込みオブジェクトを更新し、Originを閉じてから、元のアプリケーションに戻ります。

画像としてグラフをコピーする

  1. グラフをクリックして、これをアクティブにします。
  2. 編集:画像としてグラフをコピーするを選択します(あるいは、CTRL+ALT+J)。あるいは、グラフウィンドウのページ余白部分でクリックして表示されるミニツールバー画像としてグラフをコピーボタンをクリックします。
    MT copy graph as image mt button.png
  3. 貼り付け先のアプリケーションで貼り付けを選択するか、CTRL+Vキーを押します。

画像としてグラフをコピー(CTRL+ALT+J)するときに、画像形式(PNG, EMF, DIB, HTML, JPG)を選択できます。また、簡単なサイズ調整や、背景透過の設定が可能です(PNG)。画像としてグラフをコピー(copyimg) ダイアログでは、ダイアログテーマを利用でき、<前回通り>の設定を呼び出したり、現在の設定を<デフォルト>として保存したり、設定内容をテーマとして名前を付けて保存することができます。

Copy graph as image dialog.png

環境設定:オプション:ページタブのコピーの設定で、CTRL+Cホットキーで画像としてグラフをコピー<前回通り>するかページコピー(CTRL+J)(編集可能なOLEグラフオブジェクトとしてコピー)するか設定できます。これにより、画像としてグラフをコピーダイアログを経由せずに、CTRL+Cを使用して標準化された画像を素早くクリップボードに配置できます。

編集可能なOLEグラフオブジェクトとしてグラフをコピー

  1. 編集: ページコピーを選択します(あるいはCTRL+J)。
  2. 貼り付け先のアプリケーションで貼り付けを選択するか、CTRL+Vキーを押します。


Note: 詳細については、次のヘルプ文書を参照して下さい。

ヘルプ:Origin:Origin ヘルプ > グラフのエクスポートと出版 > 他のアプリケーションでのグラフのリンクや埋め込み

プレゼンテーション用グラフの編成やエクスポート

Originのプロジェクトファイルに、エクスポートしたりOriginのスライドショーで使ったりするグラフがたくさんある場合、プロジェクトエクスプローラのお気に入りフォルダーにグラフのショートカットを作成しておき、そこで操作すると作業が簡単になります。

  • プロジェクトエクスプローラでウィンドウを右クリックし、ショートカットをお気に入りに追加を選択します。この操作で、それぞれのグラフウィンドウのショートカットを、新しいお気に入りサブフォルダ(プロジェクトエクスプローラで表示)に追加できます。
  • PowerPointにグラフを送ったり、Originのスライドショーを作成したりする場合、(1)ダイアログボックスに応じてスライド順を設定したり、(2)この手順に沿ってスライド順を設定したりできます。

出版用の原稿を作成する場合は、次を参照してください。FAQ-441 出版社から指定されたサイズおよび解像度でグラフをエクスポートするにはどうしたらよいでしょうか?

レイアウトページ

Origin 2022bでは、レイアウトページを.SVGファイルへエクスポートできます。グラフをレイアウトに追加する場合は、レイアウトの右クリックメニューからグラフの追加を選択すると、SVGファイルの要素(テキストなど)がInkscapeやAdobeIllustratorなどのアプリケーションで編集可能になります。

レイアウトページは名前のとおり、出版またはエクスポート用にさまざまな要素をレイアウトするのに役立つウィンドウです。グラフ、結果表、テキストオブジェクトなどを1つのパネルにまとめるために使用します。

UG PubExport Layout1.png

通常、空白のパネルを作成することから始めます。

  1. 標準ツールバーの新レイアウトウィンドウボタンをクリックします。
  2. 空白のレイアウトを右クリックして、クリップボードのコンテンツの貼り付け、テキストの追加、ファイルからの画像の挿入、グラフ、表の追加などを行います。
  3. ファイルから画像を挿入する場合は、挿入したい場所を右クリックします。グラフまたはワークシートを追加する場合は、ブラウザ内のウィンドウを選択して、レイアウト上の領域をマウスでドラッグします。追加したオブジェクトはマウスでドラッグして移動、サイズ変更可能です。
    • 挿入した画像はダブルクリックして、編集できます。画像はイメージウィンドウに開きます。
    • さらに、挿入したグラフオブジェクトをダブルクリックすると、グラフを編集できます。これにより、編集用のソースグラフが開きます。ソースグラフを編集すると、レイアウトページのグラフが更新されます。
    • 挿入した表は、表オブジェクトをダブルクリックして編集できます。スタイルの調整は、表オブジェクトを選択し、使用可能なミニツールバーボタンを使用して行うことができます。
  4. レイアウトページの要素は、複数選択してオブジェクト編集ツールバーボタンを使用して整列できます。
Object Edit bar.png


レイアウトページの詳細については、Originヘルプファイルのレイアウトページウィンドウの利用を参照してください。

レイアウトにグラフを追加

手動でレイアウトを作成する方法のほかに、Originには、複数グラフを統合して1つのレイアウトウィンドウに等間隔に配置するツールがあります。この場合、統合されたグラフは画像になるので、前セクションのステップ3で説明した方法による編集ができません。しかし、編集が完了したグラフであれば、見た目よく配置する最も速い方法です。

UG graph merge layout.png


ひとつのレイアウトにグラフ画像を統合

  1. グラフウィンドウがアクティブな状態で、グラフ操作: レイアウトにグラフを追加をクリックします。
  2. 設定ドロップダウンリストからグラフの選択方法を指定します。個々のグラフを選択するには、指定を選択し、グラフの横にある参照ボタンを使用してグラフブラウザを開き、グラフを選択します。

Origin 2022b では、オブジェクトにページを合わせるメニュー(フォーマット:ブジェクトにページを合わせる)が追加され、アクティブなレイアウトページに均一な余白を適用できます。これは、前述のグラフウィンドウのレイヤにページを合わせると同じように機能します。

画像ファイルへのグラフやレイアウトページのエクスポート

Origin 2021bには、従来のものより設定項目がシンプルなグラフエクスポート機能が追加されています。

  • ファイル: グラフを画像としてエクスポート: 1つまたは2つのグラフをいくつかの一般的な画像形式(PNG、BMP、JPEG、TIFF、EMF)のいずれかにエクスポートします。画像サイズ程度の制御で十分な場合、すばやく、簡単なこの方法が便利です。
  • ファイル:グラフエクスポート(詳細): 複数グラフ(現フォルダプロジェクト内の全グラフ)のエクスポート時やPDFやEPSなどのベクター形式のエクスポートにはこの機能を使います。このダイアログでは、指定のパスへの出力、自動命名、スピードモード設定のオンオフ、余白の設定、画像サイズなどの設定が可能なほか、ファイル形式に固有の設定項目も用意しています。

Origin 2022bでは、グラフやレイアウトページを.SVG ファイルにエクスポートできます。エクスポート前に、@SVGTC = 1であることを確認してください。テキストオブジェクト(軸のタイトルや目盛ラベルなど)がInkscapeやAdobeIllustratorなどのアプリケーションでより簡単に編集できます。

ファイル: グラフを画像としてエクスポート

ファイル:グラフを画像としてエクスポート(Xファンクション= expG2img)は、アクティブなグラフページを画像(PNG, BMP, JPEG, TIFF, EMF)にエクスポートするシンプルな機能です。 ファイル:グラフエクスポート(詳細)のようなレベルの制御や柔軟性はありませんが、個々のグラフページを単純にエクスポートする場合にはお勧めです。


expG2imgを使用してエクスポートするには:

  1. グラフウィンドウをアクティブにし、ファイル:グラフを画像としてエクスポートを選択します。
  2. EMF 画像の場合、縮小率を設定でき、ダイアログ下部に画像サイズが表示されます。ラスター形式では、DPIの設定を選択できます。または、自動チェックボックスをオフにして、幅をピクセル単位で指定します。
UG expG2img.png

ファイル: グラフエクスポート(詳細)

ファイル: グラフエクスポート(詳細)(Xファンクション=expGraph)は、グラフとレイアウトページをエクスポートするためのOrignの主要なツールです。ラスターまたはベクター出力、柔軟なマルチページエクスポート(すべてアクティブフォルダ内など)、DPIおよびスピードモード制御などをサポートします。


グラフまたはレイアウトページをイメージファイルとしてエクスポートするには:

  1. ファイル: グラフエクスポート(詳細)メニューを選択します。
UG expGraph DB.png


expGraphルーチンは、グラフを15のファイル形式のいずれかにエクスポートします。

ラスター形式 BMP, GIF, JPG, PCX, PNG, TGA, PSD, TIF
ベクター形式 CGM, DXF, EPS, EMF, PDF, SVG, WMF


エクスポートの設定をテーマとして保存

ほとんどのOriginのダイアログボックスの場合と同様に、カスタムした設定をダイアログテーマに保存して繰り返し使用できます。

UG expGraph Dialog Theme.png

エクスポート設定を変更したら以下のように操作します。

  • ダイアログテーマの右にある矢印ボタンをクリックしてテーマ保存オプションの一つを選択します。
  • 任意のカスタム設定グループを使用すると、<前回どおり>という一時的なデフォルトテーマが作成されます。このテーマは、expG2imgおよびexpGraphダイアログボックス、またはファイル: 最近エクスポートしたファイルメニューからアクセスでき、前回の設定をロードします。
ExpGraph Last used.png


Origin 2021以降、expGraphダイアログボックスの設定は、エクスポート時にグラフに自動的に保存されます。

  • エクスポートせずに現在の設定を保存するには、保存先<グラフ>を選択します。
  • エクスポートダイアログで変更した後に保存した設定を復元するには、<グラフ>を選択します。
UG Save to Graph Theme.png
Note: 詳細については、次のヘルプ文書を参照して下さい。

ヘルプ:Origin:Origin ヘルプ > グラフのエクスポートと出版 > グラフやレイアウトページの画像ファイルへのエクスポート

フォルダ内の全グラフやプロジェクト内の全グラフといった複数のグラフをマルチページPDFファイル1つにエクスポートできます。ファイル: グラフエクスポートを選択してダイアログボックスを開きます。画像の種類Portable Document Format (*.pdf)にし、グラフを選択でオプションの一つを選択するとマルチページPDFファイルとしてエクスポートのチェックボックスを使用できます。

Export as multipage PDF.png

画像をラスターファイルでエクスポート

イメージウィンドウの内容をラスター形式のファイル(BMP, GIF, JPG, PNG, TIF)としてエクスポート可能です。

UG cvExport dlg.png

Origin 2022bでは、エクスポート画像の DPIを設定できます。

PowerPointにグラフを送る

OriginグラフのグループをMS PowerPointに画像や埋め込みオブジェクトとして送信することができます(上述した埋め込みオブジェクトとマスターアイテムの制限を参照)。埋め込みオブジェクトとして挿入されたグラフは、Originソフトウェアで編集できます。PowerPointのグラフをダブルクリックして、OriginのOLEインスタンスでグラフを開きます。


PowerPointにグラフを送る方法

  1. 標準ツールバーのPowerPointにグラフを送るボタンButtons send graphs to PowerPoint.pngをクリックします。

または、

  1. 右側またはOriginワークスペースにドッキングされているアプリギャラリーSend Graphs to PowerPointアイコンAPP SG2PP.pngをクリックします(アプリギャラリーが表示されない場合は、表示:アプリをクリックするか、ALT + 9を押します)。

または、

  1. プロジェクト・エクスプローラの下部パネルの上で右クリックし、PowerPointにグラフを送る を選択します。


チュートリアル:PowerPointにグラフを送る

  1. Originを起動し、サンプルファイル<Origin EXE Folder> \ Samples \ Graphing \ Column and Bar.opjuを開きます。
  2. 標準ツールバーのPowerPointにグラフを送るボタンButtons send graphs to PowerPoint.pngをクリックします。
  3. グラフを選択 ボタンを押して、個別指定 を選択します。
  4. 左側のパネルでGraph5B以外のすべてを選択し、ダイアログボックスの中央にあるButton Add Files.pngをクリックして、右側のパネルに移動します。OKをクリックします。スクロール可能なグラフのリストがアプリケーションの左側のパネルに追加されます。
  5. グラフの挿入形式画像 に設定します。
  6. スライドの余白の最上部の寸法を8%に設定し、他の寸法は0のままにします。
  7. タイトル行スライドの上部に設定し、タイトルウィンドウロングネーム に設定します。
  8. スライドインデックスの開始3 に設定し、 スライドモード今すぐ開始 に設定します。
  9. <Origin EXE Folder> \ Samples \ Import and Export \ Column_Plots_in_Sample_OPJ.pptxファイルをロードするには、ファイル/テンプレートのロード(オプション)の横にある参照ボタンを使用します。
  10. 作成されたPPTXファイルの保存パスとして(オプション)出力パスを指定します。

Originソフトウェアに事前インストールされているSend Graphs to Wordアプリもあります。このアプリは、ブックマーク済みのMS Word文書にバッチ式にエクスポートする場合に特に便利です。

グラフのスライドショー

Originには、グラフを表示したり、プレゼンするためのスライドショーの機能が備わっています。以下の2通りの方法でスライドショーを開始可能です。

  • プロジェクトエクスプローラを開き、対象のフォルダレベルで右クリックしてグラフのスライドショーを選択

または

  • 標準ツールバーより、グラフのスライドショーボタン Button Slide Show Graphs.pngをクリックします。

ダイアログボックスが開き、スライドショーの順番やスライドの間隔、サブフォルダないのグラフを含めるかどうかなどを設定できます。また、このダイアログでは、スライドショーの間使用できるショートカットキーをリスト(例えば、G=グラフに行く)が表示されます。

チュートリアル:グラフのスライドショー

  1. ファイル:サンプルプロジェクトを開く:2D and Contour Graphsからサンプルプロジェクトを開きます。
  2. 標準ツールバーより、グラフのスライドショーボタン をクリックします。
  3. ダイアログが開いたら、デフォルトのままOKボタンをクリックするとスライドショーが開始します。
  4. 上下の矢印キーやマウスのホイールを回してスライドをめくることができます。

グラフ動画を作成

Originにはビデオビルダーツールがあり、標準ツールバーのビデオビルダーを開くボタンButton Open Video Builder.pngからアクセス可能です。このツールを使用すると、一連のグラフウィンドウを手動でキャプチャし、これらを動画ファイル(.AVI)として1つのフレームにまとめることができます。

LabTalkスクリプトやOriginCコードを使用すれば、計算され、更新されるデータをステップごとにキャプチャし、動画を作成可能です。

Note: 詳細については、次のヘルプ文書を参照して下さい。

ヘルプ:Origin:Origin ヘルプ > グラフのエクスポートと出版 > グラフアニメーションを作成する

プログラミングにより動画を作成するための、コードやOriginプロジェクトを含むサンプルが利用可能です。www.originlab.com/animation

ノートウィンドウでレポート作成

Origin 2022bでは、ノートウィンドウでリッチテキストがサポートされます。

Originのノートウィンドウは、研究ノートを書き留めるためのプレーンテキストウィンドウから、さまざまな研究関連資料を照合するための柔軟なツールとして変化してきました。

Notesウィンドウには、グラフや画像、ワークシートのセル値といったリンク オブジェクトを含めることができるため、分析結果を要約する目的で、ノートウィンドウを分析テンプレート™に追加すると便利です。または、ファイル:印刷をクリックしてPDFドライバを選択することにより、ノートウィンドウの内容をPDFとして保存することもできます。

ノートウィンドウのシンタックス

Originのノートウィンドウは、テキストOriginリッチテキスト(デフォルト、HTMLMarkdownの4つのシンタックスをサポートしています。

  1. シンタックスの切り替えは、メインメニューのメモシンタックステキストを選択します。
  2. 一度テキストを選択すれば、ノートメニューの他のシンタックスを選択できるようになります。

リッチテキスト

リッチテキストの場合、ノートウィンドウには生のテキストモードとレンダリングモードの2つのモードがあります。これらを切り替えるには、メモ:レンダリングモードを使用するか、ショートカットキーCTRL + Mを使用します。

ノートウィンドウにテキストを追加するには、生テキストモードにする必要があります。追加したテキストのスタイルを設定するには、書式ツールバーを使用するか、事前定義された段落スタイルを適用します。

UG basic rich text fmt.png

ノートにコンテンツを追加

ノートウィンドウを右クリックして挿入できるオブジェクトは以下の通りです。

UG insert objects shortcut menu notesWin.png
オブジェクト コメント
グラフ/画像 プロジェクト内のグラフと画像を選択できるグラフ/画像ブラウザを開きます。埋め込みグラフを表示(「埋め込みグラフ」の定義については、この表の最初の行を参照)およびプロジェクトエクスプローラの「お気に入り」フォルダのショートカット(ショートカットページを含む)を選択できます。
ワークシートセル... インタラクティブ範囲セレクタを開きます。これを使ってワークシートまたはレポートシートのセル値を取得します。完了をクリックしてリンクセル値を挿入します。
情報変数... データインポート時に保存されたプロジェクト変数を挿入する変数の挿入ダイアログを開きます。
新規テーブル 基本のテーブルを構成するための新規テーブルダイアログを開きます。OKをクリックするとダイアログが閉じ、1つのワークシートを含むワークブックが開きます。ワークシートをカスタマイズしたり、データを追加したりしてから、ノートウィンドウのレンダリングモードを使用して、結果のテーブルを表示します。
シンボルマップ タブでソートされた文字で簡易版シンボルマップを開きます。詳細をクリックすると完全なシンボルマップを開けます。
LaTeX数式 無料配布のLaTeX Equation Editorアプリを開きます。未インストールの場合は、インストールするか尋ねられます。Equation ボタンUG latex equation button.pngをクリックしてOriginのフィット関数のリスト(ユーザ定義関数を含む)を開きます。関数を選択または、上部のボックスに関数名を入力してPreviewをクリックして数式を確認します。
リンク 表示するテキストリンクを入力するダイアログボックスが開きます。リンクはURLや、range://[book1]sheet1!col(1)[100]のようなワークシートのデータ範囲へのリンクなどにすることもできます。さらに、 "labtalk://" タグ(例:labtalk://newsheet)を使用して簡単なLabTalkコマンドを実行することもできます。
ファイルからの画像 ダイアログを開いて画像ファイルを選択します。挿入された画像は外部ファイルにリンクされ、プロジェクトと一緒に保存されないことに注意してください。
Webからの画像 ダイアログを開いて、Web画像の画像リンクを指定します(ヒント:ブラウザで画像を右クリックし、画像アドレスをコピー画像リンクをコピーなどを選択)。


  1. 生テキストモードを使用してコンテンツを追加します。
  2. コンテンツを表示する準備ができたら、メモ:レンダリングモードを選択するかCTRL + Mを押してチェックマークを付けます。標準ツールバーのズームコンボボックスStandard button zoom combo.pngを使用して、ページをズームインまたはズームアウトできます(Ctrl +マウスホイール回転でも可能)。
UG cell notes rich text images.png

テキストスタイルマネージャ

書式ツールバーを使用したテキストのスタイル設定に加えて、各行に簡単な段落スタイルのセットを適用できます。テキストスタイルマネージャダイアログボックスでスタイルを管理します。

  1. ワークシートをアクティブにして、ツール:テキストスタイルマネージャを選択します。
  2. 変更するスタイルおよび適用または閉じるを選択します。
UG mod txt styles dlg.png

変更するスタイルドロップダウンリストから<新規> を選択すると、スタイルを追加できます。または、スタイルを選択して削除できます。

ノートウィンドウで段落スタイルを適用する方法

  1. ノートウィンドウでセルノートを開きます。
  2. レンダリングモードをオフにして(CTRL + Mで切り替え)、テキスト行をクリックして右クリックし、メニューから段落スタイルを選択してスタイルを選択します。
  3. 表示を確認するには、CTRL + Mを押してレンダリングモードをオンにします。

組み込みの段落スタイルのリストを表示するには、新しいノートウィンドウを開き、メニューからメモ:サンプルのロード:組み込みStyles.txtを選択します。

レイアウトまたはグラフにリッチテキストを追加

レイアウトまたはグラフページのテキストオブジェクトに、ノートウィンドウのリッチテキストを挿入します。

UG insert notes text to layout.png


既存のノート(レイアウトまたはグラフ)のコンテンツを追加する

  1. テキストツールText button.pngを選択して、レイアウト/グラフ上でクリックし、"@@@NotesN"(ノートウィンドウのショートネーム)と入力します。
  2. テキストオブジェクトをクリックして、ノートの内容を挿入します。


新しいメモを作成してコンテンツを追加する(レイアウトのみ)

  1. レイアウト上で右クリックして、ノートテキストを挿入を選択します。
  2. 詳細はノートにコンテンツを追加を参照してください。

印刷またはPDFにエクスポート

リッチテキストコンテンツを印刷できます。あるいは、Microsoft Print to PDFなどのサードパーティドライバを使用してPDFに印刷できます。

見栄えを良くするには、次の設定に注意する必要があります。

  • 用紙サイズ: これは、ファイル:ページの設定またはプリンタードライバーの詳細オプションで設定します。
  • 余白: ファイル:ページの設定で設定します。
  • ノート表示の余白:デフォルトでは、ノート表示の余白= 5(単位=ポイント)です。したがって、レンダリングモード(CTRL + M)では、ノートページの左側にわずかな余白があることに注意してください。この表示余白はシステム変数@NDMで制御できます。
  • ノートウィンドウのページ幅: ページ幅はプロパティ note.width (単位 = in/cmなど)で制御されています。デフォルト = 0で、制御なしの幅に対応します。最良の印刷結果を得るには、notes.widthを設定する必要があります。


用紙サイズ - 余白 - ノート表示の余白 = 印刷領域の幅 (紙またはPDF)

たとえば、左右に1インチの余白がある8.5インチ幅のページでは、表示余白は0ポイントで、幅6.5インチとして「印刷」する必要があります。したがって、最良の結果を得るには、印刷する前にpage.width = 6.5に設定してください。

HTMLおよびMarkdown

ノートウィンドウを使ってHTML あるいは Markdownレポートを作成することもできます。リッチテキストと同様に、メタデータ、統計結果、グラフなどのレポートシート要素にリンクするプレースホルダを使用してHTMLレポートを作成できます。結果のHTMLレポートは印刷またはエクスポートできます。または分析テンプレートに組み込むこともできます。Markdown構文を使用する場合は、高度なカスタマイズのためにオプションのHTML構文を含めることができます。

この機能を使用するには、ユーザーはHTMLまたはMarkdownについてある程度の基本的な知識を持っている必要があります。ほとんどの場合と同様に、ユーザーが熟練しているほど、プロ並みの出力を簡単に作成できます。ただし、基本的なレポートを作成するために必要なスキルは簡単に習得できます。このOriginLabブログの投稿記事を参照してください。

HTML Reports.png

HTMLレポートにコンテンツを追加

ノートウィンドウを使ってレポートを作成する基本的な手順は以下の通りです。

  1. グラフ作成と分析結果を含めるようにプロジェクトを作成します。
  2. 新規ノートウィンドウ ボタン Button New Notes.png をクリックして、ノートウィンドウを追加します。
  3. メニューからメモ:シンタックス を選択し、次に HTMLまたはMarkdownを選択します。(ヒントCtrl + Mキーを押すとテキスト/ビューモードとマークアップモードを切り替えることができます。LabTalkシステム変数@NPSを設定してデフォルトの構文を選択できます)。
  4. コードをノートウィンドウのマークアップモードで作成するか、Notepad ++などのテキストエディタを使用して、それをノートウィンドウにコピーして貼り付けることができます。HTMLまたはマークダウンの使用経験がない場合は、ノートウィンドウをアクティブにして メモ:サンプルのロードをクリックしてサンプルを読み込むことをお勧めします。
  5. 現在のプロジェクトのグラフ化と分析の結果をレポートに取り込むことをお勧めします。これを行う最も簡単な方法は、レポートに含める予定の各Originオブジェクトの「プレースホルダ」をコードに挿入することです。プレースホルダは、意味のある任意の文字列を使用して命名することができ、それらは二重中括弧で囲まれる必要があります(例:{{MyR-SquareValue}})。
  6. Notesウィンドウのタイトルバーを右クリックして、プレースホルダを編集を選択します。コードに組み込んだプレースホルダが選択され、ワー​​クブックのプレースホルダ ワークシートに追加されます。シートのA列に、コード内にあるすべてのプレースホルダが一覧表示されます。2番目の列(B列)は空白で、レポートに含めたい関連するOriginオブジェクト(変数、分析結果、グラフ結果など)を追加することができます。
  7. A列の各プレースホルダーについて、関連付けられているOriginオブジェクトを見つけてクリップボードにコピーします(例:統計分析の結果、シート内の数値である場合は、セルの数量を選択して右クリックしコピーを選択するか、キーボードのCtrl + Cキーを押します)。
  8. プレースホルダシートに戻り、関連するプレースホルダの横のB列を右クリックしてリンクの貼り付けを選択します。これにより目的のOriginオブジェクトがプレースホルダに関連付けられます。
  9. 分析テンプレートにHTMLレポートを含める場合は、分析テンプレートのワークブックタブを右クリックしてシートにメモを追加を選択できます。これによりノートウィンドウがワークブックに挿入されます。その後、ファイル:ワークブックを分析テンプレートとして保存を選択します。

ノートウィンドウがアクティブなときは、メモメニューをクリックしてサンプルHTMLファイルをノートウィンドウにロードできます。

HTML load samples.png

HTMLレポートの使い方

プレースホルダシートに記入すると、HTMLレポートがノートウィンドウに表示されます。完成したら、HTMLレポートで次のようなさまざまなことを実行できます:

  • ハードコピーまたはPDFに印刷(ファイル:印刷
  • ウィンドウをWebページにエクスポート (メモ: Webページにエクスポート
  • ノートウィンドウの右上隅にある埋め込みボタンをクリックして内容をワークブックに埋め込んでから、そのワークブックを分析テンプレートとして保存ファイル:ワークブックを分析テンプレートとして保存)します。

ワークシートと行列のエクスポート

ワークシートをエクスポート


ワークシートがアクティブなとき、メインメニューのファイル:エクスポートを選択すると以下のオプションが使用可能です:

  • ASCIINI TDM (TDM, TDMS)サウンド (WAV)
    このオプションはデータ列を含むシートに対して利用可能ですが、フィット機能により出力されたレポートシートなどには使用できません。ワークシート列からデータのみがエクスポートの対象です。ワークシート上に貼り付けたグラフや埋め込んだグラフなどはエクスポートされません。
  • Excel
    テキストと数値データを含むワークシート列の書籍をMS Excelファイル(XLS、XSLX、XSLM)にエクスポートします。階層テーブルを含む分析レポートシート、および埋め込まれたグラフや画像などは、Excelファイルにエクスポートされません。通常のOriginワークシートに出力された解析結果はエクスポートされます。

分析レポートシートのコピーとMSOfficeアプリケーションへの貼り付けについては、FAQ-815 コピーしたレポートシート表をPowerPoint やWordに貼り付けるにはどうすればよいですか?を参照ください。

  • SQLite
    このオプションはアクティブワークシートをSQLiteファイルとしてエクスポートします。ファイル拡張子は、sqlitesqlite3dbから指定します(ファイル構造は同じです)。非表示列または行をスキップするオプションもあります。ワークシート列のデータのエクスポートに制限されています。
  • 複数ページのPDFファイルとして
    このオプションはデータ列を含むシートに対して有効です。レポートシートでは使用できません。メニューの表示:改ページプレビューラインを選択すると、エクスポート時それぞれのページにどの行、列までを含むかが確認できます。エクスポートしたイメージには、ワークシート上に貼り付けたグラフや埋め込んだグラフなども含まれます。
  • 画像ファイルとして
    データシート、レポートシートの両方で使用可能なオプションです。開いたダイアログでは、シートすべてをエクスポートするか、指定した範囲をエクスポートするか指定可能です。PDF形式を含む画像ファイルフォーマットをサポートしています。エクスポートしたイメージには、ワークシート上に貼り付けたグラフや埋め込んだグラフなども含まれます。
  • PDFファイルとして
    データシート、レポートシートの両方で使用可能なオプションです。開いたダイアログで、シートすべてをエクスポートするか、指定した範囲をエクスポートするか指定可能です。貼り付けたグラフや埋め込みグラフを含めたPDFがエクスポートされます。

数値データやグラフ等を組み合わせて作成したカスタムレポートをエクスポートする場合には、PDFファイルか、マルチページPDFファイルとしてエクスポートすることをお勧めします。

行列をエクスポート

Originの行列データは以下の2つのフォーマットでエクスポート可能です。

  • ASCII
    アクティブな行列オブジェクト内のデータからASCIIファイルを作成します。
  • イメージ
    このオプションを選択すると、アクティブな行列オブジェクトをラスター形式のイメージファイルとしてエクスポートできます。
Note: 詳細については、次のヘルプ文書を参照して下さい。

ヘルプ:Origin:Origin ヘルプ > データのインポートとエクスポート > ワークシートと行列のエクスポート

参考