データ分析

はじめに

Originには、ピーク分析、カーブフィッティング、統計、信号処理を含む強力な解析ツールがあります。Originの解析ツールのほとんどは、ユーザが保存した設定を再利用できます。ダイアログテーマと呼ばれるもので、それは繰り返し分析を簡単にします。さらに、ある操作からの出力は別の操作への入力になるため、一連の操作を設定することができ、一連のデータファイルをインポートするときのようにソースデータに変更があるたびに結果が更新されます。

以下の節で、(1)解析したいデータの選択、(2)データ解析に利用可能なOriginとOriginProツールについて説明します。分析テンプレート、ダイアログテーマ、その他の操作時間短縮機能の詳細については、このユーザガイドの繰り返し処理の方法の章をご覧ください。

アプリは、Originのグラフ作成や分析の機能を拡張するアドオンツールです。様々な分析ツールをOriginLabのファイルの交換ページから無料 で取得できます。Originのアプリについての詳細は、Originのアプリの章を参照してください。

データ入力

Originの分析ツールは、その機能によってワークブック、行列、グラフデータから起動します。デフォルトでは選択されたデータに対して分析が実行されます。行列データの場合は、使用する機能によって、行列シートまたは行列オブジェクトが「選択データ」となります。ワークシートまたはグラフデータを使用する場合、解析を対象をデータのサブセット、つまり、ワークシート中の行や列のある範囲、または、グラフ中のあるX範囲に制限したい場合があります。

データの選択は、解析ダイアログを開く あるいは開いた に編集できます。解析ツールに基づくOriginのXファンクションの多くは、標準の範囲選択コントロールが付いた入力データの項目があります(以下で説明します)。

ワークシートでのデータ選択

ワークシートのある範囲を選択し、解析統計メニューに等にあるXファンクションベースのダイアログボックスを開くと、入力データの項目に、選択したデータ範囲が入力されます。このように、分析や統計のダイアログボックスを開く前に、ワークシートのデータを選択し、分析したいデータを指定しておくと簡単な操作で解析を実行できます。

Selecting Data in the Worksheet-1.png

データを事前選択せずに、Xファンクションダイアログボックスを開いた場合、まず最初に、入力データの項目で、データ選択をします。

XF range selection control.png
  1. 入力または入力データ)の隣にある範囲選択コントロールをクリックします。するとダイアログが縮小します。
  2. ワークシートに移動し、ワークシート範囲を選択したら、ロールアップしたダイアログボックスの右端にあるボタンXf open dialog.pngをクリックします。入力データブランチに選択したデータが入力されます。

必ずしもデータセット(列)全体を選択する必要はありません。ワークシートデータの一部を選択することができ、その範囲に対して解析処理が実行されます。また、複数のデータセットで解析する場合は、複数Y列や、Y範囲といった複数範囲で実行できます。分析機能が一つのデータセットのみをサポートしている場合、ワークシートの複数範囲の選択は可能ですが、分析では最初の範囲のみが使用されます。

Selecting Data in the Worksheet-2.png



ノート

  • 入力データブランチは、階層構造になっています。複数データセットでの解析に対応しているツールでは、入力データで複数範囲を追加することが可能です。範囲1範囲2などのように表示され、XYエラーといった項目もあります。
  • それぞれのレベルにカーソルを合わせると、そのレベルにあるデータがどこ(つまり、ブック、シート、列)にあるのかを示すツールチップを表示します。
  • それぞれの範囲ノードの下にあるコントロールで、行インデックスやX値ごとに範囲を設定します。入力データの下にある全ての範囲に同じ行範囲を適用したい場合、範囲ノードの右にある矢印ボタンをクリックして、行範囲をすべてに適用を選択します。
  • 階層的に入力データがどこにあるかによって、範囲選択ボタンはいくつかの制限を持ちます(例えば、Yの隣の範囲選択コントロールをクリックした場合、ワークシートの複数列を選択できますが、最初の列のみが受け入れられます)。
  • 範囲選択コントロールの右の矢印ボタンをクリックすると、個別のワークシート列を素早くデータ選択に追加できるような選択オプションが表示されます。
  • 矢印ボタンをクリックしたときの選択肢はレベルによって様々です。例えば、入力データの隣の矢印ボタンをクリックして「列の選択」をクリックすると、列ブラウザが開き、異なるワークシートから列を複数選択できます。

XF shortcut menu.png

  1. データセットのリストドロップダウンを使って、選択したいシートをフィルタにかけます。列ヘッダのどれかをクリックして、上部パネルのリストを並べ替えできます。例えば、ロングネームコメントが同じ全ての列を選択することができます。
  2. そして、追加ボタンをクリックして、下のパネルの選択リストに列を追加します。
  3. データセットの入力範囲を変更するには、下のパネルに追加されたデータセットの右にある範囲ボタンをクリックして、開始終了を編集します。


グラフでのデータ選択

グラフウィンドウがアクティブで、解析メニューツールの一つを選択すると、デフォルトで解析ダイアログボックスが開き、入力データ としてアクティブデータセットの選択範囲が表示されます。(解析ダイアログには、インタラクティブデータ範囲セレクタボタン、データ範囲変更など、多くのデータセットを追加する入力データノードを含みます。)

データリストとアクティブデータプロット

データメニューの下部にある、データセットのリストでチェックマークがついているのが、アクティブなデータプロットです。アクティブグラフレイヤにプロットグループが含まれる場合、デフォルトでは、グループ内の最初のデータがアクティブデータプロットとみなされます(下図のにある「g1」は、そのプロットがグループ1 に属していることを示しています)。データメニューの下部にあるプロットリストで他のデータをクリックすると、そのデータをアクティブにすることができます。その後、分析ダイアログボックスを開くと、新しく選択したプロットが入力データとして設定されます。

Select Data from Graphs-1.png

しかし、ほとんどの場合、データリストを無視して、グラフウィンドウで直接、またはオブジェクトマネージャを使用してプロットデータを選択できます。

  • データがプロットグループ内にある場合、Shiftキーを押しながらプロットをクリックして、グループ全体 を選択します。あるいは、オブジェクトマネージャ内でグループアイコンをクリックします。どちらの操作も、グループ内の プロットが入力範囲として設定されます。
  • 単一プロットを選択する場合、それが独立したプロットがグループの一部であるかにかかわらず、プロット上で一度クリックします。あるいは、オブジェクトマネージャのプロットアイコンをクリックします。どちらの操作も、選択されたプロットが入力範囲として設定されます。
UG OM Group Plot Selection.png


プロットの凡例内に赤い矩形を表示することで、アクティブデータセットを示すことができます。グループ化プロットの場合、赤い矩形はグループ内の最初のプロットに表示されます。

この機能をオン/オフする方法:

  • グラフウィンドウをアクティブにして、フォーマット: 作図の詳細(ページ属性)を選択し、凡例/タイトルタブのアクティブデータセットの標識のチェックボックスを使用
  • グラフ凡例を選択して右クリックし、凡例: アクティブデータセットの標識を選択し、この機能のオンオフを切り替えます。
  • グラフ凡例上で右クリックし、凡例: 凡例の更新を選択して、アクティブなデータセットを表示のチェックボックスを使用します。

分析ダイアログの「行」の設定を使ってX範囲を設定

解析ダイアログの入力データの項目にあるの設定を使ってデータ範囲を調整が可能です。解析ダイアログを開き、以下のように操作します。

  1. 入力データの項目を開きます。
  2. ドロップダウンリストから、行によるまたはXによるを選択し、開始終了の値を入力します。範囲N 毎にの設定があることに注意してください。
UG Rows Range Controls.png

軸スケールミニダイアログを使ってX範囲を編集

解析ダイアログを開く前に操作します。

  1. 軸上でクリックしてミニツールバーの軸スケールボタンをクリックし、軸スケールダイアログを開きます。
  2. UG Analysis Axis Scale MTB.png
  3. 軸スケールを設定します。
  4. 線形フィットなどの解析ダイアログを開き、入力データボックスの右隣にある、矢印ボタンをクリックし、Xスケール範囲を使用を選択します。
Select X Scale as Input.png

上図のように、解析の入力データ範囲として、グラフで編集されたX軸のスケール範囲が使用されます(=Xによる)。

領域データセレクタを使用してグラフィカルにデータを選択

領域データセレクタを使用して、データプロットの一部範囲をグラフィカルに選択することができます。

  1. グラフウィンドウをアクティブにし、プロット操作・オブジェクト作成ツールバーのアクティブプロットから選択ボタンQuick Help Reg Data Sel button.pngを長くクリックします。そして、アクティブプロットから選択または、すべてのプロットから選択を選択します。
  2. ドラッグして矩形オブジェクトまたはフリーハンドオブジェクトにより、プロットの領域を選択します。スペースキーを押して、矩形Select Data from Graphs-3.pngとフリーハンドSelect Data from Graphs-4.pngモードの切り替えが可能です。
Select Data from Graphs-2.png

一度選択されると、選択した領域を示すようにデータマーカーがグラフに現れます。解析ツール(線形フィットなど)を使ってこの選択範囲のデータを解析できますが、いくつかの解析ダイアログでは、複数のデータ範囲を解析対象にできないので注意が必要です。 例えば、スムージングダイアログ(解析:信号処理:スムージング)は、アクティブなデータセットまたは選択された単一のプロットデータのみをスムージングします。

データマーカー使用時に、新しいミニツールバーでXスケール範囲の設定が可能です。データマーカーをクリックしてボタンを使い、表示範囲に設定全範囲にリセットが可能です。

UG MT Data Markers.png

チュートリアル:特定のXデータに線形フィットを実行する

  1. \Samples\Curve Fitting\Exponential Decay.datを新しいワークブックにインポートします。
  2. 全てのY列を選択し、折れ線グラフを作成します。
  3. プロット操作・オブジェクト作成ツールバーの領域データセレクタボタンを長くクリックし、すべてのプロットから選択ボタンQuick Help Reg Data Sel All button1.pngを選びます。
  4. 矩形をドラッグし、Xの範囲がだいたい0.6から1.0の間のデータを選択します。
  5. メニューから解析:フィット:線形フィットと選択して線形フィットダイアログを開きます。
  6. 入力データブランチが、3つの範囲になっています。入力データブランチにマウスのカーソルを合わせると、「1X,1Y, ...3X,3Y」といった様に、ツールチップが表示されます。
  7. 選択したデータを変更したい場合、入力データ矢印ボタンをクリックして、グラフから全てのデータを再選択するを選びます。すると、ダイアログが縮小します。再度、グラフ内でドラッグして矩形を作成して選択範囲を指定し、ロールアップしたダイアログボックスの右端にあるXf open dialog.png ボタンをクリックします。入力データブランチに、新しいデータセレクションが表示されます。
  8. デフォルトの線形フィット設定のまま、OKを押してダイアログを閉じます。選択された範囲の3つの曲線データに対して線形フィットが実行されます。


Data Selection and Fitting.png

この節で説明したデータ選択データマスクの方法のほかに、Originには、データフィルタデータ削減ツールがあります。詳細は、リンクのページをご覧ください。

データマーカーの編集

データマーカーの編集方法:

  • データ範囲を変更するには、データマーカーを右クリックして編集を選択するか、データマーカーをダブルクリックします。赤いマーカーの色が暗い色に変わり、カーソルがクロスヘアに変わります。開始や終了のマーカーを新規位置にドラッグしたり、下記リストのキーボードのショートカットのひとつを使い、データ範囲を変更します。編集モードを終了するには、マーカーをダブルクリックするか、Enterキーを押します。
  • データマーカーを右クリックするとマーカーを削除データを削除などほかのオプションもあります。
Select Data from Graphs-7.png

Note: 領域データセレクタツールを使って、複数プロットにマーカーを置いた場合(全てのプロットで選択)、マーカーの移動はアクティブプロットのみのデータ範囲に影響するので、注意が必要です。そのほかの選択したプロット範囲は、アクティブプロットに従いません。これは、「領域データセレクタ」の制限です。


データマーカーの選択と編集には、キーボードショートカットを使うことができます。

  1. これらのキーを使用してデータマーカーを選択します。
    ホットキー アクション
    s (「1」とマークされている)グラフ上のデータマーカーの最初のペアを選択する
    Tab (編集モードではない)データマーカーの次のペアか、(マーカー編集モードの)ペアのその他データマーカーを選択する
    Home 最初のデータマーカーに戻る
    End 最後のデータマーカーに移動
  2. その後、以下のキーを使用して編集します。
    ホットキー アクション
    Enter 選択データを編集のためにアクティブにする(データセレクトモード解除する場合はEnterをもう一度押す)
    矢印キー アクティブデータマーカーを1つのデータポイントに正確に移動します。
    Ctrl/Shift + 矢印キー アクティブデータマーカーを複数データポイントに移動します。
    Deleteキー アクティブデータマーカーを削除

データマーカーと解析マーカーの違い

  • データマーカは、データセレクタツールを使って選択したサブ範囲を定義します。
    グラフに配置したデータマーカーを削除するには、メニューのデータ:データマーカーのクリアを選択するか、マーカーと錠前アイコンツールバーのデータマーカーのクリアボタンClear data markers.pngをクリックします。
Select Data from Graphs-5.png
  • 解析が終了すると、データマーカーは、解析マーカーに置き換わります。全データで解析が終了すると、デフォルトで解析マーカーは、表示されなくなります。サブ範囲で実行した場合、解析マーカーはサブ範囲の最初と最後を表示します。データ範囲を変更して解析を再実行するには、解析マーカーを右クリックしてパラメータの変更を選択します。入力データ範囲を変更して、解析を再実行します。
Select Data from Graphs-6.png

Note:
  1. 解析のダイアログボックス再計算モードなしに設定すると、解析マーカーは表示されません。
  2. ファイル:グラフエクスポートを選択してエクスポートするときは、データマーカーと解析マーカーはエクスポートされません。
  3. 別の解析をする際に、まったく同じ範囲を選択するには、緑の鍵のアイコンをクリックして、入力データをデータマーカーと共にプロットするを選択し、新規グラフを作成してから解析します。
  4. 解析マーカーと錠前を制御するマーカーと錠前アイコンツールバーがあります。たとえば、解析マーカーの表示/非表示 Marker hide show.png で解析マーカーのオンまたはオフを切り替えます。メニューの「データ解析マーカー」のサブメニューと、解析マーカーや緑色の錠前アイコンの上で右クリックしたときのコンテキストメニューでも、解析マーカーを制御します。

データポイント取得

データポイント取得ツールを使ってグラフ上でデータを取得できます。これは、小さいデータセットの散布図または折れ線+シンボルプロットに最適です。

  1. データ:データポイント取得を選択します。ポイント取得ダイアログが開きます。
  2. クロスヘアのカーソルを使って現データポイントの座標(データソース情報を含む)をポイント取得ダイアログ内で読み取れます。取得したいポイント上でダブルクリックするとクロスヘアが丸くなり、実際のXとYの値が記録され、取得ポイントの合計が数えられます。
    Pick Points DLG.png
  3. ポイントの取得が終了したら、完了ボタンをクリックして新しいワークブックに結果を生成します。

データハイライター

プロット操作・オブジェクト作成ツールバーのデータハイライターは、さらなる分析のためにデータの一部を選択するのに便利です。例えば、2Dの散布図があり、グラフ内の特定範囲のデータポイントにのみ興味がある場合を考えます。

  1. プロット操作・オブジェクト作成ツールバーのデータハイライターボタンButton Data Highlighter.pngをクリックします。
  2. 目的のデータポイントのグループをハイライトします。データハイライターがアクティブなときにスペースキーを押すと、長方形とフリーハンドの選択モードを切り替えできます。グラフ内の選択されたポイントが、ソースワークシート上の行でも選択されます。
  3. ソースワークシートに移動し、右クリックしてサブセットシートの作成を選択します。

グラフ内で選択したデータのみ含まれたwcopyNという名前の新しいワークブックが作成されます。

詳細は、データハイライターツールをご覧ください。

データの出力

Originの分析ツールには通常、出力ブランチ(ツールによって名称が異なります)があり、生成する出力とその出力先を指定できます。 以下は、積分ツールの出力ブランチです。

UG output range strings.png

出力先としては、ワークシートのセルまたは列の範囲、ワークシート、ワークブック、行列シート、グラフレイヤ、といったさまざまな場所を指定できます。 出力オプションは、出力するオブジェクトと、ツールを開いたときにアクティブだったウィンドウのタイプによって異なります。 次の方法で出力先を決定できます。

  • 標準の範囲表記を使用して、関連するテキストボックスに直接入力する
  • インタラクティブな範囲選択でデータを選択する。
  • 事前に定義した範囲文字列のセットを使用して目標を入力または選択します。


この入門マニュアルでは、事前定義した範囲文字列を使用した方法を紹介します。他のオプションについては、上記のリンクを参照してください。

範囲文字列を使用した出力の指定

範囲文字列は< >文字で囲まれています。有効な文字列は、ダイアログごとに異なります。たとえば、<ソース>は、線形フィットダイアログの出力ブランチのブックリストから利用できますが、スムージングダイアログでの出力の指定には使用されません。

一般的な範囲文字列:

  • <なし>: 出力しません。
  • <新規>: 新しいオブジェクト(列、ワークシート、グラフなど)を作成します。
  • <入力>: 出力に対して入力オブジェクトを使います。

これらの文字列は編集ボックスに直接入力してもいいですが、フライアウトメニューから選択するだけで指定できます(利用できるオプションはツールによって異なります)。または、カスタムボタンをクリックして、範囲構文ビルダーを開くこともできます。範囲構文ビルダーを使うと、出力先を指定するのに使用する出力範囲文字列を簡単に作成できます。範囲文字列と範囲構文ビルダーの詳細については、Originヘルプファイルの出力結果を参照してください。

データマスク

マスク機能は、ある一部のデータだけを解析したり、異常値を解析対象から外して解析を行なうような時に役に立ちます。データのマスク、マスク解除により、リンクされた操作の再計算が実行されます。

  • ワークシートとグラフ両方でデータポイントをマスクすることができます。
  • データがワークシートとグラフの両方に存在していて、どちらか一方をマスクすると、対応するもう一方のウィンドウでもマスクされます。
  • マスクツールバーボタンはグラフとワークシート両方で使用できます。
  • プロット操作・オブジェクト作成ツールバーボタンは、グラフ上で使用できます。
  • ワークシート上でデータを選択すると、ミニツールバーのデータをマスクするボタンが有効になります。
  • さらに、数学的な条件によってワークシートデータをマスクすることもできます。

Origin 2022は、ステータスバーに表示されるアクティブワークシートの統計情報にマスクされたデータ数マスクされていないデータ数を追加しました

マスクツールバー (ワークシート、グラフ)

このツールバーボタンは、マスクをかけたり、マスクをかけたデータの操作のために使用できます。一度データが選択されると、グラフも含まれることに注意してください(グラフの選択については、次のセクションのプロット操作・オブジェクト作成ツールバーボタンを参照してください)。

アクション ツールバーボタン ショートカットメニュー ノート
マスクを掛ける Button Mask Range.png マスク: 範囲のマスク 選択したデータ範囲をマスクします。マスクされたデータは異なる色で表示されます。
マスク取り外し Button Unmask Range.png マスク: マスク取り外し 選択したデータ範囲のマスクを取り外します。マスクを取り外したデータは解析に含まれ、通常どおりグラフに表示されます。
マスクの逆転 Button Swap Mask.png マスク: マスクの逆転 アクティブなデータセット内のマスクされた点とマスクされていない点を入れ替えます。
マスクカラーの変更 Button Change Mask Color.png マスク:次のマスクカラー マスクされたデータ範囲の表示カラーを変更します。
マスクポイントの表示/非表示 Button Hide Show Mask.png マスク: 非表示モード マスクされた点の表示のオンとオフを画面上および印刷・エクスポートされたグラフで切り替えます。
マスク解除 Button Disable Or Enables Masking.png マスク:マスク解除 ワークシート内のマスクされたデータすべてのマスクを解除します。オフにすると、すべてのデータポイントが分析され、印刷およびエクスポートされたグラフに含まれます。

プロット操作・オブジェクト作成(グラフ)

Origin 2021以降、デフォルトのマスクモードに変更が加えられました。

  • デフォルトが、行番号によるマスクから矩形の範囲によるマスクに変更されました。
  • それ以外の挙動は以前と同じで、スペースキーを押してマスクモードの切り替えが可能です(次を参照)。
  • システム変数 @MTI=1(永続)を使用して、デフォルトを行番号によるマスクに戻すことができます。

グラフウィンドウをクリックして、アクティブにします。

  1. データ:データポイントのマスクを選択、または、プロット操作・オブジェクト作成ツールバーの現プロットのマスクポイントボタンか全プロットのマスクポイントボタンをクリックします。
  2. 単一ポイントをマスクするには、そのポイントをダブルクリックします。ポイント領域をマスクするには、スペースキーを押して、行番号/矩形領域/フリーハンド領域のようにマスク範囲を切り替えます(下記参照)。その後、矩形やフリーハンド領域を描いて、領域のデータをマスクします。
  3. データがグラフでマスクされたら、前述のマスクツールバーボタンを使用できます。
現プロットを対象にマスクを付加する アクティブレイヤの全てのプロットのポイントをマスク 目的
Masking Data in Graphs-3.png Masking Data in Graphs-8.png 矩形の範囲ででマスクを掛けます。矩形内のデータポイントのみマスクされます。
Masking Data in Graphs-4.png Masking Data in Graphs-9.png フリーハンドで囲んだ領域のデータポイントをマスクします。フリーハンドの領域内のデータポイントのみマスクされます。
Masking Data in Graphs-6.png Masking Data in Graphs-7.png 行インデックスによって、データポイントをマスクします。選択した範囲の最小、最大のインデックス番号間の全てのデータポイントがマスクされます。マスクされるデータが矩形の範囲内に入っているかどうかは関係ありません。


グラフウィンドウデータに対して掛けたマスクを削除するには、

  1. プロット操作・オブジェクト作成ツールバーの現プロット上のデータマスクを外すButton Mask On Active Plot.pngか、全プロット上のデータマスクを外すButton Mask On All Plots.pngを選択します。
  2. スペースキーを使用し、マスクを外す領域をインデックスで指定するか、矩形オブジェクトで指定するか、フリーハンドオブジェクトで指定するかを選択できます。このツールはESCを押すかポインタ Button Pointer.pngツールをクリックするまで有効です。

マスクミニツールバーボタン(ワークシート)

ワークシートデータ(セル範囲または列全体)を選択すると、ミニツールバーのデータをマスクするボタンButton MT Mask.pngが有効になります。ボタンをクリックすると、選択したデータに対してマスクを有効化あるいは無効化します。

条件でセルをマスクする(ワークシート)

ワークシートデータを条件によってマスキングするためのツールがあります(例: <= 0)。

  1. セル範囲や列などのデータを選択し、列: 条件でセルをマスクするを選択します。これによりcolmaskダイアログが開きます。
  2. 条件を選択し、必要に応じてほかのオプションを設定してOKボタンをクリックします。

数学

Originは、基本的な数学操作や補間、面積や体積の計算などのツールを提供しています。

基本的な数学操作

ツール名 説明 メニュー項目
  • 算術演算/曲線上の算術演算
  • 複数列/曲線の正規化
  • 複数曲線の平均
  • 微分
  • ワークシート列やグラフ内のXYデータに対する演算処理
解析:数学(ワークブック、グラフ)
  • 算術演算
  • 2つの行列に対して要素ごとの演算を実行します。
解析:数学(行列)
  • 参照データの減算
  • データセットをもう1つから減算します。
解析:データ操作(ワークブック、グラフ)
  • 直線の減算
  • グラフ内でクリックしてグラフィカルに定義した直線を減算します。
解析:データ操作(グラフ)
  • 減算
  • シート内の行列を別の行列で減算します。
解析:数学(行列)
  • 垂直移動
  • 水平移動
  • ガジェットを使用して垂直または水平に曲線を移動します。
解析:データ操作(グラフ)
  • 微分ガジェット
  • 関心領域内で微分を実行
ガジェット:微分(グラフ)
  • 交差ガジェット
  • 2つ以上のデータプロットの交点を算出します。
ガジェット:交差(グラフ)
  • 垂直カーソル
  • 複数グラフのデータポイントのXおよびY座標値を読み取り、タグを付ける
ガジェット: 垂直カーソル(グラフ)
  • 列値の設定
  • ワークシート列の値を設定/変換するための計算式を使用
解析:数学(ワークブック、グラフ)
  • 逆行列
  • 逆行列を生成
解析:数学(行列)
  • メディアンフィルタ
  • 特殊フィルタ
  • カスタムフィルタ
  • 列にメディアン/特殊/カスタムフィルタを適用
解析:数学(行列)

補間

ツール名 説明 メニュー項目
  • 補間ガジェット
  • 関心領域内で補間を実行
ガジェット:補間(グラフ)
  • 補間/補外
  • XYZトレース補間(3Dグラフ)
  • トレース補間 (2D グラフ)
  • XYデータグループに補間/補外を実行
  • XYZデータに対して周期的な補間を実行
  • 円形または周期的な曲線に対して補間
解析:数学(ワークブック、グラフ)
  • XからYを補間/補外
  • 3D 補間
  • XYデータに対して補間を実行し、与えられたXに対するY値を得る
  • XYZデータに対して2次元の線形補間を実行し、与えられたXY値に対するZ値を8つの方法を用いて取得
  • XYZデータに対して3D補間を実行
解析:数学(ワークブック、グラフ)
  • 2D補間/補外
  • Originの行列に保存されている2Dデータに対して補間を実行
解析:数学(行列、行列からのグラフ)

面積/体積計算

ツール名 説明 メニュー項目
  • 積分ガジェット
  • 2Dグラフの内の関心領域内部で積分を実行
ガジェット:積分(グラフ)
  • 2D積分ガジェット OriginPro Symbol.png
  • 行列やXYZデータから作図された等高線図やイメージグラフで最大高さ、体積、FWHM (X,Y)を計算(OriginPro のみ)
ガジェット:2D積分(グラフ)
  • 積分(2Dグラフ)
  • 多角形面積(2Dグラフ)
  • 表面積:XYZデータ(3Dグラフ) OriginPro Symbol.png
  • 入力データに対して積分を実行
  • 閉じたプロットの面積を計算
  • XYZ曲面の表面積を計算
解析:数学(ワークブック、グラフ)
  • 2D求積 OriginPro Symbol.png
  • 行列データの表面積 OriginPro Symbol.png
  • 平面Z=0と曲面図(行列)の間の体積を計算
  • 行列曲面の表面積を計算
解析: 数学: 2D積分(求積)(行列、行列からの3Dグラフ)
または
解析: 数学: 表面積: 行列データ(行列、行列からの3Dグラフ)

カーブフィット

OriginLabのファイルの交換の場から、さまざまなカーブフィット操作用の無料アプリを利用することができます。これらのアプリを検索・インストールを行うには、解析: フィット: アプリ検索をクリックします。アプリセンターが開き、フィットに関連したアプリのみが表示されます。アプリを参照し、ダウンロードとインストールボタンAC Download Icon.pngをクリックしてアプリをインストールします。

線形および多項式フィット

ワークシートデータ、グラフのプロットデータに対し、線形および多項式フィットを実行することができます。行列の線形フィットは一連の行列オブジェクトに対して実行します。

ツール名 操作
  • 線形フィット
解析:フィット:線形フィット
または
ガジェット:クイックフィット (グラフ)
  • 線形フィット:Xエラーあり OriginPro Symbol.png
解析:フィット:線形フィット:Xエラーあり
  • 線形多重回帰
解析:フィット:線形多重回帰
  • 多項式回帰
解析:フィット:多項式フィット
または
ガジェット:クイックフィット (グラフ)
解析: 線形フィット(行列)

非線形曲線フィット

組み込まれている多くのフィット関数のひとつを使用して、非線形曲線フィットを実行可能なほか、ユーザが作成したフィット関数(ユーザ定義関数)を使用してフィット処理することもできます。また、OriginProの場合、陰関数によるフィット、曲面フィット、フィット比較をサポートしています。OriginProのみで利用可能なツールもいくつかあります。

下表は非線形曲線フィットの機能一覧です。

ツール名 特徴 メニュー項目
  • クイックフィットガジェット
  • グラフ内の関心領域に対してインタラクティブにフィットを実行
  • 組み込み関数または、ユーザ定義関数でフィット
  • 単一または、複数データセットをフィット
  • 事前定義の分析(Linear, Cubic, Peak, Sigmoidalを含む)の数を選択
ガジェット:クイックフィット (グラフ)
または
ガジェット:クイックシグモイダルフィット (グラフ)
  • 非線形曲線フィット
  • 組み込み関数または、ユーザ定義関数でフィット
  • 単一または、複数データセットをフィット
  • フィットの比較、複数パラメータセット
  • パラメータ共有でのグローバルフィット
  • グローバルフィット、複数関数でパラメータ分割 OriginPro Symbol.png
  • 複製してフィット
  • 境界、制約、フィット制御などの高度なオプション
解析:フィット:非線形曲線フィット(ワークブック、グラフ)
  • 陰関数曲線フィット OriginPro Symbol.png
  • 陰関数を使用したフィット
  • 直交距離回帰(ODR )アルゴリズム
解析:フィット:非線形陰関数フィット(ワークブック、グラフ)
  • 曲面フィット OriginPro Symbol.png
  • XYZデータ(行列、ワークシート)をフィット
解析:フィット:非線形曲面(3D)フィット (ワークブック、グラフ)
または
解析:非線形行列フィット(行列)
  • フィット関数ビルダ
  • ユーザ定義関数の作成と編集
ツール:フィット関数ビルダ
  • フィット関数オーガナイザ
  • カテゴリごとにフィット関数を管理
  • カテゴリ間での関数の移動や共有
ツール:フィット関数オーガナイザ
  • Fitting Function Library アプリ
  • originlab.com からフィット関数をダウンロードします。
  • OriginLabへ関数をリクエストまたは共有します。
アプリギャラリーでFitting Function Libraryのアイコンをクリックします。
  • シミュレート
  • 与えられた関数から曲線をシミュレート
  • 与えられた関数から曲面をシミュレート OriginPro Symbol.png
解析:フィット:曲線シミュレート
または
解析:フィット:曲面シミュレート
  • フィット比較 OriginPro Symbol.png
  • 同一関数による2つのデータセットをフィットし、結果を比較
  • 1つのデータセットに対し、2つの関数でフィットし、結果を比較

有意水準の設定

解析:フィット:データセットの比較
または
解析:フィット:モデルの比較(ワークブック、グラフ)
  • フィットと関数のランク OriginPro Symbol.png
  • 単一データセットに対する2つ以上の関数によるフィット結果の比較
解析:フィット:モデルの比較(ワークブック、グラフ)

ピーク解析

Originはピーク解析のために、複数のツールを提供しています。これらのツールを使用して、基線の定義と減算、ピークの検出、積分、フィットが可能です。OriginProのみで利用可能なツールもいくつかあります。

OriginLabのファイルの交換の場から、さまざまなピーク解析用の無料アプリを利用することができます。これらのアプリを検索・インストールを行うには、解析: ピークと基線: アプリ検索をクリックします。アプリセンターが開き、ピーク解析に関連したアプリのみが表示されます。アプリを参照し、ダウンロードとインストールボタンAC Download Icon.pngをクリックしてアプリをインストールします。

下表はピーク分析のために使用可能な機能の一覧です。

ツール名 特徴 メニュー項目
  • クイックピークガジェット
  • 関心領域内でピーク解析を実行
  • ベースラインの作成
  • 基線の減算
  • ピークの検出
  • ピークの積分
  • ピークフィット
ガジェット:クイックフィット(グラフ)
  • 複数ピークフィットツール
  • 複数のピークを検出
  • ピークフィット
解析:ピークと基線:複数ピークフィット(グラフ、ワークブック)
  • ピークアナライザ
  • ベースラインの作成
  • 基線の減算
  • ピークの検出
  • ピークの積分
  • 複数ピークデータセットのフィット OriginPro Symbol.png
  • 基線のフィット OriginPro Symbol.png
  • 隠れたピークを検出する
  • 多くのピーク特性値を算出 OriginPro Symbol.png
解析:ピークと基線:ピーク解析
(グラフ、ワークブック)
  • バッチピーク解析
  • ピークアナライザーツールで作成したテーマを使用
  • 複数のデータセットのピーク解析をバッチ処理
解析:ピークと基線:テーマによるバッチピーク解析
(グラフ、ワークブック)

ピークアナライザー:スムーズなフィット曲線の描画のためにフィット曲線のプロットのポイント数を増やしました(ピークフィット(Pro) > 結果 > グラフ構成の設定 > フィット曲線のプロット > 個別ピークのXデータポイント)。

信号処理

Originは、信号変換やスムージング/フィルタリング、1Dまたは2D相関を含む多くの信号処理のためのツールを提供します。OriginProでは、いくつかの追加のツールが利用可能です。

信号処理ツールとそのメニュー項目については、以下の表をご確認ください。

信号変換

ツール名 操作
  • FFT ROIツールガジェット
ガジェット:FFT ROIツール(グラフ)
  • 高速フーリエ変換(FFT)
  • 逆高速フーリエ変換(FFT)
解析:信号処理:FFT(ワークブック、グラフ)
  • 2D FFT OriginPro Symbol.png
  • 2D IFFT OriginPro Symbol.png
解析:信号処理:FFT(行列)

Origin 2022で新しいウィンドウ = GaussianおよびKaiserオプションを追加

  • STFT (短時間フーリエ変換) OriginPro Symbol.png
解析:信号処理:STFT(ワークブック)
  • ヒルベルト変換 OriginPro Symbol.png
解析:信号処理:ヒルベルト変換(ワークブック、グラフ)
  • イメージプロファイル
作図>2D: プロファイル: イメージプロファイル (行列、ワークシート、XYZデータ)

フィルタリング

ツール 操作
  • FFTフィルタ
解析:信号処理:FFTフィルタ(ワークブック、グラフ)
  • 2D FFTフィルタ OriginPro Symbol.png
解析:信号処理:2D FFTフィルタ(行列)
  • IIR フィルタ設計 OriginPro Symbol.png
解析:信号処理:IIRフィルタ(ワークブック、グラフ)

スムージング

Origin 2022では、msmoothダイアログでスムージングの度合いをコントロールする列の係数行の係数を追加しました。

ツール 操作
  • スムージング
解析:信号処理:スムージング(ワークブック、グラフ、行列)

相関

ツール名 操作
  • 相関
解析:信号処理:相関(ワークブック、グラフ)
  • 2D相関 OriginPro Symbol.png
解析:信号処理:2D 相関(行列)

コンボリューション

ツール名 操作
  • コンボリューション
解析:信号処理:コンボリューション(ワークブック、グラフ)

ウェーブレット変換 (Proのみ)

ツール 操作
  • 連続ウェーブレット変換
  • ウェーブレット分解
  • ウェーブレット再構成
  • Multi-Scaleウェーブレット分解
  • スムージング
  • ノイズ除去
解析:信号処理:ウェーブレット(ワークブック、グラフ)
  • 2D ウェーブレット分解
  • 2D ウェーブレット分解
解析:信号処理:ウェーブレット(行列)

その他の高度なツール(Proのみ)

ツール 操作
  • 立ち上がり時間ROIツール
ガジェット:立ち上がり時間ROIツール(グラフ)
  • デシメーション
解析:信号処理:デシメーション(ワークブック、グラフ)
  • コヒーレンス
解析:信号処理:コヒーレンス(ワークブック、グラフ)
  • 包絡線
解析:信号処理:包絡線(ワークブック、グラフ)

画像処理

Originは、基本的な画像処理のためのツールを提供しています。これらは、行列ブックがアクティブなときに表示される、イメージメニューから使用できます。いくつかはOriginPro Symbol.png のみで使用可能です。

以下のサブメニューにより、このツールが構成されます。

  • イメージ:調整
  • イメージ:代数的変換
  • イメージ:変換
  • イメージ:幾何学的変換
  • イメージ:空間フィルタ

参考