クラスターガジェット (Proのみ)


Video Image.png 関連動画はこちら

概要

クラスターガジェットROI(Region of Interest)範囲で簡単な統計を行います。このガジェットではデータポイントの編集、消去、マスクができます。ROIオブジェクトを移動したり大きさを変えると、統計結果が更新されます。このガジェットダイアログには2つのパネルがあります。ROIデータポイントを変更するためのツールが上側パネルに、ROI内の基本的な統計情報が下側パネルに表示されます。

Cluster Gadget Overview.png


クラスターガジェットでは次のことを行えます。

  • データのクラスター上で、簡単な統計をすばやく実行出来ます。
  • メニューオプションまたはボタンを使って、データポイントを簡単に編集出来ます。
  • ROIボックスは矩形と楕円形から選択
  • ROIボックスの内部または外部のポイントの統計値を表示します。
  • 内部と外部のポイントの結果をワークシートに出力します。
Note
  • 下側パネルに表示される統計結果は、ROIを動かしたり、サイズを変更すると表示されます。
  • 結果パネルの中を右クリックすると表示されるコンテキストメニューで、計算に含まれるデータポイントのオンオフを切り替えることができます。
  • マスキングや削除等の操作はダイアログ内のボタンで行われます。データメニューでこれらのボタン操作の影響を受けるポイントを確認できます。
クラスターガジェットを使うには

クラスターガジェットを使うには、グラフがアクティブなときに、メニューからガジェット:クラスター操作を選びます。

Originの分析ツールのほとんどは、インポートされたデータを変更することができません。ただし、クラスターガジェットの一部の機能では、データの変更が可能です(値の設定ボタンとそれに付随する編集ボックスなど)。したがって、データコネクタを使用してデータをインポートしていて、インポートしたデータを変更する関数を使用する場合は、インポートワークブックのデータのロックを解除する必要があります。

ガジェットダイアログのツールバーボタン

これらのボタンはROI範囲内のデータを変更するのに使います。作業するプロットを変更するには、データメニューから行います。編集メニュー内にあるオプションを使ってデータポイントの編集もできます。

統計レポートの出力

Region stats outputstats.png

クリックすると、統計レポートの出力を行います。レポート内容はクラスター変更設定でセットできます。
レポートシートに行く

Region stats gotoreport.png

クリックすると、結果ワークシートに行きます。レポートワークシートが作成された後だけ利用できます。
ソースワークシートに行く

Region stats gotosource.png

クリックすると、選択したデータポイントに対するワークシートに移動します。プロットが異なるワークシートからの場合、最初に選択したプロットのワークシートに行きます。
ROIの変更

Region stats modifyroi.png

クリックし、ROIを作成ダイアログボックスを開く図形を選択して、グラフ上でドラッグします。完了をクリックするまでダイアログは開いたままになります(必要に応じて、別のROIの形からやり直すことができます)。
新しいROIを追加

Region stats addnewroi.png

クリックし、追加のROIボックスをグラフに追加します。新しいROIを追加したら、完了をクリックします。別のROIを追加する場合は、新しいROIを追加ボタンをもう一度クリックして、操作を繰り返します。追加されたROIにはそれぞれ異なる色が割り当てられ、クラスターガジェットのROIボックス列に表示されます。グラフのROIをクリックして、ROIを切り替えます。
  • グラフウィンドウ内のROIは、塗り色形状、および位置を除いて、設定を共有します。
  • ROIの塗り色は、アクティブなROIを識別するためのツールの最初の列として表示されます。
  • 複数のROIが存在し、ポイント内部の色が有効になっている場合、アクティブなROIのポイントのみが色付けされます。
外部/内部ポイントに切り替える

Region stats switchiopoints.png

クリックすると、ROIの内部または外部のデータポイントをマスキングや消去の操作で編集する箇所を指定します。ダイアログのタイトルは、このステータスを反映しています。
最後の変更を元に戻す

Region stats undo.png

クリックすると、最後の操作を元に戻します。
データのコピー

Region stats copy.png

クリックすると、選択したデータポイントの値をコピーします。
データを消去

Region stats clear.png

クリックすると、ソースワークシートで選択したデータポイントのセルを消去します。
ワークシート行の削除

Region stats delete.png

クリックすると、ソースワークシートで選択したデータポイントと対応する行を消去します。
データポイントのマスク

Region stats maskdp.png

クリックすると、ソースワークシートで選択したデータポイントのセルをマスクします。
データポイントのマスクを外す

Region stats unmaskdp.png

クリックすると、ソースワークシートで選択したデータポイントのセルをアンマスクします。
カテゴリーを作成

Region stats create categories.png

カテゴリーグループを作成して、現在の関心領域(ROI)でグループにデータを加え、カテゴリー値を設定します。このボタンをクリックして、カテゴリー値の作成ダイアログを開くと、カテゴリーの設定をすることができます。元のワークシートに、カテゴリーグループ列が追加されます。

カテゴリーを定義したら、マウスでROIをグラフ上で移動し、ホットキー「C」を押して同じカテゴリにポイントを追加できます(カテゴリー値の作成ダイアログを再度開かずに)。

値を設定

Region stats set.png

クリックすると、元のワークシートで選択したデータポイントの値を、ボタンの右側の編集ボックスに入力した値に設定します。
下側パネルの表示/非表示

Region stats hide.png

クリックすると、ダイアログの下側のパネルを表示/非表示します。
Notes:
  • これらの編集ボタン(データのクリア, ワークシート行の削除, データポイントのマスク, データポイントのマスクを外す,値の設定) は、ロックされた分析プロットが選択されたとき、無効になります。
  • データポイントは1つのカテゴリー(グループ)のみに属します。既にグループに設定されているデータポイントを、別のグループに属するように変更する場合は、上書きをします。

ROIを作成

この小さなダイアログを使用して、任意の形状のROIを現在のグラフウィンドウに追加します。複数のROIを追加する場合は、現在のROIを追加したら完了をクリックし、クラスターガジェットのツールバーの新しいROIを追加ボタンRegion stats addnewroi.pngをクリックして新しいROIの描画を開始する必要があります。

OH cluster gadget create ROI.png

形状の作成については、スムーズな曲線を描くにはおよび四角形、円、多角形、自由閉曲線を描くを参照してください。

カテゴリー値の作成

Region stats create categories dialog.png

現在の関心範囲(ROI)にあるデータポイントでカテゴリーを作成して、その値を設定します。

カテゴリーグループ名 カテゴリーグループの名前を入力このグループ名はカテゴリー化した列のロングネームになります。
カテゴリ 各データプロットをグループ列に追加数値データ、または、テキスト文字列になります。グループには複数のカテゴリを追加できます。
カテゴリーでデータを色付け データプロットの色番号として新しいカテゴリ列値を指定します。
グループ列に、各データプロットを追加 ( データメニューによって、)選択したプロットのみをカテゴリーグループ列に追加するかどうか、あるいは、レイヤの全てのプロットをそれぞれ、グループ列に追加するかどうか、を指定しますこれは、デフォルトでは選択されていません。
カテゴリをクリア 現ROIのカテゴリからデータポイントをクリアするには、データポイントのカテゴリをundefinedに設定します。

カテゴリーを定義したら、マウスでROIをグラフ上で移動し、ホットキー「C」を押して同じカテゴリにポイントを追加できます。

ガジェットダイアログのメニュー設定

編集

このメニュー内の項目を使ってソースワークシートのデータを編集します。

元に戻す 最後の操作を元に戻します。
データのコピー 選択したデータポイントの値をコピーします。
データを消去 ソースワークシートで選択したデータポイントのセルを消去します。
ワークシート行の削除 ソースワークシートで選択したデータポイントと対応する行を削除します。
データポイントのマスク ソースワークシートで選択したデータポイントのセルをマスクします。
データポイントのマスクを外す ソースワークシートで選択したデータポイントのセルをマスクを外します。
カテゴリーを作成 カテゴリーグループを作成して、現在の関心領域(ROI)でグループにデータを加え、カテゴリー値を設定します。このメニューを選択して、カテゴリー値の作成ダイアログを開くと、カテゴリーの設定をすることができます。元のワークシートのデータプロットの隣に、カテゴリーグループ列が追加されます。
これらのメニューオプション(データを消去, ワークシート行を削除, ータポイントのマスク, データポイントのマスクを外す) は、ロックされた分析プロットが選択されたとき、無効になります。

データ

このメニュー内項目はどのデータがボタンの影響、例えば削除やマスク、の影響を受けるか指定します。
Note: このメニューで、下側パネルに表示されているデータプロットや統計情報には影響を与えません。下側パネルのエントリをコントロールするには、パネル内部を右クリックしてコンテキストメニューから行ってください。

プロット(n) アクティブレイヤのn番目のデータプロットを選択します。

このメニューで最初の20データセット/プロットを表示します。20以上のプロットがグラフ中にある場合は、プロットリストの一番下にあるMore...をクリックして、プロットの選択ダイアログを開いて他のプロットを選択します。

ロックされた分析プロットを表示 ロックされた分析プロットをデータメニュー内に表示するかどうか選択します。ロックされた分析プロットは一般的に、他の解析ツール、例えばフィットやスムージングなど、から生成されます。
全てのプロット データメニュー内にリストされている全てのプロットを選択します。ロックされた分析プロットがデータメニューに表示されていない場合、選択されません。
内部ポイント ROI内のデータポイントで作業を行うにはチェックを付けます。
外部ポイント ROI外のデータポイントで作業を行うにはチェックを付けます。

設定

円形ROI 現在のROIの形状を長方形または円形の間で切り替えます(これらのROI形状でのみ使用可能)。
プロット群の最大範囲に拡大する 選択されたプロット全てが入るように高さと幅を広げます。
全レイヤ幅に拡張 ROIの幅を選択中のレイヤ幅に広げます。
レイヤの最大高さに拡大する ROIの高さを選択中のレイヤ高さに広げます。
ROI位置のリセット ROIの位置をデフォルトに戻します。
付加したボタンを表示 ROIの右上に閉じるボタンとコンテキストメニューを表示します。
リアルタイム計算 ROIを移動するとリアルタイムに計算します。大きなデータセットを使っているときはこのオプションのチェックを外すことをお勧めします。
<デフォルト>として保存 現在のダイアログの設定をデフォルトテーマとして保存します。
テーマに名前を付けて保存 現在のダイアログの設定をテーマとして保存します。
テーマのロード テーマリストからテーマをロードします。
ユーザ設定 クラスター操作設定 ダイアログを開き、ガジェットをカスタム化します。

クラスター操作設定

このダイアログは次の方法で開く事ができます。

  1. Originメニューからガジェット:クラスター操作と選択します。
  2. クラスターガジェットのダイアログメニューから、設定:設定と操作します。
  3. ROIのフライアウトメニューから設定を選択します。


同じグラフウィンドウ内の複数のROIは、塗り色形状、および位置を除いて、ROIボックスタブの設定を共有します。

ROIボックス

「閉じる」ボタンとコンテキストメニューを表示 ROIの右上に閉じるボタンとコンテキストメニューボタンを表示するかどうか指定します。
ツール名を表示する ROIの上部にツールの名前を表示するかどうか指定します。
塗り色 ROIの塗りつぶの色を指定します。
内部ポイントの色 ROI内で選択された散布図のポイントの色を変更するか指定します。
形状 ROIの形を指定します。これは四角から選べます。
図形の位置 この設定グループは、ROIの正確な位置を設定します。形状ドロップダウンで円形が選択されていると、この設定では四角形を定義し、円はその四角形の内接円となります。
  • X1: 四角形の左側のX位置を指定します。
  • X2: 四角形の右側のX位置を指定します。
  • Y1: 四角形の下側のY位置を指定します。
  • Y2: 四角形の上側のY位置を指定します。

出力先

スクリプトウィンドウ スクリプトウィンドウに結果を出力するかどうかを指定します。
結果ログ 結果ログに結果を出力するかどうかを指定します。
ワークシートに追加 結果をワークシートに書き出すかどうかを指定します。
結果のワークシート名 ワークシートに追加にチェックを付けた場合、この編集ボックスを使って出力ワークシートの名前を指定します。
  • 結果は、デフォルトで[Cluster]RegionStatsに出力されますが、ほかのブックやシートを指定することもできます。指定したブックやシートがない場合、作成して出力します。
  • もう一つの方法として、結果ワークシート名の右側にあるフライアウトボタンGadget flyout button.pngをクリックして、入力ブック内のシートを選択します。これにより、編集ボックスには[<input>]RegionStatsが入力されます。結果は、元データのワークシートRegionStatsに出力されます。

計算

外部ポイントの計算 ROI外のポイントを計算するかどうか指定します。
リアルタイム計算 ROIボックスを移動しているとき、クラスターガジェットダイアログに即座に計算の結果を表示するか指定します。このチェックボックスを外すと、「即時計算はオフです」のメッセージがROIの上に表示されます。
入力凡例 元のデータセットの凡例テキストを出力するかどうかを指定します。
形状 ROIの形状を出力するか指定します。
データポイント情報 これは出力するデータポイント情報を指定するのに使います。
インデックス
データポイントのインデックスを出力するかどうか指定します。
値を表示
データポイントの値を出力するかどうか指定します。
統計 XまたはY値の統計量を計算するかどうか指定します。
X 値
X座標値の統計量を計算するか指定します。
Y 値
Y座標値の統計量を計算するか指定します。
計算する値 計算する統計値を指定します。
N
データポイントの数を出力するかどうかを指定します。
合計
データポイントの合計を出力するかどうかを指定します。
平均
データポイントの平均を出力するかどうかを指定します。
中央値
データポイントの中央値を出力するかどうかを指定します。
SD
入力データ範囲の標準偏差を出力するかどうかを指定します。
最小値
データポイントの最小値(統計で指定)を出力するかどうかを指定します。
最小のX / Y
最小データ点のX座標(統計 = Y値の場合)/ Y座標(統計 = X値の場合)を出力するかどうかを指定します。
最大値
データポイントの最大値(統計で指定)を出力するかどうかを指定します。
最大X / Y
最大データ点のX座標(統計 = Y値の場合)/ Y座標(統計 = X値の場合)を出力するかどうかを指定します。

下側パネルのコンテキストメニュー

グラフ内のすべてのプロットの結果が行でここに一覧表示されます。統計結果の異なる量は異なる列に表示されます。

列タイトルを右クリックして表示されるコンテキストメニュー

Region stats iotab.png

列タイトルを右クリックすると、コンテキストメニューが現れ、この表に表示する統計結果を選択します。

Notes: 統計結果レポートの内容はこのコンテキストメニューではなく、クラスター操作設定ダイアログでコントロールされます。

セルを右クリックして表示されるコンテキストメニュー

Region stats iotab2.png

セルを右クリックしたとき、コンテキストメニューが現れ、選択したセルをコピーし、アクティブレイヤに対応する表を表示します。

Notes: 変更を加えているデータは、このコンテキストメニューではなく、データメニューでコントロールされています。

ROIフライアウトメニュー

ROIボックスの右上角にある三角形のボタンROI menu.pngをクリックして、フライアウトメニューを開きます。ボタンが表示されない場合は、次のいずれかを実行して有効にできます。

  • メインメニューから、ガジェット:クラスター操作を選択します。ROIボックスタブで、「閉じる」ボタンとコンテキストメニューを表示にチェックを入れます。
  • クラスターガジェットツールが開いている場合は、設定をクリックし、付加したボタンを表示にチェックが入っていることを確認します。


フライアウトメニューコマンドは以下の通りです:

新しい統計出力 オプションを選択し、クラスター操作ダイアログの出力先で指定した項目に結果を出力します。
レポートシートに行く 結果ワークシートに移動します。レポートワークシートが作成された後だけ利用できます。
ソースワークシートに行く 選択したデータポイントに対するワークシートに移動します。プロットが異なるワークシートからの場合、最初に選択したプロットのワークシートに行きます。
クリップボードに出力 選択すると(メニューの項目にチェックが入っている)、新しい出力がクリップボードに出力されます。
データ変更 ROIまたはROI以外でデータプロットを選択します。
プロット(n)
アクティブレイヤのn番目のデータプロットを選択します。
ロックされた分析プロットを表示
フライアウトメニューでロックした分析プロットを表示するかどうかを指定します。
全てのプロット
フライアウトメニュー内にリストされている全てのプロットを選択します。ロックされた分析プロットがメニューに表示されていない場合、選択されません。
内部ポイント
ROI内のデータポイントを選択します。チェックが付いてると、外部ポイント が消去されます。ダイアログのタイトルは、「内部ポイントを編集」に変わります。
外部ポイント
ROI以外のデータポイントを選択します。チェックが付いてると、内部ポイント が消去されます。ダイアログのタイトルは、「外部ポイントを編集」に変わります。
プロット群の最大範囲に拡大する ROI範囲をすべての選択したプロットに合うように拡大します。
レイヤの最大幅に拡大する ROIの幅を選択中のレイヤ幅に広げます。
レイヤの最大高さに拡大する ROIの高さを選択中のレイヤ高さに広げます。
円形ROI 円形のROIを使用するかどうかを指定します。
テーマに名前を付けて保存 現在のダイアログの設定をテーマに保存します。これはテーマに名前を付けて保存ダイアログを開き、編集ボックスにテーマの名前を入力できます。
<デフォルト>として保存 現在のダイアログの設定をデフォルトテーマとして保存します。
テーマのロード テーマリストからテーマをロードします。
ユーザ設定 クラスター操作設定 ダイアログを開き、ガジェットをカスタム化します。

サンプル

  1. 新規ワークシートを開始して、<Originプログラムフォルダ>\Samples\Curve FittingにあるOriginのサンプルデータ、Multiple Gaussians.dat をインポートします。
  2. ワークシート全体を選択し、メインメニューより作図:基本の2Dグラフ:散布図を選択します。
  3. Originメニューからガジェット:クラスター操作を選択します。デフォルトの設定のまま、OK をクリックします。プロットに黄色いROIオブジェクトが追加され、選択した散布図のポイントの色が変わり、クラスターガジェットが開きます。
  4. クラスターガジェットのダイアログメニューから、設定:付加したボタンを表示と操作します。閉じるボタンとコンテキストメニューが、ROIの右上角に表示されます。
    Region stats graph.png
    Region stats graph2.png
  5. ROIを移動し、結果がどのように変わるかを見ます。
  6. クラスターガジェットダイアログのデータポイントのマスクボタンをクリックして、ソースワークシートのデータをマスクします。ソースワークシートの内部ポイントがマスクされるのが分かります。
    Region stats maskedwks.png


クラスターガジェットの使用方法の詳細については、このチュートリアルを参照してください。

アルゴリズム

このツールは、グラフウィンドウの曲線の記述統計を実行します。計算についての詳細は、 Xファンクションstatsのアルゴリズムをご覧ください。