Gruppiertes und gestapeltes Säulendiagramm

 

Video Image.png Video Text Image.png Website blog icon circle.png Blog Image 33x33px.png

 

Zusammenfassung

In Origin können mehrere Datensätze als ein gestapeltes Säulendiagramm gezeichnet werden. Normalerweise werden diese Datensätze zusammen gruppiert. Zusätzlich ist es möglich, Untergruppierungen für gestapelte Säulendiagramme zu erstellen, wie unten im Fall von zwei Untergruppen gezeigt:
Grouped Stacked Column 08.png

Origin-Version mind. erforderlich: 2020

Was Sie lernen werden

Dieses Tutorial zeigt Ihnen, wie Sie:

  • ein gestapeltes Säulendiagramm zeichnen.
  • Untergruppierungen des gestapelten Säulendiagramms festlegen.
  • die Tabelle der X-Achse für das Diagramm erstellen und benutzerdefiniert anpassen.

Ein gruppiertes gestapeltes Säulendiagramm erstellen

Dieses Tutorial ist mit dem Ordner Grouped Stacked Column im Projekt (<Origin-Verzeichnis>\Samples\Tutorial Data.opj) verbunden.

Hinweis: Sie können auf dieses Beispieldiagramm auch durch einen Doppelklick auf das Miniaturbild unter dem Diagrammbeispiel Grouped Stacked Column unter den Säulen- und Balkendiagrammen im Lernzentrum zugreifen (Hilfe: Lernzentrum im Menü oder über die Taste F11) .

  1. Aktivieren Sie das Arbeitsblatt Sheet1, markieren Sie die Spalten col(B)~col(G) und wählen Sie Zeichnen: Einfache 2D: Balken: Gestapelte Säulen im Menü, um ein gestapeltes Säulendiagramm zu zeichnen:
    Grouped Stacked Column 01.png
  2. Klicken Sie zum Öffnen des Dialogs Details Zeichnung doppelt auf das Säulendiagramm. Wählen Sie auf der Registerkarte Gruppe die Option Nach Größe für Untergruppierung und setzen Sie die Größe der Untergruppe auf 3.
    Grouped Stacked Column 02 2.png
  3. Wählen Sie Layer1 im linken Bedienfeld des Dialogs Details Zeichnung und klicken Sie auf die Registerkarte Stapeln. Aktivieren Sie das Kontrollkästchen Versatz innerhalb Untergruppe (Registerkarte Gruppe) für Kumulativ/Inkrementell. Klicken Sie auf die Schaltfläche Anwenden.
    Grouped Stacked Column 05.png
  4. Klicken Sie auf OK, um den Dialog zu schließen. Wählen Sie Grafik: Neu skalieren, um alle anzuzeigen im Hauptmenü, um den Layer neu zu skalieren.
  5. Klicken Sie auf die Säule und in der Minisymbolleiste auf die Option Datenbeschriftungen zeigen auf der Registerkarte Gruppe, um die Datenbeschriftungen auf den Säulen zu zeigen.
    Grouped Stacked Column 03 2.png

Tabelle für Hilfsstrichsbeschriftungen der X-Achse erstellen

  1. Um zwei Zeilen der Hilfsstrichsbeschriftung für die X-Achse zu erstellen, klicken Sie doppelt auf die Hilfsstrichsbeschriftung der X-Achse, um den Dialog Achsen zu öffnen.
    • Wählen Sie auf der Registerkarte Beschriftung der Hilfsstriche das Symbol Unten.
    • Setzen Sie auf der Registerkarte Format die Schriftgröße auf 16
    • Aktivieren Sie auf der Registerkarte Tabelle das Kontrollkästchen Aktivieren und setzen Sie die Anzahl der Zeilen auf 2. Das Symbol Unten wird im linken Bedienfeld in Unten 1 und Unten 2 umbenannt.
    • Legen Sie das Tabellenlayout, wie unten zu sehen, fest:
      Grouped Stacked Column 06.png
    • Wählen Sie Unten 2 und legen Sie den Datensatzname mit [Book4]Sheet1!H auf der Registerkarte Anzeige fest. Setzen Sie die Schriftgröße auf der Registerkarte Format auf 12. Die Zeile der Hilfsstrichsbeschriftung nimmt die Autonamen aus der Arbeitsblattspalte label (Y) an.
    • Legen Sie das Tabellenlayout, wie im Dialog unten zu sehen, fest.
      Grouped Stacked Column 07.png
  2. Klicken Sie auf OK, um den Dialog zu schließen. Verschieben Sie das Legendenfeld innerhalb des Layers. Klicken Sie auf den Layer und in the Minisymbolleiste auf die Schaltfläche Layerrahmen, um den Layerrahmen zu zeigen.
    Grouped Stacked Column 07a.png

Weitere Schritte der benutzerdefinierten Anpassung

Die folgenden Schritte können das Diagramm weiterführend benutzerdefiniert anpassen, um genau so auszusehen, wie das Bild unter Zusammenfassung.

  1. Klicken Sie zum Öffnen des Dialogs Details Zeichnung doppelt auf das Säulendiagramm. Klicken Sie auf der Registerkarte Gruppe auf die Schaltfläche Button browser.png in der Spalte Details der Zeile Füllfarbe. Der Editor für Inkrement wird geöffnet.
  2. Klicken Sie auf den Pfeil rechts von der ersten Farbe und klicken Sie dann auf ein leeres Farbfeld unter Benutzerdefiniert. Setzen Sie in dem aufgerufenen Dialog Farbe die Werte für Rot, Grün und Blau auf 165, 196 und 0 und klicken Sie dann auf OK.
  3. Erstellen Sie mit Hilfe dieser RGB-Werte fünf weitere benutzerdefinierte Farben: (243, 62, 12), (243, 200, 30), (0, 64, 127) (119, 0, 31) und (124, 191, 243).
  4. Klicken Sie separat auf die Zahlen (7) und (8) links von der nächsten Farbe in der Liste Inkrementeditor. Klicken Sie auf die Schaltfläche Löschen, um diese Farben zu entfernen, so dass Sie nur die sechs Farben haben, die Sie erstellt haben. Klicken Sie auf OK, um den Inkrementeditor zu schließen.
    Grouped Stacked Column 02.png
  5. Erweitern Sie auf der Registerkarte Beschriftung die Minisymbolleiste Schriftart, setzen Sie Größe auf 12, Farbe auf Dunkelgrau und klicken Sie auf die Schaltfläche Fett. Wählen Sie Benutzerdefiniert als Beschriftungsformat und geben Sie $(p,.0)% im Feld Formatzeichenkette ein. Die Beschriftungen auf den Säulen wird angepasst.
    Grouped Stacked Column 03.png
  6. Klicken Sie auf die Registerkarte Abstände und setzen Sie die Option Lücke zwischen Balken (in %) auf 30.
    Grouped Stacked Column 04.png
  7. Wählen Sie Layer1 im linken Bedienfeld des Dialogs Details Zeichnung und klicken Sie auf die Registerkarte Stapeln. Aktivieren Sie Beschriftung der Summe für gestapelte Säulen-/Balkendiagramme zeigen.
    Grouped Stacked Column 09.png
  8. Setzen Sie auf der Registerkarte Gruppe den Modus Bearbeiten auf Unabhängig. Klicken Sie auf OK, um den Dialog zu schließen.
  9. Wie Sie sehen können, sind die Beschriftungen auf den dunklen Balken schwer zu lesen. Wir müssen ihre Farben ändern, um sie "weiß zu hinterlegen".
    1. Klicken Sie auf eine der Beschriftungen der Zeichnung Ferrari Central, wie unten zu sehen, um die Beschriftungen auszuwählen. Verwenden Sie in der Minisymbolleiste die Schaltflächen Schriftgröße und Schriftfarbe, um die Größe auf 11 und die Farbe auf Hellgrau zu setzen.
      Grouped Stacked Column 09a.png
    2. Klicken Sie auf eine der Beschriftungen der Zeichnung Ferrari West, um die Beschriftungen auszuwählen. Verwenden Sie in der Minisymbolleiste die Schaltfläche Schriftfarbe, um die Farbe auf Hellgrau zu setzen.
  10. Klicken Sie mit der rechten Maustaste auf einen leeren Bereich des Diagrammfensters und wählen Sie Layertitel hinzufügen/modifizieren im Kontextmenü. Geben Sie Sales als Layertitel ein.
  11. Verändern Sie die Größe nach Bedarf mit Hilfe der Auswahlelemente. Am Ende erhalten Sie das Diagramm, das die Zusammenfassung zeigt.