Einführung

Bildfenster

Seit Version 2021b gibt es in Origin ein neues Bildfenster zum Laden und Speichern von Bildern. Es setzt OpenCV für die Verarbeitungs- und Analyseroutinen ein. Das neue Bildfenster ist ein Fenster mit einem einzelnen Layer, wie unten zu sehen. Es verfügt über eine Informationsleiste oben (falls nicht, können Sie im Menü Ansicht: Informationen zeigen auswählen, um sie dazuzuschalten). Im Fall eines Videos oder Bildes mit mehreren Frames befindet sich eine Navigationsleiste unten (oder Ansicht: Navigation zeigen, um sie einzuschalten). Es ist verantwortlich für fast alle Operationen der Bildverarbeitung.

Bild mit einzelnem Frame Bild mit mehreren Frames oder Video
Importing Images introduction 02.png Importing Images introduction 01.png

Bildfenster vs. Matrixfenster

  • Vor Origin 2021b wurden Bilder im Matrixfenster und die Verarbeitungshilfsmittel wurden von LeadTools unterstützt. Das neue Bildfenster wird dagegen von OpenCV für Verarbeitungs- und Analyseroutinen unterstützt.
  • Das Matrixfenster ist ein Fenster mit mehreren Layern, die viele Blätter enthalten. Ein Bildfenster hat jedoch nur ein Blatt.
  • Das Matrixfenster ist verantwortlich für fast alle Standardhilfsmittel der Bildverarbeitung. Wenn ein Prozess oder eine Analyse Datenergebnisse ausgibt wie die 2D-FFT, wird das Matrixfenster verwendet. Das Bildfenster wird außerdem in den meisten Apps zur Bild-/Videoverarbeitung verwendet.
  • Sie können ein Bildfenster immer in eine Matrix umwandeln und diese Umwandlung umkehren. Siehe unten.

Bilder und Videos importieren

Weitere Einzelheiten finden Sie auf dieser Dokumentseite.

Menüs für einfache Fensteroperationen

Bearbeiten: Ausschneiden: Das aktive Bildfenster wird gelöscht.
Bearbeiten: Löschen: Wenn ein ROI-Feld ausgewählt ist, löscht dieses Menü das ROI-Feld; wenn das Bildfenster ausgewählt ist, löscht dieses Menü das Fenster.
Bearbeiten: Kopieren: Falls ein ROI-Feld ausgewählt ist, kopiert dieses Menü alle Informationen über das ROI-Feld. Falls das Bildfenster ausgewählt ist, kopiert dieses Menü das Bild. Sie können es dann als Objekt oder Bildfenster in ein Diagrammfenster einfügen.
Bearbeiten: Einfügen: Das kopierte ROI-Feld oder Bild wird eingefügt.
Ansicht: Information: Die Informationsleiste wird gezeigt/verborgen.
Ansicht: Navigation: Die Navigationsleiste wird gezeigt/verborgen.

Bilder und Videos exportieren

Weitere Einzelheiten finden Sie auf dieser Seite.

Einfache Operationen im Bildfenster

Neben Hilfsmitteln im Hauptmenü Bild stehen Symbolleistenschaltflächen und Kontextmenüs für den schnellen Zugriff auf einfache Bearbeitungsoptionen zur Verfügung.

Mini-Toolbar

Durch einen Klick auf eine beliebige Stelle im Bildlayer wird eine Minisymbolleiste angezeigt.
Bild mit einzelnem Frame:
Minitoolbar image window.png
Video:
Minitoolbar image window2.png
Gestapeltes Bild mit mehreren Frames:
Minitoolbar image window3.png

Paletten auf graustufige Bilder anwenden

Farbpaletten können auf graustufige Bilder im Bildfenster angewendet werden.

  1. Klicken Sie auf die Schaltfläche Grau Popup Gray.png der Minisymbolleiste, falls notwendig, um ein Bild in Graustufen umzuwandeln.
  2. Wenden Sie eine Palette auf das graustufige Bild an, indem Sie auf die Schaltfläche Palette Button Palette.png auf der Symbolleiste Stil klicken.
  3. Klicken Sie auf die Minisymbolleiste Palette umkehren Popup Revise Palette.png, um die Anwendung der gewählten Palette umzukehren.

Klicken Sie in der Liste Palette auf der Symbolleiste Stil auf Mehr Paletten, um den Dialog Farbmanager zu öffnen und mehr Paletten hinzuzufügen.

Kontextmenü

Save reload image.png

ROI-Feld hinzufügen Unten können Sie nachlesen, was Sie mit einem ROI-Feld tun können.
Tatsächliche Größe anzeigen/
An Fenster anpassen
  • Zeigen Sie das Bild im Pixelmodus 1:1 an ODER
  • passen Sie das Bild immer an die Fenstergröße an.
Verknüpfte Datei Aktivieren Sie dieses Kontrollkästchen, um das Bild mit der Quelldatei zu verknüpfen. Den Unterschied zwischen verknüpfter und nicht verknüpfter Datei können Sie hier nachlesen.
Pfad der Quelldatei Öffnen Sie einen Dialog, um die Quelle der Bilddatei zu ändern. Einzelheiten zum Speichern und Ändern des Bildpfads finden Sie hier.

Grafische Datenauswahl (ROI-Feld)

  • Klicken Sie in der Minisymbolleiste auf die Schaltfläche ROI hinzufügen Add ROI Button.png.
Oder
  • Klicken Sie auf die Schaltfläche Rechteck einfügen Rectangle Tool Button.png auf der Symbolleiste Hilfsmittel. Ziehen Sie ein rechteckiges Feld auf dem Bild auf.

 

Klicken Sie doppelt auf das ROI-Feld, um:
  • den ROI-Namen zu ändern.
  • das ROI-Feld neu zu positionieren, indem Sie die XY-Koordinaten der Ankerpunkte oben links und unten rechts festlegen.
Image window ROI Position.png

 

Klicken Sie mit der rechten Maustaste auf das ROI-Feld, um
Image window ROI context menu.png
  • Zuschneiden: Diese Option ist verfügbar, wenn das Bild über ein Diagramm geöffnet wurde (z. B. durch Doppelklick auf das Diagrammbild). Die Option schneidet das Diagrammbild auf die Größe des ROI-Felds zu. Die ursprüngliche Größe des Diagrammbildes wird auf die Größe des zugeschnittenen Bereiches reduziert. Um das vollständige Bild im Diagrammfenster wiederherzustellen, klicken Sie mit der rechten Maustaste außerhalb des ROI-Felds und wählen Sie Zuschneiden entfernen.
  • Ausschneiden: Das Bild im Bildfenster und das Diagrammbild (falls vorhanden) werden gemäß dem ROI-Feld ausgeschnitten. Die Größe des Diagrammbilds und die Position werden beibehalten.
  • Kopieren: Das ROI-Feld als ein Bild kopieren. Sie können es dann in andere Fenster innerhalb von Origin einfügen, z. B. ein Diagramm- und Arbeitsblattfenster, oder eine andere Anwendung. Bei Bildern mit mehreren Frames wird nur der aktive Rahmen kopiert.
  • Positionen kopieren: Die Koordinaten des ROI-Felds von 4 Vertices werden kopiert. Sie können wählen, sie als einfache Zahlen einzufügen oder das Position in ein anderes ROI-Feld einzufügen. Für die letztere Option können Sie wählen, nur die Breite/Höhe oder die horizontale/vertikale Position des ROI-Felds einzufügen.
  • ROI exportieren: Details (z. B. ROI-Name, Position der Vertizes etc.) werden in einer .ROI-Datei für später gespeichert.
  • ROI importieren: Details eines zuvor gespeicherten ROI-Felds werden auf das ausgewählte ROI-Feld angewendet.
  • Neu aus XY erstellen: Erstellen Sie ein neues ROI-Feld mit beliebiger Form aus einem Satz von XY-Koordinaten (Grenzen) und Indexdaten. Es werden nur graustufige Bilder unterstützt.
  • Neu erstellen: Das ROI-Feld wird in einem neuen Bildfenster ausgegeben.

Der Grad an Bildverdunkelung außerhalb des Bildfenster-ROIs wird durch die Systemvariable @IMGDI gesteuert. Das Festlegen von @IMGDI = 1000 veranlasst, dass die Fläche außerhalb schwarz angezeigt wird; @IMGDI = 0 schaltet die Verdunkelung aus. Eine Anleitung, wie Sie den Wert einer Systemvariablen ändern, finden Sie in dieser FAQ.

Diagramm aus Bild erstellen

Wählen Sie im Menü Bild: Bild zeichnen.

  • Ein neues Diagrammfenster wird erstellt und das aktuelle Bild wird als sein Hintergrund festgelegt.
  • Das erstellte Diagrammfenster hat automatisch isometrisch gesetzte Layer (Details Zeichnung > Layerebene > Registerkarte Größe > Achsenlänge mit Skalierung mit Verhältnis X:Y verknüpfen = 1).
  • Die Diagrammseite wird automatisch neu skaliert, um an die Layergröße angepasst zu werden.

Erfahren Sie mehr zum Einfügen eines Bildes in ein Diagramm auf dieser Seite.

Anpassungen und Umwandlungen

Neben den oben erwähnten Schaltflächen und Menüs bietet Origin eine Reihe nützliche Hilfsmittel für die Bildverarbeitung und Analyse. Sie werden folgendermaßen in Unterkategorien eingeteilt:

In Matrix konvertieren und Umkehrung

Aufgrund der unterschiedlichen Weisen, Datensätze anzuzeigen und zu speichern, müssen Sie manchmal zwischen Bild- und Matrixfenster konvertieren. Der Datentyp kann während der Konvertierung festgelegt werden. Die Wahl sollte berücksichtigen, wenn die Nachbearbeitung eine Anforderung an den Datentyp hat.

Ein Bild (einzelner Kanal) in Matrix konvertieren

  • Wählen Sie Bild: In Matrix konvertieren, um den Dialog Cv2Mat zu öffnen.

Die folgenden Datentypen werden unterstützt:

!Auto Dies ist die Standardeinstellung. Es werden Bildtypen genommen und immer ein Matrixobjekt pro Bild erzeugt: ein graustufiges Bild mit 8 Bit wird in eine Byte-Matrix konvertiert, ein RGB-Farbbild in eine UInt-Matrix.

Beachten Sie, dass es keinen Umgang mit dem Alpha-Kanal gibt und Sie ggf. eine Vorverarbeitung durchführen können.

Byte Byte-Matrix: Werte von 0 bis 255
UShort UShort-Matrix: Werte von 0 bis 65535
'UInt 'UInt-Matrix: Werte von 0 bis 4294967295
Frei beweglich 32-Bit frei bewegliche Matrix: Werte von -3,4X1038 ~ 3,4X1038
Double 64-Bit frei bewegliche Matrix: Werte von -1,7X10308 bis 1,7X10308


Eine Matrix ins Bildfenster importieren

  • Sie können es mit Python machen. Unten ist ein Beispiel dargestellt.
import originpro as op import numpy as np ml = op.find_sheet('m') a = ml.to_np3d() iw=op.new_image() iw.setup(1,True) iw.from_np(a) iw.set_int('NAV',1)