18 Publishing and Export


Grand image graphic export.png

The Master Page

The Master Page feature is used to add one or more common objects to exported or printed graphs. Use the master page to add a set of properties and objects -- a custom background, a company logo, text labels, images, etc. -- to selected graph windows in your project.

Master items applied.png

To make use of this feature, you must first create your Master Page. The Master Page should contain only the properties and objects that you want to display on your selected graph windows:

  1. From the menu, choose File: New: Master Page. If you are not in the project root folder when selecting this menu item, you will be asked to switch to the project root folder.
  2. Customize the Master Template. Note that the comments that show beneath the Save Master Template button are "hidden" and will not be applied to your graph windows.
  3. Click the Save Master Template button. When you save, the Master Template will be saved to the User Files Folder as "name of active window".otpu (e.g. "C:\Users\YourName\Documents\OriginLab\User Files\Master.otpu").


Things to know about the Master Page:

  • Master items will only show in graphs pages of the same dimensions as the template. Apply Dimension to All Graphs applies Master Template page dimensions to all graphs of the same aspect ratio.
  • If you create a graph and modify page size, then choose File: New: Master Page and load a Master Template into the workspace, the Master Template will be loaded with the page dimensions of your modified graph page.
  • The Rotate button swaps the Master Template page dimensions (toggles orientation between landscape and portrait).
  • When you click Apply Dimension to All Graphs you are prompted to apply dimensions only to graphs of the same aspect ratio, or to all graphs of the same orientation (portrait or landscape).
  • Master Page items on a graph with portrait orientation will not show on a graph with landscape orientation and vice versa.
  • When NOT using Master Items, Edit: Copy Page (CTRL + J) will place an OLE-editable Origin graph object on the Clipboard. When using Master Items, Edit: Copy Page will place an image on the Clipboard; the Copy Graph as Image dialog will open asking you to accept or adjust image settings before clicking Copy.
  • If a graph uses Master Items, Send Graphs to PowerPoint does not support Insert Graphs as Embedded Object. Instead, use Insert Graphs as Picture which does support Master Items.
  • There is a mechanism for selectively excluding Master Items in your exported or printed page. Any object that you do not want to appear in the exported or printed page should begin with "NoExport" (e.g. open an arrow object's Properties dialog and on the Programming tab, rename "Arrow" to "NoExport_Arrow").
  • When you customize and save your Master Page to the User Files Folder, the next time you choose File: New: Master Page, you load your customized template.
  • If you don't want to show Master Items in the workspace, click View: Show: Master Items and remove the check mark. The exported graph will still contain the Master Items (they just won't show in the workspace).
  • If you want to remove Master Items from a graph in both the workspace and exported images, click Format: Page..., Display tab and clear the Use Master Items check box.

You could use the Text tool to add project and system information to your Master Template as static text objects, but since the idea is to build a template for re-use, consider "soft-coding" information in your text labels. To learn more, see these topics:

The Export Margin Offsets Dialog Box

By default, the margins of your copied or exported graph are determined by the Margin Control in Copy Page Settings group of Preferences: Options (Copy actions) or the Export Settings branch of Export Graphs (Export actions). You can interactively modify the default margins using the Export Margin Offsets Dialog Box.

Export margin control.png
  1. Click on the graph window (to activate) and choose Edit: Set Export Margins. This opens the Export Margin Offsets dialog.
  2. Drag the blue selection handles that appear at the page margins; or enter values into the dialog edit boxes and click Apply.

Fit Page to Layer and Layer to Page

There are two small dialog boxes that are also helpful for removing white space or placing a margin around your graph before exporting:

  • Fit Page to Layers: Choose Graph: Fit Page to Layers to open the pfit2l dialog box.
  • Fit Layers to Page: Choose Graph: Fit Layers to Page to open the gfitp dialog box.
DB pfit2l 1 small.png

Both dialogs can be used to remove white space. Both can perform resizing, with or without changing graph aspect ratio. You can view the documentation for both to decide which might work best for you but basically it boils down to whether you need to keep a particular page size. If so, you'll likely want Fit Layers to Page; if not, either one may work for you.

Copying and Pasting Graphs to Other Applications

There are two ways you can include Origin graphs in another application's files (e.g. Microsoft Word .docx files):

  • As an image
  • As an editable OLE graph object


When you paste as an image, you are pasting a static object. In MS Word, for instance, you may be able to modify the image using Word's picture-editing tools, but you cannot make edits to the graph in Origin and have it update the graph in Word (short of deleting the existing image and replacing it with a new one).

By contrast, when you paste an editable OLE graph object you can later double-click on the object in the host application to launch a new instance of Origin. The graph and any associated data sheets will be available for editing. After editing, use Origin's File: Exit and Return to... menu item to update the embedded object, close Origin and return to the host application.

Copy Graph as Image

  1. Click on your Origin graph to activate it, then ...
  2. Choose Edit: Copy Graph as Image (CTRL+ALT+J). Alternately, click on the graph window near the page margin and click the Copy Graph as Image button on the Mini Toolbar.
    MT copy graph as image mt button.png
  3. In your host application choose Paste or press CTRL+V.

When copying the graph as an image (CTRL+ALT+J), you have a choice of image formats (PNG, EMF, DIB, HTML, JPG). Additionally, you can make quick size adjustments and specify background transparency (PNG). The Copy Graph as Image (copyimg) dialog includes a Dialog Theme control which allows repeating <Last used> settings, saving current settings as default Save as <default> or saving settings to a named Theme (Save As...).

Copy graph as image dialog.png

There is a Copy control on the Preferences: Options: Page tab that lets you assign the CTRL+C hotkey combination to either Copy Graph as Image <last used> or Copy Page (CTRL+J) (i.e. "editable OLE graph object"). This allows you to bypass the Copy Graph as Image dialog and speed up placing a standardized image on the Clipboard using CTRL+C.

Copy Graph as Editable OLE Graph Object

  1. Choose Edit: Copy Page (CTRL+J).
  2. In your host application choose Paste or press CTRL+V.


Note: For more information, please refer to the:

Help: Origin: Origin Help > Exporting and Publishing Graphs > Pasting or Embedding Graphs in Other Applications

Organizing Your Graphs for Presentation or Export

If your Origin project file contains a large number of graphs that you plan to export or use in an Origin slide show, you can make things easier by adding shortcuts to your graphs to a Project Explorer Favorites folder and arranging them there:

  • Right-click on a window and choose Add Shortcuts to Favorites. This will add a shortcut to each graph window, to a new Favorites subfolder (visible in Project Explorer).
  • When sending graphs to PowerPoint or creating an Origin slideshow, you can (1) set slide order in the corresponding dialog box or (2) set slide order following this procedure.

If you are preparing a manuscript for publication, you may want to see FAQ-441 How do I export graphs with exact size and resolution as specified by publishers?

The Layout Page

Origin 2022b supports export of layout pages to .SVG files. When adding graphs to the layout, choose Add Graph from the layout shortcut menu and elements of your SVG file (e.g. text) will be editable in applications such as Inkscape or Adobe Illustrator.

A layout page, as the name implies, is a window useful for laying out different elements for publication or export. Use it to assemble graphs, result tables, text objects, etc. onto a single panel.

UG PubExport Layout1.png

Typically, you start by creating a blank panel:

  1. Click the New Layout button on the Standard toolbar.
  2. Right-click on the blank layout to paste Clipboard content, add text, insert images from files, add graphs, tables, etc.
  3. When inserting an image from file, right-click in the area where you want to insert. When adding graphs or worksheets, pick a window in the Browser and drag out an area on the layout with your mouse. Note that added objects can be moved or resized by dragging with your mouse.
    • You can make edits to inserted images, by double-clicking on the image. This opens the image in the Image Window.
    • You can make edits to the graph by double-clicking on the inserted graph object. This opens the source graph for editing. Edits to the source graph will update the graph on the layout page.
    • Inserted tables can be edited by double-clicking on the table object. Style adjustments can be made by selecting a table object and using available Mini Toolbar buttons.
  4. Note that selected elements on the layout page can be aligned using Object Edit toolbar buttons.
Object Edit bar.png


For more on the layout page, see Using the Layout Page Window in the Origin Help file.

Merge Graphs to Layout

As an alternative to manually creating layouts, Origin offers a tool that will merge select graphs into a single layout page of equal spacing. In this case, merged graphs are images and, therefore, not editable using the procedure described in step #3 of the previous section. However, if further graph edits are not needed, you can use this method to quickly produce a nice-looking layout.

UG graph merge layout.png


To merge graph images into a single layout:

  1. With a graph window active, click Graph: Merge Graph to Layout: Open Dialog.
  2. Use the Selection drop-down to specify how to select graphs. To choose individual graphs, choose Specified and use the browse button beside Graphs to open the Graph Browser and pick graphs.

Origin 2022b adds a Fit Page to Objects menu command (Format: Fit Page to Objects), allowing you to apply a uniform margin to the active Layout page. This works the same as the aforementioned Fit Page to Layers does for graph windows.

Exporting Graphs and Layout Pages to an Image File

Origin 2021b added a simplified graph export routine to complement the existing graph export routine:

  • File: Export Graph: If you simply want to export one or two graphs to one of several common image format (PNG, BMP, JPEG, TIFF, EMF) and need only minimal control of image size, this routine is quick and easy.
  • File: Export Graphs (Advanced): If you want to batch export graphs (e.g. All in Active Folder, All in Project, etc.), or export to vector types such as PDF or EPS, use this routine. The dialog supports outputting to a specified path, auto naming, application of Speed Mode settings to exported graphs, plus margin control, image size and other filetype-specific settings.

Origin 2022b supports export of graphs and layout pages to .SVG files. Before exporting, confirm that @SVGTC = 1 and text objects (e.g. axis titles and tick labels) will be more-easily editable in applications such as Inkscape or Adobe Illustrator.

File: Export Graph

File: Export Graph (X-Function = expG2img) is a simplified routine for exporting the active graph page to one of the following formats: PNG, BMP, JPEG, TIFF, or EMF. It does not offer the level of control or flexibility as File: Export Graphs (Advanced) (next section) but it works well for simple export of individual graph pages.


To export using expG2img:

  1. When a graph window is active, choose File: Export Graph.
  2. For EMF images, set a size factor relative to the Image Size reported at the bottom of the dialog. For raster formats, choose an output DPI setting. Alternately, clear the Auto check box and specify a Width in Pixels.
UG expG2img.png

File: Export Graphs (Advanced)

File: Export Graphs (Advanced) (X-Function = expGraph) is Origin's primary tool for exporting graphs and layout pages. It supports raster or vector output, flexible multi-page export (e.g. All in Active Folder), DPI and Speed Mode control and more.


To export a graph or a layout page as an image file:

  1. Select the menu File:Export Graphs (Advanced).
UG expGraph DB.png


The expGraph routine exports graphs to one of 15 file formats:

Raster Formats BMP, GIF, JPG, PCX, PNG, TGA, PSD, TIF;
Vector Formats CGM, DXF, EPS, EMF, PDF, SVG, WMF


Saving Export Settings to a Theme

As is the case with many other Origin dialog boxes, you can save your graph export settings as a Dialog Theme for repeat use.

UG expGraph Dialog Theme.png

Once you have determined your export settings:

  • Click the flyout button to the right of Dialog Theme and choose one of the Theme save options.
  • Using any group of custom settings creates a temporary default Theme called <Last used>. This Theme then becomes available for loading your last used settings and you can access it from the expG2img or ''expGraph dialog boxes or from the File: Recent Exports menu.
ExpGraph Last used.png


Since Origin 2021, expGraph dialog box settings are saved to the graph automatically on export.

  • To save current settings withtout exporting, choose Save to <Graph>.
  • To restore saved settings after you've modified them in the export dialog, choose <Graph>
UG Save to Graph Theme.png
Note: For more information, please refer to the:

Help: Origin: Origin Help > Exporting and Publishing Graphs > Exporting Your Graph or Layout Page to an Image File

You can export multiple graphs, such as all graphs in a folder or all graphs in a project file, to a single, multi-page PDF file. Choose File: Export Graphs and open the Export Graphs dialog box. Set Image Type to Portable Document Format (*.pdf) and Select Graph(s) to one of the following options and you will see a checkbox for Export as multi-page PDF file.

Export as multipage PDF.png

Exporting Images to a Raster File

Image window content can be exported to several raster formats: BMP, GIF, JPG, PNG, TIF.

UG cvExport dlg.png

For Origin 2022b, you can set a DPI for your exported image.

Send Graphs to PowerPoint

You can send a group of Origin graphs to MS PowerPoint as pictures or as embedded objects (see limitations of embedded objects and Master Items, explained above). Graphs inserted as embedded objects can be further edited in your Origin software. Double-click on the graph in PowerPoint to open the graph in an OLE instance of Origin.


To Send Graphs to PowerPoint:

  1. Click the Send Graphs to PowerPoint button Buttons send graphs to PowerPoint.png on the Standard toolbar.

or...

  1. Click the Send Graphs to PowerPoint icon APP SG2PP.png in the Apps Gallery, docked to the right-side or your Origin workspace (if you do not see the Apps Gallery, click View: Apps or press ALT + 9).

or...

  1. Right-click in the lower-pane of Project Explorer and choose Send Graphs to PowerPoint.


Tutorial: Send Graphs to PowerPoint

  1. Run Origin and open the sample file <Origin EXE Folder>\Samples\Graphing\Column and Bar.opju.
  2. Click the Send Graphs to PowerPoint button Buttons send graphs to PowerPoint.png on the Standard toolbar.
  3. Click the Select Graphs button and choose Specified.
  4. Select all except Graph5B in the left panel and move them to the right panel by clicking the Button Add Files.png in the middle of the dialog box. Click OK. A scrollable list of graphs is added to the left panel in the App.
  5. Set Insert Graph as = Picture.
  6. Set the Slide Margin top dimension as 8% and leave the others as 0.
  7. Set Title Line = Top of Slide, and Title = Window Long Name.
  8. Set Starting Slide Index = 3 and Slide Mode = Start New.
  9. Use the browse button beside Load File/Template (optional) to load the file <Origin EXE Folder>\Samples\Import and Export\Column_Plots_in_Sample_OPJ.pptx.
  10. Specify a Save File as (optional) output path for the resulting PPTX file.

There is also a Send Graphs to Word App that is pre-installed with your Origin software. This App is particularly useful for batch export of graphs to a book-marked MS Word document.

Slide Show of Graphs

Origin has a built-in slideshow utility for viewing or presenting your graphs while running Origin. The slide show can be started in two ways:

  • Right-click on any folder in Project Explorer and select Slide Show of Graphs...

or

  • Click the Slide Show of Graphs button Button Slide Show Graphs.png on the Standard toolbar.

A dialog box opens offering options to set slide order, slide cycle time, whether to include graphs in sub folders, etc. The dialog also lists shortcut keys for use during the slide show (e.g. G = go to the actual graph window of the currently displayed slide).

Tutorial: Slide Show of Graphs

  1. Use the File: Open Sample Projects: 2D and Contour Graphs menu to open the sample project.
  2. Click on the Slide Show of Graphs button in the Standard Toolbar.
  3. Accept default settings in the dialog that opens, and press OK to start the slide show.
  4. You can use the up/down arrow keys or the mouse wheel to flip thru the slides.

Creating Movies

Origin provides a Video Builder tool, accessible from the Open Video Builder button Button Open Video Builder.png on the Standard Toolbar. This tool can be used to manually capture a series of graph windows, and write one frame at a time to a video (.AVI) file.

Videos can be created using LabTalk script or Origin C code, by programmatically computing or updating data and then writing out the graph as a frame in the video, at each step during the computation.

Note: For more information, please refer to the:

Help: Origin: Origin Help > Exporting and Publishing Graphs > Creating Graph Animation

For specific examples of programmatically created movies, including Origin Projects and code, please visit www.originlab.com/animation.

Notes Windows for Reporting

For Origin 2022b, the Notes window gets Rich Text support.

Over time, Origin's Notes window has morphed from a plain-text window for jotting down your research notes, into a flexible medium for collating a variety of research-related materials.

Because the Notes window can contain linked objects -- graphs, images, worksheet cell values, etc. -- it can be useful to add a Notes window to an Analysis Template™ for purposes of summarizing analysis results. Alternately, you can save your Notes window as a PDF by clicking File: Print and choosing a PDF driver.

Notes Window Syntax

Origin's Notes window supports four syntaxes: Text, Origin Rich Text (default), HTML, and Markdown.

  1. To switch syntaxes, choose Notes: Syntax: Text.
  2. Once you have selected Text, you can freely choose other syntaxes from the Notes menu.

Rich Text

With Rich Text, the Notes window has two modes -- raw text mode and Render mode. Toggle between these modes using Notes: Render Mode or shortcut key combination CTRL + M.

To add text to the Notes window, you need to be in raw text mode. To style added text, use the Format toolbar and/or apply pre-defined paragraph styles.

UG basic rich text fmt.png

Adding Content to Your Notes

Objects that you can Insert by right-clicking in the Notes window:

UG insert objects shortcut menu notesWin.png
Object Comments
Graph/Image Opens the Graph/Image Browser where you can pick project graphs and images. Note that you can Show Embedded Graph (see the first row of this table for a definition of "embedded graph") and Project Explorer "Favorites" folder shortcuts (Include Shortcut Page).
Worksheet Cell... Opens the interactive range selector. Use this to pick a cell value in a worksheet or report sheet. Click Done to insert a linked cell value.
Info Variable... Opens the Insert Variables dialog for inserting project variables stored on data import.
New Table Opens the New Table dialog for configuring a basic table. Clicking OK closes the dialog and opens a basic workbook containing a single worksheet. Customize the worksheet, add data, etc., then use Notes window Render Mode to view the resulting table.
Symbol Map Opens a simplified Symbol Map with characters sorted by tab. Click Advanced to go to the full Symbol Map.
LaTeX Equation Opens the LaTeX Equation Editor App (if you've not already installed this free App, you are prompted to do so). You can click the Equation button UG latex equation button.png to open a list of Origin's fitting functions (incl. your user-defined functions). Pick a function (or enter a function into the top box) and click Preview to see your equation rendered.
Link Opens a dialog box for entering Text to display and a Link. The link can be a URL or it can be a link to such things as a worksheet data range (e.g. range://[book1]sheet1!col(1)[100]). Additionally, you can run simple LabTalk commands using a "labtalk://" tag (e.g. labtalk://newsheet).
Image from File Opens a dialog to browse for image files. Note that the inserted image is linked to an external file and is not saved with the project.
Image form Web Opens a dialog to specify a Image Link for a web image (hint: In your browser, right-click on an image and Copy Image Address, Copy Image Link, etc).


  1. Add your content using raw text mode.
  2. When you are ready to view your content, turn on (place a check mark beside) Notes: Render Mode or press CTRL + M. Note that you can use the Zoom combo box Standard button zoom combo.png on the Standard toolbar to zoom in or out on the page (CTRL + mouse wheel also works).
UG cell notes rich text images.png

Text Styles Manager

In addition to styling text with the Format toolbar, you can apply a simple set of paragraph styles on a line-by-line basis. Manage styles with the Text Styles Manager dialog box.

  1. With a worksheet active, choose Tools: Text Styles Manager.
  2. Select a Style to Modify and Apply or Close.
UG mod txt styles dlg.png

Note that you can add styles by selecting <new> from the Styles to Modify drop-down list; or select a style and Delete.

To apply a paragraph style to Notes window text:

  1. Open the cell note in a Notes window.
  2. With Render Mode off (CTRL + M, to toggle), click on a line of text then right-click, choose Paragraph Styles and choose a style from the popup menu.
  3. To check results, press CTRL + M (Render Mode).

To see a list of built-in paragraph styles, open a fresh Notes window, then from the menu choose Notes: Load Samples: Built-in Styles.txt.

Adding Rich Text Content to Layout or Graph

Insert Rich Text content of a Notes window to a text object on a Layout or graph page.

UG insert notes text to layout.png


To add the content of an existing Note (Layout or Graph):

  1. Select the Text tool Text button.png, then click on the Layout/Graph and enter "@@@NotesN" (i.e. the Notes window Short Name).
  2. Click off the text object to insert Notes content.


To add content by creating a new Note (Layout only):

  1. Right-click on the Layout and choose Insert Notes Text.
  2. See Adding Content to Your Notes.

Print or Export to PDF

You can output Rich Text content to a physical printer; or print to PDF using a third-party driver such as Microsoft Print to PDF.

To create nice-looking output, you'll need to pay attention to these settings:

  • Paper Size: This is set in File: Page Setup or in the Advanced options for your printer driver.
  • Margins: These are set in File: Page Setup.
  • Notes Display Margin: By default, the Notes display margin = 5 (units = points). Thus, you will note that in Render Mode (CTRL + M), there is a slight margin to the left side of the Notes page. This display margin is controlled by setting system variable @NDM.
  • Notes Window Page Width: Page width is controlled by the property note.width (units = in/cm, etc). Default = 0, which corresponds to an uncontrolled width. For best printing results, you will need to set notes.width.


Paper Size - Margins - Notes Display Margin = Width of the printed area (paper or PDF).

So, for example, an 8.5 inch wide page with 1 inch margins to the left and right; and a display margin of 0 points, should "print out" as 6.5 inches wide. Therefore, for best results, set page.width = 6.5 before printing.

HTML and Markdown

You can also use Notes windows to create HTML or Markdown reports. Similar to Rich Text, you can build your HTML report using placeholders that link to report sheet elements such as metadata, statistical results or graphs. The resulting HTML report can be printed or exported; or it can be incorporated into your Analysis Template. If Markdown syntax is used, optional HTML syntax can be also included for advanced customization.

To use this feature, the user should have some basic familiarity with HTML or Markdown, and as with most things, the more proficient the user is, the easier it will be to create professional-looking output. However, the skill needed to generate a basic report can be easily mastered. See this OriginLab blog post for guidance.

HTML Reports.png

Adding Content to Your HTML Report

The basic steps of creating reports using an Origin Notes window, are as follows:

  1. Create your project to include graphing and analysis results.
  2. Click the New Notes button Button New Notes.png to add a Notes window.
  3. From the menu, choose Notes: Syntax, then choose HTML or Markdown (Hint: You can toggle between text/view and markup modes by pressing CTRL+M and you can choose the default syntax by setting LabTalk System Variable @NPS).
  4. You can write your code in the Notes window's markup mode or you can use a text editor such as Notepad++, then copy and paste it to your Notes window. If you have no experience with HTML or Markdown, you may want to load samples by activating your Notes window and clicking Notes: Load Samples (HTML = ".html", Markdown = ".md").
  5. You will likely want to incorporate graphing and analysis results from the current project, into your report. The simplest way to do this is to insert "placeholders" for each Origin object that you intend to include in your report, into your code. These placeholders can be named using any string that makes sense to you and they should be enclosed in double-curly braces (e.g. {{MyR-SquareValue}}).
  6. Right-click on the Notes window title bar and choose Edit Placeholders. Placeholders that you have incorporated into your code will be picked up and added to a Placeholders worksheet in the workbook. The sheet will list, in column A, all of the placeholders found in your code. A second column -- Column B -- is blank and is reserved for adding the associated Origin objects (i.e. the variables, analysis and graphing results, etc.) that you want to include in your report.
  7. For each placeholder in column A, find the associated Origin object and copy it to the Clipboard (e.g. if it is a numeric quantity in a sheet resulting from some statistical analysis, select the cell quantity, right-click and choose Copy, or press CTRL+C on your keyboard).
  8. Return to the Placeholders sheet, right-click in column B, beside the associated placeholder and choose Paste-Link. This associates your placeholder with the intended Origin object.
  9. If you intend to include your HTML report in an Analysis Template, you can right-click on a workbook tab in your Analysis Template and choose Add Notes as Sheet. This inserts your Notes window into workbook and you can now choose File: Save Workbook as Analysis Template.

When a Notes window is active, you can click the Notes menu and load a sample HTML file into the Notes window.

HTML load samples.png

Using Your HTML Report

As you fill in your Placeholders sheet, you should see your HTML report take shape in the Notes window. Once completed, you can do various things with your HTML report, including:

  • Print to hard-copy or to PDF (File: Print).
  • Export the window as a webpage (Notes: Export to Webpage).
  • Click the embed button in the upper-right corner of the Notes window to embed the content into your workbook, then save the workbook as an Analysis Template (File: Save Workbook As Analysis Template).

Exporting Worksheets and Matrices

Exporting Worksheets


With a worksheet active, the File: Export menu item provides the following options:

  • ASCII, NI TDM (TDM, TDMS), and Sound (WAV)
    This option is available only for sheets containing data columns, and is not available when report sheets such as those created by the Nonlinear Fitting tool are active. The exported file will contain only data from the worksheet columns. Floating or embedded graphs placed in the worksheet will be ignored.
  • Excel
    Export books of worksheet columns with text and numeric data to an MS Excel file (XLS, XSLX, XSLM). Note that analysis report sheets with their hierarchical tables, and things such as embedded graphs and images, are not exported to the Excel file. Analysis results that are output to regular Origin worksheets are exported.

For information on copying analysis report sheets and pasting to MS Office applications, see FAQ-815 How do I copy report sheet tables and paste them into Word, Excel or PowerPoint?

  • SQLite
    This option exports the active worksheet(s) as an SQLite file. Specify a file extension of .sqlite, .sqlite3 or .db (note that file structure is identical). Options to skip hidden columns or rows. Limited to export of data in worksheet columns.
  • As Multipage PDF File
    This option is available only on sheets with data columns, and not for report sheets. Use the View: Page Break Preview Lines menu item to view the vertical and horizontal page break lines that determine which columns and rows will be included in each page of the export. Floating or embedded graphs placed in the worksheet will be included in the exported image.
  • As Image File
    This option is available on both data and report sheets. In the dialog that opens, you can select whether to export the entire sheet, visible area, or selection. Image file formats including PDF are supported. Floating or embedded graphs placed in the worksheet will be included in the exported image.
  • As PDF File
    This option is available for both data and report sheets. In the dialog that opens, you can opt for exporting the entire sheet, the visible area, or a selection. Floating or embedded graphs are included in the exported PDF.

When creating a custom report from a worksheet that combines data, numeric results and graphs, the best option is to export the entire sheet as a PDF file, or export the sheet as a multi-page PDF file.

Exporting a Matrix

Origin matrix data can be exported in these two formats:

  • ASCII
    This will create an ASCII file of the data contained in the active matrix object.
  • Image
    This option will export the image view of the active matrix object, as a raster file.
Note: For more information, please refer to the:

Help: Origin: Origin Help > Importing and Exporting Data > Exporting Worksheets and Matrices

Topics for Further Reading