8 Import Data

Import grand image4 650px.png

A new generalized data import mechanism we call Data Connectors was added in Origin 2019b. As the name implies, Data Connectors create a link between your project and an external source file. The source file may be local, it can be on a company network; it can even be on a web-server. Data Connectors support options for excluding imported data when saving the project (smaller files, plus, maintain a live link to source data) and for protection of data against accidental alteration or deletion. Data Connectors also make possible import of previously-unavailable data sources, including HTML Tables and JavaScript Object Notation (JSON). Data Connectors support drag-and-drop and Auto Import on Project Open. In addition, OriginLab continues to expand Connector support to new data formats. In Origin 2021b, for instance, we have improved Connectors for National Instruments TDMS and NetCDF files; plus we've added a new Thermo Fisher Scientific MSRawFile Connector.


Other supported import mechanisms:

  • OriginLab continues support for Origin's long-standing X-Function + filter-based routines for ASCII, CSV, Excel, binary files, and many third-party formats, including MATLAB, pClamp, NI TDM and NetCDF. If you are a long-time user and you have import filters and Themes that you have long relied on, they should still work as they always have.
  • Copy-paste for quick import of simply-structured data (mostly useful for quickly adding data to worksheets).
  • For complex ASCII, binary or User-defined file types, you can use the graphical interface of the Import Wizard to parse your file and save settings to an import filter file. The Import Wizard supports power features such as saving file metadata to variables and use of custom Origin C functions for data processing and import.
  • If you work with SQL databases, you can use Origin's Database Connector and SQL Editor interface to create connection strings and SQL queries.

A Note to Upgrade Users

Longtime Origin users who are upgrading from older versions should note that import routines have moved from the File menu to a new Data menu. Here, you will also find Origin's newest data-import tool: Data Connectors.

Import fF Moved.png

Data Connectors

Data Connector General Concept.png

Data Connectors are a general mechanism for importing data to your Origin projects from local or from web-based files and pages. Data Connectors differ from older Origin import methods primarily in two default (but modifiable) behaviors:

  • Data imported via Connector is locked to editing. This helps ensure data integrity.
  • Data imported via Connector is not saved with the project. This helps to keep your project files smaller.

Origin 2021b supports unlocking of connected data by clicking the Connector icon and choosing Unlock Imported Data. This data remains unlocked until you click the Connector icon and choose Import (thereby, reimporting from your data source).

UG unlock connected data.png


Data Connectors support a number of common data formats, including:

  • Text/CSV
  • Excel
  • MATLAB
  • Origin File (project, workbook, matrix)
  • HTML Table
  • JavaScript Object Notation (JSON)
  • HDF
  • TDMS
  • NetCDF
  • Import Filter (use a custom import filter with the Data Connector mechanism)

To connect to SQL database, see Database.


To import data with a Data Connector:

  1. With your workbook active, click the Data menu.
  • If you are connecting to a local or network file, click Connect to File and pick a file type.
  • To connect to multiple files, click Connect Multiple Files.
  • If you are connecting to web data, click Connect to Web and enter a URL.

Things to Know about Data Connectors

  • By default, when import data file size exceeds 500kB, the imported data and graphs made from that data are NOT saved with the Origin file (see LabTalk system variable @FSE). All analysis output resulting from imported data ARE saved with the Origin file. Not saving raw data with your project file can significantly reduce file size and improve performance when working with large projects.
  • IMPORTANT: Since, by default, connector-imported data (> 500kB) is not saved with the project file, users should always ask themselves whether they need to preserve imported data. This could be an issue when the data source is web-based and stored in a place beyond your control. If you prefer to save all data imported via a Data Connector, with your Origin file, click the Data Connector icon and clear the check mark beside Exclude Imported When Saving prior to saving your file. Note that each Data Connector-containing book will have its own Exclude... check mark. Alternately, if you decide the Data Connectors are not needed, you can click the Data Connector icon and choose Remove Data Connector (from this book) or Remove Data Connectors from All Books (in the project).
  • Data can be re-imported at any time by clicking the Data Connector icon (DC Icon DataMod.png or DC Icon Live.png) in the upper left corner of the worksheet and choosing Import (Ctrl+4) or Import All.
  • By default, imported via a Data Connector is locked from editing. You can graph it and analyze it but you cannot modify it. While this ensures against accidental modification, some users may find this too restrictive. See this FAQ for information on removing editing restrictions from Connector-imported data.
  • A workbook can have only one type of Connector (e.g. Text/CSV). For files with a simple structure such as Text/CSV, you can have multiple sheets with each connecting to a separate file, as long as they share the same Connector. For files with more complex structures such as Excel or MATALAB, you will initially connect to one sheet/variable, then use the Data Navigator's Add and Connect Sheet(s) shortcut menu command to add other sheets/variables in the book, as needed. You can only connect a single Excel or MATLAB file to a single Origin workbook or matrixbook.
  • In books containing files with a simple structure (e.g. CSV), when you right-clicking on a sheet tab and add a new sheet, the sheet is added with an empty Connector. The unconnected state is denoted by a pale-yellow Connector icon DC Icon Empty.png (see Connector states, below). Click on the Connector icon to open a shortcut menu where you can connect the sheet to a data source.
Data Connector Shortcut Menu.png
  • Data Connectors that you do not use can be hidden by choosing Data: Connect to File: Customize... and clearing the checkbox next to unused Connectors.
  • Data Connectors for file formats not shipped with Origin, are available by clicking Data: Connect to File: Add New.... New Data Connectors are added to the Data menu.
UG data connector add new.png

Origin caches data imported by Data: Connect to Web, for a period of time determined by LabTalk system variable @CFDT, plus file size. By default, a 10MB file will use cached data for ~24 hrs. In other words, if you re-import (i.e. reconnect to the web file) within 24 hrs, you will be using data that was cached on first import. If you re-import to this 10MB file after 24 hrs passes, the cache is cleared and the data are freshly imported. To learn how to control this caching behavior see, these topics:

Data Source File Path

A Data Connector icon appears in one of five states:

  • When the data source is connected, the icon looks like this: DC Icon Live.png
  • When data in the sheet are unlocked to editing (either by the Connector menu or @IPDC=0), the icon looks like this: DC Icon Unlocked.png
  • When a data source import is pending, the icon looks like this: DC Icon DataMod.png
  • When a new sheet is added to a connected book, an empty Connector is added to the sheet and the icon looks like this: DC Icon Empty.png
  • When the data source is no longer viable (e.g. the data source has been moved), the icon looks like this: DC Icon Broken.png


Regardless of the state of the connection, you can click the Connector icon, then use the Data Source File Path and Common Data Path to help you maintain the connection between your Origin files and your source data.

UG Common Data Path Dialogs.png
  • Relative to Project Path: If your data are stored in folders under the project file, you could set Data Source File Path to Relative to Project path. You can then move the project and data sources together, and their relative paths are preserved. No path corrections are then needed when re-opening the project file from a different location on your network.
  • Relative to Common Data Path: If data sources are under some common path, you could set Data Source File Path to Relative to Common Data Path. If the files are subsequently moved, you can re-establish the Common Data Path and then Import All Books.

Data Navigator

The Data Navigator is a collapsible panel that is automatically added to the workbook when you connect to multi-page/multi-variable files such as Excel, MATLAB or Origin Projects.

UG data navigator overview.png
  • Origin will import data from the first sheet and list other sheets in dimmed type.
  • Right-click on a dimmed sheet -- or press CTRL or SHIFT and select multiple sheets -- then choose Add and Connect Sheets.
  • The file name is assigned to the book Long Name and sheets are the original sheet name is assigned to sheet Name.
  • Connected sheets can be deleted from the current Origin workbook.

Data Connectors and Drag-and-Drop

There is drag-and-drop support for the file types listed under Data: Connect to File. If you are using an older import filter for drag-and-drop import (see below), Origin will give priority to that filter as long as it is saved to the template, to the data folder or to the User Files\Filters folder (see this FAQ).

Note, however, that Data Connectors offer some advantages for drag-and-drop such as automatic column formatting of date-time data in CSV files and automatic import of MATLAB variables to Origin matrix objects and the addition of a slider control for viewing images in sequence.

For more information, see these topics:

Connecting to Text/CSV

You can use a Data Connector to import local or web-stored text files (TXT, DAT, CSV). Data Connector methods work well for these file types, simplifying and in some cases eliminating, some of the problems associated with Origin's older X-Function-based import routines. For instance, import of date-time data always required manual configuration of date-time columns. With Connectors, if your date-time data are of a standard, easily-recognized format, that configuration is done for you automatically.


To connect to a file on a local or LAN drive:

  1. With the workbook active, choose Data: Connect to File: Text/CSV.
  2. Browse to and select your file.
  3. Set your CSV Import Options. In many cases, you can simply accept defaults and your file will be cleanly imported, so as a test, try importing data without modifying defaults. If the results are unsatisfactory, rerun the import and modify the default settings.

In this mini-tutorial, we use the Text/CSV Connector to import a text file with a date-time component. While older Origin import methods treated the date-time data as text, requiring the user to manually set the date-time column to Date after import, the Text/CSV Connector is able to automatically configure the worksheet column on import.

  1. Click the New Workbook button Button New Workbook.png and choose Data: Connect to File: Text/CSV.
  2. Browse to the <Origin Program>\Samples\Import and Export\ folder and open Date with higher precision.dat.
  3. In the CSV Import Options dialog, accept default settings and click OK. Data are imported to the workbook.
  4. Click on the column A header to select the column, then right-click and choose Properties. Note that Format has been automatically set to Date, Display has been set to Custom Display and a custom format shows in Custom Display.
Import custom date time.png

In this mini-tutorial, we use a Data Connector to import multiple files. These identically-structured files have multiple rows of metadata that we want to preserve. So, you will make use of an import filter file that has been developed using the Import Wizard, to import the files and write file metadata out to multiple column label rows in each worksheet. In so doing, you will see (a) how to import multiple files using a Data Connector and (b) how you can use an import filter file (*.oif) developed with an earlier version of Origin, to import files using Origin's newer Data Connector technology.

  1. Start a new project and with the workbook active, choose Data: Connect Multiple Files.
  2. In the files2dc dialog box, set the following:
    • Data Connector = Import Filter
    • Source = Specified Files
    • File Names = <Origin Program>\Samples\Import and Export\S15-125-03.dat, S21-235-07.dat and S32-014-04.dat
    • Same Book = enabled (checking the box will bring all files into one book)
  3. Click OK and in the dialog that opens, set Import Filter = Data Folder: VarsFromFileNameAndHeader.oif
  4. Click OK and the three files are imported as separate sheets in the workbook.


To connect to a file on the Web:

  1. Choose Data: Connect to Web.
  2. If you have a file URL, enter it in the URL box. Otherwise, set File Type to Text/CSV (optional but helps to filter Recent URLs), then click directly on Recent URLs and pick from the list.
Connect to web dialog URL.png

You can use the CSV Import Options dialog to specify a partial import of web-stored files just as you can for locally-stored files. Check the Partial Import box for guidance on the syntax used to define Column and Row import.

Note: To learn more about working with the Text/CSV Connector, see the Origin Help:

Help: Origin: Origin Help > Text/CSV Connector

Connecting to MATLAB Files

  • MATLAB Connector now supports date-time variables in v 7.3 MAT-files.
  • Improved import speed for large files.
  • Added system variable @MLAM to control max number of array elements to show in Data Connector Browser and Data Navigator.

While Origin continues to support older X-Function based MAT file import, Data Connectors offer some distinct advantages for import of both locally-stored and web-stored MATLAB files:

  • Connecting to a MATLAB file at the root level will add all variables as Origin matrix objects in the matrixsheet.
  • A slider is added so that you can flip through Origin matrix objects in the sheet. You can toggle between slider and thumbnails using the Slider or Thumbnails Mini Toolbar button.
  • The Connector also adds a collapsible Data Navigator panel to the window. If you wish to add variables as individual sheets, you can right-click on the Data Navigator list and add them.
UG slider or thumb MAT.png


To connect to a MATLAB file:

  1. With a workbook or matrixbook active, click Data: Connect to File: MATLAB or Data: Connect to Web and enter a URL to your .mat file.
  2. Select the variables that you want to import (add them to the Browser's bottom panel) and click OK.


Note: To learn more about working with the JSON/MATLAB Connector, see the Origin Help:

Help: Origin: Origin Help > JSON/MATLAB

Connecting to NetCDF and Shapefiles

Origin's NetCDF Connector is greatly improved, especially in its handling of geographic data. For added support of NetCDF geodata, we've preinstalled a Data Connector for the familiar Shapefile format so that you can overlay your NetCDF data with geo-spatial data.

The NetCDF file format is used for sharing multi-dimensional scientific data. The format is widely used in climate science. Shapefiles are commonly used to store geographic boundaries and other geo-spatial data.

Import NetCDF Image Map.png


To connect to a NetCDF file:

  1. With a workbook or matrixbook active, click Data: Connect to File: NetCDF or Data: Connect to Web and enter a URL to your .nc file.
  2. Select the variables that you want to import (add them to the Browser's bottom panel) and click OK.
  3. If a workbook is active but the variable requires a matrixbook, you will be prompted to add a new matrixbook or an embedded matrixbook in the active workook.


To connect to a Shapefile:

  1. With a workbook or matrixbook active, click Data: Connect to File: Shapefile and browse to and choose your .shp file.
  2. Specify whether to Load Attributes and (optionally) encoding, and click OK.


Note: To learn more about working with the NetCDF Connector, see the Origin Help:

Help: Origin: Origin Help > NetCDF Connector

Working with Excel Data

There are five ways to work with MS Excel data in Origin:

  • You can copy Excel data to the Clipboard and paste or paste link that data into Origin.
  • You can use a Data Connector to import a local Excel file by (1) clicking Data: Connect to File: Excel, (2) clicking the Button Import Excel.png button on the Standard toolbar, or (3) dropping your Excel file onto the Origin workspace.
  • You can use a Data Connector to import Excel data from the web by clicking Data: Connect to Web: Excel (see below).
  • You can Origin's older X-Function-based routines to import a local Excel file by clicking Data: Import From File.
  • You can also open your Excel workbook in Origin as an Excel workbook (must have MS Excel installed). To do this, use the File: Open Excel... menu command.

When you paste or import your Excel workbook data into an Origin workbook (including import by Data Connector), you have full access to Origin's powerful graphing and analysis features. When you open your Excel workbook as an Excel workbook, you are actually running an OLE instance of Excel inside of the Origin workspace. In this case, you have access to Excel's menus and features, but very limited access to Origin's graphing and analysis features. For most users, choosing one of the Excel import options (first four options) will be preferable to opening the Excel workbook in Origin as an Excel workbook.


Things to know:

  • To open an Excel file in Origin as an Excel workbook, you need to have Office 97 or later installed on your computer. However, you can import an Excel file into Origin without having Excel installed.
  • Origin imports files of type .xls, .xlsx or .xlsm.
  • You can link your Origin project file to an external Excel file. That way, updates to the Excel file will trigger updates to dependent graphs etc. when you open the Origin project file.
  • Origin does not support dynamically linking a formula in an Excel workbook to source data in another Excel workbook.
  • Certain file import information is saved to the workbook on import. Having once imported an Excel file to an Origin workbook, you can use the Re-import feature to re-import an updated Excel file -- including those that contains multiple sheets -- to your Origin workbook.


Note: To learn more about working with Excel data, see the Origin Help:

Help: Origin: Origin Help > Working with Microsoft Excel and Connecting to File > Excel

You can do partial import of your Excel data by delineating one or more row and column ranges. A flexible syntax is provided for including or excluding data ranges. For information, choose Data: Import From File: Excel (XLS, XLSX, XLSM), check Show Options Dialog and choose a file for import. In the impMSExcel dialog, expand the Partial Import branch and note the in-dialog syntax hints under Custom.

Connecting to Excel Files

Origin's Excel Connector now supports Partial Import.

  • To connect to a local file, click Data: Connect to File or click the Button Import Excel.png button located on the Standard toolbar.
  • To connect to a web-stored file, click Data: Connect to Web.
  • You can only connect one Excel file per Origin workbook.
  • If the file is a multi-sheet file, you must first connect to a single sheet. This opens the the Data Navigator panel (described above) where you can connect to additional pages, as needed.
  • If all sheets are identically structured, taking the time to setup the connection to the first sheet, will allow you to easily connect additional sheets.
Excel connect import options structure.png
  1. Click the New Workbook Button New Workbook.png button to create a new workbook, then choose Data: Connect to File: Excel.
  2. Browse to and open <Origin Program>\Samples\Import and Export\United States Energy (1980-2013).xls.
  3. In the Excel Import Options dialog, set the following:
    Excel Sheet = Oil
    Main Header Lines = 0
    Enable Column Labels
    Long Names = 3
    Units = 4
    Comments From = 1
    Comments To = 2
  4. Click OK and the sheet Oil is imported into the workbook.
  5. In the Data Navigator panel that opens to the left side of the workbook, hold the CTRL key and select the other three sheets, right-click and choose Add and Connect Sheet(s). The remaining sheets -- Natural Gas, Coal and Total Primary Energy -- are imported into the workbook. Note that if the unconnected sheets are large in size, you can opt to connect to them one-at-a-time, as needed.

Import from File

The import routines listed under Data: Import From File pre-date Data Connectors. While the Import From File routines are no longer being developed, they are still supported and in some cases users may prefer the older routines (you may be using a reliable import routine and have no need for the Data Connector's data protection).

In addition, Connectors may not exist for some of the file types listed in this table. In such cases, you should continue to use the Data: Import From File methods.

The Standard toolbar Import Single ASCII button Button Import ASCII.png now calls the Data: Connect to Files: Text/CSV routine. For the impASC routine, see the next section.

Importing ASCII Files with impASC

  • The Data: Import From File: Multiple ASCII... (Button Import Multiple ASCII.png) method is generally satisfactory for importing text files having a simple structure (works for single or multi-file import). This routine will typically handle files with commonly-used delimiters and a simple header structure, without adjustments.
  • If the file import needs adjustments, select the Show Options Dialog checkbox when selecting your file(s) in the ASCII dialog. This will open the impASC dialog box prior to file import, allowing you to tweak the way that the files are handled.
Import data 1.png
Note: To learn more about working with the ASCII Import using the impASC dialog, see the Origin Help:

Help: Origin: Origin Help > Customizing the ASCII Import Options

Saving Import Settings

Once you've adjusted import settings, you can save them in one of two ways:

Saving import settings with the worksheet template offers portability (e.g. templates are easily shared with colleagues). Saving import settings as a Theme offers the advantage of being able to recall any number of import options combinations when importing via the impASC dialog box.

For more information on Themes and templates, see the Customizing Origin chapter later in this User Guide. Additionally, see topics listed under "Topics for Further Reading", below.

You can quickly load your custom import theme from the list at the bottom of the Data menu. You can also use the Data: Import from File: Add/Remove File Types ... menu to open the Import Menu Customization dialog box where you can select and add User Themes to the Data: Import From File menu.

Third Party Formats

If a Data Connector does not exist for a certain third-party format, you can still use Origin's older X-Function-based import routines. These include many widely-used formats, including pClamp, NI TDM, and NetCDF. As with all X-Function-based routines, you can customize third-party file import options and save your settings with the worksheet template or as a dialog Theme for later use. As with other supported file types, you can import third party files by drag-and-drop.

File Type Method To Learn More, see

Help: Origin: Origin Help > Importing and Exporting Data


Thermo (SPC, CGM)
pCLAMP (ABF, DAT, AB?)
Princeton Instruments (SPE)
Sound (WAV)
NetCDF (NC)
CDF (CDF)
HDF5 (H5, HE, HDF5)
NI DIAdem (DAT)
Famos (DAT, RAW)
ETAS INCA MDF (DAT, MDF)
IgorPro (PXP, IBW)
Prism (PZFX, XML)
MATLAB (Mat)
Minitab (MTW, MPJ)
KaleidaGraph (QDA)
SigmaPlot (JNB)
MZXML(mzData, mzXML, mzML, imzML)
EarthProbe (EPA)
EDF (EDF, BDF, REC, HYP)
Somat SIE (SIE)
JCAMP-DX (DX, DX1, JDX, JCM)
HEKA (DAT)
SPSS (SAV)
BRUKER OPUS
SAS (sas7bdat)
Tektronix (ISF)
Data Translation (DCF, HPF)
Binary 2D Array (IMG, B2D)
Image

Data: Import from File: > Importing Third Party Files
Note: Some of these 3rd party file formats are hidden by default. To add, choose Data: Import From File: Add/Remove File Types.... This opens the Import Menu Customization dialog box where you can choose which file types to show in the Import From File menu. To insert a separator after a menu command, right-click on the command in the right-hand panel and choose Add Separator. To remove a separator, double-click on it in the right-hand panel.

If no Data Connector exists for a given file type (i.e. those listed in the table above), then drag-and-drop support is managed by file extension, using the Filter Manager dialog. From the main menu, click Preferences: Import Filters Manager....

Note: To learn more about working with the Third-party Formats, see the Origin Help:

Help: Origin: Origin Help > Importing Third Party Files

The Import Wizard

For import of complex ASCII files -- those not satisfactorily handled by the methods previously discussed -- you can use the interactive Import Wizard. Files with an optional header section followed by a sequential binary structure, can also be imported using the Import Wizard:Import Wizard


To run the Import Wizard:

  1. Choose Data: Import From File: Import Wizard... or click the Button Import Wizard.png button located on the Standard toolbar.


  • Using wildcards, you can create import filters that are targeted to a group of similarly-named data files. This filter can then be used for drag-and-drop import operations: When you drop the appropriate files onto the workspace, Origin looks at the file name, matches it with the correct custom import filter and imports the file according to your specifications.
  • Import data from the web pages using the Clipboard (see below).
  • Extract variables from the import file name and header.
  • Specify custom delimiters and date formats to parse your data.
  • The ability to post-process your imported data using a custom LabTalk script.


Note: For more information, view the help topic:

Help: Origin: Origin Help > Importing and Exporting Data > The Import Wizard

Copy/Paste the Clipboard Data

One obvious way to get data into Origin is simply to copy data to the Clipboard and paste it into Origin. This can be as easy as selecting a block of data in an Excel workbook and pasting it into an Origin workbook. However, Clipboard data may not be formatted, arrayed or delimited in a way that makes it easy to paste your data into Origin. Here are some things you should know:

  • Data copied from Excel and pasted to Origin will be brought over with full precision, regardless of the number of displayed decimal digits in Excel.
  • When working with Excel files with header information, paste the Clipboard data into data row 1 in Origin (not into the column label rows), then select a row and use the (right-click) shortcut key commands Set as Long Name, Set as Units, Set as Comment, etc. to tag your header information.
  • Data copied from the web can be formatted in various ways. You may have to experiment a bit to find a method that brings the data over cleanly. If a simple copy and paste doesn't work, try using the Import Wizard. The Import Wizard provides an interactive interface for parsing Clipboard data, with the added benefit that you can save your procedure to an import filter file (.oif) for reuse with identically formatted data. For more information, see the tutorial Using the Import Wizard to Import Clipboard Data.
Import data wizard composite resample office 600px.png

Selectively Import Data by Querying an Origin File

You can selectively import columns of data from an external Origin file by specifying an SQL-like Query in the Data Connector Browser prior to import.

UG Import Origin SQL.png

To selectively query Origin files using the Origin Connector:

  1. With the worksheet active, choose Data: Connect to File or Connect to Web.
  2. Browse to your Origin file and click Open. This opens the Data Connector Browser.
  3. Click the Select Query button UG Select Query Button.png.
  4. Enter your Query in the Select Query dialog, then click OK.

Data will be selectively imported into the active workbook as specified by your query.


Common Keywords:

Keyword Description
_SName short name, e.g. _SName, Sheet_SName
_LName long name, e.g. _LName, Book_LName
_Comments comments, e.g. _Comments, Sheet_Comments
Column_D1 column user-defined parameter, where 1 is the parameter index
Column_[Name] column user-defined parameter, where [Name] is a parameter name containing spaces


Examples:

Select Column from Project where _SName == "A";
Select Column from Project where _Comments like "S*3";
Select Column from Project where (Column_P1 like "*y*" and Column_D1 > 3);
Select Column from Project where Sheet_SName like "Trial*";
Select Column from Project where (Book_SName like "Book*" or Book_LName like "*fit*")


For more information, see Examples of using SQL query condition in Origin Connector.

Database

Origin supports connecting to databases by ODBC and OLE DB. Additionally, Origin includes a simple SQL Editor to add connection strings and generate SQL queries within Origin.


To import SQL data, start with the Data: Connect to Database menu command:

  • Open lets you browse for and open a saved connection (ODS) or query (ODQ) file.
  • New opens the Database Connector dialog.
UG database connector dialog.png
  • Connection string: Select this if you already have a text-based connection string for a given data source (ODBC or OLE DB).
  • ODBC data source: Select this if you have defined an ODBC data source via the Windows ODBC Data Source Administrator applet.
  • ODBC driver: Select this if you have an ODBC driver and want to create a data source applicable to this data connector instance.
  • Windows Data Link Properties dialog: Select this if you are using an OLE DB-based data source such as some SQL Server or Access client libraries.


Other things to note:

  • Use the LabTalk system variable @IPDB to control protection of imported range (0 = no protection, 1 = protected but allow reorder, 2 = protected).
  • Similar to other Connectors, you can opt to Exclude Imported (data) When Saving as OPJU/OGWU.
DB Save wo data.png
Note: For more information, see the Origin Help

Help: Origin: Origin Help > Importing and Exporting Data > Importing Data from a Database

Digitizer

At times, you may only have a graphic representation of some data that you would like to explore further. In such cases, Origin's Digitizer tool may prove handy. Use the Digitizer to import an image file, then digitize the plots, converting your image to numeric data that you can study and re-plot using Origin's analysis and graphing tools.

Digitizer data import chapter 2.png
  • Import most common image formats.
  • Rotate the imported image, remove noise and calibrate scales by picking start and end values.
  • Pick points on curves manually or automatically.
  • Manually add curve inflection points, as needed.
  • Interactively remove points that you do not want digitized.
  • Support for Cartesian, polar and ternary coordinate systems.


To open the Digitizer:

  1. Click the Digitize Image Button Digitize Image.png button on the Standard toolbar or choose Tools: Digitizer... from the main menu.

Saving Origin Files without Imported Data

Users have long had the option of saving Origin files without data. Save Template As..., Save Workbook As Analysis Template and Save Project without Data, were three options for saving Origin files without data while preserving settings and operations with the file.

Users now have the option to save Origin files without imported data. This is a particularly attractive option for those who work with large data files, where saving of that data with the file would hinder performance or waste disk space.

  • By default, data imported using a Data Connector, will not be saved with the book when the import file size exceeds 500kB. Each book has its own Exclude Imported When Saving check mark and clearing the check mark on any page in the book will cause all imported data to be saved with the book.
Exclude imported when saving.png
  • Any book in the project -- not only those with Data Connectors -- can be configured to exclude imported data by right-clicking on the window title bar, selecting Properties, then checking the Exclude imported data when saving project box at the bottom of the dialog.
Exclude imported when saving Properties dialog.png


The act of excluding data when saving differs from saving a template file in a couple of important ways:

  • When you exclude imported data, you are still saving all output resulting from analysis operations on imported data -- fitting results, statistical analyses, Set Values calculations, etc. -- you just don't save imported data or graphs of that imported data.
  • Books which you have saved without imported data retain a "live" link to the original data source. For Data Connector-containing books, click the Data Connector icon and click Import (active sheet) or Import All (all sheets in book). For books used for standard file import, activate the empty book and click Data: Re-import Directly; or click the Re-Import no dialog button on the Import toolbar (see next).

Re-Importing Data Files

There are two import commands in the Data menu that are specifically intended for repeat import of the same file (i.e. the file path and name must be the same):

  • Re-Import Directly. When you import a file into an Origin worksheet or matrixsheet, by default a number of parameters, including file path and name, are saved in the sheet. If you have an external data file that is periodically updated or you want to reload a standard file into the worksheet, you can re-import directly without opening an import dialog.
  • Re-Import.... This menu command opens the corresponding X-Function import dialog box for the file type so that you can adjust your import options before re-importing.

Notes:

  • Only one file can be re-imported at a time. When you use either of these two menu commands, only the file associated with the active worksheet or matrixsheet, will be imported. If the selected data are imported from multiple files, re-importing will fail.
  • If you import an ASCII file via the Import Wizard and select Data: Re-Import..., the impASC dialog will open instead of the Import Wizard.
  • Re-import does not work for Binary or User Defined data types brought in using the Import Wizard.

Clone Import

Clone import works by "modeling" an import -- and optionally, an associated analysis operation -- and then applying what was done to the initial file, to a series of similar files. As long as the active book contains imported data and associated operations, it can be cloned. In this sense, cloning is similar to creation of an Analysis Template but is somewhat more limited in power (e.g cannot be used with the Batch Process tool).

Clone import is supported by both Data Connector and X-Function-based import methods. A brief tutorial will show you the basics of cloning import and analysis operations.

  1. Click the New Workbook button Button New Workbook.png to open a new workbook.
  2. Using Window's File Explorer, browse to your <Origin Program>\Samples\Curve Fitting folder and find a file called Sensor01.dat. Drag-and-drop the file onto the new workbook. The .dat file is imported using the Text/CSV Connector.
  3. Click the column B header to select the column, then click the Scatter button Button Scatter.png to create a scatter plot.
  4. Click on the X or Y graph axis scale and in the Axis dialog box that opens, click the Scale tab, then press Ctrl and select both Horizontal and Vertical axis icons in the left panel. Set Rescale to Auto and click OK.
  5. With the graph active, click Analysis: Fitting: Linear Fit and open the dialog box. Set Recalculate = Auto, accept other default settings and click OK. Answer No to the Reminder Message and click OK.
  6. Right-click on one of your workbook tabs and click Add Graph as Sheet. This will add your scatter plot with the linear fit results, as a page in your workbook.
    UG clone import add graph.png
  7. Make sure the sheet with data imported from Sensor01.dat is active and click the Clone Import button Button Clone Import.png on the Import toolbar.
  8. Browse, once again, to your <Origin Program>\Samples\Curve Fitting folder, press Ctrl or Shift and select files Sensor02.dat - Sensor07.dat. Click Add Files and then click OK. What you should see is that using the original book as a model for import and analysis operations, the Sensor files are imported using the Text/CSV Connector and, one-by-one, they are processed (it may take a few seconds for all operations to go to completion).
    UG clone import results.png

Topics for Further Reading