5 What's New in 2019b

Origin 2019b New Feature Highlights

Visit www.originlab.com For Origin 2019b Feature Highlights, including a Highlights video.

  • Data Connectors:
  • New mechanism for importing data from file or a web page in which the connection is saved in the book/sheet.
  • Data are locked from editing, thus ensuring data integrity.
  • Imported data and plots of the imported data are not saved with the project but any locked analysis output is saved with the project.
  • Reconnect to a stable data source to re-import data.
  • Flexible path management options for connecting to data files (Absolute, Relative to Project, Common).
  • Support for CSV, HTML, JSON, MS Excel, Origin Files and more.
  • Exclude Imported Data when Saving Project:
  • A new book property allows the user to save a project file without saving imported data, helping to control the size of your projects.
  • HTML Reports:
  • The Origin Notes window now supports HTML and Markdown (Wikipedia link).
  • Add Notes as Sheet to add HTML reports to your Analysis Templates.
  • Support for placeholders in the HTML report that are dynamically linked to report sheet elements including calculated results and graphs.
  • File: Clone Current Project
  • Clone current project by selectively clearing data and operations.
  • Maintain Data Connectors between source project and cloned project.
  • Cloning replaces Save Project without Date and Duplicate Project without Data, with some added functionality.
  • Copy-paste Folders, Workbooks in Project Explorer:
  • Copy the contents of a Project Explorer (PE) folder (top panel of PE) and paste it within the same project or to another project in a second Origin session.
  • Copy a workbook (bottom panel of PE) and paste it within the same project or to another project in a second Origin session.
  • Add Rug Marks to Axes:
  • Add Rug Marks to a graph axis to create a one-dimensional data plot on the axis.
  • Export Worksheet or Book to Excel File:
  • Added support for exporting multi-sheet workbook as a multi-sheet Excel file.
  • Sheets can be selectively excluded.
  • Improvements to Main Menu Structure:
  • More first-level menus have been added in an attempt to reduce the length of menus.
  • A new Data menu is added to list data-import related tools.
  • A new Insert menu for inserting such things such as plots, graphic objects and tables into the active graph.
  • The Plot menu is reorganized with tabbed categories that allow for display of graphs without hiding variants behind a split-button; Additionally, most-recently used templates are grouped at the top of the menu now, for greater visibility.

New Features by Category

Ease of Use

  • Menu Reorganization:
  • Reorganization of the main menu, with more top menu commands for easier navigation.
  • Import file menu commands added to a new Data menu along with new Data Connector methods.
  • Plot menu reorganized with tabs for separate categories for easier browsing of graph types.
  • Copy and Paste Project Explorer Folder:
  • Right-click on a PE folder and copy the folder and contents to a another PE folder.
  • Support for CTRL+C and CTRL+V.
  • Support for copy-paste between sessions.
  • Append Projects Improvements:
  • If no windows exist in the root folder and there is only one subfolder, File: Append gives the option to put all appended windows into the current folder, without creating subfolders for each project.
  • HTML-based Rich Text Reports from Notes Windows:
  • Notes windows now have an "HTML mode" that can be toggled on or off (CTRL+M).
  • Support for direct links and placeholders to Origin project data (graphs, worksheet cells, string registers, etc).
  • New HTML main menu entry when a Notes window is active (either mode).
  • Notes windows can be saved or exported to disk including supporting content such as images.
  • Recently-used Fonts
  • Most-recently used fonts show at the top of the Font list.
  • Font Control for Notes: There is now Format toolbar support for Font and Font Size buttons.
  • Reset Dialog Position with Each Origin Session
  • Many users work with multiple monitors, increasing the chance that they will move and "lose" a dialog box. By default, dialog box position will now reset with each Origin session.
  • Set system variable @RDP=0 to prevent position reset on startup.
  • Copy Cell(s) and Paste to a Range
To more-closely mimic copy-paste behavior in MS Excel:
  • e.g., select cell A1 and copy (CTRL + C). Select cells B1 - B3 and paste. Cells B1 to B3 will fill with value of A1.
  • e.g., select cells A1 - A3 and copy (CTRL + C). Select cells B1 - B6 and paste. Cells B1 - B3 will be filled with A1 - A3, B4 - B6 will be filled with A1 - A3.
  • Use System Variable @CPNB=0 to roll back to old behavior.
  • Plot Details Controls Moved: Reorganization of some controls at the layer level of Plot Details.
  • The Display tab is renamed as Display/Speed.
  • The Size/Speed tab is renamed as Size.
  • The Scale Elements group is moved to the renamed Display/Speed tab.

Graphing

  • Rug Plots
  • Rug plots can be added to Scatter, Histogram and Distribution plots.
  • A Rug tab is added to the Axis dialog box for showing and customizing rug marks.
  • Stack Lines by Y Offsets Supports Grouping by Label Row Data
  • Subgroup plots by column label row and offset them.
  • Plot Details Group tab includes enable subgrouping By Column Label row.
  • Stack tab (layer level) controls for offset spacing.
  • 3D Waterfall Support for Label at Specified Indices
  • Specify indices to label by dataset, or by space-separated list with 0=last point.
  • More Transparency Control
  • Independent Transparency Control for Multiple Patterns in One Plot.
For two curve plots with below and above colors, areas above and below can have independent transparencies. For Violin with Box plots, both the violin and the box can have independent transparencies.
  • Independent Transparency of 2nd Color in Gradient Fill .
When you choose a two-color gradient fill, there is now independent transparency control for both colors. This includes gradient fills in page and layer backgrounds.
  • Template Library Search by Keyword
  • Keywords matched from Template Library Name or Description.
  • Custom Legend Notation for Column Plots
  • Better control of legend fill colors or patterns.
  • Legend Properties dialog, Symbol tab support for font scaling.
  • Polar Line Plot Data Labels
  • New Label tab added to polar line plots.
  • Ternary Plot Axis Titles
  • Option for Ternary plot axis titles to be located at vertices.
  • 3D Vector Plot Line Styles
  • Plot Details 3D Vector tab controls for different line styles
  • Remove Line Segments in Line + Symbol Plots
  • You can designate a special point and remove the connection line between the special point and the next point.
  • Worksheet Source Data Highlighting
  • When you click on a data plot in the graph window, the corresponding worksheet column is highlighted.
  • Multi-point Data Label for Vertical Cursor
  • The Vertical Cursor Gadget can now (optionally) display all data points in intersected lines as a single label.
  • Leader Lines for Labeling of 3D Vector Graphs
  • Draw leader lines connecting vectors and labels.
  • Better Exclusion of Added Layers from Common Display
  • Common Display controls apply changes made to one layer to other layers in the graph window. It was found that adding layers to such graphs sometimes caused undesired modifications to existing layers. Now, the default behavior is to prevent added layers from modifying existing layers.
  • Colormap Support for Color List
  • Color List option now added to limited color mixing and Color Palette options.

Worksheet

  • Exclude Imported Data when Saving
  • A workbook-level property allows the user to exclude any imported data (not just that brought in via the Data Connectors) when saving the project or workbook. This helps to control file size.
  • Filter Columns by Label Row
  • When worksheet is in Column List View (View: Column List View), add a filter condition to label row data before returning to standard worksheet view.
  • New "Reference Column" Method for Splitting Columns
  • Split by specified Separator (Blank/missing, text, 1, 0, -1) or Interval (given a starting value).
  • Use Column Short Names and Long Names in Worksheet Query
  • In addition to aliases, you can now use dataset names in your conditional expressions.
  • Extraction of Worksheet Rows by Random Sample
  • Reduce By Group, More Options
  • Merge X by X of Min Y or X of Max Y.
  • Recalculation Support for Split Worksheet Tool

Import and Export

  • Data Connector
  • Connect to CSV, JSON, OPJ, OPJU, Matlab from files or web URL.
  • All analysis results are saved with the project but imported data are excluded when saving the project to help control file size.
  • Re-import (ALT+4) is supported.
  • Export Data to Multi-sheet Book to Excel
  • Exclude specified sheets from Excel export.

Analysis

  • Adjust Height of Worksheet Label Row for Output Columns
  • When analysis is done, Comments and Long Names in the output can be many characters long. In the past, we expanded column width to accommodate display. Now, by default, we will adjust column label row height in order to accommodate display.
  • Use the System Variable @RCW=1 to roll back to the old behavior.
  • Support Non-integer Multiples of SD in Mask Cells by Condition
  • e.g. Outliers by Std. Deviation x 1.5.

Programming

  • Multi-sheet Range Support
  • A new range syntax that allows statistical tools to calculate stats on a given range, across multiple sheets.
  • Improvements to IF() and IFNA() Functions
  • Fixed if(C=0,A,"") issue of only filling 1st occurrence of true condition.
  • Else defaults to blank (e.g. fill column A with 1, 2, 3 and enter if(A=2,100) in F(X)= for column B, row 1 and 3 should be blank instead of missing values).
  • IF() supports both numeric and string return (e.g. if(A<5,"small","big") works now, whereas in 2019, the user had to type if(A<5,"small","big")$).

Apps for 2019b

  • Isosurface Plot: This App creates an isosurface graph from volume data sampled at regular intervals.
  • Fit ODE OriginPro Symbol.png: Fit ordinary differential equations.
  • Quantile Regression OriginPro Symbol.png:
  • Piper Diagram: Improved version of the water-chemistry plot that is shipped with Origin.
  • Import NMR Data: Import common NMR file types.
  • Hystersis (Updated): Create and plot separate datasets for each segment of hysteresis data.
  • 2D Correlation Spectroscopy Analysis OriginPro Symbol.png
  • 3D Wind Rose Graph
  • Apparent Linear Fit
  • Change Point Analysis
  • Grouped Pie/Bubble Pie Chart