Origin 8.1 Beta Documentation

Contents

What's New in Beta3 Release

User Interface

  1. Password Protection of OPJ and Audit Log - Menu: Tools->Protection
  2. Restricted folder in PE: Can mark any folder as restricted, and will not be visible in Viewer
  3. Insert Symbol Support in Worksheet

Import

  1. Support for HDF5 Files
  2. Some Import Wizard bug fixes

Data Manipulation

  1. Find and Replace dialog improvements such as finding and replacing blank cells
  2. Improvements to Remove bad data/masked data
  3. Improvements to XYZ Gridding
  4. Reducerows xf removed - was not working well
  5. wDelRows Xf introduced, not yet in menu

Analysis

  1. Fly out menu for Dialog Theme saving has been changed
  2. Improvements to Rescale, Zoom in and Out improvement in Preview of analysis tools

Graphing

  1. Improvements to Time axis
  2. Improvements to customizing Contour plots
  3. Improvements to Ternary Contour plot
  4. Legend Symbol Size Control - new syntax introduced

Export

  1. EPS and PDF now support export of Unicode text characters

What's New in Beta2 Release

Productivity

  1. Batch Processing Tool: Support for starting report from specified row and appending header cols to report, support for adding report rows to Excel book open inside Origin, Script after each file and script at end of process
  2. Slide Show: Right-click selected column to see new menu Slide Show of Dependent Graphs.
  3. Defining Variables in Set Values Dialog: Buttons replaced by new menu item in dialog, improved mechanism for variable definition and insertion including relative indexing, support for variables from header rows
  4. User Files Folder:' New menu Tools: Change User Files Folder allows easy changing of UFF including copying files to new location
  5. Transferring User Files: Improvements to Tools:Transfer User Files dialog to allow transfer of files from older versions

GUI - General

  1. Support for Undefined Property in Dialogs: In dialogs such as Column Properties and Layer Management, if more than one object is selected, then properties with different values for different selected objects are shown differently indicating to user they are all not the same. User can then change value to be same for all.

Graphing

  1. Layer and Text Alignment: Object Edit toolbar can be used to select and align/resize multiple layers, can select layer and Text Label to align
  2. New Layer Title Object: Right click within a layer and select Add/Modify Layer Title.... It will place a text object attached to layer and centered with respect to layer
  3. New Plot Types: P-P Plot, Q-Q Plot

Data Processing

  1. Worksheet Unstack: Improvements to tool including selecting any header row for grouping variable, and selecting what additional columns to carry over
  2. Worksheet Stack: This tool is still in menu, but we have decided to delay this for later, so will not be in 8.1 SR0

Data Analysis

  1. New Rise Time Tool: New tool added under Analysis: Data Exploration menu when graph is active, to compute rise/fall time of curves that rise/fall from one level to another
  2. New Envelope Tool: Under Analysis: Signal Processing: Envelope for computing upper and/or lower envelope curves for signals
  3. New Surface Area Tool: Available under Analysis: Mathematics menu, for computing surface area of matrix or XYZ data
  4. New: Peak Analysis of Multiple Y cols: Accessible under the menu item Analysis: Peaks and Baseline: Batch Peak Analysis Using Theme, allows processing multiple Y datasets using a pre-defined Peak Analyzer theme, including generating summary report

Programming

  1. LabTalk Variables Viewer: Improvements to dialog that displays all LabTalk Variables, can be opened with list command or from Tools: Variables... menu item in script window

Top-Ten New Features in Origin 8.1

  1. Batch Processing with Analysis Templates
  2. Slide Show of All Graphs in Folder
  3. Pivot Table
  4. Menu Customization
  5. Multi-page PDF Export of Worksheets
  6. Project Explorer Shortcuts and Favorites Folder
  7. Export All Graphs in Folder to PowerPoint
  8. Data Reduction, Decimation and Data Rearrangement Tools
  9. New Graph Types: Ternary Contour, Windrose, Weibul, B&W Pie Chart
  10. New Find and Replace Dialog for Sheets

Productivity

Batch Processing

A new tool has been added for performing Batch Processing of multiple files from the GUI. This is available from the File: Batch Processing... menu item, and is based on the batchProcess X-Function.

The tool can either repeatedly use a specified Analysis Template for each selected file, or the files can be imported one after one into the active workbook of the current project. In the case of the active window, it is assumed that the active workbook has some operations already set up and the Recalculate mode is set to Auto or Manual.

The Import to Sheet drop-down should be used to specify which named sheet in the book/template should receive the data from the import. The Sheet to Append drop-down should be used to specify which named sheet to use for appending to result for each imported file. The append-sheet is basically a sheet that has links to other cells such as fit result table cells, and to other variables such as import file name. If None is selected, then no information will be appended for each file.

The Summary Sheet control can be used to specify which book/sheet will receive a summary for all the imported files. This summary sheet will basically use the information from the sheet specified in Sheet to append, thus creating appended entries for each imported file.

Appending can be done by rows or by columns. Also, an option is provided whether to keep the workbook for each file import or delete the books and only keep the summary sheet. This applies to when Analysis template is used. If importing to active window, then data gets replaced repeatedly for the next file, so only the summary sheet would be relevant.

Try the following steps:

  1. Use File->Recent Books menu item and open autofit.ogw
  2. This Analysis Template has operations set up for performing multiple fits on imported data, and the sheet named Summary' contains linked cells on what information needs to be appended to final summary sheet for each imported file
  3. Use File->New menu item and select Excel to create a new Excel workbook inside of Origin
  4. Right-click on the title bar of the Excel workbook and select Save Workbook As... and save it to a location such as C:\temp\result.xls
  5. Go back to the autofit template workbook. With this book active, select File: Batch Processing...
  6. Select the Repeatedly Import into Active Window radio and set the Import to Sheet drop-down to Data
  7. Click on browse button next to the file control box and select \samples\curve fitting\step01.dat, step02.dat, step03.dat
  8. Change the Sheet to Append drop-down to Summary
  9. Click the button next to the arrow for the Summary Sheet. This will minimize the dialog. Now click and select the Excel window and then click to expand back the dialog. This sets the Excel window as the place to append summary results from the file
  10. Leave the Append By radio set to Rows and click OK
  11. Origin will import one file at a time into the analysis template book and then will append results to the Excel book.
  12. Now you can save the Origin project, or right-click on Excel window and select Save Workbook As... to just save the Excel book. Then you can close Origin and separately open the Excel file from C:\temp to view the appended results.

So in the above tutorial, the summary output was directed to an external Excel file. The summary could also of course be directed to an Origin workbook instead.

Now try these steps:

  1. With a new project, directly select File: Batch Processing...
  2. Select the Load Analysis Template radio and select the autofit.ogw analysis template from \Samples\Curve Fitting subfolder
  3. Set the Import Sheet to Data, select three files \Samples\Curve Fitting\step01.dat, step02.dat, step03.dat and then set Sheet to Append to Summary
  4. Uncheck the Delete Template Window After Appending check box and then press OK
  5. This time a new book will be created for each imported file, and a new book/sheet named [Summary]Results! will be created that contains the appended summary report.

Goto Top

Saving Analysis Templates

To give Analysis Templates more visibility, there are two new menu items: File: Save Workbook as Analysis Template and File: Save Project as Analysis Template. The menu items become available only if an operation exists at the book and project levels respectively.

The Save Workbook as Analysis Template automatically removes all data that are input to all operations in the book, leaving any other "data" intact. The OGW is saved by default to UFF location and shows up in File: Recent Books menu fly-out.

The Save Project as Analysis Template does not clear data that are input to operations.


Goto Top

Slide Show of Graphs

A new right-click context menu named Slide Show has been added at Project Explorer folder level. This brings up an X-Function dialog where user can set whether to loop continuously or not, set how many seconds between graphs etc. Such settings can then be saved as a theme for re-use. Once OK button is clicked, the graphs are shown in full screen as a slide show.

Key strokes other than Esc are assigned, such as G to stop the show and go to the currently shown graph window, and A to turn off speed mode to redraw the current slide, expecially useful for 3D surface graphs with big matrix.

This feature can then also be used with Favorites folder where PE shortcuts can be placed for select graphs and then one can right click on Favorites folder in PE and start the slideshow.

Need Movie


Goto Top

Project Exporer Shortcuts and Favorites Folder

If you drag any window in Project Explorer and then drop to another location such as another folder, a pop-up shows with the following optins: Move here, Create Shortcut Here, or Cancel. If you select Create Shortcut, an icon is added to the destination location that indicates the item is a shortcut. Double-clicking on the shortcut icon will open the window in the destination folder for viewing and editing. The shortcut can also have other states such as minimized and hidden.

If you right-click on a window title bar (or in Project Explorer), there is a new context menu item called Add Shortcut to Favorites. This will place a shortcut in a folder called Favorites at the root level of the project. This Favorites folder can then be useful in showcasing graphs and for playing slide show of such graphs. It also makes it easier to export favorites by simply exporting all graphs (shortcuts) located in that folder (export of all graphs can of course be at any folder level).

Need Movie


Goto Top

Origin Project File Size and Opening Improvement


Goto Top

Defining Variables in Set Values Dialog

Need Movie

Two new buttons have been added to Set Values dialog for setting column and matrix values. These buttons are on the top right side of the dialog and are marked R and I.

The R button opens the Range Browser dialog which then allows user to point to another column in any book/sheet in the project. Multiple columns can be selected and added to the lower panel. When the dialog is closed, appropriate range variable declarations are added to the Before Formula Script page of the Set Values dialog. User can then use these range variables in the Formula edit box. This allows novice users to easily define range variables without needing to know/understand range syntax.

The I button opens the Insert Info Variables dialog with the Insert as Link check box checked and grayed out. This dialog then lists all variables contained in the page such as variables created from header lines scanned by Import Wizard or variables that user may have programmatically created and stored in the page by other means. User can select any particular variable and press the Insert button. Then the appropriate LabTalk script statement will be added to the Before Formula Script box which will then declare the variable for use in upper formula edit box. Appropriate syntax will be automatically used to declare string versus double variables depending on what is being inserted. This again provides user with easy way to define a variable from the import varibles and use that in their formula computation, without needing to know the script syntax to access them.


Goto Top

Import and Export


Goto Top

Send Graphs to PowerPoint

In Project Explorer at the Folder level, there is a new right-click context menu named Send Graphs to PowerPoint. This opens the pef_pptslides X-Function. Options are available to place graphs as picture or as embedded objects. The Slide Position node allows specifying position on where in the slide to place the graphs. Clicking OK opens Power Point application with a new document with one slide for each graph.


Goto Top

Multi-page PDF Export

There is a new X-Function wexpPDF for exporting a worksheet as a multi-page PDF. This is accessible from the menu item File: Export: As Multipage PDF File....

The Image Settings: Multiple Pages node has options for cover page and pagination. The Print Settings node has option of either using existing worksheet's settings for printing features such as horizontal or vertical grids, or user can turn off the worksheet options and specify options in the dialog itself.


Goto Top

Append to Existing File When Exporting to ASCII

The Export to ASCII dialog (expASC X-Function) now has option to append to an existing data file instead of overwriting existing data.


Goto Top

Data Processing


Goto Top

Pivot Table

The Worksheet menu has a new entry for Pivot Table....

Try these steps:Need Movie

  1. Import \Samples\Statistics\automobile.dat
  2. Invoke the menu item Worksheet:Pivot Table...
  3. In the dialog, assign columns: Year to Row Source, Make to Column Source, then change the Output Type drop-down to Mean and assign Gas Mileage to Data Source
  4. Uncheck the Show Zeroes when Empty check box and click OK
  5. A new sheet called Pivot1 will be added and the output has Recalculate support
  6. You can for example select a few Y columns and make a line plot to view improvement in Gas Mileage as a function of Year, for different Makes of cars

Goto Top

Data Reduction X-Functions

A set of new X-Functions have been added for reducing data that already exists in a worksheet. These tools are accessible from the Analysis: Data Manipulation menu when a worksheet is active. Note that some of the tools are also available when a graph window is active.

Tool X-Function Name Description
Reduce to Evenly Spaced X reduce_ex Works on a single XY Curve. Allows creating reduced output with evenly spaced X values. Uses interpolation before reduction if input data is not evenly spaced.
Reduce Maintaining Data Shape reduce_shape Works on a single XY Curve. Provides various methods to maintain overall data shape while reducing data size. The output points will be subset of the input points, typically with uneven spacing of points.
Reduce Duplicate X Data reducedup Works on a single XY Curve. Reduces all XY pairs where X values are duplicated, allowing for options on how to handle the Y values. See also the menu item Worksheet: Remove Duplicated Rows which works with textual data as well.
Reduce Data by Skipping reducerows Works on all columns of the worksheet, or a selection of columns. A specified number of rows will be skipped each time to reduce the data size. Provides options such as picking first value in skipped rows or averaging values.
Reduce by Group reducexy Works on a single XY curve. Allows grouping the data by number of groups, every N points, or by X increment, and then allows replacing X and Y by quantities such as mean, minimum and maximum.

Need Movie


Goto Top


Data Rearrangement X-Functions

Two X-Functions have been added to rearrange data, and these are available from the menu items Worksheet: Stack Columns' and Worksheet:Unstack Columns.

These tools are mainly useful to rearrange indexed versus raw data for preparing suitable input to statistics tools.


Goto Top

Find and Replace - New Dialog

The Edit menu entries of of Find... and Replace... used to bring up dialogs with very limited capabilities in 8.0.

These menu items now open an new Find and Replace dialog which has two tabs. Depending on which menu item was invoked, the corresponding tab is active when dialog launches.

The new dialog has many improvements on finding and replacing both string and numeric data.

Note: The previous menu item of Worksheet: Replace has been removed. This used to open the wreplace X-Function. The X-Function is still available and can be opened as dialog using wreplace -d command. Only the menu item has been removed.


Goto Top

Extract Worksheet - Recalculation and Other Changes

Need Movie

This dialog existed in 8.0, it has been modified to support Recalculation when source data changes. Also, when this non-modal dialog is open, if user switches to another worksheet, the condition strings in the dialog do not get wiped out, and they continue to work on the original source worksheet. So if user needs to process another worksheet they need to close the dialog to complete the operation on the first sheet, and then re-open it on the new sheet.


Goto Top

XYZ Gridding - Recalcuation and Better Large Data Support

This dialog now supports Recalculation. Also improvements have been made to gridding algorithms to support XYZ data or larger size.


Goto Top

Graphing


Goto Top

New Plot Types


Goto Top

Windrose from Raw Data

Need Movie

In 8.0 Windrose plots can be created once user performs 2D binning on the raw data first. This is accessible from the Plot: Specialized: Windrose-Binned Data menu item.

In Origin 8.1, the Plot: Specialized: Windrose-Raw Data menu item has been added. This opens a new plot_windrose X-Function. This X-Function allows user to create Windrose plots directly from raw Speed and Wind data. User can specify how to bin the speed, and the number of directions for Wind. The dialog also provides a preview panel.


Goto Top

Weibull


Goto Top

Ternary Contour

Ternary contour plot type has been added.

Try these steps:

  1. With a new book/sheet, import the file Samples\Graphing\Ternary Contour.dat
  2. Change last two columns to type Z. The last column contains contour values0
  3. Select all four columns and invoke the menu item Plot: Contour: Ternary Contour
  4. Select Yes in the dialog that pops up asking for rescaling data to 0 to 1
  5. The ternary contour plot is created.

Plot Details at the dataset level provides Contouring Info tab that can be used to further customize the contouring, and this tab has same features such as smoothing and custom boundary etc which are supported for XYZ direct contour plots.


Goto Top

PieBW

This is a variation of the Pie Chart which uses hatch patterns and sets the angle such that the pie chart is flat and there is no 3D effect.


Goto Top

3D Graph Improvements

Need Movie


Goto Top

Grid Line Control for 3D Surface Plots

For 3D Surface Plots, a new control named Skipping Gridlines has been added to the Grids tab of the Plot Details dialog box. This control allows user to specify number of gridlines to skip for X or Y, thus allowing plotting of dense/large sized data and still clearly see the data/surface without it being obscured by too many grid lines.


Goto Top

Missing Value Support for 3D Surface Plots

When missing values (---) exist in matrix cells, 3D surface plots will now trucate the surface at those values and will not draw the surface down to z=0.


Goto Top

Major and Minor Level Support for Contour Lines

This applies to both contour plots and the contour lines drawn on 3D surface plots.

In the Color Map/Contours tab of Plot Details dialog, if you click on the Levels column header, it opens a redesigned. Set Levels dialog. This dialog now has options for Major and Minor levels. The Total # of Levels is computed using the major and minor settings.

Once major and minor levels have been set for the levels, you can then close that dialog and click the Line column header in the tab to open the Contour Lines dialog. In this dialog, there is a new check box named Show on Major Levels Only. If this checkbox is checked, then contour lines in the contour plot will only appear at the major levels, although the number of levels and colors in the contour plot use both major and minor levels. This new control allows user to cut down on the number of contour lines without losing resolution of the levels/color scale.


Goto Top

Colomapping to Z values in 3DBars

When a 3D Bar graph is created from matrix data, the Bars tab of Plot Details dialog now has a new radio option of Color map under Fill Color. This allows user to specify a color map to be used for the bars, that is based on the z values in the matrix.


Goto Top

Resize one direction only


Goto Top

Palette Support for Color Maps

With any plot that contains a color map, such as contour, 3D color map surface, or 2D plot with color map linked to another column, there is now better support for applying color palettes.

In the Color Map' tab of Plot Details when user clicks on Fill header, the Fill dialog that opens now has a Load Palette radio button. When this is selected, the Select Palette button becomes enabled. Clicking on that button displays all available palette files by name and a color icon-bar. Once a palette has been selected, one can further check the Link to Palette check box. This will then save the palette name with the plot so that it becomes part of the template.



Goto Top

Access to Contour Line Data

With a contour plot active, user can click and select any individual contour line. Once a specific contour line is selected, the right-click context menu offers two options: Add Contour Labels and Extract Contour Lines. The 2nd item when selected creates a worksheet with X, Y data corresponding to the selected contour line.


Goto Top

More LT Access on ColorMap Object

More properties and methods for LT object layer.CMap are added to provide precise control from LT.


Goto Top

Mask Support for Line Plot

With a line plot active, if one uses the mask tool to mask part of the plot, the line segments corresponding to the selected regions change color (default is to change to red) and the corresponding data in worksheet is masked. In previous versions masking required a symbol or line+symbol plot.


Goto Top

More click Mode

Click once to select the data group, click again to select one dataset, click again to select one data point. Need Movie


Goto Top

Data Analysis


Goto Top

Enhanced Syntax for General Linear Constraint

  • Notation for Initial Values of Parameters
    use (i) to refer to an initial value of a parameter. For example, xc__2(i) means the initial value of the parameter xc__2
  • Notation for Parameter Family
    use (a) to indicate all the parameters of a family. For example, A(a)<1 indicates that all amplitudes should be smaller than 1
  • Excepting Specific Parameter
    use (e) to indicate all parameters of a family, except the one preceeding (e).
  • Combination of Special Characters
    Combining (i) options with either (e) or (a) is allowed.
  • Notation for Progress
    use (n) to progress from lower to higher value from left to right. For example, W(n) < W(n+1), n=1.5.8 refers to W < W__2; W__5 < W__6; W__8 < W__9;

Goto Top

Normalize Multiple Columns/Curves


Goto Top

New Functions for Set Values Dialog

More functions are available under F(X) menu in Set Values dialog


Goto Top

Toolbar for Managing Markers

A new toolbar Markers and Locks is introduced to match couples of menus under Data menu for Graph window


Goto Top

Fit LR with X Error

A new menu item Analysis: Fitting: Fit Linear: Fit Linear with X Error... has been added. This is a varation of the Fit Linear tool where X-Error bar values if available are taken into account in the regression. Three different computation methods are available.


Goto Top

Support Periodical in 2D Frequency Count

Need Movie


Goto Top

Decimation

This feature is available only in OrigniPro.

The menu item Signal Processing: Decimation launches the Decimate X-Function.

For further details please see: X-Function Reference wiki


Goto Top

Customization


Goto Top

Custom Menus

Need Movie

A new tool called Custom Menu Organizer' has been added, and it is available from the Tools menu.

The Add Custom Menu tab allows user to add multiple new main menu items and then add entries to each such main menu item.

The Hide Built-in Menus tab displays all existing Built-in menus as a tree structure. User can expand any node and turn off entire menu or specific entries in a menu item.

Once changes have been made in either tab, the configuration can be saved to a named file with extension .OMC. The default file is named defaul.omc, but user can create other menu configurations with their desired names. The File menu of the dialog allows saving and re-opening these OMC files.

Once an OMC file has been created, the configuration can be loaded/applied by selecting it by name from the Format: Menu fly-out.


Goto Top

Global Significant digits setting

The Tools: Options: Numeric Format tab now has two radios for Decimal Digits and Significant Digits.


Goto Top

Programming


Goto Top

New LabTalk Printed Guide

LabTalk documentation is being vastly improved and will be provided as a new printed manual with Origin 8.1.

Up-to-date LabTalk documentation is currently at this wiki location.


Goto Top

LabTalk Function Support

Support for script functions that accept and return various Origin object types has been added. Please see this wiki page for more information.


Goto Top

LabTalk XYRange Variable Interpolation Notation

LabTalk has in the past support Dataset function notation for interpolation. This notation has been very popular but it requries an active graph window and the line connection in the graph will affect the interpolation method.

We now have added a new mechanism to allow interpolation notation to be completely control from script without dependency on active window or plots.

Please see this Wiki page for more information.


Goto Top

LabTalk Scripts on Project Open

All new Project Files will now have an OGS file attached to the Project and visible in Code Builder. This OGS file has three sections that are triggered on certain events. So script can be contained in the OGS file as part of the OPJ which then runs automatically when these events occur. More information is available on this page


Goto Top

Running Origin from Command Line

More options have been added to running Origin from Command Line. These are documented in this wiki page

Thus for example the -rs switch can be used to send a long line of script which can involve calls to X-Functions as in the script below that performs batch processing of multiple files and then the results are saved to a csv file on disk:

D:\originlab\Bld988-61\Origin81.exe -h -rs template$="d:\originlab\Bld988-61\Samples\Curve Fitting\autofit.ogw"; fname$="D:\originlab\Bld988-61\Samples\Curve Fitting\step01.dat%(CRLF)D:\originlab\Bld988-61\Samples\Curve Fitting\step02.dat%(CRLF)D:\originlab\Bld988-61\Samples\Curve Fitting\step03.dat%(CRLF)D:\originlab\Bld988-61\Samples\Curve Fitting\step04.dat%(CRLF)D:\originlab\Bld988-61\Samples\Curve Fitting\step05.dat%(CRLF)D:\originlab\Bld988-61\Samples\Curve Fitting\step06.dat"; batchprocess batch:=template name:=template$ impsheet:="Data" append:="Summary" ow:=[Summary Book]"Summary Sheet"!; expasc iw:=[Summary Book]"Summary Sheet"! type:=csv path:="c:\test\my batch output.csv"; doc -s; exit;

Need Movie