Origin 2015 Features

Origin 2015 Highlights


The table below only lists some highlights of Origin 2015. To see more features in 2015, please use the navigation bar on the left panel of this page.

Origin Interface

JIRA
SUMMARY

DETAILS

ORG-9847Find Metadata in Project

Sample OPJ to try: Choose menu "File: Open Sample OPJs: Analysis"

Find in Projects Dialog

  • Find folder, graph, book, sheet, column, data cell, text in graph and notes window in Project
  • Double click to go to corresponding folder/window/sheet

  • Click Select... button to specify what metadata to include in search


Menu and Context menu open Find in Project (F3)

  • Edit: Find in Project... menu
  • Right click in PE

  • Right click blank workspace


Tooltip and Context menu for findings

  • Mouse over the finding to read more info.

  • Right click the finding to copy text, range or folder location

ORG-11432

ORG-11315 

Project Explorer Improvement: Graph Previews in Project Explorer

Graph Preview When Moussing Over

Extra Large Icons to Show Graph Previews

Note:

  • To disable this feature, set system variable @PESS to -1: @PESS=-1
  • To clean all the graph previews from an OPJ, run  doc -e p {win -ppc}  After doing this, when you mouse over graphs in PE, it will ask if you want to create preview for all graphs in opj.
ORG-10413Project Explorer Improvement: Folder Comments

Project Explorer Folders now support comments just like books or graphs.

The ability to dump folder tree with descriptions has also been added to the pe_dir X-Function.

The following new variables were added to pd_dir:

1. "recursive" for searching subfolders.

2. "display", only useful when recursive=1. It has 3 options: tree, tree with description (for folder, it is Comments; for window, it is LongName), and flat (separate with CRLF)

3. "sensitive" for case sensitive.

ORG-11067 Project Explorer Improvement: Comments tooltip when Moussing over Folder/Windows

Tooltips to Show Comments from Folders and Windows

Tooltips to Show Notes Window Contents

ORG-7727Project Explorer Improvement: Show/Hide Column context menu

Details view in PE is now similar to Explorer and right-click will allow easy control of which column to display.

You can now also show Name column together with Long Name and Short Name.

ORG-11432Project Explorer Improvement: In-Place Edit of Comments, Long Name, Short Name

Support in-place edit of Name, Long Name, Short Name and Comments columns in PE.

  • Single click to enter in-place edit mode
  • If single click not working, press Ctrl key and and single click
  • Shortcut key Ctrl+Enter will start new line for multi-line comments

Edit both short name and long name in in-place edit mode of Name column.

  • Mouse over the tiny button to see if you are editing long name or short name.
  • Click the tiny button to switch between short or long name editing

ORG-11150

ORG-10819

ORG-7727

Other Improvements in Project Explorer

Bold Active Window Line

Easy to tell which window is active.

Follow Windows Text Sorting Criteria

In the past, sorting only takes care of numbers at the end of name.

Now even names like Graph10a, Graph1a, Graph2a will sort properly.

Duplicate Window in PE 

ORG-9889, ORG-10413, ORG-9889

Window/Folder Properties dialog Improvement

Meta data support for PE folder (Comment, User Tree)

Right click folder and choose Properties to add comments and user tree


Window Properties dialog with more common options like user variables

  • Modeless dialog to easily add info. for multiple windows
  • Switch between Window Properties and Folder Properties mode.

ORG-10962Sheet Comments

When right click sheet name, we used to have a Comments... context menu to edit comments. We have changed it to Name and Comments... context menu. It opens a new dialog to edit Short NameLong Name and Comments.

When hover over sheet tab, Short name, long name and comments all show as tooltip. It also indicates what the display name is in bold in tooltip.

ORG-10198,ORG-9668, ORG-10524, ORG-11534ORG-11132, ORG-104ORG-10180ORG-10277ORG-10312Axis dialog Improvements

Better Layout of the Axis Dialog

  • More friendly tab based dialog
  • Image Icons on left for easy recognition.
  • On Left panel, extra nodes e.g. bottom2, etc. only shows when Tick Labels tab is active

Second level Tabs on Tick Labels tab

  • Separate Display, Format, Table and Minor TIck Labels into tabs
  • Options in Miscellaneous branch are moved into Format tab
  • Enter Formula for Tick Labels (used to be in Layer Mangerment db only)
  • For Tick Label table, remove Independent checkboxes from 1st table row,  add Auto checkbox in other table rows.


Wrap Tick Labels

   


Customize Multiple Axes Together

E.g. highlight both Horizontal and Vertical icons on the left,

Set both Scale Type to Log10 together.


Control Line and Ticks Display separately

  • Show checkbox in Line tab to turn off line but keep major and minor ticks.
  • Customizing Color and Thickness for Major ticks and Minor ticks separately.


Customize individual special ticks

  • Table in Special Ticks tab to add special ticks easily

  • Click Details button for further customization of ticks and labels


Custom scale formula for 3D OpenGL axis 

ORG-10999ORG-11246ORG-10701ORG-9126ORG-11670Other GUI Changes in Origin 2015

Graphing and Plotting

  1. Split Multi-Curve menu under Plot into 3 menus: Multi-Y, Y-offset/Waterfall, and Multi-Panel   

  2. Right-click in Layer in Plot Details to rename layer name   

  3. Add Filepath Stamp button to easily stamp windows with project filename  


  4. Exchange XY Axis button under Rescale to show All button on Graphing toolbar. 

  5. Speed mode toggle on Graphing toolbar 
ORG-10749Colored Paires of Parentheses in Function Formula

Origin colors the parentheses in a formula, that both closing and opening are the same color. This helps you see which ")" goes with which "(":


This is supported in dialogs that accept a formula such as:
  • Set Column/Matrix Values dialog
  • Function Plot dialog (2D, 2D Parametric, 3D, 3D Parametric)
    • Function Formula (expression)
    • Before Formula Script
  • Plot Details dialog of Function Plot (2D, 2D Parametric, 3D, 3D Parametric)
    • Function Formula (expression)
    • Before Formula Script
  • Programming Control dialog of graphic objects
    • Script, Run After
  • Worksheet Script dialog
  • Worksheet Query dialog
    • the Condition text box (expression)
    • the Edit Scripts dialog opened from Worksheet Query dialog
  • Import Wizard dialog: Script After Import
  • NLFit dialog: Script Before Fitting and Script After Fitting
  • Batch Process dialog: Script after process and Script at the End
  • Custom Menu Organizer dialog: LabTalk Script for menu item
  • LabTalk Support Settings dialog opened from SQL Editor
  • Custom Data Filter dialog
    • Condition (expression)
    • Before Condition Script
ORG-11522Grouped Plot dialog

Hint tab added in Grouped Column Plot, Grouped Box Chart dialogs.

Labels are improved in the dialogs.

Grouped Column Plot - Indexed Data

Grouped Box Chart - Indexed Data

Grouped Box Chart - Raw Data


ORG-11596Collapsible Menu and Context Menus

Now most of the menu/context menu will be collapsible so user do not need to go through all options every time.

Note: To turn off the collapsible menus and show full menus, please look at the page below

http://www.originlab.com/doc/Quick-Help/collapsible-menu

     

Note: Once the hidden menu is selected, it will be shown as the commonly used ones in the collapsible menu in the next time. 

ORG-11612Data Info. Improvements

Go to Worksheet context menu in Data Info/Data Display window

With Graph window active, choosing Go to Worksheet context menu in Data Info. and Data Display window will highlight corresponding row in worksheet.

Go to Graph context menu in Data Info. window

With worksheet active, choosing Go to Graph context menu in Data Info. window will go back to Graph window.

ORG-11637PE: View Extra Large Icons context menu is added  (SR1)In Details view of bottom panel in Project Explorer, if there are many windows and they fill up the space, right click will not show View context menu to switch view mode.
show View context menu to change
ORG-12155Combine entries in File Types dropdown list of File: Open dialog.  (SR1)

Customer complained there are too many entries in File Types dropdown list which isn't convenient to use.

Some entries are combined so user doesn't need to switch File Types that often.

 


ORG-12196In Project Explorer, when click on the worksheet to rename we add a bigger toggle button and a hot-key to control to either rename Short Name or Long Name  (SR1)
  1. The hot-key Ctrl+N when at editing mode can switch to renaming by Long Name or Short Name
  2. A new system variable @PERB=0 to hide toggle button, and by default to rename Long Name.

ORG-12366Control font in Script Window  (SR1)

E.g. in [Font] section of Origin.ini in your Origin's User Files Folder, add

ScriptWindowFontHeight=24
ScriptWindowCharset=0
ScriptWindowFaceName=Verdana


ORG-12576Options to control the tooltip for windows in PE (SR2)

Set @PESH=0 to disable book comment tooltip.

Set @PESS=-1 to show preview as Comments-style tooltip.

ORG-3691Project Explorer: When it's unpinned, click X button on top of PE will hide instead of close PE by default. (SR2)

In the past, X will close PE and sometimes user doesn't know how to turn it on. So we changed the default behavior to be Hide PE if it's unpinned.

System Variable @FDPC to control this:

0 : old way, close
1 : most logical way, Hide if unpinned (default)
2 : stronger way, Hide always

ORG-12644Menu File: Import: Customize... is renamed to File: Import: Add/Remove File Types... (SR2)Make it clearer that our File: Import: menus is customizable.


Graphing

New Graph Types

JIRA
SUMMARY

DETAILS

ORG-10164Heatmap Plot

Menu to plot heatmap is Plot: Contour/Heat Map: Heat Map. Toolbar button can be found in the Contour group of 3D and Contour Graphs toolbar. (XYZ data is not supported yet)

The plotvm dialog to plot heatmap and contour plot with virtual matrix is improved.

  • Support date, time data format.for X,Y values.
  • Support to select a existed virtual matrix from virtual matrix manager to plot a graph. For example, when the following graph is plotted, there will be a virtual matrix named VM1. 
    Select the worksheet and open the plotvm dialog, click the triangle button after Input, click Select Virtual Matrix... from the fly-out menu, select VM1 from the Virtual Matrix Manager, then click OK to get the same plot.
ORG-110992D Kernel Density Plot

Plot: Statistics: 2D Kernel Density...

   

Labels, Legend, Color Scale and Bubble Scale

JIRASUMMARYDETAILS
ORG-10026Bubble Plot Legend Support

Note we will show a nested bubble scale legend by default when there is column selected for Total Dissolved Solids in plotpiper dialog. 

   

ORG-1585

ORG-10674

ORG-11511

Color Scale Improvements in Origin 2015
  1. Support ticks(major&minor) on both side and border around the ticks. 
  2. Support custom levels (user defined from/to, major/minor tick)
  3. Support wrapped text label.
  4. Support hide head and tail level.
  5. Support other label format like Date, Time, Text...
  6. Support label rotation, show label on the opposite side.
  7. Support title(including position, rotate, style definition).
  8. When there is multiple colormaps in the same layer, color bar will be added according to what data plot is selected.

    

ORG-10823

Hide legend of hidden plots 


Click Reconstruct Legend button will hide legends of hidden plots.

Right click Legend and choose Show Legend for Visible Plots Only, or open Update Legend dialog, specify show/hide legend of hidden plots

ORG-11601Reverse Legend Order

Right click Legend and choose Reverse Order.

ORG-11650Hide Legend for Fitted Curves

Right click Legend and choose Hide Legend for Fitted Curves, or open Update Legend dialog, specify show/hide legend of Fitted Curves

ORG-11611Drag and Drop to  to arrange legend entries in multiple columns

Select the legend, drag and drop the legend border while pressing Ctrl button, when the horizontal space is enough for more column, the arrangement will change.

---->  

Plot Manipulation

JIRA
SUMMARY

DETAILS

ORG-11808Allow users outside US to see graph page dimension in mm

In graph (Plot Details) Print/Dimensions Tab, the default value of the Units is Window(unit), which will be altered according to Windows: Customize Format: Measurement system:U.S./Metric.(To set this value, click Control Panel\Clock, Language, and Region,\Formats tab\Additional Settings.) Specifically, for United State and Great Britain, the default value would be Window(inch); for the rest of the world, the default value is Window(mm)

ORG-4432,

ORG-7738

ORG-7738

ORG-11225,

ORG-10256

Box Chart Improvement

Custom percentile range of the box and Whisker

  


Jitter data in box plot

This graph could be also plotted by select columns and select Plot: Symbol: Column Scatter.

Note: To plot group column scatter, go to Plot: Statistics: Group Box Charts-Indexed Data/Raw Data, select Box_column scatter for Graph Theme.

   


Related Box Chart Component dialog improvement


Box Chart Label Format Display Control

Data reader in box plot


ORG-11059ColorMapped Fill Color under Curve

Advanced Fill Area Pattern

    

ORG-7804Meteorological convention for XYAM Vector Plot

Polar/Meteorological/Custom Vector Convention

ORG-10640Improvements on Copy Format and Paste Format context menus

In the past, people complained that we gave too many options when copying format. Sometimes it's confusing and hard to tell which format to copy. 

If user chooses the wrong format to copy, he/she has to copy format again before pasting again.


Therefore we changed the design so that when copying format, show no options for less less options, while when pasting format, give more options so user can decide later what to paste and paste multiple times. 

450pxE.g. Copy and Paste Format on Line+Symbol plots:

    


 E.g. Copy and Paste Format on Colormap Contour plots:

 


New Paste Format To Context Menu

This is used to better deal with when right click in page/layer level to paste format to.

  • User can choose what destination to paste format to.
  • What Format to apply

E.g. if right clicking on axis and choosing Copy Format, and then right click in blank area of another graph, Paste Format To context menu will show, allowing user to what format/style to apply.

E.g. if right clicking on line+symbol plot instead and choosing Copy formatPaste Format To will show different target and format/styles.

 


Improvements on Apply Formats dialog via Edit: Paste Format... menu

In the past, after copying format, user can choose Edit: Paste Format... to edit the format on clipboard and where to apply to. 
In Origin 2015, we improved Apply Format dialog so that user can also

  • Save the format.
  • Load any existing graph theme file and apply it to selection, layer, graph, graphs in folder, specific graphs, etc..
  • Format to Apply group with checkboxes to easily control what format to exclude, include.
  • Apply To dropdown list so user can not only choose Apply Scope, but also components in graph to apply to.

ORG-11202Square-ended XY Scale objectNew system varialbe @LCG added.If set @LCG=1, then lines in XY Scale will be square-ended.
ORG-5705Actively update floating graphs when data is changed in worksheetView: Actively Update Plots menu is checked by default in 9.2
ORG-11245Ctrl+P or Ctrl+', or Ctrl+" to add bigger and closer prime symbols

In the past, when adding prime symbols ' or " in superscript, they were tiny and too far away from the text.

For some foreign keyboard, ' and " may not be in the same location as English keyboard. So we added hotkey Ctrl+P

ORG-11765More Distribution Curve types in HistogramGamma, Kernel Smooth, and Binomial distribution curve types are added.
ORG-11000 Scatter Matrix by template/themeTemplate entries been added on dialog to allow users specify its own templates
ORG-9234Skipped Points would not break the connect lineIn line+symbol plot, you no long need to set Gap to Symbol to avoid line broken by skipped points.
ORG-9458Improve Histogram+Probability Plot
Showing overlaid plots with double y axis instead of stacked

ORG-10041

Square/Diameter/Area Based Symbol Size Mapping

When using size mapped symbols with shape of Circle/Triangles/diamond/Hexagon/Star/Pentagon, an extra drag-down list will appear asking for size drawing definition.

ORG-11202Need square ended graphing object  (SR1)

 Introduce system variable @LCG to specify the line cape type for XY scale, arrow, line and polyline object square end:

0 = Line cap round

1 = Line cap square

2 = Line cap flat

ORG-12545Support repeated offset pattern for Stacked Plot (SR2)Set Offset in Plot Detail dialog's Stack tab to be Constant and fill edit box like 0 10, the offset will like 0 0 10 10 20 20...

Graph Page and Layer

JIRASUMMARYDETAILS
ORG-11670Speed mode ON/OFF toggle on Graph toolbarEasy way to toggle speed mode on or off for all layers in active graph.
ORG-4229Support reorder when swapping layersA checkbox is added to layer management dialog so user can swap both layer position and index.
ORG-10202Turn on/off layer frame by Plot Details dialogLayer Frame is now included in Plot Details (layer) dialog, display tab, Show Elements group.
ORG-11382

Using 1st Layer's poperty in System Theme when adding new layers

Controlled by system variable @LST

If @LST=1, when adding new layer, it will use system theme's 1st layer/consolidated layer's property from the system theme

Axis 

JIRASUMMARYDETAILS
ORG-11932Auto set Y axis tick labels to Time if Y column is TimeY axis tick label will be set to time if Y column is Time format. You can use @TLD=0 to disable the feature.

3D and Contour

JIRA
SUMMARY

DETAILS

ORG-9828ORG-9940Batch Plotting for 3D and Contour Graphs

Batch plotting in Origin 2015 also supports 3D and contour graphs from XYZ data

     

How to:

  • Right click on the title bar of window and select Duplicate (Batch Plotting): Duplicate with New Sheets/Books
    or
  • Click the Duplicate with New Sheets/Books button  


Change X/Y/Z Data of the Plot

3D and Contour plot from XYZ data (worksheet) can also change X/Y/Z data of the plot from the short cut menu of the plot

How to:

  • Select the plot on graph, right click and choose Change X/Change Y/Change Z/Change Worksheet from the short cut menu.
ORG-10683Color indexing/Mapping for 3D Line Plot
ORG-10312Custom Scale for 3D Axis
ORG-6631OGL 3D frame should support move by keyboard3D OpenGL layer frame supports to move by hitting up/down/right/left direction keys on Keyboard.
ORG-853D Bar plot different shape support (Script Only)

ORG-11046ORG-11660ORG-10690ORG-11221Advanced Virtual Matrix Support

Virtual Matrix Manager

If you plot 3D or Contour graph from a range of cells in worksheet as a virtual matrix, a virtual matrix will be generated.

You can use Tools: Virtual Matrix Manager to manage the existed virtual matrices.

ClickWorkbookbutton inPlot Detailsdialog will also go toVirtual Matrix Managerdialog.

  • Right click the virtual matrix in the left list box, and select delete to delete a existed virtual matrix
  • Modify the virtual matrix name the title and Data Format in the dialog
  • Click Go to Worksheet button behind Rang box to go to the worksheet which generated this virtual matrix
  • Select a graph plotted by current virtual matrix and click Go to Graph button beside Related Graphs to go to the graph

Use Existing Virtual Matrix to make plots 
You can direct select a existing virtual matrix in plotvm dialog for plotting.
Better Virtual Matrix Name and Tooltip in Plot Details dialog

User can easily tell where the Virtual Matrix is made from and how.


LabTalk Access
New object vmatrix introduced

ORG-2851,

ORG-11783,

ORG-2766,

ORG-11438

Contour Plot Improvements

Contour plot improvements with missing values in Matrix

System variable @cmt is added in 9.2 to control how missing values in Matrix are dealt with in 9.2.

@cmt=1 (default and new behavior): no interpolation will be done around missing values. See 1st one.

@cmt=0 will do interpolation around missing values. See 2nd graph. Old behavior.

   


Options to ignore Z missing values in XYZ Contour / Surface graphs

Run the following command with Contour plot active in 9.2 to ignore missing values in XYZ columns.

set %c -lczm 1

   


Show/Hide Boundary line and Customize Border Line

    


Show Polygon area of selected contour line on Data Display

Single click a contour line several times till only that contour line is selected. Z and Area will show in Data Display window, which supports right click to copy the text.

ORG-11696Image Profile and Contour Profile are grouped under Plot: Profile menu.

ORG-11541Profile along arbitrary line. Width control available
ORG-1526More Profile Quantity options
  • Min
  • Max
  • Mean
  • Median
  • Sum
  • SD

ORG-1526Profile for Full Range
ORG-11671Create Image Profile Directly form Virtual Matrix
ORG-11659Profile GadgetWith image/contour graph window activated, user can choose Gadget: Image Profile menu to open the tool.
ORG-11968Support Duplicate Graph with New Columns for 3D graphs plotted from XYZ column.  (SR1)We added batch plotting for 3D graphs plotted from matrix data in Origin 2015 SR0. Expanded it to 3D graphs plotted from XYZ columns now.



Analysis

JIRASUMMARYDETAILS
ORG-11292General: Seven OriginPro Only Features Are Moved to Origin

In Origin 2015, seven features are also available in Origin, which previously were only available in OriginPro.

  • Discrete Frequency:  Compute counts, frequencies etc. for discrete variables. 
    Statistics:Descriptive Statistics (workbook)
  • Reduce to Evenly Spaced X: Reduce XY data into smaller size with evenly-spaced X values. 
    Analysis: Data Manipulation (workbook)
  • Reduce by Group: Reduce XY data by sub-group statistics according to X's distribution. 
    Analysis: Data Manipulation (workbook)
  • Trace Interpolation: Perform interpolation on cycle or periodic curves. 
    Analysis:Mathematics (workbook, graph) 
  • 2D Interpolate/Extrapolate: Perform 2D interpolation/extrapolation for a matrix. 
    Analysis:Mathematics(matrix, graph from matrix) 
  • 3D Interpolation: Perform interpolation with a 3D function on XYZ dataset.
    Analysis:Mathematics (workbook)
  • Advanced Normality Test: 1. One Sample Kolmogorov-Smirnov Test 2. Lilliefors Normality Test.
    Statistics:Descriptive Statistics (workbook)
ORG-11749General: Control Group Column Order in Dialogs

The input grouping range control in following dialogs is improved to enable group column order control

  • Statistics on Columns (menu: Statistics: Descriptive Statistics: Statistics on Columns)
  • Unstack Columns (menu: Worksheet: Unstack Columns)
  • Normality Test (menu: Statistics: Descriptive Statistics: Normality Test)
ORG-11137General: System variable @dam to set the default Recalculation Mode for all dialogs that applyFor example. Set Column Values Dialog, XF-Based Dialogs, and Operation-Based Dialogs). 0 = None, 1 = Auto, 2 = Manual. Default is 2 as before.  
ORG-11550General: Using Plot Legend as Data Identifier

When user is doing fitting from Graph, user can set Legend as the Data Identifier in report.

  

ORG-10677General: Analysis Marker context menu on green lock's context menu

Add Analysis Marker context menu when click on green lock on graph to turn on/off and change size of analysis markers.

ORG-11304General: XF will no longer change column short name when outputAnalysis tools which use ReportData as output data type like FFT, Average Multiple Curves, Discrete Frequency, etc will leave output column short name as default and use long name as identifier only.
ORG-8439Fitting: Distribution Fit

Origin 2015 introduce Distribution Fit which helps user to find the proper distribution for his data.


How to:

  • When a worksheet is active, select Statistics: Descriptive Statistics: Distribution Fit

  

ORG-10263Fitting: Improve Fitting Graph and Residual Graphs

Arrange multiple residual plots in one graph with multiple layers

Support Normal Probability Plot of Residuals

ORG-10263Fitting: Auto-detect Outliers in Linear Fit Tool

In Linear Fit tool, outliers can be auto-detected and output.

ORG-11852Fitting: More Results supports in Apparent Fit
  • Enable Standardized Residual, Studentized and Studentized Deleted Residual for Apparent Fit
  • Support outlier result for Apparent Fit
ORG-10303Fitting: Keep Zoom Status on Fit Curve tab When Doing Interactions

When doing a fit from graph, user can first uncheck Show Preview on Source Graph checkbox on Fitted Curves page. Then Fit Curve tab will show a preview fitted curve. Zoom In, Zoom Out and Rescale buttons are added on the tab to see more details during iteration or fitting.

 

ORG-11320ORG-11661, ORG-6206Fitting: New Build-in Fitting Functions 

Function Name: Bingham, Cross, Carreau, Herschel, Mauro-Yue-Ellison-Gupta-Allan(MYEGA), Vogel-Fulcher-Tammann(VFT), BiHill, LangevinMod, ExpGrowDec, ExpGrow3Dec2

ORG-11884Fitting: New Category of Enzyme Kinetics Functions

Origin 2015 added a new category Enzyme Kinetics for build-in fitting function and following function are included in it

Function Name: CompInhib, NoncompInhib, UncompInhib, MixedModelInhib, SubstrateInhib, MichaelisMeten, Hill

ORG-11747Fitting: Add and Search function

User can now add existing function directly from NLfit dialog

Search function button available in NLFit dialog and the Fitting Function Organizer dialog

ORG-4418Statistics: Repeated Measures ANOVA for Unbalanced Data

From Origin 2015, One-Way and Two-Way Repeated Measures ANOVA tools support data with unbalanced design

How to

  1. Start with worksheet with data of different sample size
  2. Select Statistics: ANOVA: One-Way Repeated Measures ANOVA 
    or
    Select Statistics: ANOVA: Two-Way Repeated Measures ANOVA

ORG-8481Statistics: t-tests on Rows
We have introduced t-test on rows tools. These tools  are accessible from the Statistics: Hypothesis Testing menu
  • Two-Sample t-test on Rows
  • Pair-Sample t-test on Rows

ORG-11480ORG-10803ORG-11347ORG-9795ORG-10057Gadgets Improvements
  • Hide/Show ROI box. 
  • Hidden Plots will not show in Change Data context menu of Gadget tools. 
  • Add method to context menu of peak markers converting them to data plot in Quick Peak gadget. 
  • Support virtual matrix plot in 2D Integrate Gadget. 
  • Support output for entire curve, not just ROI, for Quick Peaks gadget. 
ORG-11336ORG-11417ORG-11438Mathematics Improvements
  • Provide extrapolate options to repeat the last value for extrapolation in the Interpolate/Extrapolate Y from X tool
  • Add Simple Curve Math to menu and rearrange the menu items 
  • Show polygon area of selected contour line in Data Display 

ORG-8681Peak Analysis Improvements
  • Use plot label to tag peaks in Quick Peaks Gadget which enable further editing for the peak labels.  
ORG-7834ORG-6784ORG-8595ORG-11265ORG-331Statistics Improvements

Correlation Coefficient 

  • Provide option to turn off significance value in output 
  • Support output as flat sheet 

Principle Component Analysis

  • Introduce a control in GUI for user to specify the label column, which will be used in Scores Plot and Biplot 

Hierarchical Cluster 

  • Add orientation option (vertical/horizontal) for Dendrogram plot 
  • Enable user to find the best representative sample (clustroid) within each cluster 

Discrete Frequency

  • Provide option to sort result in desired order. If set as Categorical Order, the result will be ordered automatically according to the categorical values set in the Categories label row 
ORG-10892Signal Processing Improvements
  • Hide Signal Deconvolution from menu
    Run Labtalk script: "deconv -d; " in  Command Window or Script Window to open the dialog.


  • Generate time-frequency plots for wavelet analysis (ORG-5373)

    How to
    • When a worksheet is active, select Analysis: Signal Processing:Wavelet:Continuous Wavelet

ORG-12071Statistics: Cluster Gadget: Support statistics in X direction  (SR1) A "X Value" check-box is added in Calculation tab of the Cluster Preferences dialog.
ORG-11458Signal Processing: FFT Gadget: Add option to remove DC offset  (SR1)A "Keep DC Offset" check-box is added in the Preview graph of FFT Gadget.


Data Processing

JIRASUMMARYDETAILS
ORG-11385ORG-11252ORG-10990,ORG-11157Controlling Categorical Values

Categories Label Row

Once you set the column to data type = Categorical, a new label row named Categories will added to the default worksheet, which can help you to control your categories in analysis/graphing. 

Right click the Categories cell of column, there is a related context menu to easily copy, paste, load and save the categories. Paste or load the categories in other columns to use the same categories.

Categories Dialog

Double click the Categories cell of column, the Categories dialog pops to help you (There is also a similar Categories tab in Column Properties dialog)

  • Manually order your categorical values
  • Add or remove categorical values
  • Save and load to share categorical values between columns
  • San to find more categories from Data

      


Controlling Categorical Values in Analysis and Graphing

Analysis and graphs in Origin will be generated or updated automatically according to the categorical values set in the Categories label row

Note: the group columns and group box charts plot by index data could easily control the plot order within group, by setting the group column(s) as categorical, then adjust the order of categories.

  • Graphs auto updated by Categories Label Row

  • Analysis auto updated by Categories Label Row

Controlling Categorical Value Legend 

Origin 2015 support further control for categorical value legend.

    

Option to Ignore Missing Values in Categorical Values column

System variable @cats default value is 4 in this version. It will ignore missing values in a column with is set as Categorical. 

ORG-10636ORG-11558ORG-11434ORG-10749ORG-6077, ORG-11686, ORG-10733ORG-6093ORG-10579, ORG-8781, ORG-10393,ORG-11028,ORG-10768ORG-10257, ORG-10663ORG-9471ORG-11435ORG-11563ORG-11276ORG-11436

Set Column Values Improvements in Origin 2015

Hint on blank Formula and Before Formula Scripts boxes


Rename F(X) as F(X)= in Worksheet

  • Makes it clear user doesn't need to enter = as in Excel
  • Ignore = even if it's typed


Coloring Brackets

This works in many other places that supports writing Script, such as Code Builder, Function Builder, Function Plot, Column Filter, Worksheet Query, etc.


Function and syntax Help on Status bar and as Smart Hint

  • When mousing over a function under Function menu, function explanation shows on Status bar.

  • When a function is selected or a function name is double clicked, smart hint shows to give function info and example. The parameter names are improved.

This works in other dialogs with LT function support such as

Worksheet Query, Column Filter, Function Plot dialog, Plot Details


Search and Insert Function

  • Search Functions button (same as select Function: Search and Insert...)   
  • Search and Insert Functions dialog: Search by keyword. Double click to inset into Formula box. 
  • Click icon before the function description to go to the detail function document page.
  • This same dialog also allow to find function in other dialogs
    • NLFit: Function: <Search...>
    • Fitting Function Organizer: Search button


More Function Support in Set Column Value dialog 

  • mod2() and rmod2()  (negative values returned positive dividends) 
  • Value()
  • isText() function under Function: Miscellaneous: to test if a value is string or number. If string, returns 1, if number or empty, return 0.
  • Interp() function under Function: Math to calculation interpolation of XY based on giving some X values.
  • binopdf(), ksdensity(), ks2density() under Function: Distributions: PDF menu
  • SumIf(), CountIf(), AverageIf() , Correl() and Cov() under Function: Statistics.
  • lookup() and table() under Function: Lookup & Reference.
  • logncdf() function under Functions:Distributions: CDF
  • logninv() function under Functions:Distributions: INV


Some Menu Changes

  1. Move Variables and Constants to the top position of the Variables menu 
  2. Rename the menus under Variables menu to say Add ....  


Add and reorganized examples under Formula: Load Sample menu

Select the Formula: Load Sample entry to see the example of operators.


Insert Mode for inserting variables

The first time when user uses "Insert Range Variable by Selection" or "Insert Column Label Cell by Selection" , and finish hunting, shows Insert Mode dialog to decide the notation.


Context Menu for F(x)= label row cell

Allow Sort Worksheet

If output data is in a same worksheet as input data, "sort worksheet" will be enabled by default.


Support define a range variable from matrix cell(s) in SCV

Support range selection from Matrix when using Variables: Add Range Variable by Selection in Set Column Values dialog

ORG-10826Show more Statistics info. on status bar based on current selection and Copy Statistics
ORG-12603Add movrms function in Set Column Values (SR2)

Moving rms

vector Movrms(vector vx, int back[, int forward])


Importing

JIRASUMMARYDETAILS
ORG-10654Import SPSS Data Files

In Origin 2015, user can import SPSS data files.

How to:

  1. By default, Import SPSS does not show in Import menu. To bring it to menu: with a workbook active, choose File: Import: Customize..., then select SPSS (SAV) in the left pane to add it to the right pane.
  2. When a worksheet is active, choose File: Import: SPSS (SAV)...


Via the File Information branch in the opened dialog, user can select variables to be imported

    


Among the import options that you can control via the  dialog box: 

  • Specification of 1st file import.
  • Renaming of workbooks and worksheets with the file name, on import.
  • Whether imported data should be put into new workbooks, worksheets, columns, rows or overwrite existing data. 

         

    

ORG-10993ORG-11048ORG-10825ORG-11042ASCII Importing Improvements
  1. Extract Long name and Units on Same Header Line During Import


  2. Enable Import ASCII and Import Wizard buttons without active window. 
  3. Moved File Name Options page after Extract Variables in Import wizard and when renaming worksheet or workbook names, show the extracted variable names in a drop-down list to easily select. 
  4. Bigger buffer limit so user can import data with more than 856 columns 
ORG-11222Matlab Import Improvements
Support Transpose in Matlab Import.
ORG-10919ORG-11249ORG-10534ORG-8826ORG-11249Excel Import Improvements - Partial Import, Sheet selection in Theme file, and Reimport of Multiple Sheets
  • Support specifying Main header and Subheader

  • Support Partial Column Import 

  • Remember sheet select in Dialog theme file and Reimport


  • Support reimport of multi-sheet Excel file

 If you have imported a multi-sheet Excel file into Origin and then the excel file is updated, you can choose File: Reimport Directly to reimport.


  • Import Multiple sheets in one Excel file into same Origin worksheet

Choose Start New Columns in 1st File Import Mode

ORG-9424Support pClamp 10.4 file for third-party file import  (SR1)
ORG-12260Import pClamp files abf 2.0.5 (released on NeuroScience 2014)  (SR1)

After Origin 2015 SR0 release, Molecular Devices released a new device with new abf 2.0.5 file format so it's not supported in SR0.

Need to patch to Origin 2015 SR1 if you would like to import it.

ORG-12328Create sheets for each variable after importing Mat file into hierarchical structure  (SR1)

Introduce system variable @MVE to specify whether create sheets for each variable after importing Mat file as hierarchical structure

0 = (by default) matlab variable not expand automatically.

1 = expand the variable, and also expand all its members recursively.

ORG-10494Tool for import/export XML  (SR1)Support import and export XML file after install IOXML 1.1.opx in Origin. Need 9.0SR1 or later.
ORG-12574Certain SPE file cannot be imported since 8.5.0 (SR2)Supports more CCD sensor types



Project and Data Management

JIRASUMMARYDETAILS
ORG-10719Join Worksheet

Append Worksheet

Worksheets can be joined side by side or by adding rows in Origin 2015. 

How to:

  • When a worksheet is active, select menu Worksheet: Append Worksheet



ORG-10259Pivot Table with More than 1 Source for Column or Row

Origin 2015 supports multiple columns or rows in pivot table as data source. It helps user to summarize data by combination of multiple columns/rows

How to:

  1. When a worksheet is active, select menu Worksheet: Pivot Table
  2. More than 1 column can be selected as Pivot Table Row/Column Source.
    Note: When Options: Sort Output Rows/Columns select None, user can set the Row/Column Source column(s) as categorical, then the order in result table will be changed accordingly.

ORG-11156Remove/Combine Duplicate Rows

Origin 2015 supports removing or combining duplicated rows by different options

  • Keep First Row
  • Keep Last Row
  • Average
  • Min
  • Max
  • Sum
  • SD

How to: 

  • When the worksheet is active, choose menu Worksheet: Remove/Combine Duplicated Rows

          

ORG-8512Print/Export tab added in Worksheet Properties dialog
ORG-10665Added ability to force Text & Numeric datasets to show numeric values as  text elements
ORG-11845Copy Column supports Copy All (Data, Formula and Labels)
ORG-9736

Re-design the filter lock interface.


  • Lock – Save the filter info
  • Reload – Update the filter
  • Push Back – Apply the saved filter back to source worksheet
ORG-11314Pasted Unicode Node in Worksheet Cell need to allowed copying outSet system variable @COPU = 3, then copy the unicode texts (like Japanese or Chinese) from the cells in Origin worksheet and paste them to other application smoothly.
ORG-10592Worksheet name/comments Improvements
  • When mouse over sheet tab, the tooltip shows Short Name, Long Name, Multi-Line Comments.
  • Add Properties dialog to modify short name, long name and comments
ORG-10203Add Hotkey for Update Origin for external Excel in OriginAlt+Shift+R: Update Origin for external Excel in Origin
ORG-10673Support more quantities for reduced X and reduce Y in Reduce by Group tool
ORG-10504

A new x-function colsplit is added to split/unstack column(s).

(SR1)

In Script window, run colsplit -d to open the dialog.  

Two Subgroup Methods are provided:

 By every Nth row

By Sequential N Rows

ORG-11663

Ability to keep uneditable parameters/values in analysis template  (SR1)


If we set the column to disable edit, values in the column will be kept in analysis templates.

Example:

  1. Prepare a worksheet as the image in the left. The parameter values are put in column E. 
  2. Right click on column E and choose Format Cells from the context menu
  3. Right click on the title bar of workbook and choose Save as Analysis Template

The saved OGW file can then be used in batch processing to process multiple datasets


Programming and Connectivity




ORG-11419X-Function: Join Worksheet by Matching Column

The x-function, wjoinbycol,  enable joining worksheets by the matched column in Origin 2015. 

Detailed Documentation: Please refer the wjoinbycol help page

How to:

  1. When a worksheet is active, open the Script Window (from menu, Window: Script Window) if it is not already open.
  2. In the Script Window, enter script below and press Enter

wjoinbycol -d
ORG-11419X-Function:Join Worksheet by Matching Labels

The x-function, wjoinbylabel,  enable joining worksheets by the matched label (worksheet headers)

Detailed Documentation: Please refer the wjoinbylabel help page

How to:

  1. When a worksheet is active, open the Script Window (from menu, Window: Script Window) if it is not already open.
  2. In the Script Window, enter script below and press Enter

    wjoinbylabel -d
ORG-10971OC: Using Code Builder to Manage OC files in OPX

A Packages folder is added in workspace in Code Builder. This folder is used to manage packages. This folder contains only folders, and each folder represents a disk folder in User Files Folder. A special folder named Common is used for holding files that are shared between all packages. Each package folder contains a subfolder named "User Files", which contains files that are in the User Files Folder.

ORG-9926OC: Add ability to encrypt Origin C code

A new file type.ocz is introduced for easier Origin C code distribution. It is a C file but have the following differences:

  • Password protected, so if you try to open it in Code Builder, you will need to enter a password. You can use option in this dialog to remember the password in the local user's registry for 30 days.
  • OCZ files can be drag and drop into Origin for easy installation. It will not be added to system folder, but it will autoload so functions in such file will be available when Origin starts.
ORG-10840Python: Origin 2015 Python Support

Origin provides embedded python environment, so that you can either run python in Origin (support both command line and .py file), or use a PyOrigin module to access Origin from Python.

The embedded Python in Origin could be either version 3.3.5 or version 2.7.8 and it can be switched by asystem variable @PYV. When @PYV = 3 (Default), the embedded Python is 3.3.5, while if @PYV = 2, it is 2.7.8. To set value for a system variable, click Tools:System Variables to open the Set System Variablesdialog.

ORG-9980LabTalk: LabTalk Access to Properties of Individual Radar Axis
//Assuming a radar chart is active
//"Rescale Each Axis Independently" should be checked on Miscellaneous page
layer.y1.to = 18;
layer.y2.to = 25;
ORG-10891LabTalk: LabTalk Access to Margins of Legend

object.margin.unit 
object.margin.left, 
object.margin.right, 
object.margin.top, 
object.margin.bottom

ORG-11688LabTalk: LabTalk Access to 1D&2D Kernal Density Estimation

two LT functions in SCV's category Distributions: PDF:

ksdensity(x, vd, w)
ks2density(x, y, vx, vy, wx, wy)
ORG-9984LabTalk: Tile Windows In a Sequence
win -s th1; /// tile horizontally first by window type then by name
win -s tv2; /// tile vertically by window name
ORG-10506LabTalk: Force Recalculation on a Specific Operation
//Force the operation with UID 804 to recalculate
run -p aui 804;
ORG-10482LabTalk: New Notation support to define LabTalk Literal string
  • Support for labtalk string definition

    // The syntax <[< indicates the start of literal strings
    // The syntax >]> indicates the end of literal strings
    // The syntax can be changed in Origin.ini "Text" section
    // Can be used to include special symbols like double quotation marks in a string
    string str$ = <[<a"b'";"c">]>;
    str$=;
    //Should return a"b'";"c"
  • Support in X-Function arguments

    patternT text:=<[<"Sample A" "Sample B" "Sample C">]>;
ORG-10507LabTalk: New Macros will be called when using Draw Data tool
  • BeforePointProc will be called before PointProc macro
  • AfterPointProc will be called after  PointProc macro
Use spline for connect line in Draw Data
def AfterPointProc
{
	if (getpts.count >= 3)
	{
		set %B -l 0;
	}
}
dotool 5;
ORG-11066LabTalk: New System Variables

Size of the worksheet cell with embedded graph when auto re-size

@WCSGW

@WCSGH


OC: Origin C Workspace - User [AutoLoad] Folder

A new folder, User [AutoLoad] is introduced to Origin C Workspace in Origin 2015.

Files added to the User [AutoLoad] folder is similar to the User folder, except that the files in User [AutoLoad] folder will be compiled and linked automatically upon starting Origin, and then the functions defined in the files under this folder are available, and there is no need to compile and link manually.

ORG-8053Protection of OC/LT codes attached to OPJ

1.To prevent user seeing the codes attached to project,  use the following LabTalk code:

doc -lr 16;

Basically, in Code Builder, the Project folder cannot be opened if locked with the above LabTalk code .


2.When user run the following LabTalk code to unlock, user can see files have been added to Project folder in Code Builder:

doc -lr 0;
ORG-11096LabTalk: Toggle Button ControlOrigin 2015 support add an text box named "labtalk Variable to toggle" in the Button Settings dialog.The variable can be pass to script file.
ORG-8219LabTalk:Want Labtalk for setting substitution level for graph objects  (SR1)New property "object.link" added.
ORG-12401

LabTalk: Want combined Tile and Cascade Windows arrangement  (SR1)

Combined tile and cascade arrangement

  1. window -s ch
    tile horizontally,then cascade each column
  2. window -s cv
    tile vertically, cascade each column

  3. window -s ct
    tile and cascade

Tile all windows in descending sequence

  1. window -s th3 or window -s tv3
    tile first by window type(workbook->excel->graph->matrix->layout-notes),then by name descending
  2. window -s th4 or window -s tv4
    tile by window name descending

note: the above descending mode (3,4) and ascending mode(1,2) also support for window -s ch/cv/ct.

ORG-12150LabTalk: New labtalk functions for signal processing/FFT  (SR1)

We added following labtalk functions for signal processing:

1. fftc

vector<complex> fftc(vector<complex> cx)

It calculates the complex FFT result for given cx. We should use different algorithms depending on whether cx is real.
If cx's size is n, then output size is also n. (shift should be off.)

2. fftmag

vector fftmag(vector<complex> cx, int side=1 )

It can be used to calculate magnitude from FFT complex result. side=1 for one-sided by default, side=2 for two-sided and shift.

3. fftamp

vector fftamp(vector<complex> cx, int side=1 )

It can be used to calculate amplitude from FFT complex result. side=1 for one-sided by default, side=2 for two-sided and shift.

4. fftphase

vector fftphase(vector<complex> cx, int side=1, int unwrap=1, int unit=1 )

It can be used to calculate amplitude from FFT complex result.
side=1 for one-sided by default, side=2 for two-sided and shift.
unwrap=0 not unwrap phase angle, 1 for unwrap by default.
unit=1 for degrees unit by default, 0 for radians unit.

5. ifftshift

vector<complex> ifftshift(vector<complex> cx)

When fft result is shifted, to do ifft, we need unshift the result first.

6. invfft

vector<complex> invfft(vector<complex> cx)

Compute inverse FFT from fft result. If input size is n, output size is n.

7. fftfreq

vector fftfreq(double time, int n, int side=1, int shift=1)

Calculate frequencies for FFT results, the original result is time*data(0,n-1)
time: sampling interval
n: signal size
side: 1 for one-sided(by default), 2 for two-sided
shift: 0 for no-shift, and 1 for shift(by default), it is used for two-sided.
Return frequencies, two-sided size is n, one-sided size is ceil((n+1)/2)

8. fftshift

vector<complex> fftshift(vector<complex> cx)

It can be used to shift FFT results or frequency.

9. windata

vector windata(int type, int n)

type=0 rectangle, 1: Welch, 2: Triangular, 3: Bartlett, 4: Hanning, 5: Hamming, 6: Blackman
n is size for the window.
Return a vector of size n.

ORG-12392Share UIM Tool to Origin regular  (SR1)This used to be an OriginPro feature. Make it available in Origin regular now.
ORG-12546LabTalk:Column Label Row Characters Improvement (SR2)Character O1 is reversed for Categories label row instead of K. For more details, see this page.

Other

JIRA
SUMMARY

DETAILS

ORG-10692ORG-11418Disconnect Graph Page from active Printer

The check box Set to printer dimension when creating graphs from this template (Plot Details Print/Dimensions tab, page level) has been removed. It has been replaced by a new page property page.UpdateToPrinter that will has 3 values:

  • 0 - Behaves as the old check box in the disabled state, namely, do not check printer when loading templates.
  • 1 (default) - Existing templates with Set to printer dimension... enabled will load with page.UpdateToPrinter = 1.  If the template has resolution less than 600 DPI, then it is updated automatically to 600 DPI. If DPI is equal to or greater than 600 DPI, nothing changes.
  • 2 -  Update template to printer resolution. User can save any template while value = 2 to get the "old behavior" of template having Set to printer dimension... enabled.

Once the graph is created, everything will work as it did before. If you print and the resolution of the printer is not equal to template, you will see the message asking you to update to printer resolution.


The new feature: allow default graph page size to be country dependent.

Graph page's Width*height:

6400 pixel(10.67 inch)*4800 pixel(8 inch) for US/CANADA/MEXICO .
6779  pixel(11.3 inch)*4760 pixel(7.933 inch) for other locations like Japan, Germany, UK, China.

Fit page to printer will change the page size as above value by different locations in Window system (Control Panel\Clock, Language, and Region).  


Origin 2015 32-bit vs 64-bit

Origin 2015 offers both 32-bit and 64-bit versions. For the Import/ Export file types, there are some differences in two versions.

32-Bit

The following Import/Export file types are supported in 32-bit Origin.

64-Bit

Some Import/Export formats are not supported in 64-bit Origin due to non-availability of third-party plug-ins/DLLs.

These file types are NOT supported for import/export in 64-bit:

  •  *.dbf, *.WK *, *.DIF Import
  • Database Import: Query Builder tool not available. SQL Editor tool works fine.
  • Export Graph as Image: *.cgm, *.dxf.

ORG-10714Origin Viewer: Support rotate 3D graphs separated out windows.  (SR1)Support the click to rotate in the additional graph windows.